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Foreword

We are delighted to see Wiley's latest update to the very successful AutoCAD
Bibles by Ellen Finkelstein. As has oft been noted, if nature didn’t make it,
someone using Autodesk design software probably did. Autodesk understands bet-
ter each day that our value proposition is to constantly deliver performance and
productivity improvements to you, the users of our products. Delivering on this
proposition requires more than great software —such as the recently released
AutoCAD 2004 —with the features you need. True productivity improvement also
means having available additional resources, services and support. These additional
resources make you more productive as you apply Autodesk products to solve your
design challenges. The new AutoCAD 2004 Bible is a noteworthy addition to this pool
of resources you will want at your fingertips.

The creation of Autodesk Professional Services (APS) is a recent example of our
commitment to continuously improve your design performance. APS was organized
to meet your increasing needs for support, training, and consulting. Almost every-
thing we do assumes a collaborative partnership-based approach. Indeed, “none of
us are as smart as all of us” is a principle upon which Autodesk was founded. In
2002 we were able to truly celebrate our 20th anniversary because of this “great
group” model and the magic that happens when committed people collaborate with
common goals. This includes our increased work with the “virtual” Autodesk enter-
prise — publishers such as Wiley and experts such as Ellen Finkelstein —to bring
you impressive resources that support your Autodesk software. APS is thus able to
ensure that you increasingly get the best solutions by assembling just the right
combination of features, support, and learning resources.

AutoCAD is a powerful 2D and 3D design and drafting platform that automates your
design tasks and provides digital tools so you can focus on the design rather than
the software itself. Architects, engineers, drafters, and design-related professionals
use AutoCAD to create, view, manage, plot, share, and reuse accurate, information-
rich drawings. In addition to software improvements, we are focusing more on sup-
porting the entire process of collaborative design. You'll appreciate the drawing
enhancements we’ve packed into AutoCAD 2004 such as Express Tools which
reduce the steps required to perform a task, and the Publish to Web’s XML-based
i-drop™ publishing capability. New and improved data exchange features include
support of multisheet Design Web Format (DWF) files for securely exchanging draw-
ings over the Internet with team members. These new timesaving drawing tools
minimize the number of steps you have to take, freeing you and your team to
explore more design options —and create even more outstanding designs.
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Foreword

After 20 years we can say, to paraphrase on old marketing line, “This isn’t your
father’s AutoCAD!” Your work today is not just about powering great designs with
AutoCAD’s productivity and performance tools. AutoCAD enables you to collabo-
rate with others to extend the value of your designs — and maximize the value of
your design data across your entire organization. You also need to easily acquire,
integrate, deploy, and manage your software assets to increase workflow and affect
your bottom line.

However, you can only benefit from what you know and use. Introducing these inno-
vations also poses new challenges, namely learning how to apply these enhance-
ments to the jobs you face. We have done much to address these challenges within
AutoCAD, yet the full solution must be more than what Autodesk alone can

provide —hence the critical role of the Autodesk virtual community.

We are therefore particularly grateful to Ellen Finkelstein for having written such a
comprehensive and reliable guide to AutoCAD, and to the people at Wiley for mak-
ing it so widely available. Following on the great success of the AutoCAD 2002 Bible,
this new version draws upon lessons learned from reader feedback. To get maxi-
mum value and performance from AutoCAD, you should have the AutoCAD 2004
Bible right at your fingertips. It will enable you to respond to the unexpected, which
is the norm on the job these days. Use it to augment the digital learning resources
that come with your software: AutoCAD Learning Assistance, AutoCAD Today,

the Help system, and the online resources of Autodesk Point A and Autodesk
ProjectPoint which is seamlessly integrated into AutoCAD. You will be even more
productive if you use the AutoCAD 2004 Bible to discover the myriad capabilities of
AutoCAD you probably weren’t aware even existed. However you use it, when you
combine the features in AutoCAD with the support of the AutoCAD 2004 Bible, you
will discover daily breakthroughs and productivity boosters as you use AutoCAD to
power your designs.

Wayne Hodgins

Strategic Futurist

Director of Worldwide Learning Strategies
Autodesk Professional Services
www.autodesk.com & www.discreet.com



Preface

Welcome to the AutoCAD 2004 Bible. AutoCAD 2004 is the most powerful
CAD software product available for PCs today. It can perform nearly any
drawing task you can give it. This book is designed to be your comprehensive guide
to the entire AutoCAD program.

AutoCAD 2004 is the fastest, smoothest AutoCAD yet. Certain features have been
added that are not even mentioned in this book because you never see them — you
just notice that fewer regenerations occur, drawings load faster, and you spend less
time waiting while drawing and editing. Files are automatically and invisibly com-
pressed, so they take up less room on your computer system. In addition to these
refinements, of course, are the many new features covered in this book that will
make your drawing easier and faster. This book covers every major AutoCAD fea-
ture. If you're a beginning AutoCAD user, you'll find everything you need to start
out; if you're already using AutoCAD regularly, the book covers advanced material
as well. It provides a solid reference base to come back to again and again, as well
as short tutorials to get you drawing. Finally, the CD-ROM is chockfull of drawings, a
trial version of AutoCAD 2004, and AutoLISP programs. This book should be all you
need to make full use of that expensive program called AutoCAD.

Is This Book for You?

The AutoCAD 2004 Bible covers all the essential features of AutoCAD and includes
clear, real-life examples and tutorials that you can adapt to your needs.

Although I fully cover AutoCAD basics, [ have also included material on the many
advanced features, such as external database connectivity, AutoLISP, Visual Basic
for Applications (VBA), 3D modeling, rendering, and customization. The following
categories should help you decide if this book is for you.

If you are a new AutoCAD user

If you are new to AutoCAD, the AutoCAD 2004 Bible guides you through all you need
to know to start drawing effectively, whatever your field.

If you are upgrading to AutoCAD 2004

This book highlights all the new features of AutoCAD 2004 and helps you make the
upgrade transition as seamless as possible.
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If you are switching from another CAD program

You already know what CAD is all about. This book clearly explains the AutoCAD
way of drawing the models you have already been drawing. In addition, you’ll find a
great deal of essential information about transferring information from other formats.

How This Book Is Organized

This book is divided into eight parts.

Part I: AutoCAD Basics

Part I provides the background information you need to start drawing. It starts with
a “quick tour” that gets you drawing right away, and then covers how to start a
drawing, use commands, specify coordinates, and set up a drawing.

Part 11: Drawing in Two Dimensions

Part Il covers all the commands and procedures for drawing and editing in two
dimensions. In addition, [ discuss how to control the drawing process with layers,
zooming, and panning. Also included in this part is information about dimensioning,
plotting, and printing.

Part IlI: Working with Data

Part IIl covers many ways to organize and share data, including blocks, attributes,
external references, and external databases.

Part IV: Drawing in Three Dimensions

Part IV explains everything you need to know to draw in three dimensions. It also dis-
cusses how to present 3D drawings using hiding, shading, and rendering techniques.

Part V: Organizing and Managing Drawings

Part V helps you incorporate AutoCAD into your work world by explaining how to
set standards, manage drawings, and work with other applications. It concludes
with a chapter on AutoCAD and the Internet. Many of the new features of AutoCAD
2004 are explained in this part.

Part VI: Customizing AutoCAD

Part VI introduces the tools you need to customize commands, toolbars, linetypes,
hatch patterns, shapes, fonts, and menus. You'll also find a chapter on script files,
which you can use to create macros.
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Part VII: Programming AutoCAD

Part VII introduces you to programming AutoCAD. It includes three chapters on
AutoLISP and Visual LISP and one chapter on Visual Basic for Applications.

Part VIII: Appendix
Part VIII explains what you’ll find on the CD-ROM.

r Cross- The CD-ROM contains a complete copy of this book in PDF format and four
Reference \  4ppendixes of useful information for AutoCAD users.

How to Use This Book

You can use this book in two ways: as a reference or as a learning tool or tutorial.

As a reference

The AutoCAD 2004 Bible is organized as a reference that you can refer to whenever
you get stuck or when you try to do something for the first time. Each chapter cov-
ers a topic completely, making it easy to find what you’re looking for. Each Step-by-
Step exercise (with a few exceptions) can be done on its own without doing the
other exercises in the chapter. You can easily look up a topic and complete a
related exercise without having to go through the entire chapter. A complete index
at the back of the book can also help you look up features and topics.

As a tutorial

The overall organization of the book goes from simple to complex, and each chap-
ter has several Step-by-Step sections. This enables you to use the book as a
tutorial — from beginning to end. You can then go back and redo any exercise when
you need to refresh your memory on a particular feature.

For newcomers to AutoCAD, Parts I and II are essential. After that, you can refer to
chapters that interest you. Parts Ill and V are also useful for beginners. Intermediate
users will probably be familiar with most of the material in Part I and will be more
likely to skip around looking for the specific topics they need. However, don’t forget
that many of the new features for AutoCAD 2004 are introduced in Part I. Enough
material appears in this book to bring intermediate users up to a fairly advanced
level.
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[ have designed this book to be comprehensive and to include every significant fea-
ture of AutoCAD. Therefore, do not be concerned if some of the material seems too
advanced. It will be there when you are ready for it.

Doing the Exercises

AutoCAD is a very customizable program. This book assumes that you are working
with the default setup. However, a number of changes may have been made to your
system that could result in menus, toolbars, and drawings appearing or even func-
tioning differently from those shown in this book. If you installed AutoCAD yourself
and made some adjustments, you know what changes you made. However, if you
are using a computer that was set up by someone else, it may help to talk to that
person first, to see what changes were made.

In addition, as you work through some of the exercises in this book, you will make
certain changes in AutoCAD’s setup. Most of these are minor changes that any user
would make while drawing. For safety, Cautions and Tips accompany all changes
that could have serious consequences, such as customizing the menu. For example,
when customizing the menu, you will be instructed to copy the menu template file
under a new name, and you will then work with the new menu file, not the original
one. Nevertheless, if you are working on a network or sharing AutoCAD with some-
one else, it is proper computer etiquette to consult with others who may be
affected by the changes you make.

If you do the exercises, | recommend that you do them from the beginning.
Important instructions are given during earlier exercises that may affect your sys-
tem later. For example, one of the first exercises is to create a new folder to hold
your drawings from the exercises. This folder keeps your exercise drawings sepa-
rate from other drawings created in your office. However, each exercise stands on
its own so you can go back and do only the exercise you need.

r Cross- You can create your own AutoCAD configuration that helps ensure that some
Reference h ; : : : :
changes you make will not affect others. Instructions for doing this appear in

Appendix A, “Creating Multiple Configurations,” on the CD-ROM.

The exercises in the AutoCAD 2004 Bible have been carefully checked by a technical
editor to ensure accuracy. However, we cannot anticipate all situations, either due
to varying hardware/software configurations or customization within AutoCAD. If
you have a problem with an exercise, contact me at the e-mail address listed at the
end of this Preface so I can correct the problem in the book’s next edition.
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Conventions Used in This Book

Given all the ways in which you can execute a command in AutoCAD, you’ll find it
useful to read through this section, which describes this book’s typographical con-
ventions. You will find this section helpful for doing the Step-by-Step exercises as
well.

AutoCAD commands

AutoCAD uses standard Windows conventions for menus and toolbars. To indicate
that you should choose a command from the menu, for example, [ say, “Choose
View = Viewports,” which means that you should click the View menu with your
mouse or puck/stylus and then click the Viewports menu item. A few of AutoCAD’s
toolbar buttons have flyouts, which are equivalent to submenus. They are called
flyouts because they fly out when you click and hold the button on the main tool-
bar, displaying even more buttons. Therefore, to indicate which button to choose, |
may need to tell you to choose (or click) Zoom Extents from the Zoom flyout of the
Standard toolbar. Although I haven’t found a good alternative, this is not completely
satisfactory for two reasons. First, it’s a mouthful! Second, the flyout names do not
appear, making it hard to know which is the Zoom flyout. However, you can check
Appendix B on the CD-ROM. It shows each toolbar and flyout along with its name.
Also, in most cases it will be obvious which flyout I'm talking about.

AutoCAD is unique in that every command also has a command name that you can
type on the command line, which appears at the bottom of your screen. Command
names are shown in capital letters, as in CIRCLE. AutoLISP functions are shown in
small capital letters, as in COMMAND.

AutoCAD prompts, your input, and instructions

In the Step-by-Step exercises, most instructions are presented in the same font and
style you are reading now. However, when I reproduce the AutoCAD command line,
AutoCAD’s prompts appear in a nonproportional font and the input you should
type in appears in bold. Other instructions (such as “Type in the first coordinate”)
are shown in italic.

Here’s a sample Step-by-Step section. In this exercise, you click the proper toolbar
button, type in the XY coordinates shown in bold, and press Enter where indicated
by the bent arrow (J) symbol.
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1. With your left mouse button (also called the pick button), choose Line from
the Draw toolbar. Notice that the command name is repeated on the com-
mand line.

Command: _line Specify first point: 0,0 J (This arrow means
to press Enter)

Specify next point or [Undol: 10,0 4

Specify next point or [Undo]: 10,7 4

Specify next point or [Close/Undo]: 0,7 d

Specify next point or [Close/Undo]: 0,0 4

Specify next point or [Close/Undo]: 4

Often [ make references to specific elements in a drawing. References to these ele-
ments appear in the text as numbers in circles, such as @, @, @, and so on. You'll
find the corresponding number in the figure to which the text refers.

Mouse and keyboard terms

You can draw in AutoCAD using a mouse or a puck. The mouse is familiar to all
users. A puck (or sometimes a stylus) is used with a digitizing tablet. Because most
AutoCAD users do not have a digitizing tablet, [ do not directly refer to it in this
book. If you have one, follow the instructions for using the mouse in the same way,
using your puck.

A mouse can have two or more buttons. Many AutoCAD users like using a mouse
with at least three buttons because you can customize the buttons to suit your
needs. However, because many mice have only two buttons, [ assume only two. The
left mouse button is used to choose commands and toolbar buttons and to pick
points in your drawing. For this reason, it is sometimes called the pick button. The
right button usually opens a shortcut menu.

AutoCAD 2004 introduces time-sensitive right-clicking. Because this feature is not

on by default, I do not assume that you have turned it on. I use the term right-click

when you need to access a shortcut menu. If you have time-sensitive right-clicking
turned on, you need to hold down the right mouse button more than 250 millisec-

onds (by default) to display the shortcut menu. See Chapter 3 and Appendix A on

the CD-ROM for more details.

If I say one of the following

4+ Choose Tools => Options
4 Click Line on the Draw toolbar

4 Select the circle in your drawing

it means to use the left button of your mouse.
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When I say to press Enter, it means to press the key that is marked Enter, Return, or
- on your keyboard. Often I use the bent arrow symbol (J) to indicate that you

should press Enter.

[ also use the mouse terms listed in the following table.

AutoCAD Mouse Terms

Term Description

Cursor The shape on your screen that shows you where the mouse is
pointed. It can take a number of shapes, such as crosshairs, pickbox,
or arrow. Also known as the mouse pointer.

Pickbox A type of cursor consisting of a small box, used to select drawing
objects.

Crosshairs A type of cursor consisting of intersecting lines.

Pick Point to a drawing object and click the left mouse button.

Click Press the left mouse button once and release it.

Double-click Press the left mouse button twice in rapid succession.

Click and drag

Choose

Right-click

Shift and click

Shift and right-click

Select

Click the left mouse button and hold it down while you move the
mouse, dragging an object on your screen with it.

Click a menu item, toolbar button, or dialog box item. You can
sometimes choose an item using the keyboard as well.

Press the right mouse button once and release it. If you have turned
on time-sensitive right-clicking, hold the right mouse button at least
250 milliseconds (by default) before releasing it.

While holding down the Shift key, press the left mouse button once
and release it.

While holding down the Shift key, press the right mouse button once
and release it.

Highlight an object in a drawing by picking it or using another object
selection method, or highlight text in a dialog box or text document.

What the Icons Mean

The AutoCAD 2004 Bible is liberally sprinkled with icons — small symbols in the left
margin that call your attention to noteworthy points.

XVIi
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New
Feature

o

\

o

Tip

- Cross-
Reference

On the )

Caution

SEN

Y

The New Feature icon means that a feature is new to AutoCAD 2004 or has been
significantly changed.

A Note icon alerts you to some important point that requires special attention or
additional information that may be helpful.

A Tip shows you a way to accomplish a task more efficiently or quickly. You'll find
plenty of practical advice here.

Cross-References refer you to a related topic elsewhere in the book. Because you
may not read this book straight through from cover to cover, use cross-references
to quickly find just the information you need.

The On the CD-ROM icon highlights references to related material on the
CD-ROM.

The Caution icon means you should pay special attention to the information or
instructions because a possibility exists that you could cause a problem otherwise.

About the CD-ROM

The CD-ROM contains all the drawings you need to do the exercises in this book.
These drawings save you time as you learn AutoCAD’s features. In addition, the
CD-ROM includes the drawings that result after you finish an exercise or tutorial. In
this way, you can check what you have done if you want.

The CD-ROM is also chockfull of resource material that I hope you will find useful
for many years to come. The Appendix at the back of the book lists the contents of
the CD-ROM. I am especially pleased to include a 30-day trial version of AutoCAD
2004 on the CD-ROM as well as this entire book in (nonprintable) PDF format.

Other Information

If you are an advanced AutoCAD user but need tips and secrets for getting the most
out of AutoCAD, this book will probably not add too much to your already great
store of knowledge.
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If you want to learn about Windows, look for a book that focuses on Windows. This
book assumes that you know the basics of Windows, although the instructions
you’ll read here are usually detailed enough to get you through any task. For more
information about Windows, try Windows XP For Dummies, by Andy Rathbone, or
try Alan Simpson’s Windows XP Bible (both published by Wiley, Inc.). For Windows
NT, try Teach Yourself Windows 2000 Professional VISUALLY, by Ruth Maran, or
Windows 2000 Professional For Dummies, by Andy Rathbone and Sharon Crawford
(both also published by Wiley).

If you want just the basics, AutoCAD LT might serve your needs better. However, if
you do have AutoCAD and want a more basic book, look at AutoCAD 2004 For
Dummies, by Bud Smith and Mark Middlebrook. The AutoCAD 2004 Bible covers
AutoCAD 2004. However, most of the information also applies to Release 2002.
have used AutoCAD in Windows XP Professional, but almost everything also applies
to Windows NT (4 and 2000), although some of the screens will look different.

Contacting the Author

[ would be happy to hear any comments you have about this book. The best way to
contact me is by e-mail at el Tenfink1@bigfoot.com. You can also use the United
States postal service (aka snail mail) and write to me in care of Wiley. Please note
that I can’t provide AutoCAD technical support for my readers.
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AutoCAD Basics

+ + + +
I he five chapters in Part I provide all the basics you need .
to start drawing in AutoCAD. These chapters are essen- In This Part

tial for the beginner, but even current users can find some

new tips and pointers especially related to features that are Chapter 1

new for AutoCAD 2004. If you feel you know enough to skip to Starting to Draw

Part II, skim this part for New Feature icons to bring yourself

up-to-date. Chapter 2
Opening a Drawing
Chapter 3
Using Commands
Chapter 4
Specifying

Coordinates

Chapter 5
Setting Up a Drawing

¢+ o+






Starting to Draw

Learning AutoCAD is a bit like trying to decide which
came first —the chicken or the egg. On one hand, you
need to know many basics before you can start drawing. On
the other hand, it can be very difficult to understand those
basics if you haven’t had the experience of drawing some-
thing. In this chapter, you resolve this problem by drawing a
simple rectangle in AutoCAD. The next few chapters then fill
you in on basic information you need to move on to more
complex drawings. By experiencing the drawing process first,
the initial learning curve will be easier and smoother.

Getting Acquainted with AutoCAD

AutoCAD, created by Autodesk, is the most widely used tech-
nical drawing program anywhere, with more than 3 million
registered users. According to Autodesk, CAD stands for
computer-aided design, but can also stand for computer-
aided drafting or drawing.

The first version of AutoCAD, running under DOS, came out in
1982. AutoCAD was the first significant CAD program to run
on a desktop computer. At the time, most other technical

drawing programs ran on high-end workstations or even main-

frames. AutoCAD’s success has been attributed to its famous
open architecture — many source code files in plain text
(ASCII) files that you can easily customize and programming

languages (such as AutoLISP and Visual Basic for Applications)
designed especially so that the end user can program AutoCAD.

As aresult, AutoCAD is the most flexible drafting program
available, applicable to all fields. AutoCAD’s support for lan-
guages other than English, including those using other alpha-
bets, is unparalleled, making AutoCAD without serious
competition abroad. As a result, AutoCAD is used in all disci-
plines and in more than 150 countries.

CHAPTER

¢+ e
In This Chapter

Getting acquainted
with AutoCAD

Starting AutoCAD

Creating a new
drawing

Using the AutoCAD

interface

Creating your first
drawing

Saving your drawing

Closing a drawing
and exiting AutoCAD

¢+ o+
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Through a high level of technical innovation and expertise, Autodesk has created a
program with unequaled features and capabilities, including 3D surface and solid
modeling and visualization, access to external databases, intelligent dimensioning,
importing and exporting of other file formats, Internet support, and much more.

The major disciplines that use AutoCAD are:

4 Architectural, Engineering, and Construction (AEC)
4 Mechanical

4 Geographic Information Systems (GIS),

4+ Surveying and Civil Engineering

4 Facilities management

4 Electrical/electronic

4 Multimedia

However, AutoCAD has many other lesser-known uses, such as pattern making in
the garment industry, sign making, and so on.

In this book, I try to provide examples from many fields. The world of AutoCAD is
very broad, and it is worthwhile to see the many approaches that AutoCAD makes
possible.

Starting AutoCAD

This section starts the quick tour of AutoCAD, designed to make AutoCAD look easy
and simple. The first step is to start AutoCAD.

Onthéx‘c-\ The CD-ROM contains a 30-day trial version of AutoCAD 2004. Look in
i c“@"‘ | \Software\AutoCAD 2004.

This book covers AutoCAD 2004 running on Windows 2000, Windows NT 4.0, or

Windows XP/XP Professional. Every computer is set up somewhat differently, so
you may need to adjust the following steps slightly. If you didn’t install AutoCAD
yourself and are unfamiliar with the folders (once called directories) on your

computer, you should get help from someone who is familiar with your computer
system.

g If you need help installing AutoCAD, see Appendix A on the CD-ROM.
Reference
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By default, installing AutoCAD places a shortcut on your desktop, as shown in
Figure 1-1. You can double-click this shortcut to launch AutoCAD. Of course, you
can also choose Start => Programs = Autodesk => AutoCAD 2004 => AutoCAD 2004.

Figure 1-1: An AutoCAD shortcut on the desktop provides a quick
IEEIEI: way to open AutoCAD.

AutaCaD 2004

Creating a New Drawing

After you launch AutoCAD, you are automatically in a new drawing named
Drawingl.dwg. You can see the drawing name on the title bar as shown in Figure
1-2. You can start drawing immediately. In Chapter 2, | explain how to start a draw-
ing based on a template and how to open an existing drawing.

Step-by-Step: Starting AutoCAD

1. Click Start on the task bar at the bottom of your screen.

2. Choose Programs > Autodesk &> AutoCAD 2004 > AutoCAD 2004.
You see a blank drawing named Drawingl.dwg.

If you are continuing on with this chapter, keep this drawing open. Exiting from
AutoCAD is covered later in this chapter.

Using the AutoCAD Interface

New
Feature

You are probably impatient to start drawing. First, though, it helps to get the lay of
the land.

Figure 1-2 shows the screen when you first open AutoCAD. Your screen may look
somewhat different — remember that AutoCAD can be customized in many ways —
but the general features will be the same.

N\ You may see the Tool Palettes window with some sample office furniture and
hatches. The palette is a way to access content that you insert into your drawing. |
cover the Tools Palette in Chapter 26. For now, you can click the palette’s close

button to get it out of the way. (If you want it back, choose Tools => Tool Palettes
Window.)

The AutoCAD screen consists of four important areas. These are discussed in the
next sections.
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Figure 1-2: The AutoCAD screen

The drawing area

The blank area in the middle of the screen, the graphics window, is where you draw.
You can think of this as a sheet of drafting paper, except that this piece of paper can
be any size — even the size of a huge factory!

At the bottom of the drawing area is a tab labeled Model. You draw on this tab. You
use the layout tabs to lay out your drawing for plotting.



Chapter 1 4 Starting to Draw

When you start to draw, you need to specify where to start drawing. One way is to
use coordinates. To specify a coordinate, the universally accepted convention is
to put the X coordinate first, then a comma, and then the Y coordinate. Figure 1-3
shows some coordinates on X and Y axes.

Y axis
-3,5
3,2
0.0 = X axis
-1,-1
6,-2

Figure 1-3: Some X,Y coordinates

r Cross- Chapter 4 is devoted to explaining how to specify coordinates. To create three-
Reference \  jimensional models, you need to add a Z coordinate when specifying a point.

Chapter 21 discusses three-dimensional coordinates.

The UCS icon

Notice the symbol with two arrows at the bottom-left corner of the drawing area in
Figure 1-2. This symbol is called the User Coordinate System (UCS) icon. The arrows
point to the positive directions of the X and Y axes to help you keep your bearings.

{C/msg You can change the look of this icon. (See Chapter 8.)
Reference

The crosshairs

In the drawing area of Figure 1-2, notice the two intersecting lines with a small box
at their intersection. The small box is called the pickbox because it helps you to
pick objects. The lines are called crosshairs. They show you the location of the
mouse cursor in relation to other objects in your drawing.

As you move your mouse around, the pickbox and crosshairs move with your
mouse. At the bottom of your screen, at the left end of the status bar (described
later), you can see the X,Y coordinates changing as you move the mouse.
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New
Feature

The menus and toolbars

At the top of your screen is the title bar, and directly beneath the title bar is a menu
bar. Below that are two rows of toolbars. In addition, your screen has two more
toolbars, the Draw and Modify toolbars, which are probably docked at the left and
right sides of the screen, as shown in Figure 1-2. Use the menus and toolbars
together to give AutoCAD commands to draw, edit, get information, and so on.

Because you can customize the menus and toolbars to suit your needs, your screen
may appear somewhat different. AutoCAD provides many more toolbars that you
can display when you need them. Some examples of the toolbars are Dimension,
Solids, Render, and Zoom. You learn about these and more in this book.

The command line

At the bottom of the screen, you see a separate window showing approximately
three lines of text. (You can change it to show as many lines as you like by dragging
the top edge of the window up or down.) Notice the word Command:. This is the
command line. All commands can be executed by typing them on the command line.

Even if you use a menu item or toolbar button to execute a command, you may
need to look at the command line to see how AutoCAD responds. Often, AutoCAD
provides options that must be typed in from the keyboard. Also, text that you type
appears on the command line. For example, when you type in coordinates specify-
ing a point, they appear on the command line. To see more of the command line,
press F2 to open the AutoCAD Text window. You can scroll back through previous
commands. Press F2 again to close the window.

The status bar

At the very bottom of the screen is the status bar, as shown in Figure 1-2. At the left
are the XY coordinates. As you move your mouse around, these coordinates
change. (If they don’t change, click them and move your mouse again.) The status
bar also sports several buttons that you read about later.

\ _ Attheright side of the status bar is a small down arrow. Click it to open the Status
bar menu. This menu determines which buttons appear on the status bar. If you
don't use a certain button, choose it to remove its checkmark and make it disap-
pear. You can always go back and choose it again to redisplay the button. Also at
the right side of the status bar is the new Communication Center icon. See
Chapter 26 for details.

Also, you can use the Express Tools FULLSCREEN command to hide the Title bar,
menu, and status bar, leaving more room for the drawing area. To return to the
regular display, type fullscreen on the command line and press Enter. See
Appendix A on the CD-ROM for information about installing the Express Tools.
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Creating Your First Drawing

You are now almost ready to draw your first lines. It is worthwhile first to take a
minute to get accustomed to using the toolbars to give AutoCAD a command.

Toolbars

On the Draw toolbar, move the mouse cursor over the first button. You see a
Tooltip that says Line, as shown in Figure 1-4. Also notice the status bar, which tells
you that this button creates straight-line segments.

Figure 1-4: Moving the cursor over the Line button
4 displays a Tooltip.
Line
0]
=
r
@
3¢
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o
>
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AutoCAD Expres=s Tools Co
AutoCAD nenu utilities 1

Command :

Creates straight line segments: LINE
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Tip

If you inadvertently start a command that you don't want, press Esc. The command-
line prompt (Command:) returns.

Drawing a rectangle

For this exercise, simply follow the instructions exactly. When you type the X and Y
coordinates (shown in bold), type the first number, a comma, and then the second
number, with no spaces between them. If you haven’t read the Preface, now is a
good time to go back and read the part that explains how to follow the exercises.
Don’t worry if you don’t understand everything you are doing. It all becomes clear
as you progress through this book.

Follow the prompts shown next. As explained in the Preface, you type what appears
in bold. Instructions to you in command sections appear in italics.

Step-by-Step: Drawing a Rectangle

~ Cross-
Reference

1. Start AutoCAD.

AutoCAD displays the new drawing. (If you are prompted for a template, type
or choose acad.dwt.)

. / With your left mouse button (also called the pick button), choose Line

from the Draw toolbar. Notice that the command name is repeated on the
command line.

Command: _Tine Specify first point: 0,0 4 (This arrow means
to press Enter)

Specify next point or [Undo]: 10,0 4

Specify next point or [Undo]: 10,7 J

Specify next point or [Close/Undo]: 0,7 4

Specify next point or [Close/Undo]: 0,0 o

Specify next point or [Close/Undo]: 4

The command-line prompt appears again, ready for a new command.

. To make the rectangle fill up the screen, type the following, shown in bold:

Command: zoom

Specify corner of window, enter a scale factor (nX or nXP),
or

[A11/Center/Dynamic/Extents/Previous/Scale/Window] <real
time>: e 4

The rectangle is centered and fills most of the screen, leaving a small space at the
edges of the drawing area. The ZOOM command with the Extents (e) option
brings the outer extents of the drawing to the edges of your screen. You read more
about the ZOOM command in Chapter 8.

. Keep your drawing open. You save it later in this chapter. It should look like

the image shown in Figure 1-5.
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[ L

Figure 1-5: Your first drawing

You may be wondering what units the coordinates you typed refer to. For now, you
can think of them as inches, although they can actually be whatever you want. As a
result, you could print out your drawing as a rectangle of 10 inches by 7 inches.

Help! My drawing doesn’t look like the figure

If your drawing doesn't look like the image shown in Figure 1-5, there could be several rea-
sons. To fix the problem, try one of the following options:

4 You may have made a mistake. If you think that's the case, choose File &> New to
start a second new drawing, choose the acad.dwt template and click Open. Then
follow the prompts again.

4 If your drawing still seems wrong, put the CD-ROM that accompanies this book
in your CD-ROM drive. Choose File &> Open and use the Open dialog box to find ab -
acad.dwg on the CD-ROM. Choose ab-acad.dwg and click Open. Then follow the

prompts again.
One of the preceding options should solve your problem. If you began more than one new

drawing, you probably have more than one drawing currently open. You can switch from
one open drawing to another by choosing any open drawing from the Window menu.

11
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You have learned several things —how to start a command by using the toolbar
(the LINE command), how to type in X,Y coordinates on the command line, and
how to end the LINE command (by pressing Enter without typing any coordinates).
You also used the ZOOM command by typing it on the command line. Most of
AutoCAD builds on these basic skills.

Saving a Drawing

Saving a drawing is similar to saving any other file in Windows. You should get in
the habit of saving your work every 10 to 15 minutes to avoid losing your work in
case your computer system crashes.

For your work with this book, you should create a new folder so that you can save
your exercise drawings where they won'’t get mixed up with other drawings.
Although saving is a standard Windows function, I review the steps here because
they are so important.

The following directions leave it up to you where to create this new folder. Each
computer system is organized differently. If you are unsure what to do, choose the
drive (not the folder) where AutoCAD is installed and create a new folder there. I do
not recommend creating a subfolder in AutoCAD’s folder (which by default is called
AutoCAD 2004) because it is too easy to make a mistake and delete necessary
AutoCAD files.

Step-by-Step: Creating a New Folder

1. Move the mouse cursor down to the task bar at the bottom of your screen and
right-click Start. (That means, click the Start button with your right mouse
button.)

2. Choose Explore.

3. On the left pane of Windows Explorer, click the drive where you want to create
the new folder. If you don’t know where to create the folder, choose the drive
where AutoCAD is installed. If you are on a network, choose the drive that rep-
resents your computer.

4. If you want to make a subfolder (a folder within a folder), choose the folder
where you want to create the subfolder.

5. From the Explorer menu, choose File > New => Folder.

A new, highlighted folder, named New Folder, appears in the right pane. You
may have to scroll down to see it.

6. Type AutoCAD Bible for the folder name and press Enter. (If you did the exer-
cises from a previous edition of this book, such as AutoCAD 2002 Bible, and
already have a folder named AutoCAD BibTe, first rename the original folder
to something such as ACAD2002Bible.)
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Now you are ready to save your drawing. Saving a drawing for the first time is differ-
ent from saving it subsequently because you have to name the drawing the first
time you save it. The important point is to save the drawing in the right drive and
folder. You should save this drawing (and all drawings you create by using this
book) in the special folder you created in the exercise just completed.
Caution Creating a folder for your drawings as described in the previous steps is essential
before you go on to exercises in the rest of this book.

To save a drawing, click Save on the Standard toolbar. If you are saving a

drawing for the first time, the Save Drawing As dialog box appears, as shown
in Figure 1-6.

El Save Drawing As B2 %]

Savein |@Automo Bible [v] b @ W Vews v Tos v
Preview
Y
History
My Documents
Favarites
Ty
‘."gf’
FTF
F"“.
@

Desktop

oy
& File name: ‘Drawing].dwg [vl

Buzzsaw Files of type: ‘AutoEAD 2004 Drawing [*. dwg) ["l [

Cancel l

Figure 1-6: The Save Drawing As dialog box

Down the left side of the dialog box are several buttons to help you find a location

to save drawings more quickly. Together, these buttons are called the Places list.
Use the Places list as follows:

4+ History lists shortcuts to recently used drawings.

4+ My Documents lists drawings and folders in the My Documents folder. Some

people store files in this folder. (Your system may call this the Personal
folder.)

4 Favorites lists files and folders in the C: \Documents and Settings\[login
nameJ\Favorites folder. (This is the location in Windows XP; it may be dif-
ferent on your computer.) You may have an AutoCAD subfolder; if so, double-
click the AutoCAD subfolder to save a drawing there. Usually, this folder

13
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Tip

New
Feature

s

contains only shortcuts to files saved elsewhere. To put a shortcut to an
already saved drawing in Favorites, choose File=> Save As and click the Tools
drop-down list; then click Add to Favorites. Then you can later open the file
from the Favorites folder.

4+ FTP sites are locations on the Internet for transferring files. When you choose

FTP, you see FTP sites that you added to the list. To add FTP locations,
choose Tools => Add/Modify FTP Locations from the menu of the Save Drawing
As dialog box. You need to list the name of the FTP site, choose a logon type
(Anonymous or User), and specify your user name and password if you are
logging on as a User. You can then save drawings (called uploading) to FTP
locations. This feature makes an intranet or any server with FTP capability as
accessible as your own computer system.

4 Desktop shows drawings on your desktop. Some of the Windows icons also

appear on this list.

4 Buzzsaw sends you to www.buzzsaw.com, the Autodesk business-to-business

portal for the building design and construction industry. You can set up a new
account or access existing projects.

In a nice touch, you can reorder the buttons in the Places list. Just drag any button
to a new location.

Of course, you can also choose a location from the Save In drop-down list to save
the file to. To save a file, type a file name in the File Name text box and click Save to
save the file.

Use the Views drop-down list of the dialog box to specify how you want to display
files in this dialog box. List just displays the name; Details adds the file size, type,
and date modified; and Preview adds a preview of the drawing.

\

The SAVEALL command of the Express Tools saves all open drawings, without clos-
ing them. If a drawing hasn't been saved, you are prompted for a file name.
Choose Expressc>File tools=> Save All Drawings. For information on installing
Express Tools, see Appendix A on the CD-ROM.

Step-by-Step: Saving a Drawing for the First Time
. The rectangle you created earlier in this chapter should still be on your

screen. Click Save on the Standard toolbar.

The Save Drawing As dialog box opens.

. Click the Save In drop-down list box. If necessary, choose the drive where you

created your AutoCAD Bible folder.

. Double-click the AutoCAD Bible folder you created for this book.

You may need to scroll down to display the folder name.

. In the File Name box, select the file name. Type ab01-01 and press Enter (or

click Save).
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AutoCAD saves your drawing under the name ab01-01.dwg. You can use a different
name if you like, but this will help you organize your drawings from this book. It just
means that this is the first drawing from Chapter 1 of the AutoCAD 2004 Bible.

Onthéﬂ“‘\ The CD-ROM includes a small program, savea . 1sp, that automatically backs up
[ CDW | your drawing to the floppy drive after you have saved it on your hard drive. If you
///.

K like to back up to a diskette regularly for safety, this program can be useful. Look
) in \Software\Chap0l\Savea.

Closing a Drawing and Exiting from AutoCAD

You can close your drawing and keep AutoCAD open. The simplest way is to use the
drawing Close button just under the application Close button. You can also choose
File=> Close.

Tip You can choose Window= Close All to close all open drawings. If any have
., unsaved changes, AutoCAD prompts you to save the changes. If you installed the
4 Express Tools (see Appendix A on the CD-ROM for details), you can choose
Express = File tools > Quick Exit, which closes all open drawings (prompting you
to save if necessary) and then exits AutoCAD. You can also choose Express > File
tools > Close All Drawings to close all drawings without exiting AutoCAD. You are

prompted to save any unsaved changes.

To exit AutoCAD, click the Close (X) box at the top-right corner of your screen. You
can also exit out of AutoCAD by typing quit on the command line and pressing
Enter. Another method is to choose File = Exit.

New N\ If you are in the middle of a command, you can now close a drawing without end-
feati ing the command.

If you have made any changes to your drawing since last saving it, AutoCAD asks
you if you want to save your changes. Choose Yes or No as your situation requires.
Choosing Cancel returns you to your drawing. If you have more than one drawing
open to which you have made changes, AutoCAD asks you about each drawing in
turn so that you will not exit AutoCAD without saving all the changes you have
made in your open drawings.

Step-by-Step: Closing Your Drawing and Exiting AutoCAD

1. The rectangle of ab01-01.dwg should still be on your screen. Choose
File=> Close. You now see a gray screen with no drawing. (Repeat this process
if you have other drawings open. Save or cancel the changes to these extra
open drawings as you like.)

2. Click the Close button in the upper-right corner to exit AutoCAD. AutoCAD
closes immediately.

15
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Summary

Chapter 1 explained how to start AutoCAD and a new drawing. I gave you a tour of
the AutoCAD screen and explained how save a drawing. This chapter provides the
basis for all your work in AutoCAD.

In this chapter, you learned the following:

4 A brief history of AutoCAD

4+ Some of the different disciplines that use AutoCAD
4+ How to start AutoCAD

4 How to start a new drawing

4 The AutoCAD interface and its various sections, including the drawing area,
the UCS icon, the crosshairs, the menus and toolbars, the command line,
and the status bar

4 How to start the LINE command from a toolbar
4 How to end the LINE command
4+ How to draw a rectangle by specifying X,Y coordinates
4+ How to start the ZOOM command by typing it on the command line
4 How to save a drawing for the first time
4 How to close a drawing
4+ How to exit AutoCAD
You may have several questions at this point, but “well begun is half done.”

The next chapter explains all the ways to start a new drawing as well as how to
open an existing drawing.

+ 0+ ¢



Opening a
Drawing

A utoCAD offers a number of options for opening new

and existing drawings. These options create a great

deal of flexibility and save you time as well. You can create
complex templates to avoid doing the same basic setup and
drawing over and over.

Creating a New Drawing
from a Template

-

A template is a special file that contains settings and possibly
objects (such as a title block). When you use a template as
the basis for a new drawing, the drawing takes on all the set-
tings and objects contained in the template. Use templates to
avoid recreating settings and redrawing objects for new draw-
ings. AutoCAD comes with many templates that you can use
as is or customize. You can also create your own templates.

If you have been using AutoCAD 2002, you may be won-
dering, “Where did AutoCAD Today go?” AutoCAD Today
was a window that opened in front of AutoCAD’s main
window and contained tools for opening new drawings.
It's gone! One feature, the window used by CAD Managers
to communicate with AutoCAD users, is in the new
Communication Center (covered in Chapter 26). If you
have been using an earlier version of AutoCAD, you may
have a similar question: “Where is the Startup dialog box?”
The Startup dialog box also offered choices for starting a
new drawing and is still available. Choose Tools > Options
and click the System tab. In the General Options section,
choose Show Startup Dialog Box from the Startup drop-
down list. Click OK to close the Options dialog box.

To create a new drawing based on a template, choose
File=> New to open the Select Template dialog box. AutoCAD
lists all the available templates, as shown in Figure 2-1. Click

CHAPTER

¢+ o+
In This Chapter

Creating a new
drawing from a
template

Opening a drawing
with default settings

Opening an existing
drawing

Using an existing
drawing as a
protfotype

Saving a drawing
with a new name

¢+ o+
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any template to see its preview, if any. Double-click a template to create a new draw-
ing based on that template. Because AutoCAD opens with Drawingl.dwg, the new
drawing is named Drawing?.dwg. Subsequent drawings that you open are named
Drawing3.dwg and so on. After you save and name your drawing, the original tem-
plate file is unaffected.

New \

Feature D

A new command, QNEW, is useful if you always start a new drawing based
on the same template. You set a default template and then click QNew on
the Standard toolbar to start a new drawing immediately, based on that default
template. To set the default template, follow these steps:

. Choose Tools => Options and click the Files tab.

. Double-click the Drawing Template Settings item.

1
2
3. Double-click the Default Template File Name for QNEW item.
4

. Click the listing under the Default Template File Name for QNEW item (which
says None by default).

5. Click Browse to choose the template that you want.

6. Click OK to close the Options dialog box.

You can set whether this default template uses metric or imperial measurement by
setting the MEASUREINIT system variable. (System variables are discussed further
in Chapter 5.) On the command line, type measureinit. Enter 0 . for imperial units
and 1 4 for metric units.

The default template is acad.dwt. Another default template is acad-Named Plot
Styles.dwt, which refers to named plot styles. (See Chapter 17.)

E] Select template (6] %]
Loak i | () Template [v] W e x [,,:,!. Views v Tool w
3 I PTw T emplates ficres
L\ﬁ [ acad -Mamed Plat Siyles. dut
i [ aead dit
ng_tmy [ aeadIS0 -Mamed Plat Styles.dwt
__.-] [ acadiso. dwt
@ AMSI A [portrait] -Calor Dependent Plat Styles. dwt
My Documents @ANSI A [portrait] -Marmed Plat Styles. duwt
n [ ANS1 & -Color Dependent Plot Styles. dwit
% [ ANS1 & -Named Plot Styles.duit
Favarites @ AMSI B -Color Dependent Plat Styles, dwt
- @ANSI B -Named Plot Styles.dwt
YB%; @ANSI C -Colar Dependent Plot Styles. dwt
[ ANSI C Named Plat Styles.dit
FTP [7%F ANS1 D -Color Dependent Flot Styles.dwt
@ (29 ANS1 D -Mamed Plat Styles. dwt
2m| [2]
Deskiop
a
W e [t [v] [ Geen )]
Buzzsaw Files of type: ‘ Dirawing Termplate [ dwt] [vl

Figure 2-1:
dialog box.

Choose a template from the Select template
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Step-by-Step: Opening a Drawing Based on acad.dwt
1. Start AutoCAD.

2. Choose File=> New.

3. From the Select Template dialog box, choose acad.dwt from the list.

You now have a blank drawing named Drawing?2.dwg, as shown in Figure 2-2.
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o -
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A
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W4k M\ Model { LayoutT [ Layout? &) [l
ButoCAD Ezpress Tools Copyright © 2002-2003 Autodesk, Inc [A
LutoCAD menu utilities loade ~
[Cannand [Sw] @]
26,6441, 8.4683 _0.0000 SNAP| GRID| ORTHO [PoL&R [osnap [aTRACK LwT|[MODEL %

Figure 2-2: When you create a drawing based on a template, AutoCAD opens a
drawing called Drawing?.dwg.

Working with Templates

A template contains ready-made settings to get you started drawing quickly. These
settings include the size of the drawing (called limits), the unit type (such as deci-
mal or feet and inches), and others. An important part of setting standards in an
office where people work together on drawings is the creation of a template so that
all users work with an identical setup.

A template may contain more than just settings — it often contains a complete title
block, for example, and may include boilerplate (standardized) text as well.
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Customizing the default template

Most people customize the default template to create one or more templates that
suit their particular needs. Once your templates are created, you don’t have to
worry about most settings; they are already available for you and you can quickly
start to draw.

To customize acad.dwt, follow these steps:

1. Open a drawing based on the template as described in the previous section.
2. Make any changes you want.

3. Click Save on the Standard toolbar.

4,

In the Save Drawing As dialog box, click the Files of type drop-down list box.
Choose AutoCAD Drawing Template (*.dwt). In the list of template files,
choose the template that you want to customize. Click Save.

[2)]

. When asked if you want to replace it, click Yes.

6. In the Template Description dialog box, revise the description as you like and
click OK.

Without templates, you would have to set up your drawing each time you start a
drawing — a time-consuming project. The use of templates over time saves hours of
work and improves consistency.

Caution Don’t change templates that come with AutoCAD if you are using someone else’s
computer without first checking with that person. It can be a frustrating experience
to start a drawing based on a template and find that all the settings have been
changed.

Creating your own templates

You may want several templates to choose from on a regular basis. For example,
you may create drawings of several sizes. AutoCAD lets you create as many tem-
plates as you want. To create your own templates, either start a drawing based on a
template and make the changes you want, or open an existing drawing that already
has some of the settings you want and make any further changes you need. Follow
these steps:

1. If you start a new drawing based on a template, choose Save from the
Standard toolbar. If you open an existing drawing, choose File > Save As from
the menu.

2. In the Save Drawing As dialog box, click the Files of type drop-down list box.
Choose AutoCAD Drawing Template (*.dwt).

3. In the File name text box, type a name for your template. Click Save.
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4. In the Template Description dialog box, enter the description as you want.
Click OK.

Name your templates in a way that clearly differentiates them from regular draw-
. ings. You may want drawings set up for each of the standard paper sizes

A through E), with a title block in each. Useful names might be tb-a.dwt, tb-b.

dwt (tb meaning title block), and so on.

Most AutoCAD users take advantage of these techniques as a standard practice.
You can usually make profitable use of a template as the basis for a new drawing.

Opening a Drawing with Default Settings

Occasionally, you want to open a drawing without any settings. It is actually impos-
sible for a drawing to have no settings at all, but you can open a drawing with the
minimum possible presets. You might want to do this if you are working on some-
one else’s computer and don’t want to take the time to get rid of a large number of
complex settings that are not helpful for your work.

To open a drawing with the fewest possible settings, choose File=> New. Instead of
choosing a template, click the arrow to the right of the Open button. (See Figure 2-1.)
Choose one of the following options:

4 Open with no template — Imperial

4 Open with no template — Metric

Opening an Existing Drawing

New
Feature

Often you need to open an existing drawing, either to complete it or make changes.
Opening a drawing in AutoCAD is like opening a file in any Windows program. You
can find existing drawings by name or by viewing a thumbnail image of the drawing.

+ Choose Open from the Standard toolbar. The Select File dialog box appears,
shown in Figure 2-3. In the Look in drop-down list box, choose the drive where
your drawing resides. In the main box, double-click the folder you need. Then
choose your drawing. The Preview box enables you to quickly look at the drawing
to see if it’s the one you want. Click Open. AutoCAD opens the drawing.

N\ If you have Windows XP, you can view thumbnail images of all the drawings in a
folder in the Select File dialog box (and other dialog boxes that enable you to
choose a file) by clicking the Views button and choosing Thumbnails. In all oper-
ating systems, you can view thumbnails in Windows Explorer in the same way —
by clicking the Views button and choosing Thumbnails.
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Figure 2-3: The Select File dialog box is equivalent to the
Open dialog box in most Windows programs.

Drawings created and saved in Release 12 or earlier versions of AutoCAD do not
~  show previews. Drawings created in Release 13 and later have previews unless
this feature has been disabled.

Q To look for a file to open on the Web, click the Search the Web button in the
dialog box. You can also use the Places list at the left side of the dialog box to
find drawings. The Places list is described in Chapter 1 for the Save As dialog box.

You can also double-click a drawing in Windows Explorer to open it. If AutoCAD is
not running, Windows loads AutoCAD and the drawing as well. If AutoCAD is run-
ning and a drawing is active, the drawing opens as a second drawing within
AutoCAD.

You can also open a drawing from the DesignCenter — a feature for managing

4l both drawing files and many of their components. First, choose DesignCenter
from the Standard toolbar. AutoCAD opens the DesignCenter palette, displaying an
Explorer-like list of drawings in the left pane. If necessary, choose Desktop from the
DesignCenter toolbar. Navigate to the folder containing the drawing and choose the
drawing’s folder in the left pane. The drawings in the folder are listed in the right
pane. Right-click the drawing of your choice and choose Open in Application
Window.

in more detail.

@ Chapter 26, as well as other chapters throughout this book, covers the DesignCenter
ererence
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You can use several shortcuts when working in dialog boxes that open or save files,
as follows:
4 Double-click the drawing file to open it immediately without clicking Open.

4 Click the Views drop-down list. Choose List to see a simple list. Choose Details
to see file size and the last date and time the file was saved.

4 Right-click inside the dialog box to open a shortcut menu with more options.

4 Click the name of a drawing to highlight it and then click it once more to
rename it (but don’t double-click it —that opens the drawing).

On the The drawing used in the following Step-by-Step exercise on opening a drawing,

\

,cnw | ab01-01.dwg, is in the Results folder of the AutoCAD 2004 Bible CD-ROM.

/ Place the CD-ROM in your CD-ROM drive.

Step-by-Step: Opening a Drawing
1. If AutoCAD is not open, start AutoCAD.
2. Lﬁ.‘ Click Open on the Standard toolbar.

3. In the Select File dialog box, choose the drive for your CD-ROM in the Look in
drop-down list box.

4. In the main box, double-click the Results folder.
5. In the main box, click ab01-01.dwag.

6. Click Open. AutoCAD opens the drawing. Keep this drawing open for the next
exercise.

Using an Existing Drawing as a Prototype

While a template can be very useful, if you plan to use the objects and settings in a
drawing only a few times, you can simply use one drawing as a prototype for other
drawings. You often need to draw a series of related drawings — perhaps several
related electrical schematics or a group of similar apartments in an apartment com-
plex. When a significant part of the first drawing is applicable to subsequent draw-
ings, don’t start over — open an existing drawing, and immediately save it under a
new name, as described in the next section. Make the necessary changes and
resave the drawing.

Saving a Drawing Under a New Name

Whether you want to use an existing drawing as a prototype or simply make a copy
of a drawing, you need to save the drawing under a new name. First open the draw-
ing and then choose File &> Save As.
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In the Save Drawing As dialog box, type a new name in the File Name text box. Then
click Save. You may also want to change the location of the new drawing by chang-
ing the folder in the Save in drop-down list box.

On the In the following exercise, you practice making changes in a drawing as well as sav-
iCD' | ing the drawing under a new name. If you did the previous exercise, you have
K /,-" drawing ab01-01.dwg on your screen. If you didn't do that exercise, open

-_— ab01-01.dwg from the Results folder of the CD-ROM.

Step-by-Step: Saving a Drawing Under a New Name
1. Choose File> Save As. The Save Drawing As dialog box opens.

2. In the File name text box, change the file name to ab02-01.dwg. Choose your
AutoCAD BibTle folder and click Save.

3. Choose Line from the Draw toolbar. Follow the prompts:

Specify first point: 10,.5 4

Specify next point or [Undo]l: 6,.5
Specify next point or [Undo]: 6,0
Specify next point or [Close/Undo]: 4

Your drawing should look like Figure 2-4.

N
i

Y

Figure 2-4: A simple title block
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4. Click the drawing Close box, which is just below the application Close box.

5. Because you haven’t saved the changes to the drawing, AutoCAD asks if you
want to save them, as shown in Figure 2-5.

(AutoCAD

!} Save changes to ChAUtoCAD Biblelab02-01. dwy?

|

Figure 2-5: If you try to exit AutoCAD
without saving the changes you made
to a drawing, AutoCAD gives you a
chance to save the changes.

6. Click Yes. AutoCAD saves and closes the drawing.
7. Click the application’s Close box (X) to close AutoCAD.

Summary

In this chapter, you explored the various ways of opening a drawing. You learned
the following:

4 Starting a new drawing based on a template

4 Customizing a template

4 Creating your own templates

4 Starting a new drawing with no template

4 Opening an existing drawing

4+ Using an existing drawing as a prototype for a new drawing

4 Saving a drawing under a new name
In the next chapter, you read about using commands.

+ 0+ ¢
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Using )
Commands

A s a result of AutoCAD’s long history, the way you give
AutoCAD commands — called the user interface —is

somewhat unique. You can give the same command in several
ways. In this chapter, you read about the various possibilities
and start to feel comfortable with all of them.

Commands are important because you can’t do anything in
AutoCAD without executing a command. In a word processing
program, you can simply start typing; in a spreadsheet pro-
gram, you can begin by entering data; but nothing happens in
AutoCAD until you give it a command.

The Windows Interface

Many new commands have been added to AutoCAD over the
years. Often, older commands that were no longer necessary
were kept to maintain compatibility with earlier versions. In
most Windows programs, all commands are included in the
menus, but in AutoCAD a number of these older commands,
as well as certain rarely used commands, are not found in the
menus. Other than this idiosyncrasy, AutoCAD’s menus are
similar to those of other Windows programs.

Using AutoCAD’s menus

A menu item can do three things. As in all Windows programs,
the menu provides clues to let you know what is going to
occur after you click a menu item. Table 3-1 explains how this
works.

¢+ o+
In This Chapter
The Windows

interface: Using
AutoCAD’s menus,
dialog boxes, and
toolbars

Working with the

command line

Repeating and
canceling commands

Undoing and redoing
commands

Executing a
command within
another command

Executing two
commands
concurrently

Using AutoCAD's
help system

¢+ 4+
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Table 3-1
Menu Symbols and What They Mean
Symbol Menu Action
No symbol appears  Executes a command after the menu item
... (ellipsis) Opens a dialog box
T Displays a submenu

The View menu, shown in Figure 3-1, includes all three types of menu items.

Displays submenu with more options

View

Redraw
Regen
Regen All

Foom +
Pan +
Aerial View

Viewports 4
Named Views...
3D Views *
3D Orhit

Hide
Shade *
Render 4

Display +
Toolhars... |

Opens a dialog box

Executes a command

Figure 3-1: The View menu
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The screen menu

In early releases, AutoCAD provided a menu on the right side of the screen, called the
screen menu. If you are still used to the screen menu, | suggest that you adjust to the new
interface. You will find its consistency with other Windows programs to be an advantage.

If you must have the screen menu, you can easily display it. Choose Tools => Options. Click
the Display tab. In the Window Elements section, choose Display screen menu. Click OK.

AutoCAD’s current default is to not show the screen menu, so | do not use it in this book.
Therefore, the word “menu” always means the pull-down menu at the top of the AutoCAD
screen.

On the The drawing used in the following Step-by-Step exercise on using a submenu,
ICD' ab02-01.dwg, is in the Results folder of the AutoCAD 2004 Bible CD-ROM.
-

Step-by-Step: Using a Submenu
1. Open ab02-01.dwg from the Results folder of the CD-ROM.

2. Choose the View menu and point to the Zoom menu item. The submenu
opens.

3. Move the mouse pointer over to the submenu. You now have a choice of a list
of ZOOM command options.

4. Choose Out from the submenu. The title block gets smaller, as if you have
zoomed out using a camera lens.

Do not save this drawing.

Looking at the command line whenever you click a menu option is worthwhile. The
Z0OOM command is repeated on the command line, and a list of options appears.
Notice that they are mostly the same as those on the submenu, with some minor
differences. For example, the Out option that you just used is not available on the
command line. This option is actually equivalent to using the Scale option that
appears on the command line with a value of 0.5x. AutoCAD’s menu sometimes
offers preset options of commands to make your work simpler.

Using shortcut menus

AutoCAD’s shortcut menus appear when you right-click your mouse. The purpose
of shortcut menus is to speed up your work; they can be faster than using the com-
mand line because you don’t have to take your eyes off the screen. The shortcut
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New
Feature

menus try to anticipate the most common tasks you might want to complete. As a
result, the menu that appears when you right-click depends on the situation:

4 If you have neither started a command nor selected any objects, you get the
default menu when you right-click in the drawing area. Here you can cut, copy,
paste, undo, pan, zoom, and so on.

4+ If you have selected any objects, you see the edit-mode menu, which lists the
most common editing commands.

4 If you have started a command, the command-mode menu opens, letting you
choose an option for that command. I explain this in more detail later in this
chapter.

4 When a dialog box is open, you can right-click active sections to see the
dialog-mode menu, which varies with the dialog box.

4 Other menus include the toolbar list you get when you right-click a toolbar
and the command-line history you see when you right-click the command line
and choose Recent Commands.

These menus are explained as appropriate throughout the book. You also have an
opportunity to use many of them in the exercises.

In earlier releases, right-clicking was equivalent to pressing Enter. You can cus-
tomize how right-clicking works — and that includes changing it back to the way it
worked in older releases. Choose Tools > Options and choose the User Preferences
tab. Then click “Right-click Customization.” For complete details, see Appendix A
on the CD-ROM.

N\ When you set right-click customization, you can turn on time-sensitive right-clicking.
Time-sensitive right-click is a great new feature that gives you the best of two
worlds — the right mouse button can be used both as equivalent to pressing Enter
and to open the shortcut menus.

If you turn on time-sensitive right-clicking, a quick right-click is equivalent to press-
ing Enter and will repeat the last command, for example, or end the LINE command
(and other commands that require Enter to end). A longer right-click (hold your
finger on the mouse slightly longer) opens the shortcut menu. You can specify the
length of time required for the longer right-click, which is 250 milliseconds by default.

Using dialog boxes

Dialog boxes offer the user a simple way to control AutoCAD without memorizing a
lot of technical command and option names. They guide you through a task by
clearly laying out all the choices.

If you're familiar with any other Windows program, you're familiar with dialog
boxes. AutoCAD, because of its complexity, has some complicated dialog boxes.
Nevertheless, you will find that navigating through them is a familiar experience.
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As a brief example, look at the Drawing Units dialog box, (Choose Format ©> Units),
which enables you to define the types of units that AutoCAD uses in your drawing.
It has most of the features you see in AutoCAD’s dialog boxes and is shown in

Figure 3-2.
Pe =
E] Drawing Units (3]
Length Angle
Type: Type:
|Decimal [v]  |Decimal Degrees v
Precision: Precision;
[00000 [« o v
[ Clockwise
Drag-and-drop scale
Unitz to scale drag-and-drop content:

Sample Dutput

1.5000,2.00:39,0.0000
3.0000¢45,0.0000

Ok }[ Cancel ][

Direction. .. I [ Help

Figure 3-2: The Drawing Units dialog box is
typical of many AutoCAD dialog boxes.

Step-by-Step: Using a Dialog Box

1. Choose File> New. In the Select Template dialog box, click the down arrow
next to the Open button and choose Open with No Template — Imperial to
start a new drawing.

2. Choose Format => Units. The Drawing Units dialog box opens. Notice the two
sections called Length and Angle.

3. The default length unit is Decimal. From the Type drop-down list, choose
Architectural. Notice how the display of units in the Sample Output box

changes.

4. Choose each type of length unit and watch how the Sample Output changes.

5. Choose the Decimal length type again from the drop-down list.

6. Click the Precision drop-down list box in the Length section. The default preci-
sion is four decimal places (0.0000). Choose two decimal places (0.00).

7. Now choose various Angle Type options in the Angle section of the dialog
box. The angle type determines how angle measurements are shown. Watch
the change in the Sample Output box.

8. Choose the default again, Decimal Degrees.

9. In the Precision drop-down list box, choose two decimal places.

10. The Direction button at the bottom of the dialog box has an ellipsis (. . .).
This has the same meaning for dialog boxes as it does for menus — it opens
another dialog box. Click Direction. The Direction Control dialog box opens.
This dialog box enables you to change the standard convention that East is
degrees, North is 90 degrees, and so on.

31
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11.

12.

13.

14.

Click Cancel because you don’t want to change these conventions. You return
to the Drawing Units dialog box. Note that you can click Clockwise in the
Angle section of the dialog box to change the convention that angles increase
counterclockwise.

In the Precision drop-down list box for Angles, choose 0 to return this specifi-
cation to its original setting. You may have to scroll up. (If your setting was
different from the default, return it to the way it was when you opened the dia-
log box.)

In the Precision drop-down list box for Length, choose 0.0000 to return this
specification to its original setting. (If your setting was different from the
default, return it to the way it was when you opened the dialog box.)

Click OK. (If you have any doubt that all settings have been returned to the
way they were originally, click Cancel.)

Tip If a dialog box has a question mark (?) icon in the top-right corner, click it to
», change the cursor to a question mark. Then click any item in the dialog box to dis-
4 play a brief explanation of that item.
Using toolbars

Toolbars provide a quick way to execute a command with one click of the mouse.
On the other hand, those little pictures on the toolbar buttons are not always self-
explanatory. Until you get used to the location of the buttons, you may find yourself
wandering (with the mouse cursor) from button to button, reading tooltips.
However, once you are familiar with the location of frequently used toolbar buttons,
toolbars may become a favorite way to execute commands.

New \
Feature

All the toolbar buttons have been redone for AutoCAD 2004, creating a whole
new look. The main toolbars are changed as well, offering a slightly different selec-
tion of buttons and adding new toolbars that are displayed by default.

By my count, AutoCAD provides 28 toolbars. Normally, you have the Standard,
Styles, Layers, Properties, Draw, and Modify toolbars showing. You can open other
toolbars as you need them.

- Cross-
Reference

You can customize toolbars to suit your needs. You can also create your own tool-
bars from scratch, perhaps containing your favorite command combinations.
Toolbar customization is covered in Chapter 29. To see all the toolbars and what
their buttons do, see Appendix B on the CD-ROM.

To display a toolbar, right-click any toolbar and choose the toolbar you want to dis-
play. Displayed toolbars have a check next to their names. To hide a toolbar, follow
the same procedure — choose the toolbar. You can also choose View > Toolbars to

open the Toolbars dialog box. Check or clear a toolbar and click OK.



Chapter 3 4 Using Commands 33

As soon as a toolbar is open, you can close it by clicking the Close button at the
upper-right corner, as long as it is not docked —that is, parked at one edge of the
screen. Toolbars can also float in the drawing area or even outside the AutoCAD
window (when it is not maximized). You can move them by dragging them and
reshape them by dragging any edge. Docked toolbars have grab bars (that look like
a double line), which enable you to easily undock and move the toolbars.

New N\ To close all the toolbars and palettes, press Ctrl + 0. You now have more space to
featis draw. To get back your toolbars and palettes, press Ctrl + 0 again.

In this exercise, you practice manipulating toolbars. This exercise can be done with
any drawing on-screen.

Step-by-Step: Manipulating Toolbars

1. Point to the grab bar at the top edge of the Draw toolbar. With the mouse
pointer, click, hold down the mouse button, and drag the toolbar until its out-
line is under the left side of the Layers toolbar (the leftmost toolbar under the
Standard toolbar) and it changes to a straight horizontal line. After you
release the mouse button, the toolbar docks under the Layers toolbar.

2. Click the Modify toolbar’s grab bar and drag it in the same way you did the
Draw toolbar until it is docked under the Properties toolbar (which is to the
right of the Layers toolbar). Your screen should look something like Figure 3-3.
(If your screen resolution is 800x600, the toolbar won’t be completely visible.
Instead, you can dock it under the Draw toolbar.)

3. To try another configuration, click the grab bar at the left edge of the Draw
toolbar. Drag the toolbar to the left side of the screen until the dotted shape
shows a one-column vertical toolbar.

1 AutaCAD 2004 - [DrawingT.dwg] o=
File Edit View Insert Format Tools Draw Dimension Modify Express Window Help -8 x|
ODHA SRR «D6 s £ URXARX BER @ | & et [v] s [v]
=[(O0® DR [v]% € ||| mepaer =l Byl ||| Bilayer v

/20070 ondn - HEA [JBAEHESODF/OIOY &
Figure 3-3: Docking the Draw and Modify toolbars at the top of the screen

4. In the same way, drag the Modify toolbar to the right of the Draw toolbar. Your
screen should look like Figure 3-4. (This configuration is similar to the way
toolbars appeared by default in AutoCAD 2002.)
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Figure 3-4: Docking the Draw and Modify toolbars at the left side of the screen

. Right-click any open toolbar. Choose Dimension to display the Dimension tool-

bar, which provides tools to enable you to show measurements in your draw-
ing. It may be a single line of icons or a rectangular arrangement. If it’s
docked, click the grab bar and drag it to the drawing area.

. Point to the fourth button. The tooltip says Radius Dimension. This button

enables you to create a dimension showing the measurement of the radius of
a circle.

. With the mouse, point to the bottom edge of the toolbar until the mouse cur-

sor takes the shape of a double-headed arrow.

8. Click and drag upward and/or downward. The toolbar changes shape.

9. Drag the Dimension toolbar by its title bar down to the bottom edge of the

drawing area until its outline becomes a dotted horizontal bar. The Dimension
toolbar docks at the lower edge of the screen, as shown in Figure 3-5. You
don’t have as much screen space as before, but the toolbar is off the drawing
area.
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Figure 3-5: The Dimension toolbar is docked at the bottom of the screen.

10. To close the Dimension toolbar (which you do after you finish placing dimen-
sions in your drawing), drag it by its grab bar onto the drawing area and click
the Close button at the right of its title bar.

11. You may leave the Draw and Modify toolbars where they are or return them to
their original positions; it’s up to you.

As you can see, it’s worth the time to learn how to move, dock, display, and hide
toolbars. This small effort can greatly increase your comfort level as you draw in
AutoCAD.

The Command Line

You have already seen how every command you give AutoCAD is echoed on the
command line, although sometimes with slightly different words, syntax, and
options. You have also given a command by typing it directly on the command line
(the ZOOM command in Chapter 1).
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Understanding command names

All commands have a special one-word command name. This may or may not be
the same as the wording that appears on the toolbar’s tooltip or on the menu. But
you can be sure of one thing— every command can be executed by typing its name
on the command line. Fast typists often prefer to use the command line because
they find it faster than searching for a command on a menu or toolbar. Most users
use a combination of command line, menu, and toolbar commands.

Some of the commands are easy to type, such as LINE or ARC. Others are long and
harder to remember, such as HATCHEDIT, DDPTYPE, or IMAGEATTACH. Command
names such as these can quickly drive you to use a menu or toolbar.

names, called aliases. Several are already included with AutoCAD. Aliases are cov-
ered in Chapter 29.

@ If you like typing commands, you can create short versions of the command
eference

You can edit what you have typed on the command line. If you type a long com-
mand and make a mistake, you can backspace up to the mistake and retype the last
part correctly. Table 3-2 shows how to use the keyboard edit keys to edit the com-
mand line.

Table 3-2
Command-Line Editing Keys
Key Function
Backspace Backspaces through the text on the command line, erasing each
letter as it backspaces.
Left arrow Moves backward through the text of the command, without erasing.
Right arrow Moves forward through the text of the command, without erasing.
Home Moves the command-line cursor to the beginning of the text.
End Moves the command-line cursor to the end of the text.
Insert Toggles between Insert/Overwrite mode. Insert mode inserts text.

Overwrite mode types over existing text. Note that there is no visual
confirmation of which mode you are in.

Delete Deletes the character to the right of the cursor on the command line.

Ctrl+V Pastes text from the Windows clipboard.

You can scroll through and reuse previous command-line entries. To repeat the last
line you entered, press the up arrow. Press Enter to execute it. To see more of the
command-line entries, press F2 on your keyboard to open the text screen. Scroll
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until you find the entry you want, highlight it, and then right-click and choose Paste
To CmdLine from the shortcut menu. AutoCAD pastes the highlighted text into the
current command line. You can also copy selected text from the command-line his-
tory or the entire history to the clipboard. Or choose Recent Commands on the
shortcut menu and choose one of the commands from the submenu that appears.

Switching from the mouse to the keyboard and back is time-consuming. In gen-

_»,eral, if you are picking points by using the mouse (covered in Chapter 4), using

menus and toolbars to give commands is faster. If you are typing coordinates as
you did in Chapter 1, your hands are already at the keyboard, so typing commands
at the keyboard is easier.

Responding to command options

Many commands have a number of options from which you need to choose. The
format for command options is as follows:

current instruction or [options] <current value>:

The current instruction explains what you need to do. For example, if you choose
an editing command, AutoCAD usually instructs you to “Select objects.” The text in
the square brackets lists the various options available for the command. The
angled brackets tell you the current or default value for the command, if any.

Choosing an option is easy:

4 To choose an option on the command line, type the one or two letters that are
capitalized in the option name — usually (but not always) the first letter(s) of
the option. You can type the letter(s) in lowercase. Press Enter.

4+ To choose a default option or current value on the command line, which
appears in angled brackets, as in <Real time>, simply press Enter or provide
the point or value required.

4 To choose an option without going to the command line, right-click in the
drawing area and choose one of the options from the shortcut menu. This
works best for options that won’t need any numerical input on the command
line. Choosing options from a shortcut menu on the screen is an example of
heads-up drawing, which increases efficiency because you don’t need to stop
to look down at the keyboard.

At this point, additional options may appear, or you may be prompted to select a
point or an object.

In the following exercise, you practice using command options. In Chapter 1, you
typed coordinates to specify points. Here you pick points on the screen directly
with the mouse.
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,,r‘\lote

Step-by-Step: Using Command Options
1. Open a new drawing by using the acad. dwt template.

2. ‘I,-- Choose Arc on the Draw toolbar.

3. Look at the command line. You see the following prompt:

Specify start point of arc or [Center]:

Specifying the start point is the main instruction, but you have an option to
specify the center of the arc. Move the mouse cursor anywhere in the middle
of the screen and click to specify the start point. This is called picking a point.

4. Now you see the following prompt:

Specify second point of arc or [Center/End]:

Say that you want to specify the end of the arc. Because specifying the second
point is the main instruction, right-click to display the shortcut menu, shown
in Figure 3-6, and choose End, one of the options. AutoCAD responds with the
Specify end point of arc: prompt.

Figure 3-6: Using the shortcut menu to choose the End option of
the ARC command

5. Pick another point on the screen fairly close to the first one.

6. At the Specify center point of arc or [Angle/Direction/Radius]:
prompt, type r .

7. At the Specify radius of arc: prompt, type 2 . AutoCAD creates the arc
and the command ends. Don’t worry at this point if the arc is partly off the
screen or doesn’t appear as you expect. (It’s possible to pick two points for
the arc that can’t have a radius of 2. If this happens, try again with two differ-
ent points.)

Do not save this drawing.

You may have noticed that AutoCAD places an underscore (_) before each com-
mand. This mark allows translation to foreign languages and can be ignored.
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Sometimes a command has so many options that AutoCAD opens a dialog box. This
method offers a more structured way of letting you choose command options.

Command Techniques

Tip

Tip

To make working with commands easier, AutoCAD offers shortcuts for repeating
and canceling commands as well as sophisticated undo and redo options. You can
also use certain commands after you have started another command.

You can have more than one command in process concurrently, one in each open
drawing. You can switch from one open drawing to another without interrupting
your commands. For example, if you are in the middle of drawing a circle in one
drawing, you can open a new drawing and start another command to get some
information you need for the circle. Then return to the first drawing and complete
the circle.

Repeating commands

The most common way to repeat a command you have just used is to press Enter at
the Command: prompt. The most recent command appears again.

You can also press the Spacebar at the Command: prompt to repeat a command

% you just used. This technique works well if you want to keep one hand on the

4 mouse and use the other hand to press the Spacebar.

If you create a toolbar button that executes a customized set of actions, right-click

_», torepeat the action of the toolbar button. You cannot press Enter to get this effect.

“ 7%

If you know in advance that you will be using a command several times, you can use
another technique —type multiple . At the Enter command name to repeat:
prompt, type the command name on the command line. The command automati-
cally reappears on the command line until you press the Esc key. For example, you
could type multiple and then arc if you knew you were going to draw several arcs
in a row. To stop repeating the command, press Esc.

Canceling commands

Sometimes you start a command and then realize you don’t need it. In this situation,
you can cancel the command and then choose a different command. Press Esc to
cancel a command that you have already started. The Command: prompt reappears.

In the following exercise, you practice the techniques for repeating and canceling
commands.
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Step-by-Step: Repeating and Canceling Commands
1. Start a new drawing by using the acad.dwt template.
2. Choose Circle on the Draw toolbar.

3. At the Specify center point for circle or [3P/2P/Ttr (tan tan
radius) ]: prompt, pick a center point anywhere near the center of the
screen.

4. At the Specify radius of circle or [Diameter]: prompt, move the
mouse cursor and click the pick button when you see a medium-sized circle.
AutoCAD draws a circle.

5. Press Enter. The CIRCLE command appears again.
6. Follow the prompts below:

Specify center point for circle or [3P/2P/Ttr (tan tan
radius)]: Right-click and choose 2P from the shortcut menu.
Specify first end point of circle's diameter: Pick any point
on the screen.

Specify second end point of circle's diameter: Press Esc.

AutoCAD responds with *Cancel* and returns you to the Command: prompt
without finishing the command that was in progress.

Do not save this drawing.

Undoing a command

Most Windows applications offer Undo and Redo commands on the Standard tool-
bar. AutoCAD is no different. Some applications remember a list of your last few
actions so that you can undo them one by one. AutoCAD remembers every com-
mand you execute starting from the time you open a drawing. You can therefore
undo every action and return your drawing to its condition when you opened it.

The Undo button on the Standard toolbar now lists the commands you have exe-
cuted so that you can quickly see how many commands you want to undo.

Actually, AutoCAD has a few obvious exceptions. For example, if you print a draw-
ing, you can’t unprint it, and you can’t unsave a drawing, either. Similarly, com-
mands that provide you with information, such as the coordinates of a point,
cannot be undone.

Some commands have their own undo options.
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f _ Each time you click Undo on the Standard toolbar, AutoCAD undoes one

command. If you click the down arrow to the right of the Undo button and
choose the bottom-most command, you undo all the commands and get the
message:

Everything has been undone

The UNDO command offers several additional options on the command line. When
you start UNDQ, you see the following options on the command line:

Enter the number of operations to undo or
[Auto/Control/BEgin/End/Mark/Back] <1>:

Enter the number of operations to undo is the default instruction. If you
type a number, such as 3, AutoCAD undoes your last three commands. This action
is equivalent to choosing the third command on the Undo button’s drop-down list.
Table 3-3 explains the other options:

Table 3-3
Options of the UNDO Command
Option How to Use It
Auto Can be On or Off. Applies to a menu item that executes more than

one command at a time. When Auto is On (the default), the entire
menu item is undone in one step. When Auto is Off, UNDO undoes
each step one at a time.

Control Offers three sub-options. All, the default, gives you the full UNDO
capability. None disables the UNDO command. One enables you to
undo only one step at a time, effectively turning the UNDO
command into the U command.

Begin Works with the End option. This starts a group at the current point of
the list of commands. Then, when you use the End option, UNDO
undoes all the commands in the group. The U command also
undoes everything within a group.

End Marks the end of all commands in the group created by using the
Begin option.
Mark This option works with the Back option. It is somewhat similar to the

Begin option, but you can place several marks as you work.

Back When you use this option, AutoCAD undoes only to the most recent
Mark point. The next Back option you use undoes to the Mark point
before that.
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‘\lote The word Group means that a group of commands is being undone. However,
~  sometimes the word Group is used even for a single command. This use of the
word Group is not significant and can be ignored.

Using the Back option when no Mark has been created undoes everything you have
done in a drawing session! Luckily, AutoCAD warns you with a message:

This will undo everything. 0K? <Y>
Type n  if you do not want to undo everything.

Tip The Begin/End and Mark/Back options are useful when you are trying something
% new and want to be able to undo a whole series of commands in one UNDO com-
4 mand in case things don't work out as planned.

Redoing a command

If you undo a command, you might realize that you want to undo the undo. This is
called redoing a command. Don’t confuse redoing a command with repeating a com-
mand. Redoing only applies when you have just undone a command.

’1 _ The new MREDO command redoes the effect of the previous UNDO
commands.

New N\ AutoCAD 2004 introduces the ability to redo multiple UNDO commands. You can

Reati choose recently undone commands from the Redo drop-down list. The old REDO
command that only redoes one command still exists, but the Redo button on the
Standard toolbar executes the new MREDO command that redoes multiple UNDO
commands.

In the following exercise, you practice using the UNDO and MREDO commands.

Step-by-Step: Undoing and Redoing Commands

. Start a new drawing by using acad.dwt as the template.

. Choose Line on the Draw toolbar.

. Draw one line and press Enter to end the command.

. Choose Arc on the Draw toolbar.

. Using the default options, pick any three points to draw an arc.

. Choose Circle on the Draw toolbar.

N O U1 AW N

. Pick one point to be the center of the circle and another nearby point to spec-
ify the radius. Your drawing now contains a line, an arc, and a circle, and looks
something like Figure 3-7. Of course, your objects will look different because
you picked different points.
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8. f _ Click the Undo button on the Standard toolbar. The circle disappears.

9. Click the down arrow to the right of the Undo button on the Standard toolbar.
Choose Line. The arc and the line disappear.

10. N - Click the down arrow to the right of the Redo button on the Standard
toolbar. Choose Circle. All three objects reappear because they were
undone by the previous UNDO commands.

Do not save this drawing. If you are continuing on, keep the drawing on the
screen for the next exercise.

/@

Figure 3-7: Your drawing should contain
a line, an arc, and a circle.

even if you have used other commands in the meantime. See Chapter 18 for fur-

@ The OOPS command restores the most recently erased object or set of objects,
eference

CD-

ther information.

Using one command within another command

Certain commands can be used within another command. These are called transparent
commands. After a transparent command is completed, the original command contin-
ues its regular operation. Many transparent commands help you display the drawing
differently so that you can complete the original command easily. Other transparent
commands change settings. In fact, almost any command that doesn’t select objects,
create new objects, cause regeneration, or end the drawing session can be used trans-
parently. When you start transparent commands from toolbars or menus, they are
automatically transparent. If you want to type a transparent command on the com-
mand line, you need to type an apostrophe before the command name.

In this exercise, you practice using transparent commands and two commands
concurrently.

0nthe~\1\ The drawing used in the following Step-by-Step exercise on using transparent

| commands and two commands concurrently, ab01-01.dwg, is in the Results

\ / folder of the AutoCAD 2004 Bible CD-ROM.

43



44

Part | + AutoCAD Basics

Step-by-Step: Using Transparent Commands and Two
Commands Concurrently

1. From the previous exercise, you have a line, an arc, and a circle on the screen.
If not, begin a new drawing using acad.dwt as the template and draw a line
and an arc anywhere on the screen. (You don’t need the circle.)

2. Choose View = Zoom > Out. The drawing zooms out, appearing smaller.

3. Choose Open from the Standard toolbar and open ab01-01.dwg from the
Results folder on the AutoCAD 2004 Bible CD-ROM. This is a drawing of a
rectangle.

4. Click the Window menu and choose your original drawing.
5. Choose Circle from the Draw toolbar. The following prompt appears:

Command: Specify center point for circle or [3P/2P/Ttr (tan
tan radius)]: Pick any point at the center of your screen.
Specify radius of circle or [Diameter]:

6. At this point, say that you want to see the drawing closer up to properly
decide where to place the radius of the circle. Type 'zoom ... The following
appears on the command line. (You may need to press F2 to see the entire
prompt.) Follow the prompts.

>>Specify corner of window, enter a scale factor (nX or nXP),
or

[Al11/Center/Dynamic/Extents/Previous/Scale/Window] <real
time>: 2x J

Resuming CIRCLE command.

Specify radius of circle or [Diameter]:

7. Now suppose that you want the radius to be equal to the height of the rectan-
gle in your other drawing. Choose Window > ab01-01.dwg.

8. Choose Tools = Inquiry = List. At the Select objects: prompt, pick one of
the vertical lines of the rectangle. Press Enter at the second Select
objects: prompt. AutoCAD opens the Text Window and displays some infor-
mation about the line you selected. One piece of information is the length,
which is 7 units.

9. Click the Window menu and choose your other drawing.

10. Type 7 . to create the circle. If necessary, choose View => Zoom => Out to see
the entire drawing.

11. Close ab01-01.dwg. Do not save the other drawing.
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Looking at the prompts for the transparent use of the ZOOM command carefully,
note three features:

4 The ZOOM command is preceded by an apostrophe. This is the sign of a
transparent command.

4 The prompt for the transparent command is preceded by >>. This helps you
distinguish between the prompts of the original command and the transpar-
ent command that is embedded in it.

4 When the transparent command is complete, AutoCAD tells you. In this case,
you see Resuming CIRCLE command.

Experiment by using transparent commands and you will soon find them
indispensable.

Of Mice and Pucks

For the sake of simplicity, this book assumes that you are using a mouse, but many
people use a digitizing tablet and a puck (or a stylus). A typical digitizing tablet and
puck are shown in Figure 3-8. A puck often has more buttons than a mouse and also
has crosshairs on a transparent area that you can use for accurately picking points
from a paper drawing.

The digitizing tablet is generally configured to include an area that represents the
screen you draw on as well as a customizable command area that you use for
AutoCAD commands. This command area of the tablet functions as another menu.
Figure 3-9 shows the default tablet provided with AutoCAD. This is generally cus-
tomized to suit individual needs. Each square is equivalent to a toolbar button and
executes a command when you click it. The top area is left blank for you to include
your own commands. This area is often used to insert parts from a library of stan-
dardized parts. Examples would be gaskets and valves in a mechanical drawing
environment or doors and windows in an architectural environment.

The square area in the right center represents the drawing area. In this area, the
puck functions like a mouse to draw, as well as to access menus and dialog box
options. The tablet can also be used for a process called digitizing, which means
transferring data from paper into AutoCAD. This transference is often done by
putting a paper document directly on the tablet and using the entire tablet as a
drawing area. Because the puck has crosshairs on a transparent surface, you can
pick points on the drawing, which then become endpoints of lines, for example.
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Figure 3-8: A digitizer and puck
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Figure 3-9: The standard tablet menu

Getting Help in AutoCAD

AutoCAD has so many commands with so many options that every user needs help
at some time. AutoCAD comes with a very complete help system. A complete set of
links and tabs makes it easy to navigate through the topics and find related material.

r Cross- See Appendix D on the CD-ROM for help available on the Internet and other
Reference’)  resources.

Getting help on a command

The easiest way to get help on a command is to start the command and press F1.
The help screen for that command opens up. Figure 3-10 shows the screen that
opens when you type zoom J and then press F1.

“\Iote After you open the Help window one time, when you press F1 it may only cause
~  the button to blink on the Windows task bar. Go to the task bar and click the blink-
ing button to open the Help window.
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ZOOM Command

Concepts Procedures Reference

Increases or decreases the apparent size of objects in the current

viewport

+
8 Standard toolbar: i b

Wiew menu: Foom

Shortcut menu: With no objects selected, right-click in the dravwing
area and choose Zoom to zoom in real time.

[EE command line: zoom (or "zoom for transparent use)

Specify comer of window, enter a scale factor (hi ar NPy, or

[AlCenter. ] =real time=

Figure 3-10: The help screen for the
ZOOM command

Using the main help system

When you have a question, try AutoCAD’s Help system. AutoCAD comes with the
most complete Help documentation [ have ever seen in a program.

Clicking F1 or choosing Help = Help opens the User Documentation window, shown
in Figure 3-11 with the Contents tab on top. Double-clicking Command Reference on
the Contents tab leads you to help on AutoCAD’s commands and system variables.
Double-click User’s Guide for the “how to” manual. You can also click the plus sign
to the left to expand the display of topics. If you click any topic on the left, you see
it in the right panel.

The help system now has five tabs that offer five different ways of finding the help
you need.

The Contents tab

The Contents tabs displays help organized by topic. It’s like the table of contents of
a book. Click the icon of a book to open that topic and see subtopics. Click a topic
to see it displayed in the right panel.

The Index tab

If you have an idea in your head but don’t know the command name, you may want
to use the index. The index is an alphabetical listing of topics. In the text box, type
the first few letters of the word or words for which you want help. As you type, the
list jumps to the closest match. When you have found the topic you want, highlight
it and click Display (or double-click it). Sometimes subtopics appear from which
you can choose.



Chapter 3 4 Using Commands

[2 AutoCAD 2004 Help: User Documentation [SE=]
R fa} B
Hide Back Horme Frint DOptions

Cantents llﬂdex I gearchl Favorites | 4] »
IR AutoCADR 2004 Help
3 User's Guide

+ @ Command Reference
= @ Driver and Peripheral Guide

Welcome to AutoCAD

+ @ Installation and Licensing Guides
2004 Help! ask
= Q Customization Guide P Ll
AutoLISP. Visusl LISP. and DXF ;‘t‘;\figf fﬂuﬂf‘; Hee General Information
[2) Activex Automation and VBA infarmatian far using Use the Hel em Efficientl E
iy Help AutoCAD. Clickthe links on Obtain Documentation Updates
the right or use the wiew the Product Readme
Contents tab to browse
Help topics. Help Files

User's Guide

Command Reference

Driver and Peripheral Guide
Installation and Licensing Guides
Customization Guide

AutoL ISP, Visual LISP, and DXF
ActiveX Automation and VBA

My Help

Resources on the Weh
=]

Figure 3-11: The User Documentation window showing the Contents tab
and the screen on AutoCAD 2004 Help

The Search tab

The Search tab enables you to find keywords from all the words in the help screens.
Type a word in the text box and click List Topics. Choose a topic and click Display
(or double-click the topic) to display it on the right.

The Favorites tab

Collect your favorite help topics on the Favorites tab. First, display the topic by
using one of the other tabs. Then click the Favorites tab and click Add. To display a
help topic from the Favorites list, double-click it.

The Ask Me tab

AutoCAD’s Ask Me tab enables you to ask a question in real English and hopefully
get the answer you want. Type a question or phrase and press Enter. Then click one
of the suggested links to see the topic displayed in the right pane.

Working with help screens

The Help screens have several features that you should know so you can make best
use of them. Many of the topics displayed on the right have three tabs:

4 Concepts: The overall description
4 Procedures: How to do it

4 Reference: Related commands
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After you arrive at the help screen you want, look for links to related topics.

At the top of most screens are several buttons. The selection of buttons depends on
which aspect of help you are accessing. These buttons help you navigate the help
system quickly and easily. Table 3-4 explains these buttons and their uses.

Table 3-4
Help Screen Buttons
Button Action
Hide/Show Hides the left pane so that you can work and look at a help screen

at the same time. When hidden, the button becomes a Show button
that displays the left pane.

Back Returns you to the previous help screen you viewed.
Print Prints the topic.
Options Offers further options such as going to the Home Help page and

refreshing the screen.

Using Active Assistance

Active Assistance offers you context-sensitive help as you work. It’s great for begin-
ners, but you will eventually find it a nuisance because it pops up in front of your
work. To turn on Active Assistance, choose Help > Active Assistance. As you use
commands, a brief explanation appears. Figure 3-12 shows the screen that appears
when you start the LINE command.

(2L Active Assistance &) Figure 3-12: Active Assistance displays help
~|| for the command that you are using.

| ask

Creates straight line segments
EI Help on LINE

® To draw lines

< I | 2]
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You can close the Active Assistance window by clicking its Close box at the top-
right corner of the window.

When you turn on Active Assistance, an icon appears in your System Tray at the
bottom-right of your screen, on the task bar. Right-click this icon to:

4+ Display Active Assistance: Choose Show Active Assistance to display the win-
dow at any time.

4 Change the settings: Choose Settings to specify when you want to see Active
Assistance and to turn on Hover Help, which displays help for dialog boxes as
you pass the mouse cursor over an area of the dialog box.

4+ Exit: Choose Exit to turn off Active Assistance. When you close the Active
Assistance window, it remains on until you exit it in this way.

Getting more help

AutoCAD’s Help menu has some additional options that provide more specialized
assistance. When you choose Help from the menu bar, choose one of these four
other items:

4 Active Assistance: Turns on Active Assistance, explained in the previous
section

4+ Developer Help: Opens the Help system for topics relating to programming
AutoCAD. See Part VII of this book.

4+ New Features Workshop: A combination of explanation and tutorials on
AutoCAD 2004’s new features.

4 Online Resources: Connects you to various support and training options on
Autodesk’s web site.

In this exercise, you practice using AutoCAD’s help system.

Step-by-Step: Using AutoCAD Help

1. If AutoCAD is not open, start AutoCAD with the acad.dwt template. If
AutoCAD is already open, this exercise can be done with any drawing on the
screen.

2. Choose Circle from the Draw toolbar. At the prompt, press F1 on the key-
board. The Circle help screen opens. (If it doesn’t open, click the Help win-
dow’s button on the Windows taskbar.)

3. Click 2P (Two Points), which appears underlined. The 2P description appears.
Read the description of the 2P option.

4. Click the Close button at the top-right corner of the help screen. Press Esc to
exit the CIRCLE command.

5. Choose Help => Help.
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6. Click the Contents tab if it is not on top. Double-click User’s Guide. From the
list, double-click The User Interface and then click the plus sign next to
Menus, Toolbars and Tool Palettes.

7. Click Shortcut Menus. Read the text in the right pane.
8. Click the Procedures tab. Click “To display a shortcut menu” and read the text.
9. Click the Index tab.

10. In the text box at the top, type transparent commands and click Display.

11. From the Topics Found list, double-click Enter Commands on the Command
Line.

12. In the right pane, scroll down until you see the heading Interrupt a Command
with Another Command or System Variable.

13. Read the text. After you're done, click the Close button of the Help window.

Summary

In this chapter, you read all you need to know about how to use AutoCAD’s com-
mands. Specifically, you read about:

4 Using AutoCAD’s menus

4 Shortcut menus

4 Using a dialog box

4+ Opening, closing, reshaping, and docking toolbars
4 Command names

4 Using and editing the command line

4+ Responding to command options and using the command line and shortcut
menus

4 Repeating commands

4 Canceling commands

4 Undoing and redoing commands

4+ Transparent commands

4 Using a puck and digitizing tablet to enter commands

4 Getting help

In the next chapter, I explain how to specify coordinates, an essential skill to learn
before you start to draw.

+ o+ 0+
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Cross- The UCS icon can take on different appearances. See
Reference\  Chapter 8 for details.

|

Specifying
Coordinates

s pecifying points on the screen is one of the most funda-
mental tasks in AutoCAD. Unless you know how to spec-
ify a point, you can’t draw anything real, whether a house or
a gasket. Most objects you draw have a specific size, and you
need to give AutoCAD that information. Drawing lines, arcs,
and circles is accomplished by specifying the coordinates of
points on the screen. As with most tasks, AutoCAD offers
many ways to accomplish this.

Understanding the X,Y
Coordinate System

Remember when you studied geometry and trigonometry in
high school? You created graphs by drawing X and Y axes.
Then you plotted coordinates on graph paper. AutoCAD works
the same way.

Look at the User Coordinate System (UCS) icon, as shown in
Figure 4-1.

o Figure 4-1: The UCS icon shows the
! direction of the X and Y axes.

CHAPTER

¢+ o+
In This Chapter

Working with
absolute, relative,
and polar
coordinates

Using direct distance
entry, orthogonal
mode, and polar
tracking

Using snap seftings

Working with object
snaps (OSNAPS)

Locating points

¢+ o+
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The arrow marked X points along the X axis in the positive direction. This means
that as you go in the direction of the arrow, the X coordinates increase. The arrow
marked Y points along the Y axis in the positive direction.

Using this system, every point on the screen can be specified using X and Y coordi-
nates. This is called a Cartesian coordinate system.

first, then a comma (but no space), and then the Y coordinate. Refer to Figure 1-4

@ As explained in Chapter 1, the universal convention is to place the X coordinate
ererence

“\lote

in Chapter 1 for some sample coordinates.

By default, the intersection of the X,Y axes is 0,0. Use negative numbers for points
to the left of the X axis or below the Y axis.

Drawing units

What do the coordinates measure? When you draw in AutoCAD, you draw in unde-
fined units. This means that a line from point 3,0 to point 6,0 is three units long. While
you are drawing, these units can be anything— a millimeter, a centimeter, a meter,
an inch, a foot, or a mile. In reality, you should know exactly what the units repre-
sent. After all, you don’t want your 36-foot-wide house to end up 36 inches wide!

When you set up a drawing, you specify how units are displayed —for example,
whether partial units show as decimal points or fractions. I cover units in Chapter 5.
However, you don’t actually specify what the units represent until you print or plot
your drawing — covered in Chapter 17.

In AutoCAD, you customarily draw full size. If you are drawing a plan for a factory
that will be 120 feet long, for example, you create lines with those measurements.
On the screen, you can zoom in to see small details or zoom out to see the whole
factory, so that you have no reason not to use the actual line lengths. It is only
when you need to print those 120-foot-long lines on a real sheet of paper that you
have to tell AutoCAD to plot out your drawing at a reduced scale.

Types of measurement notation

Users are typically familiar only with the type of notation used in their own field
of specialty, whether scientific, architectural, engineering, or whatever. However,
you should be at least somewhat familiar with all the major forms of measurement
notation.

If you are using engineering or architectural units, AutoCAD displays parts of
~—~ inches (fractions) differently than the format you must use to type them in. You
must type in coordinates without any spaces because AutoCAD interprets a space
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as equivalent to pressing Enter and ends your input. Use a hyphen between whole
and partial inches—for example, 3'2-1/2". (You can omit the " after the inches
because AutoCAD assumes inches in engineering and architectural units if no
symbol follows a number.) However, this appears on the status bar as 3'-2 1/2".
This can be confusing because AutoCAD places the hyphen in a different place
and uses a space between the whole and partial inches.

Typing Coordinates

One of the most basic ways to specify the location of an object is to type its coordi-
nates using the keyboard. You can enter several types of coordinates. You use the
type of coordinates that suit your specific situation.

Absolute Cartesian coordinates

When you type a line and enter the actual coordinates, such as a line from point 3,2
to 6,9, you are using absolute Cartesian coordinates. Absolute coordinates are mea-
sured from 0,0. These coordinates are probably familiar to you from high school

geometry class.

In this exercise, you practice entering absolute Cartesian coordinates.

Step-by-Step: Entering Absolute Cartesian Coordinates

1. Start a new drawing in AutoCAD using the acad.dwt template.

2. Choose Line from the Draw toolbar. Follow the prompts:

Specify
Specify
Specify
Specify
Specify
Specify

first point: -10,-5 4

next point or [Undo]l: 21,-5 J

next point or [Undol: 21,49 o

next point or [Close/Undo]l: -10,49 4

next point or [Close/Undo]: -10,-5 Jd

next point or [Close/Undol: 4 to end the command.

Most of the lines are off the screen. By default, a new drawing starts with 0,0
at the lower-left corner of your screen, therefore negative coordinates do not

show.

3. El Choose Zoom Out from the Zoom flyout on the Standard toolbar. If you
still cannot see the entire rectangle, choose Zoom Out again until you can
see it. Your picture should look like Figure 4-2.
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,"\lote If AutoCAD responds with Invalid Point or Point or option keyword
~~  required, you have entered a coordinate incorrectly. Try typing the coordinate
again. Also, don't forget that you can UNDO a command if you make a mistake.

(See Chapter 3 for details.)

Figure 4-2: A rectangle drawn
by using absolute coordinates

4. Start the LINE command again and follow the prompts:

Specify first point: -8,-2 4

Specify next point or [Undo]: 19,-2 4

Specify next point or [Undo]: 19,21.5 4

Specify next point or [Close/Undo]: -8,21.5 4

Specify next point or [Close/Undo]: -8,-2

Specify next point or [Close/Undo]: 4 to end the command.

5. Once more, start the LINE command and follow the prompts:

Specify first point: -8,22.5 4

Specify next point or [Undo]: 19, 22.5 J

Specify next point or [Undol: 19,46 A

Specify next point or [Close/Undo]: -8,46

Specify next point or [Close/Undo]: -8,22.5 4

Specify next point or [Close/Undo]: J to end the command.

6. Save this drawing in your AutoCAD BibTe folder as ab04-01.dwg.
You can now see that you have drawn a simple window, as shown in Figure 4-3.

Two questions might have occurred to you during this exercise. First, isn’t there a
better way of entering absolute coordinates? Typing them in is slow and prone to
error. Second, how do you know the absolute coordinates for what you are drawing?
Read on for the answers.
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Figure 4-3: A window drawn
with absolute coordinates

Relative Cartesian coordinates

In practice, you usually do not know the absolute coordinates of the points you need
to specify in order to draw an object. Whether you are drawing an architectural lay-
out, a physical object (as in mechanical drawing), a three-dimensional model, or an
electrical schematic, you don’t have X,Y coordinates to work from. However, you
often do have the measurements of what you are drawing. Usually, you start from
any suitable point and work from there. In this situation, you know only the length
of the lines you are drawing (if you are drawing lines). Real life doesn’t have a 0,0
point. Relative coordinates were developed for these situations.

Relative coordinates specify the X and Y distance from a previous point. They are
called relative coordinates because they only have meaning relative to a point previ-
ously specified. Suppose that you need to draw a window. You can start the window
from any point. From there, you have the measurements you need. (The measure-
ments may be shown on a piece of paper you’'re working from, or you may have the
actual window sitting next to you so you can measure it.)

You tell AutoCAD that the coordinates are relative by using the @ symbol. For exam-
ple, if you start a line by picking any point with the mouse, and you know it should
be two units long, you can specify the next point as @2,0. AutoCAD creates a line
starting with the first point you picked and ending two units to the right, as shown
in Figure 4-4. The line is horizontal because the Y coordinate is 0. In a relative coor-
dinate, this means that the Y distance does not change.
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Start point End point=@2,0

Figure 4-4: A line whose start point
could be anywhere and whose endpoint
is specified with the relative point @2,0
is a horizontal line two units long.

Relative Cartesian coordinates are often used for lines drawn at 90-degree angles,
that is, they are either horizontal or vertical. These are called orthogonal lines.
When you create a diagonal line from point 3,3 to point @2,5 you don’t know how
long the line is.

When you specify a positive number such as the 2 in @2,0, AutoCAD assumes the
positive direction. However, if you want to draw a line in the negative direction of
an axis, type a minus sign before the number. Figure 4-5 shows how to draw lines
in four directions using relative coordinates.

l @0,2

J - @-2,0

‘[ @0,2

—@2,0

Figure 4-5: Drawing lines in the four
orthogonal directions by using relative
coordinates. The arrow on each line
shows the direction of the line.

Polar coordinates

Another common situation is to know the distance and angle of a point from either
0,0 or a previous point. In this case, you can use polar coordinates, which can be
either absolute or relative. Most commonly, you use relative polar coordinates.

Polar coordinates take the form distance<angle. (To type the angle symbol, use the
less than symbol on your keyboard.) Relative polar coordinates must have the @
sign before the coordinate.
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r Cross- Chapter 21 explains more about coordinates in 3D drawings.
Reference

By default, angles are measured according to the diagram in Figure 4-6, although
AutoCAD enables you to change this system. The positive and negative angles
shown next to each other are interchangeable. Use whichever is more meaningful

to you.
90 Figure 4-6: The standard angle
-270 measurement system
180 0
-180 -360
270
-90

In the following series of steps, you draw part of a portico, the decorative molding
above a door or window. Because it is an architectural design, you use architectural
units. In this case, only inches are used, which don’t need to be specified. You can
specify feet by using an apostrophe (also called a prime) after any number.

When typing architectural units, partial inches are indicated by fractions in the
form 3/4. You need to separate the fraction from the whole inches by a hyphen.
This can be a little confusing because the hyphen is also used for negative num-
bers. For example, to draw a horizontal line of 5% inches to the left, you would type
@-5-1/4,0. (The 0 indicates no change in the Y axis because it is a horizontal line.)

Onthékl\ The drawing used in this Step-by-Step exercise on using relative and polar coordi-
i cD, | nates, ab04-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

& /,--"' CD-ROM.

Step-by-Step: Using Relative and Polar Coordinates

1. Open ab04-a.dwg from the CD-ROM. As you move your mouse around, notice
that the coordinates displayed on the status bar are in architectural units,
that is, in feet and inches. If the coordinates are grayed out, click them or
press the F6 key.

2. Choose Filew> Save As and save the drawing in your AutoCAD Bible folder as
ab04-02.dwag.
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The next steps involve some complex typing. If you get an error message from
AutoCAD, try typing the coordinate again. If you realize you made a mistake after
ending the command, click Undo on the Standard toolbar.

. Start the LINE command. Follow the prompts:

Specify first point: Pick any point at the lower-left corner
of your screen.

Specify next point or [Undo]: @0,-3/4 4

Specify next point or [Undol: @75-1/4,0 A

Specify next point or [Close/Undo]: @0,3/4

Specify next point or [Close/Undo]: @-75-1/4,0 4

Specify next point or [Close/Undo]: 4 to end the command.

. Start the LINE command again. Follow the prompts:

Specify first point: 4. This starts the line at the Tast
endpoint you specified.

Specify next point or [Undo]l: @4-3/4,0 4

Specify next point or [Undo]: @43<40 J

Specify next point or [Close/Undo]: @43<320 A

Specify next point or [Close/Undo]: @-2-1/4,0

Specify next point or [Close/Undo]: @39-7/8<140 A
Specify next point or [Close/Undo]: @39-7/8<220 4
Specify next point or [Close/Undo]: 4 to end the command.

In this exercise, you draw a line on top of a line, which is not good drawing prac-
tice. Later in this chapter and in coming chapters you learn techniques to avoid
this.

. Save your drawing. You have created a portion of a portico, which goes over a

window of a house, as shown in Figure 4-7.

Figure 4-7: Part of a portico over a window,
drawn using relative Cartesian and polar
coordinates in architectural notation

You can type @  at the first prompt of any drawing command to indicate the
most recent coordinate specified.
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Notice that using relative coordinates, both Cartesian and polar, is much more real-
istic than using absolute coordinates. However, typing in all those coordinates is
still awkward. Typing in coordinates is often the only way to get exactly what you
want. Nevertheless, several other techniques for specifying coordinates are easier
in many circumstances.

Direct distance entry

One shortcut for entering coordinates is direct distance entry. After you specify
the start point of a line, at the Specify next point or [Undo]: prompt, simply
move the mouse cursor in the direction you want the line to go and type in the
line’s length. It works best in orthogonal mode or with polar tracking, discussed
next, which makes it easy to specify exact angles.

You can use direct distance entry for any command that requires you to specify a
~  distance and a direction, including both drawing and editing commands.

Orthogonal mode

As mentioned earlier in this chapter, lines drawn at 0, 90, 180, and 270 degrees are
called orthogonal lines. When in orthogonal mode — ortho mode as it’s called for
short—you can only draw orthogonal lines with the mouse. Ortho mode also affects
editing. For example, with ortho mode on, you can only move objects vertically or
horizontally. Combined with snap and grid, ortho mode makes drawing easier and
more efficient. Ortho mode is also great for direct distance entry.

Click ORTHO on the status bar to toggle ortho mode on and off. You cannot have
polar tracking on at the same time that ortho mode is on. Polar tracking is dis-
cussed next.

Orthogonal mode only affects points picked directly on the screen by using your
-~ mouse. Any relative or absolute coordinates typed on the command line override
orthogonal mode.

Polar tracking

Polar tracking guides you, using a tooltip and vector line, when you want to draw
(or edit) at an angle other than the four orthogonal angles, as shown in Figure 4-8.
You can use polar tracking for orthogonal angles as well.

Polar tracking makes it easy to use direct distance entry to specify distances for
many angles. To use polar tracking, you first set the angles that you want to use.

To set the angles, choose Tools &> Drafting Settings or right-click the POLAR button
on the status bar and choose Settings. AutoCAD opens the Drafting Settings dialog
box. If necessary, click the Polar Tracking tab, which you can see in Figure 4-9.
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@

q

—Polar tracking vector

Polar: 3'0 38" < 45d«— Polar tracking tooltip

Figure 4-8: When polar tracking is on, a tooltip appears when you move
the cursor close to one of the polar angles. Here you see a tooltip
indicating an angle of 45 degrees.

[E] Drafting Settings

(B[]

Polar Tracking On [F10)
Polar Angle Settings

Increment angle:

90 v

[ &dditional angles

Options..

Mew

Snap and Grid | Polar Tracking | Object Snap

Object Shap Tracking Settings
(%) Track orthogonally only

(7 Track wsing all palar angle settings

Palar Angle measurement
(%) Absolute

() Relative to last segment

I Ok, ” Cancel H Help ]

Figure 4-9: The Polar Tracking tab of the Drafting

Settings dialog box

To change the increment angle, click the Increment angle drop-down arrow, where
you can pick from angles that range from every 90 degrees to every 5 degrees. You
can also type your own incremental angle in the text box. To add additional angles
that you think you’ll need, check Additional angles, click New, and then type in an
angle. You can add up to 10 additional angles. Note that additional angles you add
are not incremental angles — if you type 35, AutoCAD will only mark 35 degrees,

not 70 degrees or other increments of 35. To delete an additional angle, select it

and click Delete.
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On the right side of the dialog box, you can choose how polar tracking works with
object snap tracking (covered later in this chapter). You can set object snap tracking
to use all the polar angle settings or limit it to orthogonal angles only. You can also
set whether polar angles are measured absolutely (relative to 0 degrees) or relative
to the segment drawn most recently. By default, absolute angles are used.

To customize how polar tracking works, click Options in the Drafting Settings dialog
box to open the Options dialog box with the Drafting tab on top. The following set-
tings in the AutoTracking Settings section apply to polar tracking:

4+ Display polar tracking vector turns on and off the polar tracking vector,
which is the faint dotted line that extends to the end of the screen.

4+ Display AutoTracking tooltip turns on and off the tooltip that tells you the
distance and angle.

To turn on polar tracking, check Polar Tracking On on the Polar Tracking tab of the
Drafting Settings dialog box. If you are not in the dialog box, press F10 or click the
POLAR button on the status bar.

To use polar tracking, you need to move the cursor slowly through the angles to
give AutoCAD time to calculate and display the vector and tooltip. Say that you are
drawing a line. Specify the start point. To specify the second point, move the cursor
in the approximate angle of the line you want to draw. When you see the polar
tracking vector and tooltip, leave the mouse where it is and type the length of the
line. Then press Enter. AutoCAD creates the line with the proper length and angle.
You will find this method easier than typing polar coordinates for lines with angles
specified in your polar tracking settings.

Tip Turn on NumLock on your keyboard and use the numerical pad for typing in
~, lengths. Use the Enter key on the numerical pad as well.
s
You can specify a polar angle for just one command. If you're drawing a line, the
polar angle applies for one segment only. If you're drawing a line, after specifying
the first point, for example, type the angle preceded by the angle symbol (<).
AutoCAD then locks the next segment to that angle while you type its length. A
polar angle specified in this way is called a polar override angle because it over-
rides the current polar angles in effect. Of course, a polar override is not faster than
simply typing a polar coordinate, but it does let you see the angle of the line seg-
ment (if you're drawing a line) before you type its length.

In the following exercise, you practice using direct distance entry with ortho mode
and polar tracking. Before beginning, check that Polar Tracking is set for 45
degrees, as described previously.

0nth'e“¥-\ The drawing (ab04-b.dwg) used in the following Step-by-Step exercise on using
, CDW | direct distance with ortho mode and polar tracking is in the Drawings folder of
& /  the AutoCAD 2004 Bible CD-ROM.

Y.
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Step-by-Step: Using Direct Distance with Ortho Mode
and Polar Tracking

1.
2.

Open drawing ab04-b.dwg from the CD-ROM.

Choose File= Save As to save the drawing in your AutoCAD BibTe folder as
ab04-03.dwg. If ORTHO is not on (that is, if the ORTHO button on the status
bar doesn’t look pushed in), click ORTHO.

. Start the LINE command and, at the Specify first point: prompt,

type 2,2 .

4. Move the mouse horizontally to the right, and then type .5 .

5. Move the mouse up vertically (in the 90-degree direction) and then type .5 .

6. Move the mouse horizontally to the right and then type 2 .. Your drawing

should look like Figure 4-10.

Figure 4-10: Drawing with direct distance entry enables you
to specify coordinates by typing in a length after you move the

B — pointer in the desired direction.

7. Move the mouse up in the 90-degree direction and then type .5 .

8. Move the mouse to the left in the 180-degree direction and then type 2 .

9. Move the mouse up in the 90-degree direction and then type .5 .

10.
11.

12.
13.

14.

15.

16.

17.

Move the mouse to the left in the 180-degree direction and then type .5 .

Move the mouse down in the 270-degree direction and then type 1.5 .
Press Enter again to end the command.

Click POLAR on the status bar. The ORTHO button pops out.

With your cursor in the drawing area, right-click with your mouse and choose
Repeat Line from the shortcut menu.

Press Enter to start the new line from the most recent point. At the Specify
next point or [Undo]: prompt, move the cursor diagonally up and to the
left so the line is approximately in the 135-degree direction. When you see the
tooltip confirming the angle, let go of the mouse and type .7071 ..

Move the cursor up until you see the polar tracking tooltip confirming a
90-degree angle. Type .5 .

Move the cursor diagonally in the 45-degree direction until you see the
tooltip. Type .7071 4. Press Enter again to end the LINE command.

Save your drawing. It should look like Figure 4-11.
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Figure 4-11: The completed drawing
of a bolt

Displaying Coordinates

As you work, you can refer to the coordinate display on the status bar. This display
helps you know where your cursor and objects are and is also helpful when editing,
such as how far and in what direction you are moving or copying objects.

AutoCAD has three coordinate display modes that you can use:

4 Dynamic absolute coordinates (absolute): Absolute coordinates that change
as you move the mouse, as shown in Figure 4-12.

Figure 4-12: Dynamic absolute coordinates

4 Static absolute coordinates (off): Absolute coordinates that change only

when you specify a point, as shown in Figure 4-13. The coordinate display is
dimmed.

Figure 4-13: Static absolute coordinates

4+ Dynamic polar coordinates (relative): Polar coordinates that change continu-
ously as you move the mouse, as shown in Figure 4-14. They appear after you
have already specified a point and are ready to specify a new point, as when
you are in the process of drawing a line.

T.9580< 29 . 00000  Figure 4-14: Dynamic polar coordinates
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You can change the coordinate display in three ways:

4 Press the F6 key.

4 Click the coordinates area on the status bar.
4 Press Ctrl+D.

For purposes of this chapter, I ignore the Z coordinate that follows the X and Y
coordinates. In two-dimensional drawings, the Z coordinate is always zero.

In the following exercise, you practice using the coordinate display options. This
exercise can be done with any new or existing drawing open on the screen.

Step-by-Step: Using Coordinate Display Options

1.

Look at the coordinate display on the status bar. It should be shown in black.
If the coordinates are shown in gray, press F6 on your keyboard.

. Move the mouse around in a few directions. Notice how the coordinates

constantly change with the mouse movement.

. Press F6. The coordinate display is grayed out. The command line shows

<Coords off>.

. Move the mouse around again. The coordinate display does not change with

the movement of the mouse.

5. Start the LINE command and pick any point on the screen.

6. Watch the coordinate display as you pick any point at the Specify next

point or [Undo]: prompt.

. Pick several other points and watch as the coordinate display changes only

when you pick a point. This is the static coordinate display.

8. Press F6 again without ending the LINE command.

9. Move the mouse to another point that you would like to pick but watch the

10.
11.
12.

coordinate display before you pick the point. This time, the length and angle
of the new line segment is shown. These are dynamic polar coordinates.

Pick a few more points, watching the polar coordinates.
Press F6 again to return to dynamic absolute coordinates.

Press Enter to end the LINE command. Do not save your drawing.

The next sections introduce three new ways to specify coordinates.
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Picking Coordinates on the Screen

The easiest and quickest way to specify coordinates is to pick them directly on
the screen with the mouse. AutoCAD offers several techniques to help you do so
accurately.

You can adjust the size of the crosshairs that cross the cursor. By default, they are
5 percent of screen size. To change the crosshair size, choose Tools = Options and
click the Display tab. In the Crosshair size text box, you can type a new percentage
or drag the bar to increase or decrease the percentage. Choose OK.

Snap settings

The SNAP command is often an alternative to tedious entry of coordinates. This
command restricts the cursor to an incremental distance that you choose, such
as 0.5 units. You can set the snap size to anything you want. For example, if all
your measurements are rounded off to the nearest 0.25 units, you can set your
snap to 0.25.

The snap technique is not very useful when you need to draw to three or more
decimal places of accuracy. And when you are zoomed out in a large drawing, the
snap points may be so close together that you cannot easily find the one you want.
But in the right situation, snap is one of the quickest, most accurate drawing tech-
niques available.

AutoCAD 2004 provides two types of snap settings — grid snap and polar snap.

Snapping to a grid

When you snap to a grid, AutoCAD creates an invisible grid (which you can make
visible using the GRID command, discussed in the next section). As soon as you
turn on snap, the mouse cursor can only move to the snap grid points.

To set the snap size, choose Tools > Drafting Settings or right-click the SNAP but-
ton on the status bar and choose Settings. AutoCAD opens the Drafting Settings
dialog box, as shown in Figure 4-15. (If necessary, click the Snap and Grid tab.) In
the Snap X spacing text box of the Snap section, type the spacing you want between
snap points. Make sure that Grid snap and Rectangular snap are checked in the Snap
type & style section of the dialog box. Click OK.

r Cross- Note that you can change the angle of the snap spacing. In Chapter 8, | discuss
Reference’) ,tating the angle of the snap and grid. Chapter 8 also discusses Isometric snap,

used for isometric drawing.
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[E] Drafting Settings (B]=]
Shap and Grid | Palar Tracking | Object Snap
[] Snap On [F9) []Grid On [F7)
Shap Grid
Shap ¥ spacing: 0.5000 Girid ¥ spacing 0.5000
Shap ¥ spacing: 0.5000 Grid " gpacing: 0.5000
Angle: 0
Shap tepe & stple
% base: 0.0000
(=) Grid shap
¥ base: 0.0000
(%) Rectangular snap
() Isometric snap
Polar spacing
) PolarSnap
[ ak, ] [ Cancel 1 [ Help ]

Figure 4-15: The Drafting Settings dialog box

Usually you want the X spacing (going across) to be the same as the Y spacing
(going up and down). You need to specify only the X spacing, and AutoCAD auto-
matically changes the Y spacing to equal the X spacing. X and Y spacing will be
different only if you type a different number in the Snap Y spacing box.

You can also turn snap on in this dialog box by clicking the On check box. However,
the most common way to turn snap on, after you have set the spacing, is to click
SNAP on the status bar (or press the F9 key). Click it again to turn snap off.

Snapping at polar angles

After you set polar tracking settings, discussed earlier in this chapter, you can snap
to increments along the polar angles you have set. When polar snap is on, the polar
tooltip only shows distances in increments of the snap setting. When you see the
distance you want, just click. Polar snap makes it easy to draw accurately without
having to type coordinates.

To use polar snap, follow these steps:

1. Right-click the SNAP button on the status bar and click Settings to open the
Drafting Settings dialog box with the Snap and Grid tab displayed, as just
explained.

2. Check Polar snap in the Snap type & style section of the dialog box. (See
Figure 4-15.)

3. Type a number in the Polar distance text box.
4. Click OK to close the dialog box.
5. Click SNAP on the status bar.
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Note that polar snap and grid snap are mutually exclusive. If polar snap is on, the
cursor will not snap to the grid. Used with polar tracking, polar snap is a powerful
tool. Remember that you can polar track along orthogonal as well as other angles.

You can choose either polar snap or grid snap (switch between them) by right-
_», clicking SNAP on the status bar. A shortcut menu lets you choose the type of snap
4 you want, or turn both off.
The grid

Sometimes you may find it helpful to see a grid of dots to help get your bearings
while you draw, as shown in Figure 4-16. If the dot grid is not visible, click GRID on
the status bar or press the F7 key. Notice how you can quickly judge the approxi-
mate width of a windowpane, knowing that the grid dots are half a foot apart. If you
turn on snap, the grid helps you visualize the snap points. However, the grid dots
do not have to be set to the same spacing as the snap points.

Figure 4-16: A portion of a drawing with the grid turned on and set to
6 inches
Thanks to Henry Dearborn, AlA, Fairfield, lowa, for this drawing.

The smaller the grid size and the farther out you zoom, the denser the grid and the
longer it takes to display. At a certain point, AutoCAD issues a message, Grid too
dense to display, and refuses to display the grid.

Some users find the grid annoying, but when you first start to use AutoCAD, you
may find it helpful. Even accomplished users can take advantage of the grid, espe-
cially when starting a new drawing.

If you are working with a small snap spacing and the dot grid is too dense, set the

_», dot grid to twice the size of the snap spacing. You can even set the dot grid to four

4 or five times the snap spacing.
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To set the grid size, choose Tools > Drafting Settings to open the Drafting Settings
dialog box, shown previously in Figure 4-15. If necessary, click the Snap and Grid
tab. In the X Spacing text box of the Grid section, type the spacing you want
between grid points. Click OK.

As with the snap feature, you usually want the X spacing (going across) to be the
same as the Y spacing (going up and down). You need to specify only the X spacing,
and AutoCAD automatically changes the Y spacing to be the same. X and Y spacing
will only be different if you type a different number in the Y Spacing box.

You can turn Grid on in this dialog box by clicking the On check box, but the most
common way to turn the grid on, after you have set the spacing, is to click GRID on
the status bar (or press F7).

In the following exercise, you practice using polar and grid snap points as well as
grid dots.

On the The drawing used in the following Step-by-Step exercise on using snap points and

%

/  CD-ROM.

7

ECDW | grid dots, ab04-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

Step-by-Step: Using Snap Points and Grid Dots
1. Open ab04-b.dwg from the CD-ROM.

2. Choose Filew> Save As to save the drawing in your AutoCAD Bible folder as
ab04-04.dwg.

3. Choose Tools => Drafting Settings. The Drafting Settings dialog box opens.
Click the Snap and Grid tab if it is not displayed. In the Snap type & style
section, make sure that you check the Grid snap and Rectangular snap.

4. In the Snap section, change the Snap X Spacing to 0.5.

5. Click in the Grid section, in the Grid X spacing text box. Change the Grid X
spacing to 0.5. Click OK. AutoCAD automatically sets the Grid Y spacing to
match the Grid X spacing of 0.5.

6. On the status bar, click SNAP, GRID, and ORTHO. The grid appears. Make sure
that the OSNAP and OTRACK buttons on the status bar are off.

7. Choose View> Zoom = All.

8. Move the mouse around and watch the coordinates on the status bar. (Press
F6 if they are in static mode.) They show halves of units because you have set
the snap to 0.5.

9. Start the LINE command. At the Specify first point: prompt, click when
the coordinates on the status bar show 2.000,2.000. (For now, ignore the third
Z coordinate, which is always 0.0000 in 2D drawings.)
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15.
16.

17.
18.

19.

20.

21.
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Move the mouse around and watch the coordinates. If you don’t see polar
coordinates (for example 3.0000<0), press F6 twice until you see them.

Move the mouse to the right until the coordinates read 8.5000<0 and click the
pick (left) button. You have drawn a horizontal line with a length of 8.5 units.

Click the right mouse button and choose Enter to end the LINE command.

Move the mouse cursor away from the end of the new line and back to it
again, and the absolute coordinates appear. They should be 10.5000,2.0000.

Right-click and choose Repeat Line to start the LINE command again. Use the
coordinate display to start the line at 1.5000,1.5000. Continue to use the coor-
dinate display to pick points and draw the following line segments:

.5<0
3.0<90
.5<180
3.0<270

End the LINE command.

Start the LINE command and use the coordinate display to pick points, draw-
ing the following line segments starting from 10.5,1.5. Then end the LINE com-
mand:

.5<0
3.0<90
.5<180
3.0<270

Starting from 2,4 draw an 8.5-unit line at 0 degrees. End the LINE command.

Start the LINE command again. At the first prompt, pick 11,2. Right-click
SNAP on the status bar and choose Settings. In the Snap type & style section,
choose Polar snap. (This is equivalent to choosing the Polar Snap On feature
on the SNAP button shortcut menu.) In the Polar Spacing section, change the
Polar distance to .5. Choose the Polar Tracking tab and (if necessary) set the
Increment angle to 45.0 degrees. Click OK. Click POLAR on the status bar.

Move the cursor in a 45-degree direction from 11,2 until you see the tooltip.
Move along the polar tracking vector until the tooltip says 3.5000 < 45° and
click. End the LINE command.

Right-click the SNAP button and choose Grid Snap On. Start the LINE com-
mand and, at the Specify first point: prompt, choose 11,4.

Right-click the SNAP button and choose Polar Snap On. Move the cursor in a
45-degree direction until the tooltip says 3.5000 < 45° and click. End the LINE
command.

Save your drawing. Your drawing should look like Figure 4-17.
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712

As you no doubt experienced, this is a much easier way to draw compared to typing
in coordinates. Note that drawing with snap on works better when you are drawing
small objects. However, even when drawing an office building, you spend a great
deal of time working on small details that may be easier to draw with snap on.

Figure 4-17: The completed pipe section

Object snaps

Often you need to draw an object in a position relative to a previously drawn object.
For example, you may need to start a line from the endpoint or midpoint of an exist-
ing line. AutoCAD offers a feature called object snaps (OSNAPS for short) that enables
you to specify a point by snapping to a geometrically defined point on an existing
object. This is a very precise and efficient way to draw.

You can start an object snap in one of three ways:

4 Open the Object Snap toolbar and choose the object snap that you want.

4 Access the object snap shortcut menu by holding down the Shift key and
right-clicking. Choose the object snap you want with the left mouse button.

4 Type the object snap’s abbreviation on the command line.

r Cross- On multi-button mice, you can customize one of the buttons to show the object
Reference’\  shap menu. Displaying the object snap menu with the click of a mouse button is
very convenient. Customizing the mouse is discussed in Chapter 33.

Table 4-1 lists the object snaps. Use the abbreviation to type the object snap from

the keyboard.
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Table 4-1
AutoCAD’s Object Snaps

Object Snap

Abbreviation

Uses

Endpoint
Midpoint
Intersection

Apparent Intersection*

Extension

Center

Quadrant

Perpendicular

Parallel

Tangent

Node

Insertion

Nearest

None

End
mid
Int

App

Ext

Cen

Qua

Per

Par

Tan

Nod

Ins

Nea

Non

Lines, arcs, and so on.
Lines, arcs, and so on.
Intersection of lines, circles, arcs.

The intersection that would be created if two
objects were extended until they met.

Extends lines, arcs, and so on past their
endpoints but in the same direction. After
choosing this object snap, pause over the end
point of a line or arc until you see a small plus
sign. As you move the mouse cursor along the
extension path, AutoCAD displays a temporary
extension path so that you can draw to or
from points on the extension path.

Circles, arcs, ellipses.

Nearest quadrant (0, 90, 180, or 270 degree
point) of a circle, arc, or ellipse.

Arg, circles, ellipses, lines, multilines, polylines,
rays, splines, or construction lines.

Continues a line, polyline, and so on so that
it's parallel to an existing line or other straight-
line segment. After you choose this object
snap, pause over the line you want to draw
parallel to until you see a small parallel line
symbol. As you move the mouse cursor
parallel to the object, AutoCAD displays a
temporary parallel path that you can use to
create the parallel segment.

Starts or continues a line from or to a point
tangent with an arc, circle, or ellipse. See
Figure 4-18.

Point objects (discussed in Chapter 7).

Insertion point of text or a block (inserting text
is covered in Chapter 13; blocks are discussed
in Chapter 18).

Nearest point on any object.

Turns off any object snap modes.

* Apparent Intersection also applies to 3D objects that appear to intersect due to the angle of view.
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Figure 4-18: A line drawn tangent to an arc

When drawing a line, we think of it as having a starting point and an ending point.
After the line is drawn, however, both of these points are considered endpoints in
terms of object snaps. When picking the endpoint of a line for the endpoint object
snap, pick a point on the line closer to the endpoint that you want. The same applies
to arcs. Although the arc prompts read Start point and End, both are considered
endpoints for purposes of object snaps.

AutoSnap is a feature that helps you work with object snaps. When you move the
cursor near the geometric point you have specified, such as an endpoint, AutoCAD
lets you know in three ways:

4 Marker: An object snap shape appears. Each object snap has a differently
shaped marker.
4+ AutoSnap tooltip: A label that displays the name of the object snap.

4 Magnet: A pull that gently moves the cursor toward the geometric point.

Figure 4-19 shows an endpoint marker and AutoSnap tooltip.

| Marker

[Endpoine—Tooltip

Figure 4-19: AutoSnap shows you the
endpoint of the line.

You can customize the AutoSnap feature to suit your needs or make it go away
completely if you want. Choose Tools => Options and click the Drafting tab. Here
you can individually turn on and off the marker, AutoSnap tooltip, and the magnet.
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You can also change the marker size and color. If you want, you can display the
aperture box, which Release 13 and prior releases of AutoCAD used in order to let
you pick an object snap point. (You probably don’t want to display both the marker
and the aperture —it can be somewhat confusing.)

In the following exercise, you practice using object snaps.

Step-by-Step: Using Object Snaps

1. Start a new drawing by using the acad.dwg template.

2. Save the drawing in your AutoCAD Bible folder as ab04-05.dwg.

3. Click ORTHO on the status bar to turn on ortho mode. If the OSNAP button is
pushed in, click OSNAP on the status bar to turn off running object snaps
(covered in the next section).

4. Start the LINE command. Follow the prompts:

Specify
Specify
right.

Specify
Specify
Specify

command .

first point: 2,7 4. Move the cursor downward.
next point or [Undol: 4 4. Move the cursor to the

next point or [Undol: 4 4. Move the cursor up.
next point or [Close/Undo]l: 4 4
next point or [Close/Undo]: Press Enter to end the

Your drawing should look like Figure 4-20. The circled numbers are reference
points for this exercise.

Figure 4-20: These three lines are the start
of a mounting bracket.
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5. Choose Arc from the Draw toolbar. Follow the prompts:

Specify start point of arc or [Center]: Press Shift and
right-click. From the shortcut menu, choose Endpoint, as
shown in Figure 4-21.

_endpt of Move the cursor to @ 1n Figure 4-20. When you see
the endpoint marker and AutoSnap tooltip, pick it.

Specify second point of arc or [Center/Endl: Right-click and
choose Center.

Specify center point of arc: Press Shift and right-click.
Choose Midpoint from the shortcut menu.

_mid of Move the cursor to @ and pick.

Specify end point of arc or [Angle/chord Length]: end J. Move
the cursor to @ and pick.

Temporary track point Figure 4-21: Choosing the Endpoint
From object snap from the shortcut menu
Point Filters 4

Endpoint

Midpoint %
Intersection

Apparent Intersect
Extension

Center
Quadrant
Tangent

Perpendicular
Parallel

Node

Insert

MNearest

None

Osnap Settings...

6. Choose Circle from the Draw menu. Follow the prompts:

Specify center point for circle or [3P/2P/Ttr (tan tan
radius)]: Choose Snap to Center from the Object Snap shortcut
menu.

_cen of Move the cursor over the arc until you see the Center
marker and tooltip, and then click.
Specify radius of circle or [Diameter]: .75 4
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7. Start the LINE command and use any method you want to draw a line from the

endpoint at @ to the endpoint at @. End the LINE command.

When you press Shift and right-click to get the object snap menu, the mouse
pointer must be in the drawing area. If it is on a toolbar, you get the Toolbars list.
If that happens, press the Esc key, or hold the Shift button and right-click again in
the drawing area.

. Save your drawing. It should look like Figure 4-22.

Figure 4-22: The start of a drawing of a
mounting bracket (including a construction
line that would later be erased). It was
created by using the endpoint, midpoint,
and center object snaps.

Running object snaps and OSNAP mode

The endpoint object snap is probably the most commonly used of all the object
snaps. You might have a drawing project in which you need to use the endpoint
object snap often. You can set a running object snap, which keeps one or more
object snaps on until you turn them off.

Many users like to work with three or four running object snaps on at once, such
as endpoint, midpoint, center, and intersection. If you can't find the object snap
you want because you have several object snaps near each other, press the Tab
key to cycle through the object snaps, one by one, until you find the one that you
want.

To set running object snaps, choose Tools &> Drafting Settings (or right-click the
OSNAP button on the status bar and choose Settings) to open the Drafting Settings
dialog box, as shown in Figure 4-23. (If necessary;, click the Object Snap tab.)
Choose the object snaps that you want and click OK. To clear a checked object
snap, click it. Click Clear All to clear all running snaps.
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[E] Drafting Settings (B]=]

Sriap and Grid | Polar Tracking | Obiect Snap

Dhject Snap On [F3] Object Snap Tracking On [F11]
Object Snap modes
| Endpoint 04 [ insertion
/v [ Midpaint b [ Perpendicular
O Center = [Tangent
% [INode % [Mearest
<> [ Quadiant [ []Apparent intersection
X Intersection 4[] Parallel
- Estension

T To track from an Oshap point, pause over the point while in a
m
? command. & tracking wector appears when you move the cursor.
To stop tracking, pause over the point again.

[ ak, ” Cancel H Help ]

Figure 4-23: Use the Object Snap tab of the
Drafting Settings dialog box to set running object
snaps.

You use the OSNAP button on the status bar to turn on your running object snaps.
If you want to turn them off temporarily, just click the OSNAP button. This capability
to toggle running object snaps on and off makes it easy to work with running object
snaps on almost all the time because you can turn them off at the click of a button.
(You can also press F3.)

In the following exercise, you practice using running object snaps with OSNAP mode.

Step-by-Step: Using Running Object Snaps with OSNAP Mode

1. Start a new drawing by using the acad.dwt template. Save the file in your
AutoCAD Bible folder as ab04-06.dwg.

2. Choose Tools => Drafting Settings and click the Object Snap tab. Choose
Endpoint. Uncheck all other object snaps and click OK.

3. Start the LINE command and start the line at 2,2.

4. Turn on ortho mode by clicking ORTHO on the status bar. If OSNAP is not on,
click it on the status bar.

5. Move the mouse in the 0-degree direction and type 6 ..

6. Move the mouse up in the 90-degree direction, type 3 4, and end the LINE
command.

7. Start the ARC command. At the Specify start point of arc or
[Center]: prompt, pick the endpoint at @, shown in Figure 4-24. (Look for
the marker and AutoSnap tooltip.)
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Figure 4-24: Drawing a steam boiler
with an endpoint running object snap

. At the Specify second point of arc or [Center/End]: prompt, right-

click and choose End. Pick the endpoint at @, shown in Figure 4-24.

. At the Specify center point of arc or [Angle/Direction/Radius]:

prompt, right-click and choose Angle, and then type 180 ..

Start the LINE command and at the Specify first point: prompt, pick the
endpoint at @ in Figure 4-24.

Move the mouse to the left in the 180-degree direction, type 6 ., and end the
LINE command.

Right-click the SNAP button on the status bar and choose Settings. Click Grid
snap in the Snap type & style section. Set the Snap X spacing to 0.25. Check
the Snap On check box. Click OK.

Start the LINE command. At the Specify first point: prompt, place the
cursor 0.25 units above @ in Figure 4-24 (at 2,5.25). You may need to turn off
the running OSNAP temporarily. Pick point 2,5.25.

At the Specify next point or [Undo]: prompt, pick point 2,1.75.
(If necessary, press F6 to get absolute coordinates.)

Press F6 twice to get polar coordinates. Follow the prompts:

Specify next point or [Undol: Pick .5<180.

Specify next point or [Close/Undo]: Pick 3.5<90.

Specify next point or [Close/Undo]: Pick the endpoint at @ in
Figure 4-24.

Specify next point or [Close/Undo]: 4

Save your drawing.

Even if you have running object snaps, if you specify an object snap during a com-
mand, it overrides the running object snap. For example, having a running end-
point object snap does not mean you cannot use a midpoint object snap for any
specific drawing command.
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By default, if you type absolute or relative coordinates, they take precedence over
any running object snaps. This lets you leave running object snaps on but override
them with keyboard entry of typed coordinates whenever you want. In general, the
default gives you the most control and flexibility. However, you can change this
default to give running object snaps precedence. To change the default, choose
Tools => Options and click the User Preferences tab.

Locating Points

Sometimes you need to locate a point that is not on an existing object. For example,
you might need a point a certain distance and angle from an existing object. This
section explains three techniques that enable you to locate points that are not on
objects — object snap tracking, point filters, and the From feature.

Object snap tracking

The purpose of tracking is to let you specify a point based on the object snaps of
existing objects. Temporary tracking lines are drawn from points you specify, and
you can use polar snap or direct distance entry to easily specify new points.

Object snap tracking significantly changes the way you draw in AutoCAD, offering
increased ease and speed of drawing, because it provides visual confirmation of
your tracking points. You will need to use the keyboard less often, and thus you’ll
be able to do more heads-up drawing. Use the OTRACK button on the status bar to
turn object snap tracking on and off.

Object snap tracking can easily handle all of the following tasks and many more:

4 You are drawing a line and have specified the start point. You want the end-
point to be exactly vertical to the endpoint of an existing line.

4 You are drawing a line and have specified the start point. You want the line
to be 3 units long and parallel to an existing line.

4 You are drawing a circle inside a rectangle (which could be a hole inside a
sheet metal plate). You want the center of the circle to be exactly centered
inside the rectangle, at the intersection of the midpoints of the rectangle’s
two sides.

4 You want to start a line at the point where two existing lines would intersect
if they were extended.

To start using object snap tracking, at least one object snap must be active. You
can specify an object snap for just that command or turn on a running object snap,
as explained in the previous sections. Then click OTRACK on the status bar.
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After object snap tracking is on, follow these steps:

1. Start a command that requires you to specify a point.

2. Place the cursor briefly over an object snap, such as the endpoint of a line, to
temporarily acquire it. You can acquire more than one point. AutoCAD uses
these acquired points to calculate the tracking paths. You see a small plus
sign (+) over the object snap as confirmation, as shown in Figure 4-25.

Acquired point Figure 4-25: When you pause over an object snap
and then move the cursor slightly, you see a plus sign
(+) at the acquired point to show that the point has
been acquired and can now be used for object snap
tracking.

h Cursor

3. Move the cursor away from the object snap toward your desired point.
AutoCAD displays temporary alignment paths as you move the cursor over
available drawing paths, as shown in Figure 4-26. If ORTHO is on, AutoCAD dis-
plays only horizontal and vertical paths. If POLAR is on, AutoCAD displays
polar paths based on the polar angle settings, as explained earlier in this
chapter.

Acquired endpoint of existing arc

¥

Temporary
alignment path

/ Cursor
Desired endpoint of S;(art pol!nt
i X" of new line
new line (at the "X’} Endpaint 39 168" < 270°]_]

Tooltip

Figure 4-26: With the endpoint object snap active and ORTHO
on, AutoCAD displays temporary alignment paths based on the
acquired point.
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4. When you see a tooltip and a small x, click. AutoCAD continues or completes
the command, using this point.

After you acquire a point, you can clear it in any one of three ways:

4 Move the cursor back over the point’s plus sign.
4 Click OTRACK off using the status bar.
4 Start any new command.

,‘\lote Tracking is intended for use in two dimensions only. For 3D point location, use X,
~ Y, and Z point filters, covered later in this chapter.

You can customize the following features of object snap tracking by using the
Drafting tab of the Options dialog box (Choose Tools => Options):

4+ Uncheck Display Polar Tracking Vector to eliminate the tracking paths.

4 Uncheck Display Full Screen Tracking Vector to display the tracking paths
only from the cursor to the object snap point.

4 Uncheck Display AutoTrack Tooltip to eliminate the tooltips.

4 In the Alignment Point Acquisition section, choose “Shift to acquire” to
require you to press Shift to acquire a point when the cursor is over an object
snap point.

In the following exercise, you practice locating points with object snap tracking.

Unthékl\ The drawing used in the following Step-by-Step exercise on locating points with
iCD' | object snap tracking, ab04-c.dwg, is in the Drawings folder of the AutoCAD
\ /2004 Bible CD-ROM.

Step-by-Step: Locating Points with Object Snap Tracking
1. Open ab04-c.dwg from the CD-ROM.

2. Save the drawing as ab04-07.dwg in your AutoCAD Bible folder. This draw-
ing is a section of a simple plan layout of an apartment. Set endpoint and mid-
point running object snaps only. Make sure that OSNAP and OTRACK are on
and that POLAR is off.

3. Start the LINE command. At the Specify first point: prompt, pick the
endpoint at @ in Figure 4-27. Be sure to pick on the endpoint itself, in order
to acquire it.

4. At the Specify next point or [Undol]: prompt, pass the cursor over @.
Move the cursor down a little, and you see the small plus sign showing that
this endpoint has been acquired.
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Figure 4-27: The tub, door, and sink to be completed in this plan layout

. Move the cursor down until it is to the left of @ and vertical to @. When you

see the tooltip (reading Endpoint: < 270°, Endpoint: < 180°) and the small x
marking the intersection of the two points, click to end the line segment.

. At the Specify next point or [Undo]: prompt, click at @ and end the

LINE command.

. Start the LINE command again. At the Specify first point: prompt, pick

the endpoint of the arc at @ in Figure 4-27. If you’re not sure that you found
the right endpoint, press Tab until the arc is highlighted. Make sure that you
have acquired the endpoint by clicking the endpoint itself or passing the
crosshairs over it.

. At the Specify next point or [Undo]: prompt, pass the cursor over @

until you see the small plus sign. Move the cursor to the left until you see the
tooltip (reading Endpoint: < 90°, Endpoint: < 180°) and click.

. At the Specify next point or [Undo]: prompt, pick the endpoint at @

and end the LINE command.

Start the CIRCLE command. At the Specify center point for circle or
[3P/2P/Ttr (tan tan radius)]: prompt, pass the cursor over @ and then
over @ to acquire both midpoints.

Move the cursor to the middle of the sink, where lines from both midpoints
would intersect until you see the tooltip (reading Midpoint: < 90° Midpoint:
< 180°) and click.
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12. At the Specify radius of circle or [Diameter]: prompt, type 7.5 Jto
complete the sink.

13. Save your drawing. It should look like Figure 4-28.

O
-

)

Figure 4-28: The completed drawing

Point filters

Point filters enable you to specify a coordinate using the X coordinate of one existing
object snap and the Y coordinate of another. You construct an X,Y coordinate based
on coordinates of existing objects. If this sounds complicated, it is. Object snap
tracking should mostly eliminate the need to go back to the old point filter way of
doing things. (Point filters have been around for a long time.)

¢ Cross- Point filters are often used in 3D drawings where object snap tracking doesn't
Reference’\ \\ork. See Chapter 21 for more details.

Here’s how to use point filters:

1. Start a command to draw an object.

2. To specify a coordinate, type .x or .y on the command line. You can also find
point filters on the object snap shortcut menu (Shift+right-click).

3. AutoCAD prompts you for a point. Generally, you specify the point by using
an object snap.

4. AutoCAD prompts you for the other coordinate value, which you generally
provide by using an object snap. (If you are working in 2D, ignore the request
for a Z coordinate.)

5. Continue your command.
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You do not need to use existing coordinates for both the X and Y portions of the
coordinate. For example, you can construct an X,Y coordinate by using the Y coor-
dinate of an existing line and picking the X coordinate anywhere on the screen.

In the following exercise, you practice using 2D point filters on the same drawing
you used in the previous exercise.

cD

On the The drawing used in this Step-by-Step exercise on using 2D point filters, ab04-c.

dwg, is on the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Using 2D Point Filters
1. Open ab04-c.dwg from the CD-ROM.

2. Save the file as ab04-08.dwg in your AutoCAD Bible folder. Make sure that
ORTHO and OSNAP are on and OTRACK is off. Set a running object snap for
endpoint and midpoint.

3. Start the LINE command.
4. At the Specify first point: prompt, pick the endpoint at @ in Figure 4-29.

=N

N
SEEN

]

Figure 4-29: Using point filters to specify the start of a line

5. At the Specify next point or [Undo]: prompt, type .x 1. At the of prompt, pick
the endpoint at @ in Figure 4-29.
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6.

10.
11.

12.

13.
14.

AutoCAD responds with the (need YZ): prompt. (Because you are drawing in
2D, you can ignore the Z.) Choose the endpoint at @ in Figure 4-29. AutoCAD
draws the line segment to the point defined by the X coordinate of @ and the
Y coordinate of @.

. At the Specify next point or [Undo]: prompt, pick the endpoint at @.

End the LINE command.

. Start the LINE command again. At the Specify first point: prompt, pick

the endpoint at @. If necessary, press Tab until you see the arc highlighted so
that you know you have the endpoint of the arc.

. At the Specify next point or [Undo]: prompt, type.y J. At the of

prompt, pick the endpoint at @ in Figure 4-29.
At the (need XZ): prompt, pick the endpoint at @.

At the Specify next point or [Undol: prompt, pick the endpoint at @.
End the LINE command.

Start the CIRCLE command. At the Specify center point for circle or
[3P/2P/Ttr (tan tan radius)]: prompt, type.y . At the of prompt, pick
the midpoint at @. At the (need XZ): prompt, pick the midpoint at @.
AutoCAD places the center of the circle.

At the Specify radius of circle or [Diameter]: prompt, type 7.5 .

Save your drawing.

From feature

The From feature enables you to create a new object starting at a known distance
and direction from an existing object. It’s like creating one or more invisible lines
between the existing object and the new object, helping you start the new object in
the proper place. Use From when no object snaps are available to help you deter-
mine a new point.

Here’s how to use the From feature:

1.
2.

Start a command to draw an object, such as LINE.

Press Shift, right-click, and choose From on the shortcut menu. You can also
type from on the command line.

. AutoCAD prompts you for a base point, which you usually provide by using an

object snap, such as endpoint.

. AutoCAD prompts you for an Offset, which you provide by using relative or

polar coordinates.

. Continue the command you started (in Step 1).
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In the following exercise, you practice using the From feature.

On the ) The drawing used in the following Step-by-Step exercise on using the From fea-
iw@“ | ture, ab04-06.dwg, is in the Results folder of the AutoCAD 2004 Bible
\ /  CD-ROM.

Step-by-Step: Using the From Feature

1. Open ab04-06.dwg, which you created in an earlier exercise. If you did not
do the previous exercise, open the drawing from the Results folder of the
CD-ROM. Make sure ortho mode is on and SNAP is off. OSNAP should be on.
Set a running object snap for endpoint.

. Save the drawing as ab04-09.dwg in your AutoCAD Bible folder.
. Start the LINE command.

. From the Object Snap shortcut menu, choose From.

(22 U

. AutoCAD prompts you for a base point. Pick the endpoint near @ in
Figure 4-30.

Figure 4-30: Using the From feature to
complete the steam boiler

6. At the <Offset>: prompt, type @-1,.5.1_.

7. You are now ready to continue the line at the Specify next point or
[Undo]: prompt. Move the cursor in the 90-degree direction and type 2 .

8. Move the mouse in the 180-degree direction and type 1 .
9. Move the mouse in the 270-degree direction and type 2 .

10. Move the mouse in the 0-degree direction, find the Endpoint marker of the
start point of the first segment of the line, and pick the point. End the LINE
command.

11. Save your drawing. It should look like Figure 4-31.
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|

Figure 4-31: The completed steam boiler

summary

This chapter covered a great deal about specifying coordinates in this chapter.
These skills form the basis for all your future work with AutoCAD. You read about:

4 The XY coordinate system

4+ Using absolute Cartesian coordinates

4+ When and how to use relative Cartesian coordinates

4 Absolute and relative polar coordinates

4 Direct distance entry

4 The orthogonal (ORTHO) mode

4 Using polar tracking

4+ Controlling the display of coordinates on the status bar

4 Grid and polar snap settings

4+ Using the visible grid

4+ Using object snaps (OSNAPS) to specify geometric points on objects

4 Running object snaps and turning OSNAP on and off

4 Using object snap tracking to locate points

4+ Using point filters to locate points

4 The From feature for locating points not on an object
The next chapter introduces you to the basics of setting up a drawing.
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Setting Up a
Drawing

Often the first step after you start a new drawing is to set
its size and unit type. These and other setup options

are discussed in this chapter. The entire process of setting up
a drawing is essential to accurate results.

Unit Types

One of the first steps in setting up a drawing is to choose the
unit type. Units define how objects are measured. You can
save the unit type in a template.

The coordinates you use in AutoCAD are measured in units
that can represent any real-world measurement, such as
inches or millimeters. A surveyor or city planner might even
use miles as the base unit. However, different disciplines cus-
tomarily express units differently, and you should use the unit
type appropriate for the type of drawing you are creating.
AutoCAD offers five types of units, as shown in Table 5-1. The
sample measurement column shows how a line 32.5 inches
long would be displayed in the various unit types.

Notice how the engineering and architectural units translate a
line of 32.5 units into feet and inches. Engineering and archi-
tectural units assume a unit of one inch, unlike the other unit
types, which can represent any measurement.

The unit type affects how coordinates are shown on the status
bar and how AutoCAD lists information about objects. You
generally input coordinates by using the type of units you
have chosen, although AutoCAD in some cases accepts coor-
dinates in another unit type.

CHAPTER

YR SR
In This Chapter
Setting the unit type
Setting drawing limits

Presetting the
drawing scale

Inserting a title block
Understanding
AutoCAD system

variables

Using the MVSETUP

command

+ ¢+
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Table 5-1

Unit Types
Unit Type Sample Measurement Description
Decimal 32.50 Number of units, partial units in decimals
Engineering 2'-8.50" Feet and inches, partial inches in decimals
Architectural 2'-8 12" Feet and inches, partial inches in fractions
Fractional 3212 Number of units, partial units in fractions
Scientific 3.25E+01 Base number + exponent

A\lote If you are using engineering or architectural units, AutoCAD displays partial inches

~ differently than the format you must use to type them in. You must type coordi-
nates without any spaces because AutoCAD interprets a space as equivalent to
pressing the Enter key and ends your input. Use a hyphen between whole and
partial inches, for example, 3'2-1/2". (You can omit the " after the inches because
AutoCAD assumes inches in engineering and architectural units if no symbol fol-
lows a number.) However, this appears on the status line as 3'-2 1/2". This can be
confusing because the hyphen is in a different place, and AutoCAD inserts a space
between the whole and partial inches.

Setting the drawing units

Once you know the units you want to use, you set them in the Drawing Units dialog
box. To set the units, choose Format = Units to open the Drawing Units dialog box,
shown in Figure 5-1. The left side of the Drawing Units dialog box enables you to
choose which unit type you want to use. In the Precision box in the Length section,
click the arrow and a list of precision options drops down. Click the one you want.

El Drawing Units @) Figure 5-1: The Drawing Units dialog box
Length Angle
Type: Type:
Decimal lim Decimal Degrees >
Precision: Precision
0.0000 | 0 >
[ Clockwise

Drag-and-drop scale
Units to scale diag-and-diop content:

Inches v

Sample Dutput

1.5000,2.00:33,0.0000
3.0000<45.0.0000

kK 1 [ Cancel ] [ Direction. ] [ Help
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Caution
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Look in Chapter 3 for a brief overview of the Drawing Units dialog box in the exer-
cise on using a dialog box. See Chapter 18 for more on inserting drawings into
other drawings by using the DesignCenter. See Chapter 26 for full coverage on the
DesignCenter.

AutoCAD rounds off measurements to the nearest precision value you choose. Say
that you choose a precision of two decimal places, using decimal units. You want
to draw a line so that it is 3.25 units long, but when you type the coordinate, by
accident you press the 4 key at the end, resulting in a line 3.254 units long.
AutoCAD shows this line as 3.25 units long, making it difficult for you to spot the
error. Therefore, it is a good idea to set a higher precision than you need to show.

Setting the angle type

As with units, your choice of angle type depends on your profession and work envi-

ronment. Decimal Degrees is the default. Table 5-2 lists the types of angles.

Table 5-2

Angle Types
Unit Type Sample Measurement Description
Decimal Degrees 325 Degrees, partial degrees in decimals
Deg/Min/Sec 32°30'0" Degrees, minutes, and seconds
Grads (gradians) 36.1111¢g Gradians
Radians 0.5672r Radians
Surveyor N 57d30' E Surveyor (directional) units

oo

A minute is % degree and a second is % minute. Gradians and radians are simply
alternate ways of measuring angles. A gradian is a metric measurement equal to
Yoo Of a right angle. Radians measure an angle by placing a length, equal to the
radius, along the circle’s circumference. Radians range from 0 to 2 x & instead of
from O to 360 as degrees do. A radian is approximately 57.30 degrees. Surveyor
units measure angles in directions, starting with north or south and adding an
angle in a degrees, minutes, seconds format that shows how far the angle is from
north or south and in which direction (east or west).

To set the angle type, choose the option you want from the Type drop-down list of
the Angle section of the Drawing Units dialog box (shown in Figure 5-1).

- Cross-
Reference

Changing these angle settings does not automatically change the way your dimen-
sions appear. Use the Dimension Style Manager, which is discussed in Chapter 15,
to change dimensions.
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Setting the angle measure and direction

When defining angle units, you also need to specify in which direction degrees
increase. According to standard convention, you measure angles so that 0 degrees
starts to the right, in the East direction. To change this convention, choose the
direction that you want for 0 degrees and then click Next.

To set the angle measure in the Drawing Units dialog box, click Direction to open
the Direction Control dialog box, shown in Figure 5-2.

(EX Direction Control @) Figure 5-2: The Direction Control dialog box
Baze Anale
(¥) East 000
) North 90.00
) whest 180.00
O South 270.00
() Other Pick / Type
e
I ak l [ Cancel

Here you can choose to have 0 degrees start in a direction other than East. You can
also type any other angle or click the Pick an Angle button to pick two points on
your screen that specify an angle. Choose OK.

Changing the angle direction affects what happens when you input angles and

~  what you see in the coordinate display. It does not change the absolute coordi-
nates, which are set according to the UCS (User Coordinate System). Chapter 8
covers using and customizing UCSs.

By standard convention, degrees increase in a counterclockwise direction. To set
the angle direction, click Clockwise in the Drawing Units dialog box.

Step-by-Step: Setting Drawing Units

1. Begin a new drawing using the acad.dwt template.

2. Save the drawing as ab05-01.dwg in your AutoCAD Bible folder.
3. Choose Format = Units to open the Drawing Units dialog box.

4. In the Length section, choose Architectural.

5. Click the arrow to the right of the Precision drop-down list box in the Length
section. Choose 0'-0 1/8".
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6. In the Angle section, choose Deg/Min/Sec.
7. In the Precision box, choose 0d00'.

8. In the Units to Scale Drag-and-Drop Content drop-down list, set the units to
Inches.

9. Click OK.
10. Start the LINE command. Follow the prompts:

Specify first point: 2,2 4

Specify next point or [Undo]l: @1'<0 A
Specify next point or [Undo]l: @6-3/4<153 .
Specify next point or [Close/Undo]l: 2,2 4

11. End the LINE command.

12. Choose View => Zoom => All to zoom to the entire drawing. Save your drawing.
If you are continuing through the chapter, keep it open.

You would not actually use Deg/Min/Sec for angles in an architectural drawing,
~~  but the exercise gives you the opportunity to set the angular units.

Drawing Limits

You can specify the area of your drawing, also called the limits. The drawing limits
are the outer edges of the drawing, specified in X,Y units. You need to set only the
width and length of the drawing. Together, these two measurements create an invis-
ible bounding rectangle for your drawing.

Almost universally, the lower-left limit is 0,0, which is the default. Therefore, the
upper-right corner really defines the drawing size. Remember that you typically
draw at life size (full scale) in AutoCAD. Therefore, the size of your drawing should
be equal to the size of the outer extents of what you are drawing plus a margin for a
title block and perhaps for annotation and dimensioning. If you want to show more
than one view of an object, as is common in both architectural and mechanical
drawings, you need to take this into account.

To decide on the upper-right corner of your drawing limits (the width and length of
your drawing), you need to consider what the drawing units mean for you.
Generally, the smallest commonly used unit is used, often inches or millimeters.
Therefore, if you are drawing a plan view of a house that is approximately 40-feet
across (in the X direction) by 30-feet deep (in the Y direction), this translates to a
top-right corner of 480,360. Adding room for a title block brings you to about
500,380.
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,v‘\lote You can draw outside the drawing limits. However, the drawing limits setting

‘ ~  affects the size of the grid if you turn it on. This can help you visualize the size of
your drawing if you don't have a title block. The ZOOM command with the All
option also uses the drawing limits to resize the display, although it displays the
entire drawing if the drawing is outside the limits. Setting the limits makes ZOOM
All more useful.

Setting drawing limits
The limits define an artificial and invisible boundary to your drawing. You can draw
outside the limits. The limits affect the size of the grid, when displayed. (See

Chapter 4 for a discussion of the grid.) The Zoom command with the All option also
uses the limits, but only if no objects are outside the limits. (See Chapter 8.)

To set the drawing limits, choose Format = Drawing Limits to start the LIMITS com-
mand. Press Enter to accept the lower-left corner default of 0,0 that appears on the
command line. Then type the upper-right corner coordinate that you want and
press Enter.

0nthé‘¢-\ The drawing used in the following Step-by-Step exercise on setting the drawing
ECDW limits, ab05-01.dwg, is in the Results folder of the AutoCAD 2002 Bible

& /  CD-ROM.

7

Step-by-Step: Setting the Drawing Limits

1. If you did the previous exercise, continue to use ab05-01.dwg. Otherwise,
open ab05-01.dwg from the Results folder of the CD-ROM.

. Save the drawing as ab05-02.dwg in your AutoCAD BibTe folder.
. Choose Format = Drawing Limits.

. Press Enter to accept the lower-left default of 0,0.

. Type 16,10 .

. Start the LINE command. Follow the prompts:

S G AW N

Specify first point: 0,0 4

Specify next point or [Undo]: 16,0 J
Specify next point or [Undo]: 16,10
Specify next point or [Close/Undo]: 0,10 o
Specify next point or [Close/Undo]: 0,0 d

7. End the LINE command.
8. Choose View > Zoom = All.

9. Save your drawing. If you are continuing through the chapter, keep it open.
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Understanding Scales

You need to consider the fact that your drawing will most likely be plotted onto a
standard paper (sheet) size. The standard orientation for drafting (and the default
for most plotters) is landscape orientation, meaning that as you look at the draw-
ing, the paper is wider than it is tall. Figure 5-3 shows an example. These conven-
tions have carried over from the days of hand drafting. (In a computer program,
this is not really necessary, as you can rotate the drawing when you plot it.) To
scale a drawing onto a piece of paper in a pleasing manner requires a rectangular
shape that somewhat resembles the proportions of standard paper sizes.

E- 0

Figure 5-3: Drawings are usually oriented horizontally,
as in this example.

Thanks to Henry Dearborn, AlA, Fairfield, lowa, for this drawing, which
I have altered somewhat.

In addition, although you specify the scale at plotting time, it helps to be aware of
the scale you will use when plotting your drawing at the outset. The scales used for
GIS (Geographic Information Systems), where you might be drawing an entire
county, will be different from those used when drawing a house. The scales used in
mechanical drafting are again totally different. In fact, in mechanical drafting, if you
are drawing a very small object, such as a 2-inch screw-plate, you might scale up,
that is, enlarge the drawing when plotting.

One important reason for establishing the scale at the beginning is to ensure that
text, whether annotations or dimensions, is readable in its final plotted form.
Applying a scale makes it possible to ensure that text remains a reasonable size
even as the rest of the drawing is scaled up or down. In AutoCAD, scale also affects
dotted and dashed lines as well as line widths.
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Some drawings are not scaled. Examples are electrical or electronic schematics,
piping diagrams, and railroad schematics. These drawings are representations of
electrical or electronic connections but do not resemble the actual physical object
that will eventually be created from the drawing. These drawings can be any size as
long as they are clear and organized.

r Cross- You can lay out various views of your drawing on an imaginary piece of paper,
Reference\  3lled a paper space layout, to prepare it for plotting. See Chapter 17 for more on

layouts and plotting.

When determining your scale to try to fit a drawing on a sheet of paper, be aware
that a plotter cannot print on the entire sheet. A certain amount of the margin
around the edge is not available for drawing. Plotters differ in this respect. The plot-
ter’s manual can let you know the width of this unprintable margin. On average, you
can assume a half-inch margin on each side; thus you should subtract one inch

from both the length and width sheet measurements to determine the actual draw-
ing space. Table 5-3 shows standard U.S. sheet sizes.

Table 5-3
Standard Paper Sheet Sizes in the United States (in inches)
Size Wwidth Height Size Wwidth Height
A 11 8% D 34 22
B 17 11 E 44 34
C 22 17

Table 5-4 lists standard metric sheet sizes.

Table 5-4
Standard Metric Paper Sheet Sizes (in millimeters)
Size width Height Size width Height
A4 297 210 Al 841 594
A3 420 297 AO 1,189 841
A2 594 420
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Scale formats

A scale is often indicated in the format “plotted size=actual size.” Because you draw
at actual size in AutoCAD, the actual size is also the drawing size. For example, a
scale of "=1" means that % inch on the drawing, when plotted out on a sheet of
paper, represents 1 foot in actual life—and in the AutoCAD drawing. This is a typical
architectural scale. A windowpane one foot wide would appear %-inch wide on paper.

From the scale, you can calculate the scale factor. To do this, the left side of the
scale equation must equal 1, and the two numbers must be in the same measure-
ment (for example, both in inches). This requires some simple math. For i"=1', you
would calculate as follows:

et

1"=4" Both sides of the equation multiplied by 4

1" = 48" 4' converted to 48"

Therefore, the scale factor is 48. This means that the paper plot is % of real size.

In mechanical drawing, you might draw a metal joint that is actually 4 inches long.
To fit it on an 8% x 11 sheet of paper, you could use a 2"=1" scale, which means that
2" on the paper drawing equals 1" in actual life and the AutoCAD drawing. Calculate
the scale factor:

2u - 1n
ln :%n

The scale factor is %. This means that the paper plot is twice the real size.

r Cross- You use the scale factor when you set the size for text in Chapter 13 and for
Reference\  jimensions in Chapter 15.

Most professions use certain standard scales. Therefore, you do not usually have a
choice to pick any scale you want, such as 1":27'. Instead, the conventions of your
profession, client, or office dictate a choice of only a few scales. Table 5-5 lists some
standard architectural scales.
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Table 5-5

Typical Architectural Scales
Scale Factor Plotted Size Drawing/Actual Size
480 Vao"' 1
240 Yo' 1
192 Yie" 1
96 %" 1
48 " 1
24 " 1
16 %" 1
12 1" 1
4 3" 1
2 6" 1

1 1 1

Civil Engineering scales are somewhat different and range to larger sizes —a bridge
is bigger than a house — as shown in Table 5-6.

Table 5-6
Typical Civil Engineering Scales
Scale Factor Plotted Size Drawing/Actual Size
120 1" 10'
240 1 20'
360 0 30'
480 1" 40
600 Ik 50"
720 1 60'
960 Ik 80'

1,200 1" 100’
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Table 5-7 shows some typical metric scales that can be used for any purpose. You
would most typically work in millimeters, but these could represent any metric
measurement.

Table 5-7

Typical Metric Scales
Scale Factor Plotted Size Drawing/Actual Size
5,000 1 5,000
2,000 1 2,000
1,000 1 1,000
500 1 500
200 1 200
100 1 100
75 1 75
50 1 50
20 1 20
10 1 10
5 1 5

1 1 1

Deciding on a scale and sheet size

As soon as you know the size of your drawing and the scale appropriate for your
situation, you need to consider the sheet size of the paper that you will plot on.
Again, you often find that certain factors limit your choices. Your plotter or printer
may be limited to certain sheet sizes. The conventions used in your discipline or
working environment also affect your decision. You may be working on a series of
drawings that are all to be plotted on the same size sheet of paper.

As an example, the architectural drawing in Figure 5-3 is 175-feet wide by 120-feet
high. The two most typical scales for a drawing of a house are /4"=1" and 4"=1". On a
small plotter, you might have a choice of sheet sizes A, B, or C. The following steps
show the calculations you need to do in order to decide on a scale, obtain the scale
factor, and determine the appropriate sheet size.

In this exercise, you practice determining the scale and sheet size. You need only a
sheet of paper and a pencil. Use Figure 5-3 (shown earlier) as a reference.

99



100

Part | + AutoCAD Basics

Step-by-Step: Determining the Scale and Sheet Size

1.

To calculate the plotted size of the drawing at /4"=1', you can start with the
width, which is 175'. Take one-quarter of 175 to get the width of the drawing in
inches, which is 43%".

. Take one-quarter of the height, 120', to get the height of the drawing in inches,

which is 30".

. A size-C sheet (see Table 5-3) is 22"x17", which is too small for a 43%"x30"

drawing.

. Recalculate the drawing at %"=1'. Take one-eighth of 175 to get 21%. Take one-

eighth of 120 to get 15".

. The actual drawing space (minus the margins the printer requires) on a size-C

sheet is about 21"x16". The height of the drawing at this scale is adequate, but
the width is %" too long. Therefore, the best bet is to simply make the drawing
7" narrower because the drawing has some extra room. This lets you fit the
drawing on a size-C sheet.

. To calculate the scale factor of a Js"=1" scale, multiply 1' by 8 to get 8 and con-

vert it to inches, which is 96 (8x12).

Rearranging the views, dimensions, and text on a drawing to fit a standard scale
factor and sheet size is a typical task. There is no actual setup step for setting the
drawing scale, but you use it when you insert text or dimensions and when you plot
the drawing.

Inserting a Title Block

A title block is a rectangle that includes spaces for the drawing title, company name,
drafter name, and so on. It generally comes with a border that bounds your drawing.
Many drawings require title blocks. You can insert an existing title block in two ways:

4 When creating a new drawing, choose File> New to open the Select Template

dialog box. Choose one of the templates that includes a title block. For exam-
ple, ANST A -Named Plot Styles.dwt includes a title block and border that
fit on an A-size sheet. AutoCAD inserts the title block and border on the layout
tab. (Chapter 17 covers layouts and named plot styles.)

4 After you open a drawing, you can insert a drawing of a title block into it.

Choose Insert &> Block. In the Insert dialog box, type the name of the drawing
or block or click Browse to find it. Most of the templates have a correspond-
ing drawing that you can insert into your drawing. You can find them in the
\Template folder. To insert the file or block at 0,0 with no scaling or rotation,
uncheck all the Specify On-screen check boxes. Check Explode if you expect
to edit the inserted drawing after it’s in your drawing. Click OK.
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New N\ The templates and their corresponding drawings are in a new location. To find this

e location, choose Tools> Options and click the Files tab. Double-click Drawing
Template Settings and then double-click Drawing Template File Location. You see
the path to the new location displayed. The path is very long! This folder may be
hidden in Windows Explorer. For instructions on displaying hidden folders, go to
Windows Help and enter hidden folders in the search box.

r Cross- As explained in Chapter 2, you can create your own title block, make a template
Reference’\  fom it, and then start a drawing based on that template. Chapter 18 covers

blocks.

Common Setup Options

A few other items are generally set up in advance and are included in a template.
Other chapters of this book cover the following:

4+ Layers (covered in Chapter 11) enable you to organize your drawing into
meaningful groups. In an architectural drawing, for example, you might create
a layer for walls, another for doors, one for electrical fixtures, and so on.

4+ Text styles (covered in Chapter 13) enable you to format the font and other
text characteristics.

4+ Dimension styles (covered in Chapter 15) format the dimensions that mea-
sure your objects.

Setting Snap, Grid, and Ortho

If you know you will be using snap, grid, and ortho a lot in certain drawings and you
know the suitable settings for snap and grid, you can set these and save them in a
template because these settings are saved with the drawing. In other cases, you
might want to leave them off and turn them on only when you need them.

The Windows registry saves many settings, such as running object snaps, the type
of snap (grid or polar), and the polar distance when you are using polar snap. As a
result, when you open AutoCAD, they are automatically set to the same setting you
had when you last closed AutoCAD, regardless of the setting in the drawing.
Therefore, you cannot save these settings in a template.

In this final exercise, you practice specifying the drafting settings and creating a
template.

On the ) The drawing used in the following Step-by-Step exercise on setting drawing aids
i CDW | and creating a template, ab05-02.dwg, is in the Results folder of the AutoCAD
\ /2002 Bible CD-ROM.

Y

101



102  Partl + AutoCAD Basics

System variables

When you change settings in AutoCAD, such as the unit type, angle type, drawing limits,
blip marks, snap mode (on or off), grid mode, or ortho mode, you are actually changing
AutoCAD's system variables. These are simply settings that AutoCAD stores in each drawing
or in the Windows registry (which stores settings that apply to all drawings). Usually you
don't need to pay any direct attention to them, but they are the nuts and bolts behind the
dialog boxes you use to change the settings. When you start customizing AutoCAD, you
need to learn about them because programming code and script files (AutoCAD macros)
cannot access dialog boxes. Also, a few system variables are accessible only by typing them
directly on the command line. Appendix C on the CD-ROM provides more information on
system variables. Throughout this book, | occasionally mention system variables when it is
useful to use them directly. Some system variables store information about a drawing or the
drawing environment, such as the drawing name and path. These are read-only, meaning
that you cannot change them. They exist to provide information and are often used in
AutoLISP programs.

You can type system variables on the command line, just like AutoCAD’s regular commands.

Information about each system variable, where it is stored, its default, and whether it is
read-only is in AutoCAD’s help system. Choose Help=> Help and double-click Command
Reference on the Contents tab. Then scroll down and double-click System Variables.

Step-by-Step: Setting Drawing Aids and Creating a Template

1. If you did the exercise on drawing limits use that drawing or open
ab05-02.dwg from the Results folder of the CD-ROM.

2. Save the drawing as ab05-03.dwg in your AutoCAD Bible folder.
3. Choose Tools = Drafting Settings.

4. On the Snap and Grid tab, the snap spacing is set to %". In the Grid section,
change the X spacing to 1". Make sure the Snap Type is set to grid snap and
rectangular snap. Click OK.

5. Click SNAP and GRID on the status bar to turn them on. Make sure OSNAP is
turned off.

6. Choose Format = Units. Change the Angle Type back to decimal degrees. In
the Units to Scale Drag-and-Drop Content section, choose Inches from the
drop-down list (if not already set for inches). Click OK.

7. Using the coordinate display as your guide, start the LINE command and draw
line segments from 2%, 1% to %¥<270 to 11"<0 to %¥<90. End the LINE command.

8. Start the LINE command again. Again use the coordinate display to draw line
segments from 2,2 to 1/2<270 to 1'0"<0 to %<90. End the LINE command.



9.

10.

11.
12.

13.
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Save your drawing. It should look like Figure 5-4. Notice how the grid and snap
settings facilitate the drawing process.

The architectural units create a different drawing experience than decimal
units would. Setting up a drawing creates a drawing environment suited to
your work needs.

H r

Figure 5-4: The final architectural drawing

Choose File> Save As. In the Save Drawing As dialog box, click the Files of
Type drop-down list box and choose AutoCAD Drawing Template (* . dwt).
Notice that AutoCAD automatically places you in the \Template folder.

In the File name text box, change the name to archroof.dwt. Click Save.

In the Template Description dialog box, type Arch units, 16,10 limits, snap &
grid and click OK.

Choose File > New. Choose the archroof template and click Open. AutoCAD
starts a new drawing by using the template.

Do not save this new drawing.

The MVSETUP Command

The MVSETUP command is used in two different ways —to set up a drawing and to
create viewports for paper space layouts.

- Cross-
Reference

Paper space layouts are a way of laying out your drawing in preparation for print-
ing or plotting. Chapter 17, which covers laying out a drawing as well as plotting,
discusses paper space layouts.

MVSETUP provides a command-line routine to walk you through some of the basic
setup functions discussed in this chapter. You can use MVSETUP when you start to
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customize AutoCAD to set up a drawing from a script file or AutoLISP program (top-
ics covered in Parts VI and VII of this book). To use MVSETUP, type mvsetup - on
the command line. AutoCAD responds with the following prompt:

Enable paper space? [No/Yes] <Y>:
Type n Jto use MVSETUP without entering paper space.
The next prompt lets you enter the units type:

Enter units type
[Scientific/Decimal/Engineering/Architectural/Metric]:

Choose the option you want. Then AutoCAD displays a list of scale factors appro-
priate to the units option you chose. At the Enter the scale factor: prompt,
type in a numeric scale factor.

Finally, AutoCAD prompts you to set the drawing limits with the following two
prompts:

Enter the paper width:
Enter the paper height:

After each prompt, enter a number based on the size of the paper you plan to plot
on. AutoCAD draws a rectangle of the size you indicated for the drawing limits.

Creating a Customized Template

You can save many of the settings discussed in this chapter in a template so that
they are available to you whenever you start a new drawing.

To create a customized template, open any drawing. Make changes as described
in this chapter and save the drawing as a template by choosing Drawing Template
(*.dwt) from the Save as Type drop-down list box in the Save Drawing As dialog box.

There are two wizards to help you set up a drawing. You need to activate the
Startup dialog box to find them:

1. Choose Tools &> Options and click the System tab. In the General Options
section, choose Show Startup Dialog Box from the Startup drop-down list.
Click OK.

2. Close and open AutoCAD. You see the Startup dialog box.

3. Click the Use a Wizard button. Choose Quick Setup for fewer options or
Advanced Setup for more options.

4. Click OK.
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Summary

This chapter explained all about setting up a drawing so that it behaves the way
you want it to. You read about:

4 Setting the unit type

4 Setting the angle type, measure, and direction

4 Drawing limits

4 Scales and calculating a scale factor

4 Setting drawing aids and creating a template that includes the settings that

you want

This chapter ends Part I, “AutoCAD Basics.” Now that you know the basics, you can
go on to Part II, “Drawing in Two Dimensions.” The next chapter covers drawing
simple lines, polygons, rectangles, and special infinite construction lines.

+ o+






Drawing in Two
Dimensions

N ow that you have the basics under your belt, it’s time
to really draw. In Part II, you learn the techniques for
basic drawing and editing in AutoCAD. After chapters on
drawing simple lines and curves, [ explain the details of how
to control the display of your drawings. You can also find
chapters on creating text, drawing dimensions, and creating
dimension styles. Separate chapters cover getting information
from your drawing and drawing complex objects. Part Il winds
up with a chapter on plotting and printing. This part contains
all the basic information you need for two-dimensional draw-
ing and design.

+ + +
In This Part

Chapter 6
Drawing Simple Lines

Chapter 7
Drawing Curves and
Point Objects

Chapter 8
Viewing Your Drawing

Chapter 9

Editing Your Drawing:
Basic Tools

Chapter 10

Editing Your Drawing:
Advanced Tools
Chapter 11
Organizing Drawings
with Layers, Colors,
Linetypes, and
Lineweights

Chapter 12
Getting Information
from Your Drawing

Chapter 13
Creating Text

Chapter 14
Drawing Dimensions

Chapter 15
Creating Dimension
Styles and Tolerances

Chapter 16
Drawing Complex
Objects

Chapter 17
Plotting and Printing
Your Drawing
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Drawing Simple
Lines

Lines are the most commonly drawn object. You will use
the LINE command a lot! Other related commands are
also used often. Construction lines are not as common, but

you should have all these commands in your arsenal. Part |
included several exercises in which you drew lines. However,
the LINE command has several options and you can still learn a
few tricks of the trade by focusing on the LINE command itself.

Using the LINE Command

Learning all the ins and outs of the line command will make
your drawing more efficient, because you use the LINE com-
mand so often.

/ To draw a line, choose Line from the Draw toolbar. At the
Specify first point: prompt, specify any point.
Continue to specify points until you are finished. Press Enter
to end the command. You can also right-click and choose
Enter from the shortcut menu. The LINE command assumes
you will continue to use it over and over. For this reason,
AutoCAD continues to prompt you until you press Enter.

If you continue to draw line segments, the subsequent
prompts are different. Here’s how to use them:

4 AutoCAD displays the Specify next point or
[Undo]: prompt for the next two segments. Right-click
and choose Undo (or type u J) to undo only the last
line segment you created — without exiting the LINE
command.

4 After creating at least two line segments, AutoCAD
displays the Specify next point or [Close/Undo]:
prompt. Right-click and choose Close (or type ¢ ) to
automatically draw a line from the endpoint of the last seg-
ment to the original start point, thereby creating a closed
figure. You can continue to use the Undo option as well.

C H AgP T\E R

¢+ o+
In This Chapter

Using the LINE

command
Drawing rectangles
Drawing polygons

Creating construction
lines

Creating rays

¢+ 4+
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If you previously drew a line, press Enter at the Specify first point: prompt to
start the line at the endpoint of the last line. If you most recently drew an arc, press
Enter to start the line at the endpoint of the arc and draw it tangent to the arc.

Step-by-Step: Using the LINE Command
1. Start a new drawing by using the acad.dwt template.
2. Save the drawing in your AutoCAD Bible folder as ab06-01.dwg.

3. Start the LINE command. At the Specify first point: prompt, choose any
point in the center of your drawing.

. Click ORTHO on the status bar.

. Move the cursor to the right in the 0-degree direction and type .4667 .
. Type .7341<129 ..

. Move the cursor to the right in the 0-degree direction and type .4668 .
. That was a mistake. Type u .

© W N S U1 e

. The Specify next point or [Close/Undo]: prompt reappears. With the
cursor still in the 0-degree direction, type .4667 ..

10. Type c J to close the figure. This ends the LINE command.
11. Start the LINE command again.

12. At the Specify first point: prompt, press Enter. The line starts at the pre-
vious endpoint.

13. Type .8071<270 . and press Enter to end the LINE command.
14. Save your drawing. It should look like Figure 6-1.

Figure 6-1: The completed gate valve symbol

how to draw dashed and dotted lines. Chapter 16 explains how to create poly-
lines, which combine line segments and curves into one object. Chapter 16 also
covers multilines — sets of parallel lines that you draw all at once.

ﬁj Other aspects of lines are covered elsewhere in the book. Chapter 11 explains
eference

0nth'e“¥-\ Mend.1sp is an AutoLISP routine that combines two lines into one. You can find
ICDW | itin \Software\Ch06\Mend.
//j

%
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Drawing Rectangles

The RECTANG command draws rectangles. Rectangles are used in all disciplines.
The RECTANG command has a number of options that specify how the rectangle
appears.

v | Use the RECTANG command to create a rectangle by specifying the two diago-
nal corners. Choose Rectangle from the Draw toolbar.

AutoCAD prompts you for the two corners and creates the rectangle. You can spec-
ify the two corners by using any method of specifying coordinates. For example, if
you know the rectangle should be 6 inches wide and 3 inches high, you can specify
the second point as @6,3.

After you specify the first corner, you can specify the length and the width of the
rectangle instead of the second corner. Here are the prompts for specifying the
length and width of a rectangle:

Specify other corner point or [Dimensions]: Choose the
Dimensions option.

Specify Tength for rectangles <0.0000>: Type the length and
press Enter.

Specify width for rectangles <0.0000>: Type the width and press
Enter.

Specify other corner point or [Dimensions]:Pick a point to
specify where you want the rectangle.

As soon as you specify the length and width, four possible rectangles are possible,
as shown in Figure 6-2. As you move your mouse cursor around the first corner you
specified, AutoCAD displays these rectangles. Click when you see the one that you
want.

,ﬁ\lote After you set the dimensions, they remain as defaults for future rectangles that you
~  draw. As a result, you can use the Dimensions option to quickly draw a number of
identical rectangles.

¢ Cross- You can chamfer and fillet the corners as you create the rectangle. Chapter 10 cov-
Reference’\ o5 chamfering and filleting. You can specify a width for the rectangle’s line (see

Chapter 16). You can also create a 3D box by using the elevation and thickness
options (see Chapter 21). The RECTANG command creates a polyline, meaning
that all four sides of the rectangle are one object, instead of four separate line
objects. Chapter 16 covers polylines.
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First corner point ~ Figure 6-2: When you specify the first corner,
a length, and a width, choose which of four
possible rectangles you want.

Drawing Polygons

C}' AutoCAD’s POLYGON command enables you to draw multisided closed figures
with equal side lengths. AutoCAD can draw polygons with anything from 3 to
1,024 sides. To draw a polygon, choose Polygon from the Draw toolbar.

First specify the number of sides. Then choose one of three methods of defining the
polygon, as described in Table 6-1.

Table 6-1
POLYGON Command Options
Option Description
Edge Right-click and choose Edge. Specify the two endpoints of

any edge of the polygon. AutoCAD completes the polygon.

Inscribed in circle After specifying the center, right-click and choose Inscribed
in circle. Then specify the radius from the center to a vertex
(point). This defines the polygon with reference to an
imaginary circle whose circumference touches all the
vertices of the polygon.

Circumscribed about circle After specifying the center, right-click and choose
Circumscribed about circle. Then specify the radius
from the center to the midpoint of a side. This defines
the polygon with reference to an imaginary circle
whose circumference touches all the midpoints of the
polygon'’s sides.
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If you type a number for the radius, the bottom edge of the polygon is horizontal.
However, if you pick a point for the radius with your mouse, you can specify the ori-
entation of the polygon. Rotate the mouse cursor around the center, and you see
the polygon rotate. Pick when you like what you see.

- Cross-
Reference

When you type a number for the radius, the bottom edge actually aligns with the
snap rotation angle, which is usually 0. Chapter 8 explains how to change this
angle.

The POLYGON command creates a polyline, meaning that the entire polygon is one
object, rather than a series of line segments.

In the exercise that follows, I indicate inches with a double-prime (") and feet with a
prime (). It is not necessary to type the double-prime for inches, but you may find
it clearer when a measurement has both feet and inches. When you have a measure-
ment that is only in inches, it saves time to leave out the double-prime.

N
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The drawing used in this Step-by-Step exercise on drawing rectangles and poly-
gons, ab06-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible
CD-ROM.

Step-by-Step: Drawing Rectangles and Polygons

1.
2.

Open ab06-a.dwg from the CD-ROM.

Save the drawing in your AutoCAD BibTe folder as ab06-02.dwg. Verify that
snap and grid are on, set at 1". OSNAP should be off.

T Choose Rectangle from the Draw toolbar.

. At the Specify first corner point or

[Chamfer/Elevation/Fillet/Thickness/Width]: prompt, move the cur-
sor to 0'-1",0-1" and click. At the Specify other corner point or
[Dimensions]: prompt, type 2'1",1'9" .

. Start the RECTANG command again. At the Specify first corner point

or [Chamfer/Elevation/Fillet/Thickness/Width]: prompt, press
Shift and click the right mouse button and choose the From object snap.
Shift+right-click again and choose the Endpoint object snap. Pick the bottom-
left corner of the rectangle. At the <Offset>: prompt, type 2,2 1 to start the
second rectangle 2 inches up and 2 inches to the right of the first rectangle.

. At the Specify other corner point or [Dimensions]: prompt, type

19",1'3" .

. Right-click and choose Repeat Rectangle to start the RECTANG command

again. At the prompt, find 0'8",1'7" (on a snap point) and click. At the Specify
other corner point or [Dimensions]: prompt, type 11,2 .. (You don’t
need to type the double-prime for inches.)
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8.

10.

11.

12.
13.

14.

15.

16.

17.

Again, start the RECTANG command. At the prompt, find 1'1",1'8" and click. At
the Specify other corner point or [Dimensions]: prompt, type 1,-5 .J.

. C? Start the POLYGON command. At the Enter number of sides <4>:

prompt, type 5 . At the Specify center of polygon or [Edge]:
prompt, type 10,1'8 1 to indicate the center.

At the Enter an option [Inscribed in circle/Circumscribed about
circle] <I>: prompt, press Enter to accept the default. This means you
indicate the radius from the center to the vertices. (If your prompt shows <C>
as the default, type i ..)

At the Specify radius of circle: prompt, type .5 4. AutoCAD draws the
pentagon.

Repeat Steps 9-11 using a center of 1'5,1'8.

Start the POLYGON command again. At the Enter number of sides <5>:
prompt, type 3 .

At the Specify center of polygon or [Edge]: prompt, right-click and
choose the Edge option.

At the Specify first endpoint of edge: prompt, choose the top-left cor-
ner of the faucet rectangle (1'1",1'8"), which is on a snap point.

At the Specify second endpoint of edge: prompt, choose the top-right
corner of the faucet rectangle. AutoCAD completes the triangle.

Turn off the grid to get a better look at the drawing. You have completed the
sink, which should look like Figure 6-3. Save your drawing.

(6 A o]

Figure 6-3: The completed sink, drawn
by using rectangles and polygons
Thanks to Bill Wynn of New Windsor, Maryland,
for this drawing, which he created in his AutoCAD
class as part of a plan drawing of an entire house.
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Creating Construction Lines

Sometimes you want to create a line that is used solely for the purpose of reference.
For example, you might want to do the following:

4 Draw two lines from the midpoints of two perpendicular lines so that you can
use their intersection as the center for a circle.

4 Draw a line from one object to another to visually indicate the relationship
between the two objects.

4+ Show the relationship between equivalent parts of a model shown in front and
right-side views.

4 Draw a line through the center of an object shown in cross-section so that you
can show dimensions from the centerline to the edge of an object.

You could use regular lines for these purposes. However, construction lines (also
known as xlines) are unique in that they extend infinitely in both directions. This
makes them especially useful for seeing the relationships among various objects in
your drawing.

Of course, construction lines are not actually infinite. However, they extend to the
edge of the drawing area on your screen, and if you zoom out to see more of your
drawing, they expand so that they always extend to the edge of the screen.
AutoCAD’s object snap tracking sometimes eliminates the need for construction
lines; nevertheless, sometimes you can work more easily having a line visible for
several commands and then erasing it.

If you zoom to show the extents of your drawing, AutoCAD ignores the xlines and
shows you just the extents of the regular objects in your drawing. Chapter 8 covers
the ZOOM command.

r Cross- Construction lines are especially helpful when working in 3D. See Part IV of this
Reference book.

‘))r The XLINE command offers several ways to create construction lines. Start the
command by choosing Construction Line from the Draw toolbar. You see the
following prompt:

Specify a point or [Hor/Ver/Ang/Bisect/Offset]:
Table 6-2 lists the possible options. AutoCAD continues to prompt you for more

points so that you can continue to draw construction lines — much like the LINE
command. Press Enter to end the command.
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Table 6-2
XLINE Command Options
Option Description
Specify a point This option enables you to define the xline with two points. At the

first prompt, specify a point. At the Specify through point:
prompt, specify another point. The first point becomes the base
point for subsequent construction lines that you can draw by
specifying other through points.

Hor To draw a construction line parallel to the X axis, type h J to specify
the Horizontal option. AutoCAD responds with the Speci fy
through point: prompt. Specify one point. Useful for drawing a
series of horizontal construction lines.

Ver To draw a construction line parallel to the Y axis, type v . to specify
the Vertical option. AutoCAD responds with the Specify through
point: prompt. Specify one point.

Ang Type a J (for Angle). AutoCAD responds with the Enter angle of
x1ine (0) or [Reference]: prompt. If you enter an angle,
AutoCAD asks for a through point. Or you can type r - and select a
line as a reference, and then provide an angle and a through point.
AutoCAD then calculates the angle of the construction line from the
angle of the reference line. Useful for drawing a series of
construction lines at a specified angle.

Bisect To draw a construction line that bisects (divides in half) an angle,
type b . AutoCAD responds with the Specify angle vertex
point: prompt. Choose any point that you want the construction
line to pass through. Then, at the Specify angle start point:
prompt, choose a point that defines the base of the angle. At the
Specify angle end point: prompt, choose a point that defines
the end of the angle.

Offset To draw a construction line parallel to a line, type 0 . You can
specify the offset distance by typing in a number or use the Through
option to pick a point through which the construction line should
pass. Either way, the next step is to select a line. If you specified an
offset distance, AutoCAD displays the Specify side to offset:
prompt. Respond by picking a point on the side of the selected line
on which you want the construction line to appear.

Creating Rays

Rays are similar to construction lines, except that they start at a specific point and
extend to infinity in one direction only. If you need a line to extend only in one
direction, using a ray may be less confusing.
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You can use most object snaps with construction lines and rays. (You can't use
endpoint for construction lines or midpoint for rays.) Construction lines and rays

4 can be edited like any other object.

To draw a ray, choose Draw => Ray. At the Specify start point: prompt, specify
the start point for the ray. At the Specify through point: prompt, specify
another point. AutoCAD continues to ask for through points. Press Enter to end the
command.

The drawing used in this Step-by-Step exercise on drawing construction lines and
| rays, ab06-b.dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

/'I
& b/

Step-by-Step: Drawing Construction Lines and Rays

1. Open ab06-b.dwg from the CD-ROM. A simple cross-section view has been
added.

2. Save the drawing as ab06-03.dwg in your AutoCAD Bible folder.
3. ..."; Choose Construction Line from the Draw toolbar.

4. At the Specify a point or [Hor/Ver/Ang/Bisect/0ffset]: prompt,
choose point @), shown in Figure 6-4.

5. At the Specify through point: prompt, choose point @, shown in
Figure 6-4.

Figure 6-4: The pipe with cross-section

6. Press Enter to end the command. Notice that the drawing has been set up so
that the construction line is drawn in green and with a noncontinuous line-
type. This is to distinguish it from the main drawing. (See Chapter 11 for
details on how to set up a drawing in this way.)

7. Choose Draw = Ray.
8. At the Specify start point: prompt, choose point @, shown in Figure 6-4.

9. At the Specify through point: prompt, choose point @, shown in
Figure 6-4. Press Enter to end the command.

10. Save your drawing.

117
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Summary

This chapter covered the ins and outs of lines. You read about:

4 Using the LINE command

4 Drawing rectangles

4 Drawing polygons

4+ Creating construction lines, including xlines that extend infinitely in both

directions and rays that extend infinitely in one direction

The next chapter explains how to draw curves and point objects. Curves include
circles, arcs, ellipses, and donuts.

+ 0+ ¢
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Drawing circles

Drawing arcs

A utoCAD offers a number of ways to create curved Creating ellipses
objects. You can draw circles, arcs, ellipses, and
donuts (also called doughnuts). In this chapter, I also cover Drawing donuts

point objects that are neither curves nor lines, but don’t

deserve their own chapter. Creating point

L . objects
r Cross- Several complex objects involve curves, such as polylines,
\Re'e'e"ce splines, regions, and boundaries. These are covered in ¢ + + +
Chapter 16.

Drawing Circles

Circles are common objects in drawings. In mechanical draw-
ings, they often represent holes or wheels. In architectural
drawings, they may be used for doorknobs, trash baskets, or
trees. In electrical and piping schematics, they are used for
various kinds of symbols.

Understanding the circle options

@ AutoCAD provides five ways to draw a circle. To draw a
circle, choose Circle from the Draw toolbar. AutoCAD
responds with the Specify center point for circle or
[3P/2P/Ttr (tan tan radius)]: prompt. Table 7-1
describes how to use these options.
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Table 7-1
Five Ways to Draw a Circle

Option

Description

Center Radius

Center Diameter

2P

3P

Tangent, Tangent,
Radius

This option is the default. Specify the center and then the radius.
You can type the radius as a distance or pick a point on the
circumference.

Specify the center. Type d . and type the length of the diameter
or pick a point to specify the diameter.

2P stands for 2 point. Type 2p . Specify one point on the
circumference, and then an opposite point on the circumference.
These two points define the diameter of the circle.

3P stands for 3 point. Type 3p .. Specify three points on the
circumference.

Type t or ttr . AutoCAD prompts Specify point on object
for first tangent of circle: and provides an aperture
to let you pick a point. Then AutoCAD prompts Specify point
on object for second tangent of circle: and you pick
a second point. These points can be any points on the object(s)
to which you want your circle to be tangent. Finally, type a radius.

Tip You can also create a circle tangent to other objects by using the 2-point (2P) or
_»_ 3-point (3P) method and picking those points with the Tangent object snap. When

N

you choose Drawt Circle (from the menu), AutoCAD includes a tan tan tan

option, enabling you to specify a circle tangent to three objects.

Drawing circles

Drawing circles is fairly straightforward. Often you can use object snaps to define
part of the circle. In the following exercise, you practice using the most common
methods of creating a circle.

ab07-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Onthe_“\ The drawing used in the following Step-by-Step exercise on creating a circle,

" Step-by-Step: Creating a Circle

1. Open ab07-a.dwg from the CD-ROM.

2. Save the file as ab07-01.dwg in your AutoCAD Bible folder. This is a drawing
of an air compressor from which all the circles have been removed. Make sure
that OSNAP is on. Set a running object snap for endpoints only.
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3. @ Choose Circle from the Draw toolbar. Right-click and choose 2P from
the shortcut menu. At the Specify first end point of circle's
diameter: prompt, pick the endpoint at @ in Figure 7-1. At the Specify
second end point of circle's diameter: prompt, pick the endpoint

at @.

S
W
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AR COMPRESSOR

Figure 7-1: The air compressor without its circles

4. Repeat the CIRCLE command by right-clicking and choosing Repeat Circle.
Right-click and choose 2P from the shortcut menu. Pick the endpoints at @
and @ in Figure 7-1.

5. Repeat the CIRCLE command by pressing Enter. At the Specify center
point for circle or [3P/2P/Ttr (tan tan radius)]: prompt, pick the
endpoint at @. At the Specify radius of circle or [Diameter]:
prompt, pick the endpoint at @.

6. Repeat the CIRCLE command. At the Specify center point for circle
or [3P/2P/Ttr (tan tan radius)]: prompt, pick the endpoint at @. At
the Specify radius of circle or [Diameter]: prompt, right-click and
choose Diameter; then type .25 ..

7. Repeat the CIRCLE command by right-clicking and choosing Repeat Circle.
At the Specify center point for circle or [3P/2P/Ttr (tan tan
radius)]: prompt, right-click and choose 3P. At the Specify first point
on circle: prompt, pick the endpoint at @ in Figure 7-1. At the Specify
second point on circle: prompt, pick the endpoint at @. At the Specify
third point on circle: prompt, choose a midpoint object snap and pick
the midpoint at @.
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8. For the last circle on the right, choose any method you want to draw a circle.
The circle should be the same size and placement as the second circle from
the left.

9. Repeat the CIRCLE command. At the Specify center point for circle
or [3P/2P/Ttr (tan tan radius)]: prompt, choose the Center object
snap J and pick @. At the Specify radius of circle or [Diameter]:
prompt, type .05 .

10. Repeat Step 9 to create a circle inside the circle whose center is at @ and
whose radius is 0.05.

11. Repeat the CIRCLE command. At the Specify center point for circle
or [3P/2P/Ttr (tan tan radius)]: prompt, pick the endpoint at @. At
the Specify radius of circle or [Diameter]: prompt, pick the end-

point at @.

12. Repeat Step 11, choosing the endpoint at @) for the center of the circle and the
endpoint at @ for its radius, as shown in Figure 7-1.

13. Save your drawing. It should look like Figure 7-2.

T

E}\ AIR COMPRESSOR
N
o

Figure 7-2: The completed air compressor
Thanks to the U.S. Army Corps of Engineers at Vicksburg,
Mississippi, for this drawing. They maintain a Web site of
drawings at http://cadlib.wes.army.mil.
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ply have copied one circle to another location instead of creating each circle from

@ It may have occurred to you that this task would have been easier if you could sim-
eference
scratch. | cover copying in Chapter 9.

Drawing Arcs

An arc is a portion of a circle. Therefore, to define an arc, you have to define not
only a circle—for example, by specifying a center and a radius — but also you must
define the start and endpoints of the arc. You can do this in many ways. AutoCAD
offers several methods of defining an arc. The method you pick depends on the
information you have about the arc you want to draw.

Understanding arc options

Arcs have many options. Making sense of them may seem overwhelming, but after
you understand the parts of an arc and AutoCAD’s terminology, you can choose the
options that suit your needs. Figure 7-3 shows the parts of an arc that you can use
to draw an arc. Refer to these parts as you read through the arc options.

Endpoint AN

SN }<— Direction

Radius —— |}

i

Center \1\

Length of chord

Included angle

Figure 7-3: The parts of an arc

Figure 7-4 shows the flow of the arc options. When you start the ARC command, you
have two options, Start point and Center. Depending on which you choose, more
options become available.

You can also press Enter at the first arc prompt to draw a second arc starting from
the endpoint of a previous arc, line, polyline, and so on. The new arc continues in
the same direction as the end of the first arc. The only other prompt is the endpoint.
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Angle
Center Length of chord
Endpoint

!

Angle
Direction
Radius
Center point

Start point

Arc

Angle
Length of chord
Endpoint

Figure 7-4: The ARC command options

Drawing arcs

‘I,-- To draw an arc, choose Arc from the Draw toolbar and follow the prompts. As
with circles, object snaps are often helpful when drawing arcs.

When drawing an arc by using the Start, End, and Radius options, the three specifi-
cations actually define two possible arcs, one minor and one major. AutoCAD draws
the minor arc by default, in the counterclockwise direction. (A minor arc is less
than half a circle.) If you enter a negative number for the radius, AutoCAD draws
the major arc (which is more than half a circle). The options requiring an angle also
define two possible arcs, one drawn counterclockwise and one drawn clockwise.
AutoCAD draws the counterclockwise arc by default. If you type a negative number
for the angle, AutoCAD draws the arc clockwise.

ab07-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

0nlhe"‘\ The drawing used in the following Step-by-Step exercise on drawing arcs,

0"

Step-by-Step: Drawing Arcs
1. Open ab07-b.dwg from the CD-ROM.

2. Save the file as ab07-02.dwg in your AutoCAD Bible folder. ORTHO is on
and units are set to Fractional. Choose Tools => Drafting Settings (clicking the
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Object Snap tab, if necessary) and set running object snaps for intersection,
center, and endpoint. Make sure OSNAP is on. In this exercise, you draw part
of the sealing plate shown in Figure 7-5.

. Start the LINE command. Start at 2,3 and use Direct Distance Entry to create

a 7-unit horizontal line to the right. End the LINE command.

See Chapter 4 for a full explanation of how to use Direct Distance Entry.

. Draw another line starting at 5-1/2,1-5/8 and draw it 2-3/4 units long in the

90-degree direction. These two lines are center lines and would ordinarily
appear in a different color and linetype than the object you are drawing.

You can read about colors and linetypes in Chapter 11.

. Draw a circle with its center at the intersection of the two lines (use the

Intersection object snap) and a radius of Y.

. Use the Center object snap to draw another circle with the same center as

the first circle and a radius of 1.

= 37/8 =
1 13/16 ‘
R3/8 1 11/W6
\ ;// - - 2 3/4
R3/8

67.2%

‘\7/

=—115/16 —'-

=]

2207

Figure 7-5: The dimensioned sealing plate for a valve
Thanks to Jerry Bottenfield of Clow Valve Company in Oskaloosa, lowa, for this drawing.
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7. Draw a third circle, using the From object snap (Shift+right-click to open the

10.

11.

12.

object snap menu, and then choose From). For the base point, use the Center
object snap and pick either of the first two circles you drew. The offset is
@-1-15/16,0 (this means 1-15/16 units to the left of the center of the first two
circles). Its radius is X%.

. Draw a fourth circle. Use the From object snap again. For the base point, use

the Center object snap and pick either of the first two circles. The offset is
@1-15/16,0. The radius is %.

. ‘I,-- Choose Arc from the Draw toolbar. Follow the prompts:

Specify start point of arc or [Center]: Choose the From
object snap.

Base point: Use the Center object snap to pick the center of
the leftmost circle.

<Offset>: @-5/8,0

Specify second point of arc or [Center/End]: Right-click and
choose Center. Use the Center object snap to pick the center
of the leftmost circle.

Specify end point of arc or [Angle/chord Lengthl: Right-click
and choose Angle.

Specify included angle: 67.23 A

Start the LINE command. At the Specify first point: prompt, press Enter
to continue the line in the same direction as the end of the arc. At the Length
of Tine: prompt, type 1-13/16 J. End the LINE command.

Choose Arc from the Draw toolbar. Follow the prompts:

Specify start point of arc or [Centerl: Use the Endpoint
object snap to pick the end of the line you just drew.
Specify second point of arc or [Center/End]: Right-click and
choose Center. Use the Center object snap and pick any point
on one of the large central circles.

Specify end point of arc or [Angle/chord Length]: Use
Endpoint object snap to pick the lower end of the vertical
construction line.

Repeat the ARC command. Follow the prompts:

Specify start point of arc or [Center]l: Right-click and
choose Center. Use the Center object snap and pick any point
on one of the large central circles.

Specify start point of arc: Use the Endpoint object snap to
pick the endpoint of the arc you just completed.

Specify end point of arc or [Angle/chord Length]: Right-click
and choose Angle.

Specify included angle: 22.77 J
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13. Start the LINE command. At the Specify first point: prompt, press Enter
to continue the line in the same direction as the end of the arc. At the Length
of Tine: prompt, type 1-13/16 . End the LINE command.

14. Start the ARC command. Follow the prompts:

Specify start point of arc or [Center]: Use the Endpoint
object snap to pick the endpoint of the line you just drew.
Specify second point of arc or [Center/End]l: Right-click and
choose End.

Specify end point of arc: Choose the From object snap.

_from Base point: Use the Center object snap to pick the
center of the rightmost circle.

<O0ffset>: @5/8,0 4

Specify center point of arc or [Angle/Direction/Radius]: r J
Specify radius of arc: 5/8 4

15. Save your drawing. Your drawing should look like Figure 7-6. You can com-
plete this drawing in Chapter 10 by creating a mirror image.

BN/

Figure 7-6: The partially completed sealing plate, created
by using lines, circles, and arcs

Creating Ellipses and Elliptical Arcs

You can create ellipses (ovals), and you can also create elliptical arcs, which are
partial ellipses. Like a circle, an ellipse has a center. The difference, of course, is
that an ellipse has a longer radius along its major axis and a shorter radius along its
minor axis, as shown in Figure 7-7.
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Center
7’\//Major axis

Minor axis

Figure 7-7: The parts of an ellipse

Understanding ellipse options

You can draw ellipses by defining a center first. Another option is to define the axis
endpoints first. If you want to draw an elliptical arc, you must specify the start and
end angle.

Ellipses

The default option is to specify endpoints 1 and 2 of the first axis. Then you specify

the second axis distance, which is the distance from the first axis line to the circum-
ference along the second axis. Instead of specifying a second axis distance, you can

choose the rotation option.

The rotation option defines the minor axis by defining an angle from 0 degrees to 90
degrees, which is the ratio of the major axis to the minor axis. (Actually, AutoCAD
only accepts up to 89.4 degrees.) When the angle is 0, you get a circle. As the angle
increases, the ellipse gets flatter and flatter until you reach 89.4 degrees. A 45-
degree angle results in a minor axis whose length is the square root of the major
axis length.

Instead of specifying endpoints, you can type c to specify the center of the ellipse.
Then specify the endpoint of the first axis, which can be either the major or the
minor axis. Finally, specify the other axis distance, which is the radius from the cen-
ter to the circumference along the second axis. Again, instead of specifying the sec-
ond axis distance, you can define the ellipse by using the rotation option.

Elliptical arcs

To draw an elliptical arc, choose Ellipse Arc from the Draw toolbar. The first
prompts are the same as for an ellipse because you must first define the ellipse.
Then AutoCAD continues with the Specify start angle or [Parameter]:
prompt, offering the following options:

4 Start angle: This option is the default. Specify the start angle, which AutoCAD
redefines to start along the major axis. AutoCAD responds with the Specify
end angle or [Parameter/Included anglel: prompt.

4+ End angle: Specify the end angle to complete the ellipse arc.
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4 Included angle: After specifying the start angle, you can complete the arc
by specifying the included angle from the start point to the endpoint, going
counterclockwise.

4+ Parameter: Choose this option to define the arc portion by the ellipse’s area
rather than its included angle (which defines the arc portion by its circumfer-
ence). AutoCAD responds with the Specify start parameter or
[Angle]: and Specify end parameter or [Angle/Included angle]:
prompts. By typing in angles, you define the percent of the full ellipse’s area
that you want to include. (For example, starting at 15 degrees and ending at
105 degrees includes 90 degrees. AutoCAD then draws one quarter of an
ellipse.) The options in brackets let you return to regular angle specification.

Drawing ellipses

&5 To draw an ellipse, choose Ellipse from the Draw toolbar. In addition to the

information AutoCAD explicitly requests in the prompts, you need to know the
angle of the first axis that you define. Not all ellipses are horizontal or vertical. You
control this when you stipulate the second point of the first axis. The second axis is
automatically perpendicular to the first axis.

P To draw an elliptical arc, choose Ellipse Arc from the Draw toolbar. When you

draw an elliptical arc, AutoCAD introduces a helpful but sometimes confusing
feature: While you are defining the arc angles, AutoCAD redefines 0 degrees along
the major axis. This helps you define the included angle in an orientation that
relates to the ellipse, rather than the usual orientation where 0 degrees is to the
right.

In this exercise, you practice drawing ellipses and elliptical arcs.

On the The drawing used in the following Step-by-Step exercise on drawing ellipses and

o

/  CD-ROM.

Y,

i CDW | elliptical arcs, ab07-c.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

Step-by-Step: Drawing Ellipses and Elliptical Arcs
1. Open ab07-c.dwg from the CD-ROM.

2. Save the file as ab07-03.dwg in your AutoCAD Bible folder. The drawing
shows an empty conference room. Snap is on, set to 6". Check that OSNAP is
on with a running object snap set for endpoint only.

3. =5 Choose Ellipse from the Draw toolbar. At the Specify axis endpoint
of ellipse or [Arc/Center]: prompt, right-click and choose Center.
At the Specify center of ellipse: prompt, choose 8,10', which is a snap
point. At the Specify endpoint of axis: prompt, move the cursor to the
right until the coordinates read 3'<0 and click. (If necessary, press F6 until you
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see polar coordinates.) At the Specify distance to other axis or
[Rotation]: prompt, move the cursor up until the coordinates read 6'6"<90
and click. This completes the conference table.

e Choose Ellipse Arc from the Draw toolbar. Follow the prompts:

Specify axis endpoint of elliptical arc or [Centerl: Right-
click and choose Center.

Specify center of elliptical arc: Pick 8',3', a snap point.
Specify endpoint of axis: Move the cursor to the right until
the coordinates read 1'<0 and pick.

Specify distance to other axis or [Rotation]: Move the cursor
up until the coordinates read 6"<90 and pick.

Specify start angle or [Parameter]: 162 .

Specify end angle or [Parameter/Included angle]: 18 J

. Turn off ORTHO. Start the LINE command. At the Specify first point:

prompt, use the Endpoint running object snap and pick the right side of the
elliptical arc. At the Specify next point or [Undo]: prompt, press F6 to
change to dynamic absolute coordinates (if necessary) and pick the snap
point 8'6",3". (You may have to turn off OSNAP in the middle of the command
to pick this point and avoid getting an endpoint.) End the LINE command.

. Start the LINE command. At the Specify first point: prompt, choose the

Endpoint object snap and pick the left side of the ellipse arc. At the Specify
next point or [Undo]: prompt, pick the snap point 7'6",3". End the LINE
command.

. Choose Ellipse Arc again. Follow the prompts:

Specify axis endpoint of elliptical arc or [Center]: Use the
Endpoint object snap to pick the free endpoint of the line on
the right.

Specify other endpoint of axis: Use the Endpoint object snap
to pick the free endpoint of the line on the left.

Specify distance to other axis or [Rotation]: @3<90 .

Specify start angle or [Parameter]: Use the Endpoint object
snap to pick the free endpoint of the line on the right.
Specify end angle or [Parameter/Included angle]: Use Endpoint
object snap to pick the free endpoint of the line on the
left.

. Choose Ellipse from the Draw toolbar. At the Specify axis endpoint of

ellipse or [Arc/Center]: prompt, pick point 2',18', a snap point. At the
Specify other endpoint of axis: prompt, pick point 2',16', also a snap
point. At the Specify distance to other axis or [Rotation]: prompt,
move the cursor to the right until the coordinates read 6"<0. (Press F6 twice if
necessary.) This is also a snap point. Click the mouse button to complete the
small side table.

9. Save your drawing. It should look like Figure 7-8.
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Figure 7-8: The conference room with a
conference table, a chair, and a side table

Making Donuts

A donut is a wide polyline that looks like two concentric circles. You define a diame-
ter for the inner and outer circles. AutoCAD accepts both DONUT and DOUGHNUT
if you type in the command. Donuts are often used in electrical drawings and to
create symbols. If the inner circle’s radius is zero, you create a filled-in circle.

The setting of the FILL command determines whether AutoCAD fills in the donut.
Type fill 1 and type on . or off . FILL is on by default. Turning FILL off displays
aradial pattern of lines, as shown in Figure 7-9. Type regen . or choose View =
Regen to update existing donuts to the new FILL setting.

Tip If you have many filled objects in your drawing, AutoCAD may need to take some
_»,  time to display the drawing. You can save time by turning FILL off while you draw.
4  Then turn FILL on just before you need to print or plot the drawing.
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—OQutside diameter

Inside diameter Center

Figure 7-9: The parts of a donut, shown with FILL off

Understanding DONUT options

The DONUT command has the following prompts:

4 Specify inside diameter of donut <0.5000>: Type the diameter of the
inside circle or pick two points to specify the inside diameter. The number in
brackets is the last inside diameter that you defined or 0.5 if you haven’t pre-
viously used the DONUT command in this drawing session.

4 Specify outside diameter of donut <1.0000>: Type the diameter of
the outside circle or pick two points to specify the outside diameter. The out-
side diameter must be larger than the inside diameter. The number in brack-
ets is the last outside diameter u that you defined or 1.0 if you haven’t
previously used the DONUT command in this drawing session.

4+ Specify second point: If you define the inside or outside diameter by pick-
ing a point, AutoCAD asks for a second point. Use this technique if you are
using object snaps to define the diameters.

4+ Specify center of donut or <exit>: Specify the center of the donut.
Pressing Enter ends the command.

Drawing donuts

Drawing donuts is relatively easy in AutoCAD. Choose Draw = Donut. Then specify
the inner and outer diameters and the center. AutoCAD continues to prompt for
centers so you can place additional donuts. Press Enter to end the command.

Tip You can use the hatch feature to fill in any object with a solid fill, with a great deal
.~ more flexibility in the shape of your objects. (Chapter 16 discusses hatching.) As a
4  result, the DONUT command is not as essential as it once was.

You draw some donuts in the next exercise.
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Placing Points

Points are used for reference. It is sometimes helpful to mark a point that you use
later as a guide to place an object or to help you return an object to its original
position. When it’s no longer needed, you may erase the point. This is a typical con-
struction method. In some cases, the From object snap or object snap tracking can
be used instead of a point.

¢ Cross- The DIVIDE and MEASURE commands place point objects along an object.
Reference \  Chapter 12 covers these commands.

Changing the point style

Different disciplines have different conventions for drawing point objects. As a
result, AutoCAD provides 20 types of point styles that you can use in your drawing.
Before you draw a point, you should set the point style. You can save this setting
in your template.

Choose Format => Point Style to open the Point Style dialog box, shown in
Figure 7-10.

__IEEE
EIEIEEE
Il ED =]
el o

(E1 Point Style =]

&

Poirt Size: | 5.0000

(%) Set Size Felative to Screen
() Set Size in Absolute Units

[ QK H Cancel ][ Help ]

Figure 7-10: Choosing a point style

To set the point style, click the box showing the style that you want. Then set the
point size, which has the following options:
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Tip

4 Set Size Relative to Screen: Use this option if you want the point to always
appear the same size, no matter how much you zoom in and out — for exam-
ple when you are using the point as a reference. The size is set as a percent-
age of the screen. This option is the default, with the size set to 5 percent of
the screen.

4 Set Size in Absolute Units: Use this option if you want the point to have a real
size, just like any other object. The size is set in units. Use this option when
you want the point to stay the same size relative to other objects in your
drawing.

Click OK to close the dialog box.

When you change the point style, previously drawn points automatically and
~~  immediately change to the new style.

Creating points

After you determine the point style, you are ready to create points. Choose
Point from the Draw toolbar.

You see the following on the command line:

Current point modes: PDMODE=0 PDSIZE=0.0000
Specify a point:

PDMODE is the system variable for the point style you have chosen. If left in its
default value, the PDSIZE system variable remains at zero. Once altered, the PDSIZE
is negative if the point size is set relative to the screen. PDSIZE is positive if the
point size is set for absolute units. If you set the size in absolute units, the unit size
appears here. Specify the point you want, either by picking a point on the screen or
by typing coordinates. (You can specify a Z coordinate to create a point in 3D
space.) You can use object snaps to specify the point.

AutoCAD automatically repeats the prompt of the POINT command so that you can
continue to specify points. To end the command, press Esc.

If BLIPMODE is on and you are using the first point style—a small dot—you
cannot see the point until you use the REDRAW command to remove the blips.

If you are using the points for temporary reference, instead of erasing them, you
_»_ can set the point style to the second style in the Point Style dialog box (no dot)
4 before plotting. Then the points do not appear on your plot.

After you create a point, use the Node object snap to snap to the point.
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The drawing used in the following Step-by-Step exercise on drawing donuts and
points, ab07-d.dwg, is in the Drawings folder of the AutoCAD 2004 Bible
CD-ROM.

Step-by-Step: Drawing Donuts and Points

1.
2.

Open ab07-d.dwg from the CD-ROM.

Save the file as ab07-04.dwg in your AutoCAD Bible folder. The drawing
contains a rectangle and connecting wires for an electrical switch. Make sure
that OSNAP is on. Set running object snaps for endpoint, quadrant, center,
and node.

. Choose Format => Point Style. The Point Style dialog box opens. Choose the

third point type, the plus sign. The radio button Set Size Relative to Screen
should be marked. The Point Size should be 5.0000%. Choose OK.

Choose Point from the Draw toolbar. Follow the prompts:

Specify a point: Use From object snap. (Shift+right-click to
open the Object Snap shortcut menu.)

Base point: Use the Endpoint object snap to pick the top-Tleft
corner of the rectangle.

<Offset>: @.08,-.09

Specify a point: Press Esc

AutoCAD places the point.

. Choose Draw => Donut. Follow these prompts:

Specify inside diameter of donut <0.5000>: .04 4

Specify outside diameter of donut <1.0000>: .06 A4

Specify center of donut or <exit>: Use the Node object snap
to pick the point you drew.

Specify center of donut or <exit>: @.19,0 4

Specify center of donut or <exit>: d

. Start the POINT command again. Follow the prompts:

Specify a point: .x Jd

of Use the Center object snap to pick the center of the
right-hand donut.(You may have to press Tab until you get the
center object snap, and not a quadrant object snap.)

(need YZ): Pick a point about halfway between the right donut
and the bottom of the rectangle, as shown in Figure 7-11.
Specify a point: Press Esc.

. Start the LINE command. Follow the prompts:

Specify first point: Use the Quadrant object snap to pick the
right (0 degrees) quadrant of the left donut. If you don't
see the Quadrant SnapTip, press Tab until it appears.

Specify next point or [Undo]: Use the Node object snap to
pick the point you just drew. End the LINE command.

135
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8. Save your drawing. It should look like Figure 7-11.

o o

Figure 7-11: The completed electrical
switch. The points show as plus signs.

Summary

In this chapter, you learned how to draw curved objects and points in AutoCAD.
You discovered:

4 All the ways to draw circles

4 Defining and drawing and arc

4 Defining an ellipse and an elliptical arc

4 Drawing a donut

4 Setting the point style and draw points

In the next chapter, you read how to display your drawing for the greatest ease and
comfort.

+ ¢+



Viewing Your
Drawing

Often you may wish you could zoom in to see a particu-
lar part of a drawing more closely. Several exercises in
this book have already used the ZOOM command to zoom in
and out. In this chapter, you read about controlling the dis-
play of your drawing to meet all your drawing needs and
increase productivity.

Understanding How AutoCAD
Displays Drawings

AutoCAD is a vector program, which means that it stores
information about objects in your drawing in terms of coordi-
nates and equations. This information is stored in your draw-
ing’s database. However, your screen displays information in
terms of tiny dots called pixels. To display your drawing,
AutoCAD converts the vector information in the drawing’s
database to pixels. When you change the drawing display sig-
nificantly, AutoCAD has to reconvert the object data to pixels,
recalculating the coordinates of every object in the drawing.
This is called regenerating. Perhaps you have seen the mes-
sage on AutoCAD’s command line: Regenerating model.

Regenerating an entire drawing can be time-consuming. To

avoid having to regenerate the drawing every time you change
the display, AutoCAD keeps a virtual screen in your computer’s

memory. The virtual screen covers an area beyond the cur-

rent display of your drawing and can be accessed very quickly.

When you change the display within the virtual display,
AutoCAD doesn’t have to regenerate the entire drawing — it
only redraws it. Redrawing uses the data stored in the virtual
screen to refresh the display. A redraw is much quicker than
regeneration.

When should you use REDRAW and when REGEN?

CHAPTER

¢+ o+
In This Chapter

Panning and
zooming

Using Aerial View
to pan and zoom

Working with views

Creating tiled
viewports

Creating User
Coordinate Systems

Drawing isometrically

+ ¢+
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4 In most cases, you want to redraw rather than regen because it is quicker.
Use the REDRAW command to remove blips or to quickly refresh the screen.
(The REDRAWALL command redraws the display in all viewports. Viewports
are covered later in this chapter.) To redraw the screen, choose View =
Redraw (which actually executes the REDRAWALL command).

4 Use the REGEN command whenever you want AutoCAD to recalculate the
entire drawing. AutoCAD users use the word “regen” to refer to the REGEN
command and also as shorthand for regenerate or regeneration. To regenerate
the entire drawing, type regen . at the command line. (REGENALL regener-
ates all viewports.)

Certain zooms and pans may require a regeneration, which AutoCAD does
automatically.

In recent releases, AutoCAD has significantly improved the mechanics behind the
display of your drawing. It is now rarely necessary to regenerate a drawing.

Panning

New
Feature

Often you cannot see the entire drawing on your screen. You therefore need a way
to see the parts of your drawing that are not currently visible.

To pan means to move the display without changing the magnification. The word
refers to the expression of panning a camera across a scene or view. You pan to
view a different part of your drawing. You can pan any amount and in any direction
by using the PAN command. You can pan vertically and horizontally by using the
scroll bars.

Using the PAN command

The PAN command moves the display in the direction and distance you indicate
without changing the magnification in any way. Real-time panning moves the
drawing as you move the cursor. Real-time panning makes panning quick, intu-
itive, and easy.

=4 10 pan the drawing, choose Pan Realtime from the Standard toolbar. The cur-
g\“*l sor changes to a hand. Place the cursor anywhere in your drawing, click, and
drag in the direction you want the objects to go.

N\ You can now pan past the edge of the screen (actually the viewport) in Windows
XP. This means that when the cursor reaches the edge of the screen you can con-
tinue moving your mouse in the same direction to continue the pan.
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To leave pan mode, press Esc or Enter or start any command via a menu or toolbar.
You can also right-click to open the shortcut menu shown in Figure 8-1. Pan can be
used transparently, while you are in the middle of another command. Use the
shortcut menu to exit pan mode, switch to real-time zoom or 3D Orbit, or to choose
one of the zoom options listed.

Exit il Figure 8-1: The pan shortcut menu

v Pan
Zoom
3D Orbit

Zoom Window
Zoom Original
Zoom Extents

AutoCAD 2004 supports Microsoft IntelliMouse pointing devices for panning. To

~  pan, click and hold down the wheel and move your mouse. You see the same
panning cursor, the hand, as you do when you pan by clicking the Pan Realtime
button on the Standard toolbar. However, you don't need to press Esc or Enter to
leave pan mode.

You can use displacement panning (the kind used by Release 13 and earlier
versions) by choosing View => Pan=> Point. At the Specify base point or
displacement: prompt, choose any point in your drawing. At the Specify
second point: prompt, choose another point where you want the first point to
appear. The display then moves in the direction and the distance indicated by
the difference between the first and second points.

Using the scroll bars

You can use the scroll bars to pan vertically and horizontally as you would with any
Windows program. However, you can’t easily predict just how much the drawing
view will move. Therefore, the scroll bars are less useful than the PAN command.

You can use the scroll bars in three ways:

4 Drag the scroll box in the desired direction and in the desired amount.
4 Click the scroll bar between the scroll box and the up or down arrow.

4 Click the up or down arrow to move the drawing view slightly.

théx}e\ The drawing used in the following Step-by-Step exercise on panning and scrolling,

| ab08-a.dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

/'.I
W
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Step-by-Step: Panning and Scrolling

1. Open ab08-a.dwg from the CD-ROM. This air compressor was used in an exer-
cise in Chapter 7, but this display is magnified so that you cannot see the
entire drawing. The air compressor is shown in Figure 8-2.

ALa)

Figure 8-2: The air compressor is zoomed in so that you can see only part of the
drawing.

2. Choose Pan Realtime from the Standard toolbar. Move the cursor to @ in
Figure 8-2, click, and drag to @. The air compressor moves up and to
the right. (Note that by the time you get to @, the display of the air com-
pressor has moved — but you should drag to where @ was on the screen.)
Press Esc.

3. The scroll box of the horizontal scroll bar is all the way to the left. Click any-
where in the scroll bar to the right of the scroll box. The air compressor
moves to the left.

4. Click anywhere in the vertical scroll bar between the scroll box and the down
arrow at the bottom of the scroll bar. The air compressor moves up as you
scroll down.

5. Click the right arrow on the horizontal scroll bar three times. The drawing
moves to the left slightly each time. Your drawing should look something like
Figure 8-3. You may have a different view if you chose slightly different pan
points.

Do not save this drawing.
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Figure 8-3: The final view. Your view may be somewhat different.

The ZOOM Command

The ZOOM command enables you to zoom in and out of your drawing — like the
zoom lens of a camera. When you zoom in, everything is magnified so that you

can see it more easily, but you see less of the entire drawing. When you zoom out,
objects look smaller, but you can see more of the drawing. The ZOOM command has
several options that make it easy to see just what you need at an appropriate size.

¢ Cross- Zooming does not affect the actual size of objects, just as zooming with a camera
Reference'\  |ans does not affect the size of the scene you are viewing. Chapter 9 covers chang-
ing the actual size of objects (scaling).

C’E When you use real-time zoom, the drawing zooms in and out as you move the
cursor. To use real-time zoom, choose Zoom Realtime from the Standard tool-

bar. The cursor changes to a magnifying glass with a plus sign on one side and a
minus sign on the other side. You determine whether AutoCAD zooms in or out

depending on the movement of the cursor.
4 To zoom in, click and drag up in the direction of the plus sign.
4 To zoom out, click and drag down in the direction of the minus sign.

A movement from the middle of the screen to the top edge zooms in 100 percent.
A movement from the middle of the screen to the bottom edge zooms out 100

percent.
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New N\ You can now zoom past the edge of the screen (actually the viewport) in

feati Windows XP. As you move the mouse up or down to zoom, when you reach the
edge of the viewport, continue to move the mouse in the same direction to con-
tinue the zoom in or out.

AutoCAD supports Microsoft IntelliMouse pointing devices. To do a real-time zoom,
rotate the wheel up to zoom in and down to zoom out. AutoCAD does not display
the Zoom Realtime cursor. As with panning using the IntelliMouse, you don’t need
to press Esc or Enter to leave zoom mode. You can also double-click the wheel to
do a Zoom to the extents of the drawing.

Right-click to open the shortcut menu to exit zoom mode, switch to real-time pan or
3D Orbit, or to choose one of the zoom options listed. To end real-time zoom, you
can also press Esc or Enter or start any command via a menu or toolbar.

Understanding ZOOM options

The Zoom flyout has eight options. The Standard toolbar also has a Zoom Previous
button. Table 8-1 outlines these Zoom options.

Table 8-1
Zoom Options
Button Option Description
'E_R Window This button lets you define a rectangular window as the

boundaries of the new display. AutoCAD prompts you for the
two corners of the window. Use Window to zoom in on any
area already displayed in your drawing. When you use Zoom
Window, AutoCAD displays everything in the window you
specify but reshapes the display to fit your screen. As a result,
you may see objects that were outside the specified window.
You can now continue to move the mouse past the drawing
area to define the window past the edge of the screen.

Q Dynamic Enables you to zoom and pan in one operation. This option
is covered in the next section of this chapter.

@\ Scale Enter a number to scale the display relative to the drawing
limits (a kind of absolute scaling). Enter a number followed

by x to scale the display relative to the current view (relative
scaling). Enter a number followed by xp to scale the display
relative to paper space units (discussed in Chapter 17). A
number less than 1 (such as 0.5) reduces the size of the
objects on the screen (such as by half). A number greater
than 1 (such as 2) increases the size of the objects on the
screen (such as by 2).
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Button Option Description
@ Center Lets you specify a new center for the display, and then a
new magnification/height. The current magnification/height

is shown in brackets for your reference. Type a smaller
number to increase the magnification, making the objects
larger. Type a larger value to decrease the magnification,
making the objects smaller.

In This button is a shortcut for using the Scale option with a
value of 2x. See the Scale option.

Out This button is a shortcut for using the Scale option with a
value of 0.5x. See the Scale option.

All Zoom:s the display to the greater of the drawing extents or
the drawing limits.

Extents Zoom:s to the outer extents of the drawing. You can also
double-click the wheel of an IntelliMouse pointing device.

A8 £ 08

Previous Redisplays the most recent display of your drawing. This
option has its own button on the Standard toolbar because
it is used so often.

ZOOM Dynamic

The Dynamic option of ZOOM enables you to pan and zoom in one operation. The
Aerial View (discussed in the next section) offers more sophisticated options, but
the simplicity of ZOOM Dynamic is sometimes just what you need.

When you start ZOOM Dynamic, you see the virtual screen area of the drawing in a
blue dashed rectangle —the drawing extents or limits, whichever is greater. Your
current view is bounded in a green, dashed rectangle. Your mouse cursor changes to
a rectangle with a large X inside —the Pan view box. When you click the left mouse
button, the X changes to an arrow —the Zoom view box. These are the two modes of
Z0OOM Dynamic. Each time you click the left mouse button, you switch modes. You
can switch back and forth as often as you want. Here’s how the two modes work:

4+ Pan mode: The box contains an X and can move freely around any displayed
area of the drawing.

4 Zoom mode: The box has an arrow. The left side of the box is fixed at the
point where you changed to zoom mode. As you move the cursor the box
expands or shrinks, letting you zoom to any magnification.

When the view box displays the view that you want, click the right mouse button
and choose Enter (or press Enter). AutoCAD pans and zooms to show that view.
Figure 8-4 shows the screen during a ZOOM Dynamic operation.
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Figure 8-4: Using ZOOM Dynamic

On the_“‘\ The drawing used in the following Step-by-Step exercise on using ZOOM Dynamic,
, cn@“ | @ b08-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.
Step-by-Step: Using ZOOM Options

1. Open ab08-b.dwg from the CD-ROM. This is a drawing of a warehouse, as
shown in Figure 8-5.

2. = To read the text in the lower-right corner, choose Zoom Window from the
Zoom flyout of the Standard toolbar.

3. At the Specify first corner: prompt, pick @, as shown in Figure 8-5.
At the Specify opposite corner: prompt, pick @. AutoCAD zooms in to
display the window you specified, as shown in Figure 8-6.

4. @ Choose Zoom All from the Zoom flyout of the Standard toolbar.

5. kyg\ Choose Zoom Previous from the Standard toolbar. AutoCAD quickly
returns you to the previous display.

6. @1 Choose Zoom Extents from the Zoom flyout of the Standard toolbar. The
drawing fills the screen. In this drawing, the drawing extents are similar
to the drawing limits, so that you see little difference between using Zoom All
and Zoom Extents.
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Figure 8-5: A drawing of a large warehouse, with shelving and conveyor belts
Thanks to Bryan Kelly of ATl Corporation, Fairfield, lowa, for this drawing.

7. @ Choose Zoom Center from the Zoom flyout. At the Specify center
point: prompt, pick @ in Figure 8-5. At the Enter magnification
or height <5315.176>: prompt, type 500 .. AutoCAD zooms in on the

office.

8. ~+ Choose Zoom Realtime from the Standard toolbar. Place the cursor at

the top of the drawing, click, and drag to the bottom of the screen.
AutoCAD zooms out the display about 200 percent.

SCALE: 3/647
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Figure 8-6: Your display should look approximately like this figure after using ZOOM

Window.
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9. @ Choose Zoom Scale from the Zoom flyout of the Standard toolbar. Type
_2x . AutoCAD zooms in, doubling the scale of the view and returning
you approximately to the previous view of the office.

10. Q Choose Zoom Dynamic from the Zoom flyout. AutoCAD now displays the
entire drawing. The current view is shown with a green dashed line. The
mouse cursor is a box with an X in it. You are now in Pan mode. To zoom in on
the right side of the warehouse, move the Pan box to the lower-right corner of
the warehouse and click with the pick (left) button.

11. AutoCAD switches to Zoom mode. The Zoom box contains an arrow. Move the
mouse to the left to shrink the Zoom box. Notice that the Zoom box is fixed at
its left side. When the Zoom box is about half its original size, left-click again.

12. AutoCAD switches to Pan mode again. Move the Pan box to the bottom-right
corner of the warehouse. Right-click and choose Enter. AutoCAD zooms in on
this new view. Your display should look approximately like Figure 8-7.

e
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Figure 8-7: The new view of the drawing after using Zoom Dynamic

13. Choose Zoom All from the Zoom flyout. Do not save your drawing. If you are
continuing on to the next exercise, leave the drawing open.

Aerial View

In AutoCAD 2004, Aerial View functions like a souped-up version of ZOOM Dynamic.
You can use Aerial View to pan and zoom. If you need to pan and zoom often, you
can leave the Aerial View window open and use it whenever you need to.
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To open Aerial View, choose View > Aerial View. The Aerial View window opens, as
shown in Figure 8-8. Like other windows, the Aerial View window can be active or
inactive. When active, its title bar is shown in color (usually blue). When inactive,
the title bar is gray. Inside the window, you see your entire drawing. To close Aerial
View, click the Aerial View window’s own Close button. Aerial View has its own tool-
bar and menu. These are explained in the next few sections.

Zoom In
Zoom Out
Global
fa B
3 Aqrial Miew - d:\drawingsiab8-b.... (=/@JE3
\Jievi Options Help
& C|

Figure 8-8: The Aerial View window

Zooming and panning with Aerial View

While you work in your drawing, the drawing window is active and the Aerial View
window is inactive. To pan and zoom by using Aerial View:

1. Click anywhere inside the Aerial View window to activate Aerial View. You see
a pan/zoom box that looks like the box you see when you use ZOOM Dynamic.
It has an X in it, indicating that you can pan.

2. Move the pan/zoom box over the part of the drawing you want to zoom in on.
The display in the main screen pans as you move your mouse.

3. Click to switch to zoom mode. You see the arrow in the box, indicating that
you can zoom. Move your mouse to resize the window so that it covers the
area you want to see. In the main drawing window, you immediately see the
new zoomed view.

4. Continue to click to switch between zoom and pan modes as necessary.

5. Right-click or press Esc to fix the new view.
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To quickly zoom out in the Aerial View display, click Zoom Out on the Aerial View
toolbar. To quickly zoom in, click Zoom In on the toolbar. To see your entire draw-
ing in the Aerial View display only, click Global on the toolbar.

When the Aerial View window displays your entire drawing, the Zoom Out button

- is unavailable. When the current view nearly fills the Aerial View window, the
Zoom In button is unavailable. When the drawing extents take up the entire Aerial
View window, neither button is available.

You can disable the real-time zoom just described. Choose Options => Realtime
Zoom from the Aerial View menu. Real-time zoom is available when the menu item
has a checkmark next to it. You can also right-click in the Aerial View window and
choose Realtime Zoom.

Understanding Aerial View options

The Aerial View Options menu contains two options that affect how Aerial View
works. Both features are also available by right-clicking the Aerial View window
shortcut menu.

4 Auto Viewport applies only when you have more than one viewport. I discuss
viewports later in this chapter. If this option is checked, the view in the Aerial
View window changes as you change the active viewport in the main drawing
area.

4 Dynamic Update determines whether the view in the Aerial View window is
continually (dynamically) updated as you edit your drawing. As you can imag-
ine, it takes up additional computer resources (mainly memory) to maintain
two views of your drawing at once. If you find that Aerial View slows down
your computer (but you don’t want to close it entirely), choose this option to
turn Dynamic Update off. Choose the option again to turn it on.

Using Aerial View

Aerial View is most useful in large maps or floor plans, or any drawing with lots of
detail. You can use it transparently.

Don’t forget that before you use Aerial Window you need to click in the Aerial View
window to activate it. To return to the AutoCAD window, you need to click that win-

dow as well.

To close Aerial View, click its Close button in the upper-right corner of the window.

ab08-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Onthéi“c-\ The drawing used in the following Step-by-Step exercise on using Aerial View,
/;

G
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Step-by-Step: Using Aerial View

1.

Open ab08-b.dwg from the CD-ROM if it is not already open from the previous
exercise.

. Choose View > Aerial View. The Aerial View window opens. The Aerial View

window is not currently active.

. Click the Aerial View title bar to activate it. At the bottom of the warehouse

drawing, somewhat to the left, is a rectangle (representing an office) with
some text in it. (If you did the previous exercise, you zoomed into this office
by using Zoom Center.)

. To zoom in to the office, click once in the Aerial View display. To change to

zoom mode, click again. Move the cursor down and to the left until the box is
not much bigger than the office. Click again to return to pan mode, move the
box over the office, and right-click. AutoCAD zooms in on the office. In the
Aerial View window, you still see the entire drawing, and the current view is
bounded by a thick box, the View box. Your screen should look like Figure 8-9.

<F Aerial View - d:\drawings'ab8-b.... =T/
View Options Help

@G

OFFTCE

Figure 8-9: Your screen after zooming in on the office

. Click again to activate the pan/zoom box. Move the box just to the left and

right-click. AutoCAD pans to show some windows to the left of the office.

. Click again to start panning and zooming. Using the same technique as you

just used in Step 4, pan to the top-left quadrant of the warehouse. Zoom in
again if necessary until you can read the text at the top-left corner of the
shelving area and right-click. (The red columns represent shelving in the
warehouse.) Your screen should look approximately like Figure 8-10.
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<F Aerial View - d:\drawingstab8-h.... [=JOEJ
View Options Help

S

Bottery Chorgers

g

e

L.,

Figure 8-10: Zooming in on the top-left corner of the warehouse. You can now see
the text, which reads “Battery Chargers.”

. Click again and move the pan box to the top-left corner of the drawing.

Click to switch to zoom mode and move the cursor to the bottom-right
corner of the drawing. AutoCAD simultaneously zooms out to display the
entire warehouse.

. Do not save your drawing. Close the Aerial View window. If you are continuing

on to the next exercise, keep the drawing open.

Named Views

After you have done a lot of panning and zooming in a drawing, you may find that
you return to the same part of your drawing again and again, especially if the draw-
ing undergoes a lot of changes. In a large drawing, it can take some time to display
the part of the drawing that you want, especially if AutoCAD needs to regenerate
the drawing. You can speed up the process by saving views.

Tip

A view is simply a display of a drawing on your screen. It can show any part of your
drawing at any magnification. After you have the display, you give the view a name

and save it. AutoCAD then lets you retrieve that view at any time, without zooming

or panning.

@5
4

In a very large drawing, you can create views as soon as you create the title block —
for example, one for each quadrant of the drawing, and another for the title block
lettering. This helps you move quickly from one section of the drawing to another.
As you determine the need for more specific views, you can add them.
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First display the view that you want to save on the screen. For this purpose,
use the ZOOM and PAN commands or Aerial View. Then choose View => Named

Views. (You can also choose Named Views from the View toolbar.) This starts the
VIEW command. The View dialog box opens, as shown in Figure 8-11.

rE] View

BE)

Named Wiews | Orthographic & |sometiic Views

Current Wiew: Cument

Name Loca. ucs

Perspective [ Set Current ]

p_L.L Curent Model

Off

Hew..

[ ok

] l Cancel I [ Help

Figure 8-11: The View dialog box

When you first open this dialog box, it shows only one view, called Current, which
is the current display. Click New to open the New View dialog box, shown in
Figure 8-12. Type a name for your view in the View name text box.

El New View

B ]

Wigw harme:

(%) Curent display () Defing window

UCS Settings
Save UCS with view

UCS name: ‘ @ waild

]

[ 0K ] [ Cancel ] [

Help I

Figure 8-12: The New View dialog box

View names can be up to 255 characters and can include spaces. You can also save
a User Coordinate System (UCS) with a view so that each view can have its own

UCS. UCSs are covered later

in this chapter.

Choose OK to return to the View dialog box, where you see your new view listed.
Click OK to return to your drawing.
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You can use the New View dialog box to define several views at once. Here’s how:

. Choose View > Named Views.

. Click New.

. Type the name of the first view in the View name text box.
. Choose the Define Window radio button.

. Click the Define View Window button. AutoCAD returns you to your drawing.

S U1 AW N -

. If necessary, adjust the view by zooming and panning. AutoCAD does this
transparently.

7. At the Specify first corner: prompt, pick one corner of a rectangular
window.

8. At the Specify opposite corner: prompt, pick the diagonally opposite
corner of the window. AutoCAD returns you to the New View dialog box.

9. Click OK. AutoCAD returns you to the View dialog box.
10. Repeat Steps 2-8 for all additional views.

Displaying a view
The View dialog box enables you to easily display any view you have saved. Follow
these steps:

1. Choose View > Named Views.

2. Choose the view you want to restore.

3. Click Set Current.

4. Click OK.

Using other view control functions

You can use the View dialog box to manage named views. Choose View => Named
Views to open the View dialog box. You can also find these features by right-clicking
inside the View dialog box.

4 To delete a view, choose the view you want to delete and press the Delete key
on your keyboard.

4 To rename a view, click it once and then a second time, but without double-
clicking. Type a new name and press Enter.

4+ To get a description of a view, choose the view for which you want to see a
description and click Details. The View Details dialog box opens, which pro-
vides some statistics about the view. In general, these statistics are more use-
ful for 3D drawings than 2D ones.
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The drawing used in the following Step-by-Step exercise on working with views,
ab08-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.
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Step-by-Step: Working with Views

1.

2. Save the file as ab08-01.dwg in your AutoCAD Bible folder.
3. @ Choose View &> Named Views to open the View dialog box.

Open ab08-b.dwg from the CD-ROM if it is not already open from the previous

exercise.

4. Click New to open the New View dialog box.

5. In the text box, type top left.

6. Click the Define Window radio button and then click the Define View Window
button. AutoCAD returns you to your drawing temporarily.

dialog box.

8. Click OK once.

9. Click New. Type bottom left in the text box of the New View dialog box.
10.

Select Define Window and then click the Define View Window button. At the
Specify first corner: prompt, pick the bottom-left corner of your screen.
At the Specify Opposite corner: prompt, pick again around the center of
the warehouse. Back in the New View dialog box, click OK. The View dialog
box should list both of your views, as shown in Figure 8-13. Click OK to close
the View dialog box.

. At the Specify first corner: prompt, pick the top-left corner of your
screen. At the Specify opposite corner: prompt, pick somewhere
around the center of the warehouse. AutoCAD returns you to the New View

rE] View

%]

Named Wiews | Orthographic & |sometiic Views

Current Wiew: Cument

Mame
>L-[ Curent
top left

Loca.
Modsl
Modsl

ucs

@ world

Perspective Set Current

Off
Off

{hottom left

Model

*) World

o

Mew..

I

Ok

] [ Cancel ] [

Help

~

Figure 8-13: The View dialog box now lists the views

you have saved.
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11. Choose View => Named Views. Choose bottom Teft from the View dialog box.
Click Set Current and then click OK. AutoCAD displays the view.

12. Save your drawing. The views you created are now part of the drawing
database.

Using Named Views to Open a Drawing

Using named views provides two additional advantages. First, you can use named
views when you open a drawing so that one of its views is immediately displayed.
Second, you can open only the part of a drawing contained in a view.

A drawing with a view

After you have saved views, you can use them to open a drawing so that a view is
immediately displayed. Click Open on the Standard toolbar. In the Select File dialog
box, choose the file that you want to open and check the Select Initial View check
box. Then click Open. In the Select Initial View dialog box, choose the view you
want to display and click OK.

Partially opening a drawing

You can also open only the part of a drawing contained in a named view. You would
do this for a very large drawing that is slow and cumbersome to work with when it
is completely opened. For example, if you have a surveyor’s drawing of an entire
county, but need to work only with one plat, you could open a named view contain-
ing only that plat.

To partially open a drawing from within AutoCAD, follow these steps:

1. Choose File = Open. AutoCAD opens the Select File dialog box.

2. Choose a drawing and then click the Open drop-down box. Choose Partial
Open. AutoCAD opens the Partial Open dialog box, shown in Figure 8-14.

3. Choose a view from the list of named views.

4. Choose one or more layers. To include all the layers, click Load All. (If you
don’t include at least one layer, no objects are loaded. Chapter 11 covers
layers.) Click Open.

After you have partially opened a drawing, you can open more of the drawing.
Choose File > Partial Load. (This item is only available if the current drawing has
been partially opened.) AutoCAD opens the Partial Open dialog box. You can
change the view. To display the entire drawing (from whatever is loaded), choose
the default view, *Extents*. To define a new view on the fly, click the Pick a
Window button and define the two diagonal corners of the view you want to see.
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Check what layers you want to include or click Load All. Click OK to open the
drawing with the new view and layers specifications.

El Partial Open (B[]
Wiew geometry to load Layer geometry ta load
“Extents™ Layer Mame Load Geometry
"Etents™ a
*Last® n
Top Yiew 19
Bottam View 20
]
COLUMNS
FIXTURES
FLOWRACK.
SHLVING
STRUCT
Index status
Load All Clear Al
Layer index: No
[ Unload all ¥iefs on open [ Open ] [ Cancel ] [ Help ]

Figure 8-14: Use the Partial Open dialog box to open only the
part of a drawing contained in a named view.

Tiled Viewports

Tiled viewports enable you to divide up the screen into rectangular bounding
boxes. You can then show a different view of your drawing in each viewport. The
purpose of tiled viewports is to make it easier to draw. For example:

4 You can see the whole drawing in one viewport and a zoomed-in portion of
that drawing in another viewport.

4 You can see widely separated views of a large drawing at one time.

r Cross- AutoCAD offers two types of viewports —tiled and floating. For more information
Reference’)  n floating viewports, see the sidebar of that title in this chapter. For a detailed dis-

cussion, turn to Chapter 17.

Actually, you are already using a tiled viewport because the regular single view of
your drawing that you have been working with represents the default of a one-tile
viewport.

Tiled viewports have the following characteristics:
4+ No matter how many viewports you have, they always collectively take up the

entire screen. They are not separate entities, but a way of dividing up the
screen.
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4+ Only one viewport can be active at a time. The active viewport has a bold
border.

4 The crosshairs only appear in the active viewport.

4 The UCS (User Coordinate System) icon (if set to On) appears in each
viewport.

4 Any change you make to your drawing in one viewport automatically appears
in every other viewport (or in each viewport that shows the part of the draw-
ing where you made the change).

4 AutoCAD enables you to create up to 96 viewports — but you’ll never want to
create that many!

4 You can begin a command in one viewport and finish it in another. For exam-
ple, you can start a line in one viewport, switch to a second viewport, and end
the line there.

4 You can save and restore viewport configurations.

Figure 8-15 shows a drawing divided into three tiled viewports. Each viewport
shows a different view of the same drawing.

=

1416 e | 75

37/54 Dia. Drill 1 3/3 desp
518 \A—m Tap % 17 desp
Wz w2

| -
18781 a74 din b
23

4 dia

1.502/1,510 dia
1

T
" Ring Sroove Dbl 5/8 raf
]_H ok I_H il

N
L

b—1 a/18—|

Figure 8-15: A drawing showing three tiled viewports with a different view in each
viewport
Thanks to Jerry Bottenfield of Clow Valve Company, Oskaloosa, lowa, for this drawing.
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Configuring tiled viewports

Creating tiled viewports involves deciding how you want to divide up the screen.

A set of tiled viewports is called a configuration. AutoCAD offers a few simple con-
figurations, but you can create your own by further dividing up any of the view-
ports. You can also join two viewports. Finally, you can always return to the default
of one viewport.

Creating tiled viewports

To create additional viewports (that is, more than the one viewport you always see),
choose View > Viewports. This opens a submenu from which you can choose from
AutoCAD'’s preset configurations, as shown in Figure 8-16.

Named Viewports... Figure 8-16: The Viewports submenu

New Viewports...
1 Viewport
2 Viewports
3 Viewports
4 Viewports

Join

You can choose to create up to four tiled viewports from the submenu, at which
point you respond to the options that appear on the command line. For example,
if you choose 2 Viewports, AutoCAD responds with the Enter a configuration
option [Horizontal/Verticall <Vertical>: prompt. Right-click and choose
Horizontal or Vertical to create two horizontal or vertical viewports. If you choose
4 Viewports, AutoCAD makes four equal viewports, one in each corner. However,
if you choose 3 Viewports, AutoCAD offers several options to let you choose the
configuration of the three viewports. These options can be confusing.

An easier way to configure viewports is to choose New Viewports from the sub-
menu. The Viewports dialog box opens with the New Viewports tab on top, as
shown in Figure 8-17. Here you choose the configuration that you want. AutoCAD
displays a preview of the configuration.

If you have named views in your drawing, you can specify a view for each viewport
to display. Click a viewport in the Preview pane and choose a named view from the
Change View To drop-down list box at the bottom of the dialog box. If your drawing
is in 3D, you can choose 3D from the Setup drop-down list box, and AutoCAD will
create standard orthogonal views in the viewports. When you have specified your
viewport configuration, click OK to return to your drawing.
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El Viewports [B[%]

New Viewports | M amed Yiewports

Mew name:

Standard viewports: Freview
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Single:
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Figure 8-17: The Viewports dialog box makes it easy to
choose a configuration.

The Viewport dialog box is usually the best place to start creating viewports.
However, if the standard configurations do not meet your needs, you can use one
of them as a starting point and then use the other options.

Notice the Apply To drop-down list at the bottom-left corner of the Viewports dialog
box (New Viewports tab) in Figure 8-17. By default, the tiled viewport configurations
apply to the entire display, meaning that they replace your current configuration.
You can also choose to apply the configuration to the current viewport. As explained
earlier, the active viewport has a bold border and crosshairs. To make a viewport
active, click anywhere inside that viewport. Then Choose View > Viewports &> New
Viewports, choose Current Viewport from the Apply To drop-down list, and choose
the configuration you want for that viewport.

Let’s say you have four equal viewports, and the top-left viewport is active. If you
choose the Four: Equal configuration from the Viewports dialog box while the top-
left viewport is active and apply it to the current viewport, AutoCAD divides the
top-left viewport into four viewports. Now you have seven viewports in the drawing.

Removing tiled viewports

One way to remove a tiled viewport is to join it to another viewport. To join one
viewport to another, choose View => Viewports > Join. At the Select dominant
viewport <current viewport>: prompt, click the viewport you want to retain or
press Enter if you want to retain the current viewport. At the Select viewport to
Jjoin: prompt, click the adjacent viewport that you want to join into the dominant
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viewport. You lose the display in this second viewport as AutoCAD joins the two
viewports. The adjacent viewports must together form a rectangle.

The only other way to remove all tiled viewports in one step is to return to the sin-
gle viewport configuration — choose View o> Viewports o> 1 Viewport. AutoCAD
keeps the display in the current viewport and discards the others.

Using tiled viewports

After you have created the viewport configuration that you want, you are ready to
use it. The first step is to create the views you need in each viewport.

Creating viewport views
Creating views in each viewport involves two steps:

1. Make a viewport current by clicking anywhere inside it.

2. Zoom and pan until you have the view that you want.

Tip Many users commonly use one viewport to display the entire drawing and the oth-
_», ersto display zoomed in views of smaller sections.

Drawing from viewport to viewport

After you have the viewport configuration and views you need, you can start to
draw. One of the great advantages of viewports is that you can draw from one view-
port to another. In a large drawing, you may need to draw a line from one end of the
drawing to another, but when you display the entire drawing you cannot see the
detail well enough to specify where to start and end the line. The basic steps to
draw from one viewport to another are as follows:

1. Click the viewport where you want to start. This might be a small detail of one
corner of your drawing.

2. Start the command and specify any options you need. Specify any necessary
coordinates as you usually would.

3. To continue the command in a second viewport, click to activate that view-
port. Continue the command, specifying coordinates as necessary.

4. You can continue the command in a third viewport by clicking it. Do this until
you have completed the command. If you have a viewport displaying the
entire drawing, you immediately see the results in that viewport as well.

r Cross- You can also use viewports to edit your drawing. Chapters 9 and 10 cover the
Reference’\  ommands used to edit your drawing.

All commands except those that change the display —such as zooming, panning,
and creating views — can be started in one viewport and continued in another.
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Floating viewports

AutoCAD has two types of viewports, tiled viewports, which are discussed here, and float-
ing viewports, which | cover in Chapter 17. These two types of viewports have many simi-
larities, but they have different purposes. Whereas the purpose of tiled viewports is to help
you draw and edit your drawing, floating viewports are generally used to lay out your draw-
ing for plotting.

Floating viewports create layouts, which enable you to treat your screen like a sheet of
paper. You create floating viewports and perhaps a title block on this electronic sheet of
paper. You can create one or more layouts. Each floating viewport can show a different view
of your drawing —just like tiled viewports. But floating viewports then let you plot all those
views on one sheet of paper. You can't do that with tiled viewports, which are just devices
to let you temporarily display your drawing in a way that helps you draw and edit. However,
you can also draw and edit by using floating viewports.

Tiled viewports are covered here because they are appropriate for learning how to draw
and edit your drawing. Floating viewports are covered in Chapter 17 because you use them
to lay out your drawing for plotting.

Saving and restoring viewport configurations

You can save a tiled viewport configuration. If you find yourself creating a particu-
lar configuration over and over, you should save it. Saving a configuration is just a
matter of giving it a name. You can then restore it when needed. Viewport configu-
ration names can be up to 255 characters and can include spaces.

Saving a viewport configuration
After you create a viewport configuration that you like, follow these steps to save it:

1. Choose View &> Viewports = New Viewports if you are not already in the
Viewports dialog box.

2. Type a name in the New name text box.

3. Click OK.

Restoring a viewport configuration

After returning to one viewport or using a different configuration, you can restore
a named viewport configuration, as follows:

1. Choose View > Viewports = Named Viewports. AutoCAD opens the Viewports
dialog box with the Named Viewports tab on top, shown in Figure 8-18.
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El Viewports [B[%]

Mew Yiewports | Named Yiewports

Current name: side four
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Figure 8-18: The Named Viewports tab lists saved viewport
configurations.

Choose the viewport that you want to restore.
Click OK.
The drawing used in the following Step-by-Step exercise on creating, naming, and

restoring tiled viewport configurations, a08-c.dwg, is in the Drawings folder of
the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Creating, Naming, and Restoring Tiled Viewport
Configurations

1

. Open ab08-c.dwg from the CD-ROM.
2. Save the file as ab08-02.dwg in your AutoCAD BibTe folder.

3.

4. In the listing at the left of the dialog box, choose Three: Above. Click OK.

Choose View => Viewports & New Viewports to open the Viewports dialog box.

AutoCAD creates three tiled viewports.

. Click the bottom-left viewport. Choose Zoom Window on the Zoom flyout of

the Standard toolbar and choose a window around the left portion of the
threaded model (the upper part of the drawing).

. Click the bottom-right viewport. Choose Zoom Window on the Zoom flyout of

the Standard toolbar and choose a window around the bottom-left portion of
the drawing (not including the title block).

. Click the top viewport. Choose Zoom Extents from the Zoom flyout of the

Standard toolbar. Figure 8-19 shows the results.
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8. Choose View => Viewports &> New Viewports. In the New name text box, type 3
view O Ring and click OK.

9. With the top viewport still active, choose View > Viewports = 1 Viewport.
AutoCAD displays the view shown in the last active viewport.

10. Choose View > Viewports &> Named Viewports.
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Figure 8-19: The three tiled viewports now display three different views.
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11. Choose 3 view O Ring and click OK. AutoCAD restores the viewport configura-
tion, including the views in each viewport.

12. Save your drawing.

Snap Rotation

Not all 2D drawings are vertical and horizontal. In some drawings a significant por-
tion of your objects are drawn at nonorthogonal angles. One example is an auxiliary
view to show the “true size” of an inclined surface. Sometimes it helps to rotate the
crosshairs to match the major angles of the drawing.

Consider Figure 8-20. A great deal of this drawing is at an angle. You could handle
this in four ways:

4+ Draw as normal, specifying the necessary angles.

4 Rotate the snap, which also rotates the grid and crosshairs.
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4 Create a new UCS (User Coordinate System).

4 Draw the entire model vertically and rotate it afterward.

Creating a new UCS is covered later in this chapter.

e
Figure 8-20: In 2D drawings such as this, you should consider

various options, such as rotating the snap or creating a new UCS.
Thanks to Robert Mack of The Dexter Company, Fairfield, lowa, for this drawing.

-

If you need to draw several objects at a certain angle, such as 45 degrees, you can
rotate the snap to that angle. AutoCAD rotates the grid and crosshairs to follow
suit. This technique works best when the decimal point accuracy required lets you
draw using snap points. You can also use this technique to guide the cursor at an
appropriate angle for direct distance entry, although polar tracking is another way
to accomplish the same task.

To change the snap rotation angle, choose Tools = Drafting Settings (or right-click
SNAP on the status bar and choose Settings) to open the Drafting Settings dialog
box. In the Snap section, type an angle in the Angle text box.

Note that you can also set an X base and a Y base. This simply ensures that the

grid goes through a point of your choice, which is very important if you are using
snap mode to draw. If you are just starting to draw an object, use the 0,0 base and
draw to the existing snap points. However, if you have an existing object and need to
add to it, changing the base can be very helpful. Setting X and Y bases does not
change the coordinates, which are tied to the UCS. The UCS is discussed in the next
section.

r Cross- You can use the ID command to get the coordinates of a point. Then use these
Reference \ o ordinates as the X and Y bases. Chapter 12 covers the ID command.



164

Part Il + Drawing in Two Dimensions

Tip

Click OK to return to your drawing. Make sure that the grid is on. The crosshairs
and grid now reflect the new snap angle. Figure 8-21 shows the same drawing with
a snap angle of 45 degrees. Notice how the crosshairs now match the angle of the
drawing. The crosshairs have been set to 100 percent of screen size, which is useful
when rotating the snap angle. (To reset the crosshairs size, choose Tools &> Options
and click the Display tab.)

Figure 8-21: The snap angle in this drawing has been changed to
45 degrees. Note that the grid follows the snap.

The grid does not have to be on, but it helps you get your bearings when working
~, with an unusual snap angle.

&

You can create a new UCS (User Coordinate System) rather than rotate the snap
angle. The results are similar, except that when you create a UCS, you also affect
the XY coordinates. The UCS is much more flexible when you start drawing in
three dimensions.

User Coordinate Systems

By default, a drawing is set up by using a World Coordinate System. This sets the
origin of the XY points at 0,0 and the angles using the familiar East (right-facing)
equals 0 degrees system. Figure 8-22 shows the UCS icon in its default display.

You can easily create your own UCS and even save it for future use in the drawing.
Creating a UCS is essential for 3D drawing but often useful for 2D drawing as well.
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Figure 8-22: The UCS icon in its default display

To define a UCS in a 2D drawing, you indicate the angle of the X and Y axes and an
origin point. The origin point then becomes the new 0,0 coordinate. AutoCAD offers
several options for specifying the UCS.

Understanding UCS options

Understanding the UCS options will help you create a new UCS more easily, based
on the information you have available. To create a UCS, choose Tools => New UCS.
A submenu opens offering the options listed in Table 8-2.

Choose Tools &> Move UCS to leave the orientation of the XY axes the same but
move the origin. This option is similar to the Origin option. You can specify a new
origin or, for a 3D drawing, move the origin along the Z axis by a positive or nega-
tive number of units (called the Z depth).

These views are used only in 3D drawings. See Chapter 21 for details on 3D

@ Choose Tools > Orthographic UCS to open a submenu with several preset views.
elerence

coordinates.

Table 8-2
UCS Options

Option

Meaning

World

Object

Face

View

Specifies the default UCS, with the X axis horizontal, the Y axis vertical,
and the origin at the initial 0,0 location.

Enables you to align the UCS with an object. In general, AutoCAD uses
the most obvious object snap as the origin and aligns the X axis with the
object. For example, when you choose a line, the endpoint nearest your
pick point becomes the origin and the X axis aligns with the angle of the
line. When you choose a circle, the X axis points toward the point you
pick on the circumference.

Aligns the UCS with the face of a 3D solid.

Aligns the X and Y axes with the current view. Used in 3D drawing.
AutoCAD arbitrarily sets the origin.

Continued
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Table 8-2 (continued)

Option Meaning

Origin Specifies a new 0,0 point of your choice relative to the current origin.

Z Axis Vector Specifies which way the Z axis points. This option is not used in 2D
drawing.

3 Point Enables you to specify three points. The first point is the origin, the

second point indicates the positive direction of the X axis, and the third
point indicates the positive direction of the Y axis.

X Keeps the current origin and rotates the Y and Z axes around the current
X axis. You specify the angle. This is used in 3D drawing.

Y Keeps the current origin and rotates the X and Z axes around the current
Y axis. You specify the angle. This is used in 3D drawing.

yA Keeps the current origin and rotates the X and Y axes around the current
Z axis. You specify the angle. This option can be used in 2D drawing.

Saving and restoring a custom UCS

After you create a UCS, you can save it so that you can easily switch back and forth
between the World Coordinate System and your UCS. To save a UCS, follow these
steps:

1. Specify the UCS as described in the previous section.

2. Choose Tools &> Named UCS. AutoCAD opens the UCS dialog box with the
Named UCSs tab on top, as shown in Figure 8-23. If your current UCS is not
named, it is listed as Unnamed, and highlighted. Previously named UCSs are
also listed. You can also use this dialog box to return to the previous UCS or
the World Coordinate System (WCS).

3. Click Unnamed. Type a name for the UCS and press Enter. The name can be up
to 255 characters and can include spaces.

4. Click OK.

To restore a saved UCS, choose Tools => Named UCS. Choose the UCS that you want
to use and click Set Current. Then click OK.

You can use the same dialog box to return to the previous UCS you used. You can
also choose UCS Previous from the UCS toolbar. Using this button, you can quickly
switch back and forth between two UCSs.

To delete a saved UCS, select it in the UCS dialog box and press the Del key:.
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Eucs 8]
Hamed UCSs | Orthographic UCSs | Settings
Current LICS: arc base
@ World Set Curent
¥ Previous
}iarc base Details

I ok ] [ Cancel ] [ Help ]

Figure 8-23: Use the UCS dialog box to
save and restore a UCS.

Controlling the UCS icon

When you start a new drawing, the UCS icon is at the bottom-left of your drawing at
0,0. By default, the icon remains at 0,0 even if you pan around the drawing. The icon
may therefore end up in the middle of your drawing. If 0,0 is not displayed, then the
icon reverts to the bottom-left of your drawing.

You can turn off the UCS icon completely. If you are not working with customized
UCSs, you often have no reason to see the UCS in a 2D drawing. If you want the
UCS icon on, you can also tell AutoCAD to display it only at the bottom-left of your
drawing —to keep the icon out of the way so that it does not obstruct your
drawing.

If you create a new UCS, keeping the UCS icon at the 0,0 point (the origin) of your
new UCS helps you get your bearings. AutoCAD places a plus sign in the icon to
indicate the origin. However, if the origin is out of the current display or so close
to the edge that the icon won't fit, AutoCAD places the UCS icon at the lower-left
corner of your drawing anyway.

To control the UCS icon, choose View => Display => UCS Icon. (Don’t confuse this
with Tools &> New UCS, which creates a custom UCS.) A submenu opens with the fol-
lowing items:

4 On: Toggles the display of the UCS icon on and off.

4 Origin: Toggles the placement of the UCS icon at the origin on and off.
You can customize the look of the UCS icon. To customize the look of the UCS icon,
choose View > Display => UCS Icon => Properties (or type ucsicon and choose the

Properties option) to open the UCS Icon dialog box, shown in Figure 8-24. As you
make changes, you can see the result in the preview box.
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E1'UCS Icon (]|
LICS icon style Preview
® 22 /\
O Line width: e
ULCS icon size N
- 3 + X
ULCS icon color
Model space icon color: Layout tab icon colar:
M Black [v] |. Blue [v]

[ (0] ] [ Cancel ] [ Help I

Figure 8-24: Use the UCS Icon dialog box to
customize the look of the UCS icon.

Choose between 2D and 3D styles. The 3D style shows the Z axis, but you won’t see
it when you are looking at your model from the top (called plan view). If you choose
the 3D style, you can check the Cone box to display a cone effect for the arrows of
the X and Y axes. Either way, the Z axis has no arrow, so that you can distinguish it
from the X and Y axes. You can also choose a line width from 1 to 3, 1 being the
default.

You can change the size of the icon. Just drag the slider up and down to get the
result you like. Finally, you can change the color of the icon both in model space
and in paper space layouts. Click OK to close the dialog box.

Using a custom UCS

Although it seems confusing at first, after you try creating your own UCS it’s easier
to understand how the process works.

In this exercise, you practice drawing with a custom UCS to create the basic frame-
work for the drawing shown previously in Figures 8-20 and 8-21, a bearing housing
for a commercial dryer.

gll;th(;\‘\ The drawing used in the following Step-by-Step exercise on drawing with a cus-
r |

tom UCS, ab08-d.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

\@/ CD-ROM.

Step-by-Step: Drawing with a Custom UCS
1. Open ab08-d.dwg from the CD-ROM.

2. Save the file as ab08-03.dwg in your AutoCAD BibTe folder. ORTHO should
be on. If necessary, turn on OSNAP. Set a running object snap for endpoints
only.
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3. Choose Tools &> New UCS > Z. Because no objects exist in the drawing, you
cannot easily use the 3 Point or Object options that might otherwise be
useful.

4. At the Specify rotation angle about Z axis <90>: prompt, type 45 ..
The UCS icon and crosshairs are displayed at a 45-degree angle.

5. Choose Rectangle from the Draw toolbar. At the prompt, pick a point at the
bottom center of your screen. At the Specify other corner point or
[Dimensions]: prompt, type @3-15/16,31/32 .1. AutoCAD creates the rectangle
at the proper angle.

6. Start the LINE command. At the Specify first point: prompt, choose the
From object snap. At the Base point: prompt, use the Endpoint object snap
to pick point @ in Figure 8-25. At the <Offset>: prompt, type @-1/8,0 . At
the Specify next point or [Undol: prompt, type @5-3/16<93.3 .. End the
LINE command.

7. Start the LINE command again. Follow the prompts:

Specify first point: Choose the From object snap.

Base point: Use the Endpoint object snap to pick point @.
<Offset>: @1/16,0

Specify next point or [Undol: Move the cursor in the 90°
direction relative to the UCS. 35/64 d. (Remember that the
UCS has been rotated 45 degrees so that 90 degrees looks like
135 degrees.)

Press F6 twice for polar coordinates (if necessary) to
confirm the 90° direction as you move the cursor.

Specify next point or [Undol: Move the cursor in the 18°
direction. 3-9/64

Specify next point or [Close/Undol: Move the cursor in the
270° direction. 35/64 J

Specify next point or [Close/Undo]l: ¢ 4 (to close the figure)

8. Start the LINE command. At the Specify first point: prompt, choose the
From object snap. At the Base point: prompt, use the endpoint object snap
to pick @ in Figure 8-26. At the <Offset>: prompt, type @1/16,0 ..

9. At the Specify next point or [Undo]: prompt, again choose From. At
the Base point: prompt, use the endpoint object snap to pick @. At the
<0ffset>: prompt, type @1/8,0 I to complete the model, as shown in
Figure 8-26. End the LINE command.

10. Because you would normally continue working on this drawing, you should
save the UCS. Choose Tools => Named UCS. In the UCS dialog box, click
Unnamed. Type Rotated 45 and press Enter.

11. Still in the dialog box, choose World, click Set Current, and click OK to return
to your drawing. The UCS icon and crosshairs return to their familiar angle.
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Figure 8-25: Starting to draw the framework for the bearing housing
drawn by using a customized UCS

12. To return to the Rotated 45 UCS, choose Tools => Named UCS to open the
UCS dialog box. Choose Rotated 45 and click Set Current. Click OK. AutoCAD
restores the Rotated 45 UCS.

13. Save your drawing.

Y\/ X

Figure 8-26: The completed framework for the bearing housing
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Tip After creating a new, rotated UCS such as the one in the previous exercise, type

. plan (the start the PLAN command) and use the Current UCS option to remove
‘ the rotation. Now you aren’t working at an angle in your UCS. To return to the
World UCS, type plan again and choose the World option to return to your draw-
ing’s previous state.

N

Isometric Drawing

An isometric drawing is a 2D drawing drawn to look like a 3D drawing. Every child
learns how to draw a box that looks three-dimensional. By drawing parallelograms
instead of squares, the drawing gives the impression of being in three dimensions.
AutoCAD enables you to do the same thing.

Understanding isometric planes

AutoCAD uses the ISOPLANE (short for isometric plane) command to rotate the
crosshairs to the special angles required for isometric drawing. You then toggle the
ISOPLANE setting from left to right to top to draw on each of the three “planes.” As
you do so, AutoCAD changes the angles of the crosshairs, snap, and grid to the
appropriate angles.

These angles are 30 degrees for the X axis, 90 degrees for the Z axis, and 150
degrees for the Y axis. As you toggle among the planes, you see the crosshairs take
on various configurations of these angles. Figure 8-27 shows the standard isometric
cube. You can see three sides —left, right, and top. In the figure, the crosshairs are
set to the right isometric plane.

[sometric drawing is not often used for precise drawing because it can be difficult to

specify the exact points that you need. Also, true 3D drawing has mostly supplanted
isometric drawing. It is, however, used for piping work as well as for illustrations.

Left plane Top plane Right plane

\
/

]
gt
|

. - - . . 1 axis
I—t-x

Figure 8-27: The isometric cube
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Tip

A

Use snap points and object snaps as much as possible in an isometric drawing.
Also, set the cursor to 100 percent of the screen to better visualize the isometric
planes. (Choose Tools = Options and click the Display tab.) The grid is also a help-
ful aid.

Drawing in isometric mode

To

start isometric mode, choose Tools => Drafting Settings to open the Drafting

Settings dialog box. On the Snap and Grid tab, in the Snap type & style section,
choose Grid snap (if not already selected), and then Isometric snap. While you're
there, turn on Snap and Grid if you want them on. Click OK. After you are in isomet-

ric

mode, press F5 to toggle from plane to plane.

Drawing lines in isometric mode is fairly straightforward if the lines are parallel to
one of the isometric plane angles. Circles and arcs in isometric mode must be
drawn as ellipses and elliptical arcs. When you are in isometric mode the ELLIPSE
command has an Isocircle option.

Step-by-Step: Drawing in Isometric Mode
1. Start a new drawing by using the acad.dwt template.
2. Save the drawing in your AutoCAD Bible folder as ab08-04.dwg.

3. Right-click the SNAP button on the status bar and choose Settings. On the
Snap and Grid tab, in the Snap type & style section, choose Grid snap (if not
already selected), and then Isometric snap.

4. In the Snap section, ensure the Snap Y spacing is set to 0.5 and click Snap On.
In the Grid section, ensure the Grid Y spacing is set to 0.5 and click Grid On.
Click OK to return to your drawing.

5. Choose Tools => Options and click the Display tab. In the Crosshair size text
box, change the cursor size to 100. Click OK.

6. Press F5 until you see the <Isoplane Left> prompt.
7. Do a Zoom Window to zoom into the area covered by the grid.
8. Start the LINE command. Follow the prompts:

Specify first point: Use the coordinate display to choose
3.4641,2, which is a snap point. (It may take you a while to
find the point.)

Specify next point or [Undol: Choose 6.4952,0.25. (Press F6
if necessary to get dynamic absolute coordinates.)

Specify next point or [Undol: Choose 6.4952,1.25.

Specify next point or [Close/Undo]: Choose 3.4641,3.

Specify next point or [Close/Undol: Right-click and choose
Close to close the left side of the model. All these points
are snap points.

The results are shown in Figure 8-28.
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Figure 8-28: The left side of the iron plate. The cursor has been
changed to extend to 100 percent of the screen.

9. Press F5 twice until you see <Isoplane Right> on the command line.

10. Start the LINE command again. At the Specify first point: prompt, pick
6.4952,1.25. Press F6 twice to get dynamic polar coordinates. At the Specify
next point or [Undol: prompt, pick when the coordinates show
2.0000<30. At the Specify next point or [Undo]: prompt, use the polar
coordinate display to draw a line of 1.0000<270. At the Specify next point
or [Close/Undo]: prompt, draw a line of 2.0000<210. End the LINE
command.

11. Press F5 twice until you see <Isoplane Top> on the command line.

12. Start the LINE command. Start the line at 8.2270,2.25, which is a snap point.
Draw a line of 3.500<150 and continue another line of 2.000<210. End the LINE
command. This completes the box.

13. Choose Ellipse from the Draw toolbar. Right-click and choose Isocircle from
the shortcut menu. At the Specify center of isocircle: prompt, choose
5.1962,3. At the Specify radius of isocircle or [Diameter]: prompt,
type .5 4. AutoCAD draws the ellipse. Your drawing should look like
Figure 8-29.

14. Change the cursor size back to 5 (%). Save your drawing.
Tip Polar coordinate display is very helpful while drawing isometrically. The coordi-

_»  nNates are easier to understand than the unusual absolute snap point coordinates
4 created by ISOPLANE.
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Figure 8-29: The completed iron plate with a hole
in it, drawn isometrically

Summary

In this chapter, you read how to control the display of your drawing. You learned
about:

4 The PAN and ZOOM commands, including real-time pan and zoom and the
many ZOOM options

4 Using Aerial View to pan and zoom

4 Saving several views of your drawing so that you can retrieve them quickly

4 Creating tiled viewports for drawing and editing, as well as how to name and
display useful viewport configurations

4 Rotating the snap and grid

4+ Creating a User Coordinate System, including how to save a useful UCS and
then set it as current at any time

4 Setting the snap style to isometric to create isometric drawings, which are 2D
drawings that give the appearance of three dimensions

In the next chapter, you discover how to start editing your drawings.

+ o+ ¢



Editing Your
Drawing:
Basic Tools

N o drawing project is ever completed without changes.
You make changes in a drawing for many reasons. Some

editing processes are simply part of the drawing process,
such as copying an object instead of drawing it a second time
from scratch. Other types of editing involve making changes
to many objects at once, such as moving an entire section of a
drawing to make room for newer added objects. You often
need to erase, move, rotate, and resize objects.

Without knowing how to edit, working on a drawing would
become repetitive. To avoid drawing the same object a sec-
ond time, you draw an object once and then copy it to a new
location.

Editing a Drawing

Making changes to a drawing is called editing. In order to edit
an object, you need to select it. AutoCAD offers numerous
techniques for selecting objects. In this chapter, | cover basic
editing commands as well as most of the ways to select
objects. The rest of the 2D editing commands, as well as addi-
tional selection and editing methods — grips, the Object
Property Manager, selection filters, and groups — are covered
in the next chapter.

Most of the editing commands are on the Modify toolbar. In
most cases, you can do one of the following:

4 Start the command first and then select the objects to
which the command applies.

4+ Select the objects first and then start the command.

CHAPTER

<+

In This Chapter

<+

<+

Erasing objects

Copying and

moving objects

Rotating objects

Scaling objects

Selecting obijects

Customizing object-
selection features

<+

<+

<+

<+

<+



176

Part Il + Drawing in Two Dimensions

The question of which comes first, the command or the object, is fully covered later
in this chapter.

Understanding object-selection basics

When you start editing drawings, the main new skill to learn is how to select
objects. The selection options are covered later in this chapter.

The simplest selection technique is to place the pickbox —the box at the intersec-
tion of the crosshairs —over the object and click with the pick button on the
mouse. This is known as picking an object. If you start an editing command before
selecting an object, AutoCAD responds with the Select objects: prompt. When
you pick an object, AutoCAD highlights it, usually by making it dashed, as shown in
Figure 9-1.

Figure 9-1: The selected line is dashed.

AutoCAD continues to provide Select objects: prompts so that you can select
other objects. Continue to select objects until you have selected all the objects that
you want to edit. Then press Enter or right-click to end the Select objects:
prompt.

When you select an object first, the selected object becomes dashed and you also
see one or more small boxes, called grips, as shown in Figure 9-2. The next chapter
covers grips. In the next few exercises, you use this picking technique to select
objects.

Figure 9-2: The selected line is dashed
and also displays grips.

Erasing objects

# Somehow, no drawing is ever completed without erasing an object. The ERASE
-#— command is very simple —it has no options. To erase an object, select the
object and choose Erase on the Modify toolbar or press Del on the keyboard.
Alternatively, choose Erase and then select the object.
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On
i o ab09-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

|
/
& -

thé‘“l-\ The drawing used in the following Step-by-Step exercise on erasing objects,

Step-by-Step: Erasing Objects
1. Open ab09-a.dwg from the CD-ROM.

2. Save the file as ab09-01.dwg in your AutoCAD BibTle folder. This drawing is a
schematic of a gas extraction well, shown in Figure 9-3.

3. To erase the line at point @ of Figure 9-3, move the mouse until the pickbox at
the intersection of the crosshairs is anywhere over the line and click. Notice
that the line is dashed and displays grips.

4. # Choose Erase from the Modify toolbar. AutoCAD erases the line.

5. Right-click and choose Repeat Erase.
6. At the Select objects: prompt, pick the line at point @ in Figure 9-3.

7. AutoCAD responds with 1 found and repeats the Select objects: prompt.
Right-click to end the Select objects: prompt. AutoCAD erases the line.

8. Save your drawing.

- Cross- The OOPS command restores the most recently erased object and is covered in
Reference Chapter 18

Moving objects

Use the MOVE command to move objects in your drawing. Moving an object is
more complex than erasing one because you need to tell AutoCAD the distance and
direction that you want the object to move.

To move an object, select it and choose Move on the Modify toolbar.
'&' Alternatively, choose Move and then select the object.

When you choose the MOVE command and after you have selected an object,
AutoCAD responds with the following prompt:

Specify base point or displacement:

You now have two ways of telling AutoCAD how to move the object or objects:
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Figure 9-3: The gas-extraction well schematic
Thanks to the Army Corps of Engineers for this drawing. The COE
maintains a Web site of drawings at http:// cadlib.wes.army.mil.

4+ Displacement method: At the Specify base point or displacement:

prompt, state the entire displacement as an X,Y coordinate such as 2,3 or a
polar coordinate such as 2<60. Because the word displacement already implies
the relative distance from the object, you do not use @. (AutoCAD actually
uses 0,0 as the relative point.) AutoCAD responds with the Specify second
point of displacement or <use first point as displacement>:
prompt. Because you have already given AutoCAD all the information it needs,
press Enter. AutoCAD uses the first point you indicated as the displacement
(the default) and moves the object.

4 Base point/second point method: At the Specify base point or

displacement: prompt, pick a base point. This can be anywhere in your
drawing. At the Specify second point of displacement or <use first
point as displacement>: prompt, specify the distance and angle of move-
ment either by picking a second point on the screen or by typing a relative
coordinate by using @.
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The displacement method requires less input and is simpler when you know the
exact displacement so that you can type it in. The only disadvantage is that as soon
as you type in the displacement, AutoCAD sometimes displays a confusing drag line
and copy of your object or objects. Ignore this display, press Enter, and your object
or objects move as you specified.

The base point/second point method works best when you want to move an object
relative to another object on the screen.

Tip When you move an object, choose an object snap on the object or a nearby-
~, related object as the base point for exact results.
4
You can use polar snap to move an object. Turn on polar snap and, if necessary, use
the Drafting Settings dialog box to set the increment. You can set the polar dis-
tance; if the polar distance is 0, AutoCAD uses the Snap X spacing value. Use polar
snap with the base point/second point method. At the first prompt, pick a point
such as an object snap on the object. At the second prompt, drag the object in the
desired direction. Use the tooltip to guide you and then click.

You can use object drag-and-drop to move objects if you are not too particular
about where they end up. Here’s how it works:

1. Pick an object.
2. Continue to pick as many objects as you want to move. They all show grips.

3. Pick any of the objects, but not on a grip. Keep the mouse button pressed
until the cursor changes to an arrow with a small rectangle.

4. Drag the object(s) to any other location in your drawing.

For a little more control over the placement of your objects, use the Windows clip-
board. Pick the object(s) that you want to move. Right-click and choose Cut from
the shortcut menu. Right-click a second time and choose Paste. AutoCAD asks you
for an insertion point, which you can pick with an object snap or by typing coordi-
nates. However, you can’t control the base point (AutoCAD uses 0,0) as you can
with the MOVE command.

Onthehl\ The drawing used in the following Step-by-Step exercise on moving objects,
; CDW | ab09-b.dwg, isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

>
~ Step-by-Step: Moving Objects
1. Open ab09-b.dwg from the CD-ROM.
2. Save the file as ab09-02.dwg in your AutoCAD Bible folder. This drawing
shows the plan of a bathroom. Each object is a block, a set of objects that you

can select as one object. Make sure that OSNAP is turned on. Set a running
object snap for intersection only.
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3. .&’ Pick anywhere on the tub to select it. Notice the grip and dashed lines.

Choose Move on the Modify toolbar. Follow the prompts:

Specify base point or displacement: Move the cursor to the
Intersection at @ in Figure 9-4 and click.

Specify second point of displacement or <use first point as
displacement>: Move the cursor to the Intersection at @ 1n
Figure 9-4 and click.

AutoCAD moves the tub to the bottom-right corner of the bathroom.

. Choose Move on the Modify toolbar. Follow the prompts:

Select objects: Pick the sink.

Select objects: 4 Specify base point or displacement: 4'<0
Specify second point of displacement or <use first point as
displacement>: dJ

AutoCAD moves the sink 4 feet to the right.

"o
e

Figure 9-4: The bathroom plan
Thanks to Bill Wynn of New Windsor, Maryland for this drawing.

. Click SNAP on the status bar to turn it on. Now, right-click SNAP. Choose Polar

Snap On (unless it is already on, in which case it is unavailable). Click POLAR
on the status bar.

. Pick the toilet and choose Move on the Modify toolbar. At the Specify base

point or displacement: prompt, pick the intersection at the bottom-left
corner of the toilet tank. At the Specify second point of displacement
or <use first point as displacement>: prompt, move the toilet to the
left until you see 0'-6"<180° on the tooltip and click. AutoCAD moves the toi-
let 6 inches to the left. (If you can’t get a 180° tooltip, check your polar angle
settings.)

7. Save your drawing.
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Copying objects

Copying is very similar to moving. In fact, the only difference is that AutoCAD does
not remove the object from its original spot so that you end up with two objects
instead of one.

C% To copy an object, select it and choose Copy Object on the Modify toolbar.
Alternatively, choose Copy Object and then select the object.

The COPY command has a Multiple option that lets you make any number of copies
from the original object or objects.

When you choose the COPY command and after you have selected an object,
AutoCAD responds with the following prompt:

Specify base point or displacement, or [Multiplel:
You now have two ways of telling AutoCAD where to copy the object or objects:

4 Displacement method: At the Specify base point or displacement, or
[Multiple]: prompt, state the entire displacement as an X,Y coordinate
such as 2,3 or a polar coordinate such as 2<60. Because the word “displace-
ment” already implies the relative distance from the object, you do not use @.
(AutoCAD actually uses 0,0 as the relative point.) AutoCAD responds with the
Specify second point of displacement or <use first point as
displacement>: prompt. Because you have already given AutoCAD all the
information it needs, press Enter. AutoCAD uses the first point you indicated
as the displacement (the default) and copies the object.

4+ Base point/second point method: At the Specify base point or
displacement, or [Multiple]: prompt, pick a base point. This can
be anywhere in your drawing. At the Specify second point of
displacement or <use first point as displacement>: prompt,
specify the distance and angle of movement either by picking a second
point on the screen or by typing in a relative coordinate, using @.

As explained in the previous section on moving objects, you can use polar snap to
copy objects.

You can also use drag-and-drop to copy objects. Follow the steps in the previous
section, but press and hold the Ctrl key as you drag the object. Notice the plus sign
in the cursor’s rectangle. In the same way, you can use the clipboard to copy and
paste objects from one location in a drawing to another.

| ab09-c.dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

thé“‘fe\ The drawing used in the following Step-by-Step exercise on copying objects,

/'I
& _/
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Step-by-Step: Copying Objects

1.
2.

Open ab09-c.dwg from the CD-ROM.

Save the file as ab09-03.dwg in your AutoCAD Bible folder. This drawing
shows part of an electrical schematic. Make sure that OSNAP is turned on. Set
a running object snap for endpoint only.

. Use ZOOM Window to zoom into the area of the drawing marked @ in

Figure 9-5. This shows a 24-volt transformer.

e o 8 o
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Figure 9-5: The electrical schematic
Thanks to Robert Mack of the Dexter Company,
Fairfield, lowa, for this drawing.

. 0% Note that three of the arcs that make up the right side of the transformer

are missing. Pick the arc at @ in Figure 9-6. Choose Copy Object from the
Modify toolbar. Follow the prompts:

Specify base point or displacement, or [Multiplel: Right-
click and choose Multiple from the shortcut menu.

Specify base point: Pick the endpoint at the top of the arc
at @ (see Figure 9-6).

Specify second point of displacement or <use first point as
displacement>: Pick the endpoint at the bottom of the first
arc at @ (see Figure 9-6).
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Specify second point of displacement or <use first point as
displacement>: Pick the endpoint at the bottom of the second
arc at @ (see Figure 9-6).

Specify second point of displacement or <use first point as
displacement>: Pick the endpoint at the bottom of the third
arc at @ (see Figure 9-6).

Specify second point of displacement or <use first point as
displacement>:

Figure 9-6: Close-up of the transformer

. Choose ZOOM Previous from the Standard toolbar to return to your previous

view.

. Pick the circle at @ in Figure 9-5 (which shows the entire schematic section).

Note the grips. You also want to select the text inside the circles, but it’s hard
to see because of the grips. Press Esc to remove the grips.

. Choose Copy Object from the Modify toolbar. Now select the circle at @ in

Figure 9-5 again. This time no grips obscure the text. Separately pick both
lines of text inside the circle.

. Continuing to select objects to copy, select the circle at @ in Figure 9-5. Also

select the two lines of text inside the circle. Right-click to end the Select
objects: prompt.

. At the Specify base point or displacement, or [Multiplel]:

prompt, use the Endpoint object snap to pick point @ in Figure 9-5. At the

Specify second point of displacement or <use first point as

displacement>: prompt, use the Endpoint object snap to pick point @ in
Figure 9-5. AutoCAD copies the two circles with the text.

Save your drawing.
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Copying and moving objects from
one drawing to another

If you use other Windows programs, you usually use the Cut command to move and
the Copy command to copy objects. Then you use the Paste command to specify a
new location. In AutoCAD these commands are called CUTCLIP, COPYCLIP, and
PASTECLIP. (The CLIP refers to the Windows clipboard.) While the MOVE and COPY
commands provide more accuracy within one drawing, you can use the clipboard
to move and copy objects from one drawing to another.

You can copy objects from one drawing to another by using the drag-and-drop tech-
nique. The easiest way is to open both drawings and then choose Window => Tile
Vertically. Select the object(s) that you want to copy, point to one of them, and drag
to the second drawing. However, you don’t have much control over the exact place-
ment of the new objects. From drawing to drawing, AutoCAD copies the objects,
rather than moving them.

For more control over the placement of your objects, use the Windows clipboard. A
special feature, Copy with Base Point, gives you control over the placement of your
objects. Follow these steps:

1. Pick the object(s) that you want to copy.
2. Right-click and choose Copy with Base Point from the shortcut menu.

3. At the Specify base point: prompt, specify a base point. An object snap is
a good idea here. AutoCAD copies the object(s) to the clipboard, including the
base point.

4. Switch to the second drawing.

5. Right-click in the drawing area and choose Paste (or click Paste on the
Standard toolbar). AutoCAD prompts you for an insertion point. Specify the
insertion point by picking, using an object snap, or typing coordinates.
AutoCAD pastes the object.

To copy the object(s) to the same coordinates as the original drawing, in Step 5
choose Paste to Original Coordinates from the shortcut menu. AutoCAD pastes the
object(s) in the second drawing, matching the coordinates. Depending on your
drawing, you may need to ZOOM and PAN to see the pasted copy.

You cannot specify a base point for moving (cutting) an object, but AutoCAD does
let you specify the insertion point when you paste it. AutoCAD automatically uses
the lower-left extent of the selected object(s) as the base point.

a word processing document. For more information on working with AutoCAD
and other applications, see Chapter 27.

@ You can drag objects from an AutoCAD drawing into another application, such as
ererence
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In the following exercise, you practice copying objects from one drawing to another.

On the

o, \!
Y

.

The drawing used in the following Step-by-Step exercise on copying objects from
one drawing to another, ab09-c.dwg, is in the Drawings folder of the AutoCAD
2004 Bible CD-ROM.

Step-by-Step: Copying Objects from One Drawing to Another

1.

Close any open drawings. Open ab09-c.dwg from the CD-ROM. Save the file
as ab09-04.dwg in your AutoCAD Bible folder. Then choose Open from the
Standard toolbar and open ab09-03.dwg from your AutoCAD BibTe folder. If
you didn’t do the previous exercise, open ab09-03.dwg from the Results
folder of the CD-ROM.

. Choose Window > Tile Vertically. This displays the drawings side by side, as

shown in Figure 9-7.

.In ab09-03.dwg, which should be active, make sure that OSNAP is turned on.

Set a running object snap set for endpoint only.

4. Pick the circle at @ and the two lines of text inside it.

5. Move the cursor off the selected objects and right-click. Choose Copy with

Base Point from the shortcut menu.

6. At the Specify base point: prompt, pick the endpoint at @ in Figure 9-7.

7. Click anywhere in ab09-04 . dwg to make it the current drawing. Right-click

10.

11.

and choose Paste from the shortcut menu. At the Specify insertion
point: prompt, pick the endpoint at @ in Figure 9-7. AutoCAD pastes the
objects.

. Click in ab09-03.dwg. Press Esc to clear any grips. Pick the circle at @ in

Figure 9-7. (Don’t include the text this time.) Click again and hold the mouse
button on the circle, but not on the grips, until you see the pointer arrow with
the rectangle. Drag the circle to @ in Figure 9-7. As you can see, you have no
way to precisely place the circle.

. Click in ab09-03.dwg again. This time pick both lines of text inside the circle

at @. Right-click and choose Copy with Base Point. At the Specify base
point: prompt, pick the endpoint at the left quadrant of the circle.

Click in ab09-04 . dwg. Right-click and choose Paste to Original Coordinates.
AutoCAD pastes the two lines of text inside the circle (depending on how
accurately you dragged the circle).

Save ab09-04.dwg. Clickin ab09-03.dwg and click its Close box. Don’t save
changes to ab9-3.dwg.
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C:\Auto CAD Bible\ab0903.dwg
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C:\AutoCAD Bible'\ah09-04.dwg
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Figure 9-7: To copy objects from one drawing to another, display them both on the
screen together. (The drawings may appear reversed on your screen.)

Rotating objects

AutoCAD enables you to easily rotate an object or objects around a base point that
you specify. The base point is usually an object snap point on the object. To indi-
cate the rotation, specify an angle of rotation. As explained in Chapter 5, zero
degrees is generally to the right, and degrees increase counterclockwise, although
you can change this convention. (To do so, choose Format = Units.) By specifying a
negative angle, you can turn objects clockwise.

O To rotate an object, choose Rotate from the Modify toolbar and select an
object. Alternatively, select an object and then choose Rotate from the Modify
toolbar. At the Specify base point: prompt, indicate the point around which
you want to rotate. At the Specify rotation angle or [Reference]: prompt,
type an angle at the command line.

The Reference option lets you specify an absolute existing rotation angle and the
desired angle. At the Specify the reference angle <0>: prompt, you type in an
angle or specify an angle by picking two points. These can be object snap points on
the object that specify the object’s current angle. At the Specify the new angle:
prompt, type or pick a new angle. You can also pick an object snap on another
object in the drawing to indicate this new angle. You can use the Reference option to
align the object with the X or Y axis or with another object in your drawing.



Chapter 9 + Editing Your Drawing: BasicTools 187

Ontheﬁ\‘\ The drawing used in the following Step-by-Step exercise on rotating objects,
| cn@“ | ab07-03.dwg, isin the Results folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Rotating Objects

1. Open ab07-03.dwg from the Results folder of the CD-ROM. If you did the
Step-by-Step exercise on ellipses in Chapter 7, you can open this drawing from
your AutoCAD Bible folder.

2. Save the file as ab09-05.dwg in your AutoCAD BibTe folder. This drawing
shows a conference room, as shown in Figure 9-8.

3. Click GRID on the status bar to remove the grid.

4. Choose Tools => Drafting Settings. On the Object Snap tab, choose Center,
Quadrant, and Perpendicular. Click OK. OSNAP should be on.

5. O Pick the small elliptical table at the top-left corner of the conference
room. Choose Rotate from the Modify toolbar.

Figure 9-8: The conference room

6. At the Specify base point: prompt, pick the top quadrant of the ellipse. At
the Specify rotation angle or [Reference]: prompt, type 90 .
AutoCAD rotates the small table 90 degrees around the base point.

7. Click SNAP on the status bar to turn off snap.
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10.

11.

12.

13.

. Start the COPY command. At the SeTect objects: prompt, pick the arc that

makes the back of the chair. AutoCAD responds 1 found. Continue to pick the
two lines that make the armrests and the arc that makes the front of the chair,
making sure that each time AutoCAD responds 1 found. Right-click to end the
Select objects: prompt.

. At the Specify base point or displacement, or [Multiplel: prompt,

locate the Center object snap to pick the center of the arc that makes up the
back of the chair. (Press Tab to cycle through the object snaps if necessary or
move the cursor over the arc itself, or its center.) At the Specify second
point of displacement or <use first point as displacement>:
prompt, pick point @ in Figure 9-8. This point doesn’t have to be exact.

Start the ROTATE command. Follow the prompts:

Select objects: Pick all four objects that make up the new
chair you just created and press Enter to end object
selection.

Specify base point: Use the Center object snap to select the
center of the arc that makes up the back of the new chair.
Specify rotation angle or [Reference]: 180 .

Start the COPY command and select the four objects in the new chair. Right-
click to end object selection. Follow the prompts:

Specify base point or displacement, or [Multiplel: Right-
click and choose Multiple.

Specify base point: Use the Center object snap to select the
center of the arc that makes up the back of the chair.
Specify second point of displacement or <use first point as
displacement>: Pick a point about a third of the way around
the right side of the conference table.

Specify second point of displacement or <use first point as
displacement>: Pick a point about halfway around the right
side of the conference table.

Specify second point of displacement or <use first point as
displacement>: Pick a point about two-thirds of the way
around the right side of the conference table.

Specify second point of displacement or <use first point as
displacement>: 4

Start the ROTATE command and select the four objects in the first of the three
chairs (the top one) you just created. Right-click to end object selection. (If
Polar Tracking or Object Snap is on, turn them off for better control.) At the
Specify base point: prompt, pick the center object snap of either arc of
the chair. At the Specify rotation angle or [Reference]: prompt,
move the cursor around, watch the image of the chair rotate, and click when
the chair faces the angle of the table.

Repeat Step 12 for the second chair.
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14. Start the ROTATE command and select the four objects in the last chair you
created by using the COPY command. Follow the prompts:

Specify base point: Choose the Center object snap of either
of the chair arcs.

Specify rotation angle or [Reference]: Right-click and choose
Reference from the shortcut menu.

Specify the reference angle <0>: Use the Quadrant object snap
to pick the back arc of the chair.

Specify second point: Use the Quadrant object snap to pick
the front arc of the chair.

Specify the new angle: Use the Perpendicular object snap to
choose the conference table next to the chair.

15. Save your drawing.

Scaling objects

Scaling, or resizing, objects is another common editing task in AutoCAD. As with
rotating objects, you specify a base point, usually an object snap on the object. The
base point is the one point on the object that does not move or change as you scale
the object. The most common way to resize an object is to specify a scale factor.
The current object has a scale factor of 1. Therefore, to increase the size of the
object, type in a number greater than 1. For example, a scale factor of 2 doubles the
size of the object. To decrease the size of the object, type in a number less than 1.
A scale factor of 0.25 creates an object one-quarter of its previous size.

As with the ROTATE command, you can scale by using the Reference option. You
specify the reference length, usually the current length of the object, by typing it in
or using object snaps on the object. At the Specify new length: prompt, you can
type a new length or pick a point. AutoCAD measures this point from the base point
you specified to determine the new length.

To scale an object, choose Scale from the Modify toolbar and select the object.
Alternatively, select the object and choose Scale from the Modify toolbar.

Onthé\fe\ The drawing used in the following Step-by-Step exercise on scaling objects,
, CDW | ab09-d.dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.
//j

Step-by-Step: Scaling Objects
1. Open ab09-d.dwg from the CD-ROM.

2. Save the file as ab09-06.dwg in your AutoCAD Bible folder. This drawing,
shown in Figure 9-9, shows part of a valve that is manufactured in several sizes.
In this exercise, you scale both views to represent a different-size valve piece.
Ensure OSNAP is on. Set running object snaps for quadrant and endpoint.
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Figure 9-9: The valve piece in two views
Thanks to Jerry Bottenfield of Clow Valve Company,
Oskaloosa, lowa for this drawing.

Choose Scale from the Modify toolbar. At the Select objects: prompt,
..id pick both circles in the top view (they are actually arcs because they are
broken at the bottom) and the two short lines at the bottom of the circles.
Press Enter to end object selection. Follow the prompts:

Specify base point: Use the Quadrant object snap to pick the
left quadrant of the inner circle.

Specify scale factor or [Referencel]: Right-click and choose
Reference.

Specify reference length <1>: Use the Quadrant object snap to
pick the left quadrant of the inner circle again.

Specify second point: Use the Quadrant object snap to pick
the right quadrant of the inner circle.

Specify new Tength: 1 4

Because the distance between the two quadrants you chose is 2.5 units, the
SCALE command scales the objects to 40 percent (1 divided by 2.5).

. Right-click and choose Repeat Scale. Select all eight lines in the bottom view

including the green dashed lines. Be sure that AutoCAD says 1 found each
time. If necessary, use ZOOM Window to zoom in. Right-click to end object
selection after you finish selecting the lines. Follow the prompts:

Specify base point: Use the Endpoint object snap at point @
in Figure 9-9.
Specify scale factor or [Referencel]: .4 d

5. Save your drawing. It should look like Figure 9-10.
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Figure 9-10: The valve piece has now been scaled down.

O

Using the CHANGE command

The CHANGE command changes the endpoint of a line and the radius of a circle.
This command can also be used to change text and the location of blocks (covered
in Chapter 18), but other newer commands do the job better, so that CHANGE is
now used mostly for lines and circles. You can also use grips and the Object
Property Manager, both covered in the next chapter, to change line endpoints and
circle radii (among other object properties).

@ CHANGE also enables you to change an object’s properties — layer, linetype, line-
elerence

type scale, lineweight, color, elevation (Z coordinate of an object), thickness, and
plot style. Layer, linetype, linetype scale, lineweight, and color are covered in
Chapter 11. Elevation and thickness are basic 3D concepts that are covered in
Chapter 21. Plot styles are explained in Chapter 17.

To change an object, select it and type change . on the command line.
Alternatively, type change J on the command line and select the object.

Caution The CHANGE command works differently depending on whether you select lines
or circles. For this reason, it can give unexpected results if you choose lines and cir-
cles at the same time. Use the command for either lines or for circles but not for
both at once.

Changing lines

If you select one line, the CHANGE command changes the endpoint closest to where
you picked the line. AutoCAD prompts you for a change point. When you pick it,
AutoCAD brings the endpoint of the line to that change point, as shown in Figure
9-11. You can use an object snap to specify the change point. If ORTHO is on,
AutoCAD makes the line orthogonal, bringing the endpoint of the line as close as
possible to the change point you specify, as shown in Figure 9-11.

If you select more than one line, CHANGE works differently — it moves the nearest
endpoints of all the lines to the change point so that all the lines meet at one point,
as shown in Figure 9-12.
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Original line

,—Change point

—New line with ORTHO off
— New line with ORTHO on

Figure 9-11: Using the CHANGE command on one line

Change point

Figure 9-12: Using the CHANGE command
on several lines. The original lines are shown
as continuous. The new lines, after using the
CHANGE command, are dashed.

Changing circles

Changing the radius of a circle has the same result as scaling it. When you select a
circle, AutoCAD prompts you for a change point. If you pick one, AutoCAD resizes
the circle so that it passes through the new point. You can also press Enter. Then
AutoCAD prompts you to enter a new radius.

If you select more than one circle, AutoCAD moves from circle to circle, letting you
specify a new radius for each, one at a time. You can tell which circle is current
because of its drag image, which lets you drag the size of the circle.

If you select more than one circle and try to pick a change point, AutoCAD responds
with Change point ignored. At that point, one circle becomes active, and you
can then pick a change point.
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0nthe_ﬁ‘\ The drawing used in the following Step-by-Step exercise on changing circles and
,cnw lines, ab09-e.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

AN /  CD-ROM.

Step-by-Step: Changing Circles and Lines
1. Open ab09-e.dwg from the CD-ROM.

2. Save the file as ab09-07.dwg in your AutoCAD BibTe folder. Ensure OSNAP is
on. Set running object snaps for endpoint and perpendicular.

3. Use ZOOM Window to zoom in on the concentric circles at the bottom of the
drawing.

4. Type change . At the Select objects: prompt, pick the innermost circle.
Right-click to end object selection.

5. At the Specify change point or [Properties]: prompt, press Enter (or
right-click and choose Enter) so that you can type in a radius. At the Specify
new circle radius <no change>: prompt, type 3/16 .

6. Use ZOOM Dynamic to zoom in to the top of the release valve. Your view
should look like Figure 9-13.

fam
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Figure 9-13: The zoomed-in view of the air and
vacuum release valve
Thanks to the Army Corps of Engineers in Vicksburg, Mississippi,

for this drawing.

7. Type change .. At the Select objects: prompt, pick points @ and @ in
Figure 9-13. End object selection. At the Specify change point or
[Properties]: prompt, pick the endpoint object snap at @ in Figure 9-13.
AutoCAD redraws the lines.



194

Part Il + Drawing in Two Dimensions

8. Pick the line at @. Right-click and choose Repeat CHANGE. At the Specify
change point or [Properties]: prompt, press Shift+right-click and
choose the Intersection object snap to pick the new intersection near @ in
Figure 9-13. AutoCAD trims the line.

just performed with the CHANGE command.

@ The TRIM command, discussed in Chapter 10, can make the same change that you
eference

9. Do a ZOOM Extents and save your drawing.

Selecting Objects

New
Feature

If you have been following through this chapter’s exercises, you have probably
thought it tedious to pick several objects one at a time. Imagine trying to individu-
ally pick every object in a drawing just to move all the objects one-half unit to the
left! Of course, there is a better way. In fact, AutoCAD offers many ways of selecting
objects.

Selected objects are also called the selection set of objects.

Selecting objects after choosing a command

When you choose an editing command, AutoCAD responds with the Select
objects: prompt. This prompt has 16 options —all you could ever want for select-
ing objects — but these options are not shown on the command line. To specify an
option, type the option abbreviation. Because the Select objects: prompt repeats
until you press Enter, you can combine options to select objects for any command.

In the following list of options, the capitalized letters of the option are the abbrevia-
tion you type (uppercase or lowercase letters work) at the Select objects:
prompt.

Window

The Window option lets you pick two diagonal corners that define a window. All
objects entirely within the window are selected. Figure 9-14 shows the process of
picking the window. Figure 9-15 shows the result —the selected objects are high-
lighted by appearing with dashed instead of continuous lines.

N\ You can now drag past the edge of the screen (actually the viewport) to specify a
window. Hold down the mouse button and continue to move the mouse in the
same direction. The display automatically pans so that you can see objects that
were off the screen. When you see all the objects you need to select, pick the sec-
ond corner of the window.
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Last

The Last option selects the last object that you created.

Selection window

—

i
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— A — fi—
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Figure 9-14: Selecting objects with a window. AutoCAD selects only objects
that lie entirely within the window.
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Figure 9-15: The selected objects are highlighted.

Crossing

Crossing enables you to pick two diagonal corners that define a window. All objects
entirely or partly within the window are selected. Figure 9-16 shows the process

of picking the window. Figure 9-17 shows the result —the selected objects are
highlighted.
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Crossing window

I |
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Figure 9-16: Selecting objects with a crossing window. AutoCAD selects any
objects that lie within or partly within the window.
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Figure 9-17: The selected objects are highlighted.

New N\ You can now drag past the edge of the screen (actually the viewport) to specify a

fea crossing window. Hold down the mouse button and continue to move the mouse
in the same direction. The display automatically pans so that you can see objects
that were off the screen. After you see all the objects you need to select, pick the
second corner of the crossing window.

BOX

BOX is a combination of Window and Crossing. If you pick the two window corners
from left to right, AutoCAD treats it as the Window option. If you pick the two
points from right to left, AutoCAD treats it as the Crossing option. By default, you
can select objects this way without specifying the BOX option. See the section on
implied windowing later in this chapter.
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ALL

The ALL option selects all objects on thawed layers in the drawing. (I discuss layers
in Chapter 11.)

Fence

The Fence option enables you to specify a series of temporary lines. AutoCAD
selects any object crossing the lines. Figure 9-18 shows the process of defining a
selection fence. Figure 9-19 shows the result —the selected objects are highlighted.

—
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Figure 9-18: Using a fence to select objects

Selected objects
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Figure 9-19: The selected objects are highlighted.

WPolygon

The Window Polygon option (WPolygon) is like Window except that you create a
polygon instead of a rectangular window. AutoCAD selects all objects that lie
entirely within the polygon.

197
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Tip

CPolygon

The Crossing Polygon option (CPolygon) is like Crossing except that you create a
polygon instead of a rectangular window. AutoCAD selects all objects that lie
entirely or partly within the window.

Group

The Group option selects a named group of objects. See Chapter 10 for more infor-
mation on groups.

Remove

The Remove option enables you to deselect objects. After you use this option, all
objects you select are deselected and are therefore removed from the selection set.
Use the Add option to once again select objects.

Add

Use Add after using Remove to start selecting objects again.

An alternative to using Remove to deselect objects is to press Shift and deselect
_», objects by picking or implied windowing. See the section on implied windowing
#  later in this chapter.
Multiple

The Multiple option turns off highlighting as you select objects. However, you can-
not visually determine which objects are in the selection set.

Previous

Previous automatically selects all objects you selected for the previous command.
Objects selected and edited by using grips are not remembered for this option. See
Chapter 10 for more information on grips.

Undo

Undo deselects the object(s) selected at the last Select objects: prompt. (If you
removed objects from the selection set at the last Select objects: prompt, Undo
reselects them.)

AUto

AUto combines picking with the BOX option. By default, you can select objects this
way without specifying this option. See the section on implied windowing later in
this chapter.

Single

When you specify this option, AutoCAD responds with another Select objects:
prompt. You select objects by using any option, and then AutoCAD immediately
ends the selection process. You don’t have to press Enter.
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ClLass

Allows you to select certain objects that were created in another application.
Certain applications, such as Autodesk Map, can add a feature classification to an
object. Doing so creates an associated classification (XML) file. If you have such an
object and the XML file is present, you can select objects by classification property.

Cycling through objects

It may happen that you have many objects close together in a drawing, making it
hard to select the object or point you want. You could always zoom in, but in a com-
plex drawing this can take quite a bit of time. Another trick is to use object cycling.
At the Select objects: prompt, hold down Ctrl and pick at the area where more
than one object overlaps. AutoCAD displays the <Cycle on> message. One object
is highlighted. If it is not the one you want, continue to hold down Ctrl and pick.
AutoCAD cycles through the objects. After you have the one you want, release Ctrl.
Press Enter to turn object cycling off. You can continue to select other objects or
end object selection by pressing Enter.

Selecting objects before choosing a command

If you select objects before choosing a command, your options are more limited
than if you choose a command first. Nevertheless, you have enough flexibility for
most situations. The reason for the limitation is that the Command: prompt is active
and anything you might type at the keyboard to indicate a selection option could be
confused with a command. You can pick the object to highlight it, use implied win-
dowing, or use the SELECT command to select objects in advance.

The purpose of the SELECT command is simply to select objects. AutoCAD then
saves these objects for use with the Previous selection option. Choose an editing
command and type p - at the Select objects: prompt. AutoCAD selects the
objects you selected with the SELECT command.

Implied windowing

Implied windowing is equivalent to the Auto selection option listed earlier in this
chapter. By default, implied windowing is always active. As a result, implied win-
dowing is useful for selecting objects before or after choosing a command. By care-
fully choosing which way you create a selection window, you determine how
AutoCAD selects objects:

4 From right to left: If the first window corner is to the right of the second one,
AutoCAD creates a crossing window. AutoCAD selects all objects that lie
entirely or partially within the window.

4 From left to right: If the first window corner is to the left of the second one,
AutoCAD creates a regular selection window. AutoCAD selects all objects
entirely within the window.
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New N\ You can now drag past the edge of the screen (actually the viewport) to specify a

feati window. Hold down the mouse button and continue to move the mouse in the
same direction. The display automatically pans so that you can see objects that
were off the screen. After you see all the objects you need to select, pick the sec-
ond corner of the window.

0nthe—“\ The drawing used in the following Step-by-Step exercise on selecting objects,
ab09-f.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Selecting Objects
1. Open ab09-f.dwg from the CD-ROM, as shown in Figure 9-20.

2. Save the file as ab09-08.dwg in your AutoCAD BibTle folder. Make sure that
OSNAP is on. Set running object snaps for endpoint and perpendicular.

3. Draw a line from @ to @ in Figure 9-20. You will use this later to illustrate the
Last selection option.

4. Type select ..

5. To select the six-burner stovetop, pick a point near @), being careful that the
pickbox at the intersection of the crosshairs doesn’t touch any object.
Transparently zoom in and back out if necessary. Then move the mouse to @
and pick again. The objects chosen appear dashed to indicate that they have
been selected.

O-

Figure 9-20: A kitchen floor plan

6. To select the last object created, the line drawn in Step 1, type 1 .. It now
appears dashed.
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7. Turn off OSNAP. To select the interior lines on the kitchen’s island by using a
fence, type f .. Then pick points @, @, and @. Press Enter to end the fence.

8. Typer J at the Select objects: prompt (the prompt changes to Remove
objects:) and pick the line at @ to remove the external island line picked in
Step 7. At this point, all the selected items should be dashed, as shown in
Figure 9-21.

Figure 9-21: Kitchen floor plan with all
selected items shown dashed

9. Press Enter to complete the command.

10. Turn on OSNAP. Start the MOVE command. At the Select objects: prompt,
type p - and then press Enter again to end object selection. At the Specify
base point or displacement: prompt, pick the endpoint at @ in Figure
9-20. At the Specify second point of displacement or <use first
point as displacement>: prompt, pick the endpoint at . AutoCAD moves
all the objects.

11. Save your drawing.

Customizing the selection process

You can customize the way you select objects. To do so, choose Tools => Options
and click the Selection tab, as shown in Figure 9-22.
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E] Options E]\

Current profile; ellen Current drawing: fg3-1.dwg

Files | Display | Open and Save | Plotting | System | User Preferences | Drafting | Selection | Profiles

Pickbax Size Grip Size

o J ] J
Selection Modes Gripz
Moundverh selection Unselected grip color:
[ Use Shift to add to selection I Color 160 v
[] Press and diag

Selected grip color:
Implied windawing

M Red [
Dhiect grouping 1
[ Associative Hatch Hawer grip colar: )

@ Green v

Enable arips
] Enable grips within blocks
Enable grip tips

100 Object selection limit for dizplay of grips

Figure 9-22: The Selection tab of the Options dialog box

Noun/verb selection

As you already know, the editing process consists of two parts —using a command,
such as COPY or MOVE, and selecting objects. In AutoCAD lingo, noun means an
object in your drawing. Verb refers to a command because a command acts on an
object. This option lets you decide whether you want to be able to select objects
before starting a command.

AutoCAD originally required you to start the command first and then select the
objects. However, in Windows programs, you typically select objects before starting
a command. For example, if you are using Microsoft Word and want to erase a sen-
tence, you select the sentence first, and then press Del.

By default, AutoCAD enables noun/verb selection, the first option in the Selection
Modes section of the Selection tab, shown in Figure 9-22. With this option enabled,
you can select objects first—without giving up the ability to choose commands
first. This gives you maximum flexibility.

The advantage of selecting objects first is that when you switch between Windows
programs, you don’t have to change habitual ways of selecting objects. The disad-
vantage of selecting objects first is that some AutoCAD commands don’t let you
select objects first, which can be confusing. Also, when you select objects first,
grips appear — sometimes obscuring the objects you need to select.
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Use Shift to add to selection

“Use Shift to add to selection” is the second option in the Options dialog box,
Selection tab. By default, this option is not checked. In AutoCAD, you often select
more than one object at a time for editing. Therefore, AutoCAD simply lets you
select object after object—when you select a second object, the first object stays
selected — so that you can easily select any number of objects you want.

However, Windows programs typically enable you to select only one object at a
time. For example, let’s say you choose Drawing from the Standard toolbar in
Microsoft Word to open the Drawing toolbar and draw a few shapes. If you select
one shape and then select a second shape, selecting the second shape deselects
the first shape. However, if you hold down Shift, you can select any number of
shapes at a time.

Commands and object selection

Certain commands require you to choose objects in a specific order or require objects that
have a certain relationship to each other. For example, the TRIM command (see Chapter
10) requires that you first select an object to trim to (the cutting edge), and then the object
to trim. If you select the objects in advance, AutoCAD wouldn't know which object to trim.
Only after you start the TRIM command does AutoCAD know to prompt you exactly for the
objects it needs to complete the command. Other commands require that you select
objects that are related in some way. The FILLET command (also covered in the next chap-
ter) joins objects that meet— or would meet if extended —by drawing an arc to create a
rounded corner. Here again, the command would be meaningless if, say, you select three or
more objects, so AutoCAD requires that you use the command first and then specifically
prompts you to select the first object, and then the second object.

Many comments allow you to select objects first but the following are some of the most
common:

ARRAY DVIEW MOVE

BLOCK ERASE ROTATE

CHANGE EXPLODE SCALE

CHPROP HATCH STRETCH

COPY LIST WBLOCK
MIRROR

These commands enable you to select any number of objects without restriction, so that
selecting the objects first and the command second works well.
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AutoCAD lets you select one object at a time if you want, although it is not the
default, probably because selecting more than one object at a time is so common. If
you check this option, after selecting one object, you must hold down Shift to select
any additional object.

Press and drag

One of the ways to select objects is to create a window that includes a number of
objects. You are already familiar with creating a similar window from using ZOOM
with the Window option. If the Press and drag option is checked, you need to pick
at one corner of the window and, without releasing the pick button, drag the cursor
to the diagonally opposite corner. This type of action is typical of Windows programs.

By default, this option is not checked, which means that to create a window you
pick at one corner of the window, release the mouse button, and pick again at the
diagonally opposite corner.

This setting does not affect ZOOM Window, which always requires two separate
i H
picks.

Implied windowing

By default, this option is on. Implied windowing means that if you pick any point
not on an object, AutoCAD assumes you want to create a selection window. You can
then pick the opposite corner to select objects. If you pick the corners from right to
left, you get a crossing window. If you pick the corners from left to right, you get a
standard selection window. If implied windowing is not on, when you pick a point
not on an object, AutoCAD assumes you missed some object and gives you this
message on the command line:

0 found

This option applies only when you have started a command and see the Select
objects: prompt. If you turn this option off, you can still enter the Crossing or
Window selection options manually (by typing ¢ - or w J). When selecting objects
before starting the command, implied windowing is always on.

Object grouping

Creating groups of objects is discussed in the next chapter. Groups are sets of objects
that you name. If object grouping is on (the default) when you select one object in a
group, all the objects in a group are automatically selected. Object grouping is a
global setting; you can also set object grouping on or off for individual groups.

Associative hatch

If checked, selects boundary objects when you select a hatch within the boundary.
This option is off by default. Checking this option is equivalent to setting the PICK-
STYLE system variable to 2. See Chapter 16 for more information on hatches.



Chapter 9 + Editing Your Drawing: BasicTools ()5

Pickbox size

In Chapter 4, you read about the aperture, which is the little box at the crosshairs
that you use to pick object snaps, such as endpoint or intersection. The pickbox is
the box that you see at the intersection of the crosshairs when selecting (or pick-
ing) objects. The Pickbox Size area lets you set the size of the pickbox.

;‘\lote If Noun/verb selection is off and grips are disabled, no pickbox appears at the

‘ ~  intersection of the crosshairs until you start an editing command and AutoCAD
gives you the Select objects: prompt. However, if either Noun/verb selection
or grips are on, the pickbox is always at the crosshairs, letting you select objects at
any time.

Summary

All drawings need to be edited, either as part of the drawing process or to make
corrections. In this chapter, you read about:

4 Erasing objects

4 Moving objects

4+ Copying objects

4+ Rotating objects

4 Scaling objects

4 Using the CHANGE command on lines and circles

4+ The many ways of selecting objects

4 Customizing AutoCAD’s object-selection features
The next chapter covers the more advanced editing commands and options.

¢+ ¢






Editing Your
Drawing:
Advanced Tools

This chapter completes the discussion of geometric edit-
ing commands — covering the more complex commands
used to refine the details of your drawing. Then I discuss grips,
which make it easy to move, mirror, rotate, scale, and stretch
objects. I explain how to use the Properties palette to edit
objects. I end the chapter with a discussion of three ways to
control the selection of objects — groups, filters, and the new
Quick Select feature.

Copying and Moving Objects

Three commands enable you to copy objects in very specific
ways. MIRROR creates a mirror image. ARRAY copies objects
in a rectangular or circular pattern. OFFSET creates parallel
objects. Although these commands make copies of objects,
they produce a result that would be difficult or impossible
to produce simply by using the COPY command. The ALIGN
command moves objects by aligning them with other objects
in the drawing.

Using the MIRROR command

Many drawings have symmetrical elements. Often, especially
in mechanical drawing, you can create one-half or one-quarter
of a model and complete it simply by mirroring what you have
drawn.

CHAPTER

¢+ o+
In This Chapter

Using advanced
copying commands:
MIRROR, ARRAY,
and OFFSET

Using advanced
resizing commands:
TRIM, EXTEND,
STRETCH, and
LENGTHEN

Using construction
commands: BREAK,
CHAMEFER, and
FILLET

Creating a revision
cloud and a wipeout

Double-clicking
to edit objects

Editing objects
with grips and the
Properties palette

Using selection filters

and Quick Select

Creating groups
of objects

¢+ 0+ o+
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Al

an object or objects.

To mirror, select an object or objects and then choose Mirror from the Modify
toolbar. Alternatively, choose Mirror from the Modify toolbar and then select

AutoCAD prompts for the first and second points of the mirror line. This is an imag-
inary line across which AutoCAD creates the mirrored object. The length of the line
is irrelevant — only its start point and direction are important.

Tip

A

Most mirror lines are orthogonal. Therefore, after you specify the first mirror point,
turn on ORTHO and move the mouse in the direction of the second point. You can
then quickly pick the second point. Polar tracking can also easily guide you to
specify an orthogonal mirror line.

AutoCAD then asks if you want to delete the source objects. The source objects
refer to the objects you have selected to mirror. If you want to keep them, type n
or press Enter. You would keep the source objects when you are building a symmet-
rical model and want the mirror image to be added to the original object(s). Type

y <4 when you want to edit an object — change its orientation — so that only the
mirror image is retained in the drawing.

On the
cnw\l

The drawing used in the following Step-by-Step exercise on mirroring objects,
ab07-02.dwg, is in the Results folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Mirroring Objects

1

. Open ab07-02.dwg from the Results folder of your CD-ROM. If you com-

pleted the exercise on arcs in Chapter 7, you can open this drawing from
your AutoCAD Bible folder.

. Save the file as ab10-01.dwg in your AutoCAD Bible folder. Make sure

OSNAP is on. Set a running object snap for intersections only.

. Choose Erase on the Modify toolbar. At the SeTect objects: prompt, pick

the line and two arcs to the bottom-right of the two centerlines and then press
Enter. The resulting model should look like Figure 10-1.

. ﬂlﬁ-. Choose Mirror from the Modify toolbar. At the Select objects:

prompt, pick the remaining exterior line and two arcs and press Enter.

. Atthe Specify first point of mirror Tine: prompt, pick the inter

section @ in Figure 10-1. At the Specify second point of mirror Tine:
prompt, pick the intersection @.

. AutoCAD prompts: Delete source objects? [Yes/No] <N>: Press Enter

to accept the default, No.

. Again choose Mirror from the Modify toolbar. At the Select objects:

prompt, type p - to pick the original lines. Then pick the new exterior line
and two arcs and then press Enter.
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o (N o

Figure 10-1: A partially completed mounting plate

S~

8. At the Specify first point of mirror Tine: prompt, pick the intersec-
tion @. At the Specify second point of mirror Tine: prompt, pick the
intersection @. Press Enter again at the Delete source objects?
[Yes/No]l <N>: prompt.

9. AutoCAD completes the mounting plate. Save your drawing. It should look like
Figure 10-2.

SRS

Figure 10-2: The completed mounting plate

Using the ARRAY command

The ARRAY command creates a rectangular or circular (polar) pattern by copying
the object(s) you select as many times as you specify. The ARRAY command is a
powerful drawing tool. It can quickly create large numbers of objects — saving a
huge amount of time and effort.

Rectangular arrays

A rectangular array creates a grid of rows and columns of one or more objects.
Figure 10-3 shows an example of a rectangular array. To create a rectangular array,
follow these steps:

209
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Figure 10-3: The garage door was drawn with one panel as shown on
the left side. A rectangular array created the rest of the door panels as
shown on the right.

Thanks to Henry Dearborn, AlA, Fairfield, lowa for this drawing.

1. go Select the object or objects and choose Array from the Modify toolbar.
OO0 Alternatively, choose Array from the Modify toolbar and select the object
or objects. AutoCAD opens the Array dialog box, shown in Figure 10-4.

El Array B[]
(%) Rectangular Aray ) Polar Aray Select objects

0 objects selected

4 Rows: 4 | Columns: 4

(Offset distance and direction
oooo

cooo
Row offset 1.0000 S=oo
Column offset 1.0000

Angle of array: o

[ I By default, if the row offset is negative,
¥ rows are added dovwrwward. F the

columnn offset is negative, columns are

TiD added to the left.

Figure 10-4: The Array dialog box

2. Click Rectangular Array at the upper-left corner of the dialog box (if it is not
already selected).



Tip

Chapter 10 4+ Editing Your Drawing: Advanced Tools

3. If you have already selected one or more objects, the dialog box indicates the
number of selected objects. If you have not selected any object, click Select
Objects to return to your drawing and select objects. Press Enter to end
object selection and return to the dialog box.

4. Type the number of rows and columns you want in the Rows and Columns
text boxes. Press Tab after the last number you type to see the new result in
the preview panel.

5. Type the row offset (the distance between the rows). The preview panel doesn’t
display any change when you change the row or column offsets.

6. Type the column offset (the distance between the columns).

7. If you want to specify the offsets by picking points on your screen, click one of
the following buttons:

° Pick Both Offsets

° _y[é Pick Row Offset
° —ﬁ Pick Column Offset

8. _y[é If you want to change the angle of the array, type an angle. The preview
panel displays the results of this value. To specify the angle by picking,
click the Pick Angle of Array button.

9. To preview the array, click Preview. Then choose Accept to create the array,
Modify to return to the Array dialog box, or Cancel to end the command.

10. To create the array, click OK.

If you change the Snap angle or the UCS (see Chapter 8), AutoCAD creates the
rectangular array at the angle of the snap or UCS.

If you need to create a number of copies of an object along a straight path, use a
~, one-column or one-row array instead of the COPY command. It's faster and easier.

&

Polar (circular) arrays

A polar array creates copies of one or more objects arrayed in a circle around a
center point. An example of a polar array is shown in Figure 10-5.

211
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Figure 10-5: The pulley was drawn with one spoke as shown on the left.
A polar array created the additional spokes.
Thanks to Robert Mack of the Dexter Company, Fairfield, lowa for this drawing.

To create a polar array, follow these steps:

1. gO Select the object or objects and choose Array from the Modify toolbar.
OO Alternatively, choose Array from the Modify toolbar and select the object
or objects. AutoCAD opens the Array dialog box.

2. Click Polar Array at the top of the dialog box (if it is not already selected).

3. If you have already selected one or more objects, the dialog box indicates the
number of selected objects. If you have not selected any object, click Select
Objects to return to your drawing and select objects. Press Enter to end object
selection and return to the dialog box.

4. _y[é Specify the center point by typing X and Y coordinates or click the Pick
Center Point button. If you selected an object first, check that the center
point displayed is what you want.
5. Select the two items that you want to specify from the Method drop-down
box. You can choose any two from the three choices:

¢ Total Number of Items: Sets the total number of items in the resulting
array, including the one you are arraying.

e Angle to Fill: Sets the number of degrees the polar array covers. For
example, to array around half a circle, specify 180°.

¢ Angle Between Items: Specifies the number of degrees between each
item in the polar array.

6. Complete the values of the two items you specified. You can click the buttons
to pick the angle to fill or the angle between items on the screen.
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7. Check the Rotate Items as Copied check box to rotate the objects that you are
arraying. Uncheck the box to leave them unrotated.

8. Click Preview to preview the array. Then choose Accept to create the array,
Modify to return to the dialog box or Cancel to cancel the command.

9. Click OK to create the array.

You can specify which point on the last object selected AutoCAD uses to array the
objects. AutoCAD makes a calculation of the distance from the center point of the
array to a base point on the last object selected. Otherwise, AutoCAD uses a default
point based on the type of object selected. Table 10-1 lists the default base points. If
you are arraying more than one object, you may not get the result you want without
specifying the base point. Even for one object, you may want to change the base
point used.

To specify the base point, click the More button at the bottom of the dialog box.
The dialog box opens up to display the Object Base Point section. Uncheck Set to
Object’s Default and either type in coordinates or, more likely, click the Pick Base
Point button and use an object snap to pick the desired point on an object. The pre-
view box adjusts according to your choice but, because the preview only shows
rectangles in the place of your object, the display may not be very helpful.

New N You can use the Express Tools COPYM command to enhance your copying options.
Coile Choose Express > Modify=> Multiple Copy. You can create evenly spaced copies
between two points, copy objects according to a specified measurement, and cre-
ate arrays. For information on installing the Express Tools, see Appendix A on the

CD-ROM.
Table 10-1

Object Base Points for Arrays
Type of Object Default Base Point
Arc, circle, or ellipse Center point
Polygon or rectangle First corner
Line, polyline (2D or 3D), ray, spline, or donut Starting point
Text (single-line or paragraph), block Insertion point
Construction line (xline) Midpoint
Region Grip point

Onthéﬁ‘c-\ The drawing used in the following Step-by-Step exercise on arraying objects,
i CDW | ablO0-a.dwg,isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.
//;.

%
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Step-by-Step: Arraying Objects
1. Open ab10-a.dwg from the CD-ROM.

2. Save the file as ab10-02.dwg in your AutoCAD BibTe folder. It looks like
Figure 10-6. OSNAP should be on. Set center and intersection running
object snaps.

o
e | o

Figure 10-6: A partially completed mounting
bracket

3. OO Choose Array on the Modify toolbar. The Array dialog box opens.
aoa

4. Click the Select Objects button of the Array dialog box. In the drawing, pick
the horizontal centerline @ in Figure 10-6 and then press Enter. You return to
the dialog box.

(2]

. Make sure that Rectangular Array is selected at the top of the dialog box.

[=2]

. In the Rows text box, type 4. In the Columns text box, type 1.

-

. In the Row Offset text box, type 1. (You don’t need to specify the column off-
set because you are only creating one column.)

8. Click Preview. You should see a total of four horizontal lines, as shown in
Figure 10-7. Click Accept on the small dialog box that appears. (If you don’t see
the four lines, click Modify and recheck the settings in the Array dialog box.)

9. To add the holes to the pattern, again choose Array from the Modify toolbar.

10. Click the Select Objects button in the Array dialog box. In the drawing, pick
the circle @ in Figure 10-6 and then press Enter.

11. Back in the Array dialog box, type 4 in the Rows text box and type 2 in the
Columns text box.

12. Click the Pick Both Offsets button. In the drawing, pick the center of
circle @ and the intersection of centerlines near @ in Figure 10-6. (You
can also pick the intersection of centerlines at the center of circle @. If
necessary, press Tab until you get the object snap that you want.)



13.

14.
15.
16.
17.

18.

19.

20.

Chapter 10 4+ Editing Your Drawing: Advanced Tools

Click Preview to preview the array. If the circles look like Figure 10-7, click
Accept. Otherwise, click Modify and check you settings. After you're done,
AutoCAD arrays the holes to fit the centerlines.

To create a six-hole bolt circle, pick the hole @ in Figure 10-6.
Choose Array from the Modify toolbar.
In the Array dialog box, choose Polar Array.

Next to the Center Point text boxes, click the Pick Center Point button. In
the drawing, pick the center of the large circle at @ in Figure 10-6.

The Method should read "Total number of items and Angle to fill."
In the Total Number of Items text box, type 6. In the Angle to Fill text box,
type 360.

Click Preview to see the array. It should look like Figure 10-7. If it does, click
Accept. If not, click Modify and recheck the settings in the Array dialog box.

AutoCAD completes the mounting bracket.

Save your drawing. It should look like Figure 10-7.

e
T
4%4% 00
Sk

Figure 10-7: The completed mounting
bracket

Offsetting objects

The OFFSET command creates lines or curves parallel to one existing object. The
beauty of this command is apparent when you start to create complex objects, such
as polylines (see Chapter 16). Polygons and rectangles are polylines, meaning that
they are treated as one object. Using OFFSET, you can create concentric polygons,
for example, in one step. Figure 10-8 shows two concentric polygons. The outside
polygon was created with the POLYGON command, and the inside polygon was
created by using OFFSET.

215
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Figure 10-8: Use OFFSET to
create concentric polygons.

& To offset an object, choose Offset from the Modify toolbar. You cannot select
objects before choosing the command.

AutoCAD responds with the Specify offset distance or [Through]
<1.0000>: prompt. AutoCAD offers two slightly different ways to specify the offset:

4 If you type an offset distance, AutoCAD responds with the Select object
to offset or <exit>: prompt. You can select one object. Then AutoCAD
displays the Specify point on side to offset: prompt. Pick a point to
indicate on which side of the object AutoCAD should create the offset copy.
AutoCAD creates the offset and continues to show the Select object to
offset or <exit>: prompt so that you can offset other objects by using
the same offset distance. Press Enter to exit the command.

4+ If you want to indicate a through point, which is a point that the offset passes
through, such as an object snap on another object, type t 4 or right-click and
choose Through from the shortcut menu. Then AutoCAD displays the Select
object to offset or <exit>: prompt. Pick one object. At the Specify
through point: prompt, pick a point through which you want the offset to
go. AutoCAD creates the offset.

New N\ Use the Express Tools EXOFFSET command for expanded offset options. You can

Reati specify the layer of new objects and create multiple offsets. Choose Express =
Modify > Extended Offset. For information on installing Express Tools, see
Appendix A on the CD-ROM.

Onthéi“c-\ The drawing used in the following Step-by-Step exercise on using the OFFSET
icnw | command, ab10-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible
//f.

& CD-ROM.
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Step-by-Step: Using the OFFSET Command
1. Open ab10-b.dwg from the CD-ROM.

2. Save the file as ab10-03.dwg in your AutoCAD BibTe folder. It looks like
Figure 10-9. Set a running object snap for center and turn on OSNAP.

@
|/o )
AN
\\y/ >

Figure 10-9: A tension arm for a commercial dryer

3. Choose Offset on the Modify toolbar. Follow the prompts:

Specify offset distance or [Throughl] <Through>: 4

Select object to offset or <exit>: Pick @ in Figure 10-9.
Specify through point: Pick the center of @.

Select object to offset or <exit>: d

AutoCAD copies the centerline through the upper circles.

4. Choose Offset from the Modify toolbar again. At the Specify offset
distance or [Throughl] <Through>: prompt, type 4-19/64 .. Pick the
centerline @ at the Select object to offset or <exit>: prompt, and
near @ at the Specify point on side to offset: prompt. Press Enter
to end the command. AutoCAD copies the vertical centerline 4-19/64 units
to the right of the original.

5. Save your drawing. It should look like Figure 10-10.
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N . A
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Figure 10-10: The completed tension arm

Aligning objects

The ALIGN command lets you move and rotate an object or objects in one proce-
dure. It is especially useful in 3D work. By specifying which points on an object
move where, you can align the object with other objects in your drawing, as shown
in Figure 10-11.

E&A See Chapter 24 for the use of the ALIGN command in 3D editing.
Reference

1st source point

1st destination point

2nd destination point
2nd source point

Before After
Figure 10-11: Aligning a door with a wall

Aligning requires several steps. Even so, it can save time when you need to both
move and rotate at the same time, especially if you don’t know the rotation angle
that you need. To align an object, choose Modify = 3D Operation => Align and select
an object or objects. Alternatively, select the object or objects first and then choose
Modify = 3D Operation => Align. Then follow these steps:
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1. AutoCAD asks for the first source point. Specify a point, usually an object
snap on the object that you want to move.

2. AutoCAD asks for the first destination point. Specify the point where you want

the first source point to end up.

3. AutoCAD asks for the second source point. If you press Enter, AutoCAD simply
moves the selected objects. To continue to align, specify another point, usually

an object snap on the object that you want to move.

4. AutoCAD asks for the second destination point. Specify the point where you
want the second source point to end up.

5. AutoCAD asks for the third source point. You use this for 3D alignment, to
specify how you want to rotate the object in the third dimension. For 2D
alignment, press Enter to continue the command.

6. AutoCAD displays the Scale objects based on alignment points?
[Yes/No] <N>: prompt. If the distances between the source and destination
points are not the same, type y if you want to scale the original object so that
the source and destination points match exactly.

The drawing used in the following Step-by-Step exercise on aligning objects in two
dimensions, ab10-c.dwg, is in the Drawings folder of the AutoCAD 2004 Bible
CD-ROM.

Step-by-Step: Aligning Objects in Two Dimensions
1. Open ab10-c.dwg from the CD-ROM.

2. Save the file as ab10-04.dwg in your AutoCAD BibTe folder. It looks like
Figure 10-12.

3. Choose Modify => 3D Operation &> Align and follow the prompts:

Select objects: Select the horizontal angle by using a
window, picking near @ then @. Press Enter to end object
selection. This angle needs to be aligned with the long,
diagonal support angle.

Specify first source point: Pick the endpoint at @ in Figure
10-12.

Specify first destination point: Pick the endpoint at @
Specify second source point: Pick the endpoint at @.
Specify second destination point: Pick the endpoint at @
Specify third source point or <continue>: d

Scale objects based on alignment points? [Yes/No]l <N>: J

AutoCAD aligns the horizontal angle with the support angle.
4. Save your drawing. It should look like Figure 10-13.
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Figure 10-13: The washing machine base

Resizing commands

Four additional commands resize objects. The TRIM and EXTEND commands bring
the endpoint of an object to another object. LENGTHEN lets you lengthen or shorten
a line, polyline, arc, or elliptical arc. STRETCH is used to stretch (larger or shorter) a
group of objects, letting you change their direction at the same time.
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Trimming objects

As you edit a drawing, you may find that lines or arcs that once perfectly met other
objects now hang over. To trim an object, you must first specify the cutting edge,
which defines the point at which AutoCAD cuts the object you want to trim. You
define the cutting edge by selecting an object. You can select several cutting edges
and several objects to trim at one time, as shown in Figure 10-14. When you select
an object to trim, you must pick the object on the side that you want trimmed (not
on the side that you want to remain). A common use for the TRIM command is to
create intersections of walls in architectural floor plans.

While using the TRIM command, you can switch to extending objects by pressing
~, the Shift key as you select objects to trim.

)
. |

N |

24 ~_ - -
\\/:\J (;
Pick points Cutting Edges o
on lines
Before trimming After trimming

Figure 10-14: Trimming two objects by using two cutting edges

Generally, you pick the objects to be trimmed individually. You cannot use
Windows to select them. However, you can use the Fence object-selection
method. AutoCAD trims the side of the object that the fence line crosses. You can
also press Enter at the Select cutting edges: prompt. Then, when you select
the objects you want to trim, AutoCAD automatically uses the cutting edge nearest
your pick point. You can use this feature to trim to multiple cutting edges without
having to specify each cutting edge.

L\

The object you want to trim does not have to actually intersect the cutting edge.
AutoCAD can trim an object to a cutting edge that would intersect the object if
extended. This is called trimming to an implied intersection, shown in Figure 10-15.

You can trim arcs, circles, ellipses, elliptical arcs, lines, polylines, xlines, rays,

and splines. You can use polylines, arcs, circles, ellipses, elliptical arcs, lines, rays,
regions, splines, text, or xlines as cutting edges. An object can be used as both a
cutting edge and an object to be trimmed in the same trimming process. You can
also trim to objects within blocks. (Chapter 18 covers blocks.)
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Pick points on arc

Before trimming After trimming

Figure 10-15: Trimming two arcs to an implied intersection

e To trim an object, choose Trim from the Modify toolbar. You cannot select

objects before starting the TRIM command. AutoCAD displays the Current
settings: Projection=UCS, Edge=None Select cutting edges ... Select
objects: prompt. AutoCAD lets you know the values of the two system variables
that affect trimming. The Projection setting is used only for 3D models. The Edge
setting is used for implied intersections. When Edge is set to Extend, AutoCAD
trims to the implied intersection of the cutting edge and the object to be trimmed.
At this prompt, pick the object(s) that you want to use as a cutting edge. Press
Enter to end object selection.

If the object you want to use for the cutting edge is already selected before
., you start the TRIM command, AutoCAD deselects it. At the Select cutting

4  edges ... prompt, you can type p .! to reselect that object.

You can trim to an actual or an implied intersection (an intersection that would
exist if objects were extended):

4 If you want to trim to an actual intersection, at the Select object to trim
or shift-select to extend or [Project/Edge/Undo]: prompt, select
objects to trim. Be sure to pick each object between the cutting edge and the
end you want to trim off. Press Enter to end object selection. AutoCAD trims
the object(s).

4 If you want to trim to an implied intersection, at the Select object to
trim or shift-select to extend or [Project/Edge/Undol: prompt,
type e . AutoCAD responds with the Enter an implied edge extension
mode [Extend/No extend] <No extend>: prompt. Type e . Then select
the objects that you want to trim at the Select object to trim or
shift-select to extend or [Project/Edge/Undo]: prompt. Be sure
to pick each object at or near the end that you want to trim. Press Enter to
end object selection. AutoCAD trims the object(s).
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Use the Undo option if the results of the trim are not what you want. You can then
continue to select objects to trim.

Onthe_\‘\ The drawing used in the following Step-by-Step exercise on trimming objects,
, CD@W | abl0-d.dwg, is inthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Trimming Objects
1. Open ab10-d.dwg from the CD-ROM.

2. Save the file as ab10-05.dwg in your AutoCAD Bible folder. It looks like
Figure 10-16.

3. Start the TRIM command. At the Select objects: prompt, pick lines at
@ and @ in Figure 10-16 and then press Enter.

4. At the Select object to trim or shift-select to extend or
[Project/Edge/Undo]: prompt, again pick lines at @ and @ in Figure 10-16.
Be sure to pick them outside the intersection, as shown. Press Enter to end
the command.

AutoCAD trims the lines. Each line is used as the cutting edge for the other

line.
b supply — 1@
e ’l@
T TYPE
D TRAP i
LRAIN -0

Figure 10-16: A schematic of an air compressor

5. Choose Trim on the Modify toolbar again. At the Select objects: prompt,
pick the line at @ in Figure 10-16 and press Enter.
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6. At the Select object to trim or shift-select to extend or

[Project/Edge/Undo]: prompt, right-click and choose Edge. Then right-
click and choose Extend at the Enter an implied edge extension mode
[Extend/No extand] <Extend>:: prompt.

. Pick the line at @ in Figure 10-16. AutoCAD trims the line. Press Enter to end

the command.

. Start the TRIM command again. At the SeTect objects: prompt, pick @ and

press Enter. At the Select object to trim or shift-select to extend
or [Project/Edge/Undo]: prompt, pick the lines at @ and @.Press Enter to
end the command.

. Save your drawing. It should look like Figure 10-17.
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Figure 10-17: The completed clamp in two views

d '

Express Tools contains a command, EXTRIM, available on the command line.
EXTRIM can use a polyline, ling, circle, arc, ellipse, image, or text as the cutting line.
You specify one side of the cutting object, and EXTRIM trims everything on that
side. For example, if you choose a closed polyline and pick inside it, every object
inside the polyline is trimmed.

Extending objects

The EXTEND command has the same prompts as the TRIM command, but instead
of trimming objects to a cutting edge, it extends them to a boundary edge (see
Figure 10-18). As with TRIM, when you select an object to extend, you must pick the
object on the side that you want extended (not on the side that you want left as is).
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The object you want to extend does not have to actually intersect the boundary
edge after its extension. AutoCAD can extend an object to a boundary edge that
would intersect the extended object if it were longer. This is called extending to an
implied intersection, shown in Figure 10-19.

Pick points

on Iineswﬁ
Boundary edge —, @ ; @

Figure 10-18: Extending two lines by using
an arc as the boundary edge

You can extend arcs, elliptical arcs, lines, open polylines, and rays. You can use
polylines, arcs, circles, ellipses, elliptical arcs, lines, rays, regions, splines, text, or
xlines as boundary edges. An object can be used as both a boundary edge and an
object to be extended in the same extending process.

While using the EXTEND command, you can switch to trimming objects by press-

~, ing the Shift key as you select objects to trim.
&

. To extend an object, choose Extend from the Modify toolbar. You cannot
select objects before the EXTEND command. AutoCAD displays the Current
settings: Projection=UCS, Edge=Extend Select boundary edges
Select objects: prompt. AutoCAD lets you know the values of the two settings
that affect extending. Projection is used only for 3D models. Edge is used for
implied intersections. When Edge is set to Extend, AutoCAD extends to the implied
intersection of the boundary edge and the object to be extended. At this prompt,
pick the object(s) that you want to use as the boundary edge(s). Press Enter to end
object selection. You can extend to an actual or implied intersection:

4 If the extension will result in an actual intersection, at the Select object to
extend or shift-select to trim or [Project/Edge/Undo]: prompt,
select objects to extend. Be sure to pick each object at the end that you want
to extend. Press Enter to end object selection. AutoCAD extends the object(s).

4 If you want to extend to an implied intersection, at the prompt, right-click
and choose Edge. AutoCAD responds with the Enter an implied edge
extension mode [Extend/No extend] <Extend>: prompt. Right-click
and choose Extend. Then select the objects that you want to extend at the
Select object to extend or shift-select to trim or [Project/
Edge/Undo]: prompt. Be sure to pick each object at the end that you want to
extend. Press Enter to end object selection. AutoCAD extends the object(s).
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Figure 10-19: Extending a line to an implied intersection
Use the Undo option if the results of the extension are not what you want. You can
then continue to select objects to extend.

You can use the Fence object selection method to select objects to extend.
AutoCAD extends the side of the object that the fence line crosses.

cD, abl0-e.dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

1
‘ ¥
k w

Unthék‘fe\ The drawing used in the following Step-by-Step exercise on extending objects,
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Step-by-Step: Extending Objects
1. Open ab10-e.dwg from the CD-ROM.

2. Save the file as ab10-06.dwg in your AutoCAD BibTe folder. It looks like
Figure 10-20.

3. —f Choose Extend on the Modify toolbar. At the Select objects: prompt,
pick the line at @ in Figure 10-20 and then press Enter.
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Figure 10-20: An electrical schematic

4. At the Select object to extend or shift-select to trim or
[Project/Edge/Undo]: prompt, pick the line at @ in Figure 10-20. Press
Enter to finish selecting objects. AutoCAD extends the line.

5. Repeat the EXTEND command. At the Select objects: prompt, pick the
lines at @ and @ in Figure 10-20 and then press Enter.

6. At the Select object to extend or shift-select to trim or
[Project/Edge/Undo]: prompt, right-click and choose Edge. Right-click
and choose Extend at the Extend/No extend <No extend>: prompt.

7. Pick lines @ and @ in Figure 10-20 again at the points shown. AutoCAD
extends the lines to meet. Press Enter to end the command.

8. Save your drawing. It should look like Figure 10-21.
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Figure 10-21: The completed electrical schematic

227



228  Partll + Drawing in Two Dimensions

Lengthening objects

The LENGTHEN command both lengthens and shortens. It works on open objects,
such as lines, arcs, and polylines and also increases or decreases the included angle
of arcs. (You can both change the length of an arc and change its included angle by
using LENGTHEN.) AutoCAD offers several ways of defining the new length or
included angle. Use LENGTHEN when you want to lengthen or shorten an object,
but there is no available intersecting edge or boundary to use with TRIM or
EXTEND.

In the LENGTHEN command, the length of an arc is measured along its circumfer-
ence. Don’t confuse this with the Length of chord option of the ARC command,
which refers to the length of a line stretched from one endpoint of the arc to the
other endpoint.

.# To lengthen (or shorten) an object, choose Modify => Lengthen. You cannot
#  select objects before the LENGTHEN command. AutoCAD responds with the
Select an object or [DElta/Percent/Total/DYnamic]: prompt. Choose
one of the following options:

4 Select object: This is the default. However, its purpose is to display the cur-
rent measurements of the object. This can help you to decide how to define
the final length or angle of the object. The current length is displayed at the
command line, and the previous prompt is repeated.

4+ DElta: Right-click and choose DElta. Delta means the change, or difference,
between the current and new length or included angle. AutoCAD responds
with the Enter delta Tength or [Angle] <0.0000>: prompt. If you
want to change an included angle, right-click and choose Angle. Then type
the change in the included angle. Otherwise, simply type in the change in the
length of the object. A positive number increases the length or included angle.
A negative number decreases the length or included angle.

4 Percent: Right-click and choose Percent. At the Enter percentage length
<100.0000>: prompt, type in what percent of the original object you want
the final object to be. Amounts over 100 lengthen the object. Amounts under
100 shorten the object. You cannot change an included angle using this option.

4+ Total: Right-click and choose Total. At the Specify total length or
[Angle] <1.0000)>: prompt, you can either choose the Angle suboption,
as described for the Delta option or use the default total length option. Either
way, you enter the total angle or length you want.

4 DYnamic: Right-click and choose DYnamic. This option lets you drag the end-
point of the object closest to where you picked it. You can use an object snap
to specify the new endpoint.

After you have used an option to specify the length you want, AutoCAD responds
with the SeTect an object to change or [Undo]: prompt. Here you select the
object you want to change. Be sure to pick the endpoint of the object for which you
want to make the change.
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AutoCAD then continues the same prompt so that you can pick other objects by
using the same length specifications. Choose Undo to undo the last change. Press
Enter to end the command.

On thé‘“l-\ The drawing used in the following Step-by-Step exercise on lengthening and short-
H | ening objects, ab10-f.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

\ /,--" CD-ROM.

Step-by-Step: Lengthening and Shortening Objects
1. Open ab10-f.dwg from the CD-ROM.

2. Save the file as ab10-07.dwg in your AutoCAD Bible folder. It is a capacitor
symbol from an electrical schematic, as shown in Figure 10-22.

°

Figure 10-22: A poorly drawn capacitor symbol

3. .» Choose Modify=> Lengthen and follow the prompts:
s

Select an object or [DElta/Percent/Total/DYnamicl: Pick the
Iine at @ 1n Figure 10-22.

Current length: 0.200

Select an object or [DElta/Percent/Total/DYnamic]l: Right-
click and choose Delta.

Enter delta length or [Angle] <0.000>: .07

Select an object to change or [Undol: Pick the Tine at @ in
Figure 10-22.

Select an object to change or [Undo]: o

AutoCAD lengthens the line.
4. Start the LENGTHEN command again and follow the prompts:

Select an object or [DElta/Percent/Total/DYnamic]: Pick the
arc at @ in Figure 10-22.
Current Tength: 0.407, included angle: 150
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Select an object or [DElta/Percent/Total/DYnamic]: Right-
click and choose Total.

Specify total length or [Angle] <1.000)>:)>: Right-click and
choose Angle.

Specify total angle <57>: 120 A

Select an object to change or [Undo]l: Pick the arc at @ in
Figure 10-22.

Select an object to change or [Undo]:

AutoCAD shortens the arc.
5. Save your drawing. It should look like Figure 10-23.

Figure 10-23: The completed capacitor symbol

Stretching objects

The STRETCH command is generally used to stretch groups of objects. It can be
used to enlarge a room in a floor plan, for example. You can also shrink objects.
You can change not only the length of the objects but the angle as well. You use a
crossing window to choose the objects to be stretched. All objects that cross the
boundaries of the crossing window are stretched. All objects that lie entirely within
the crossing window are merely moved. Successful stretching involves precise
placement of the crossing window. Figure 10-24 shows the process of stretching a
garage. Note that the walls that cross the boundaries of the crossing window are
stretched. However, the dormer, which is entirely within the crossing window, is
just moved. This maintains the integrity of the model.

You cannot stretch circles, text, or blocks. You can stretch arcs, although the
results may not be what you expect.

The real power of the STRETCH command is in stretching a number of objects at
once. However, you can also stretch one line. The results are similar to using the
CHANGE command to change the endpoint of a line.
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Figure 10-24: Stretching a garage

|: To stretch objects, choose Stretch from the Modify toolbar. AutoCAD responds
i, with the Select objects to stretch by crossing-window or crossing-
polygon. .. instruction and then the Select objects: prompt. Create the crossing
window and select the objects that you want to stretch. (You can also use a cross-
ing polygon.) After completing the crossing window, check to see which objects are
highlighted. This helps you avoid unwanted results. You can use the object selection
Remove option (type r . at the command prompt) to remove objects by picking
that you don’t want to stretch or move.

New N\ To allow you to use multiple crossing windows or polygons to select the objects

feati that you want to stretch, use the Express Tools MSTRETCH command. Choose
Express > Modify => Multiple Entity Stretch. For information on installing Express
Tools, see Appendix A on the CD-ROM.

AutoCAD then displays the Specify base point or displacement: prompt.
This step is just like moving objects. You can respond in two ways.

4 Pick a base point. At the Specify second point of displacement or
<use first point as displacement>: prompt, pick a second point.
Object snap and polar snap are helpful for picking these points.

4+ Type a displacement, without using the @ sign. For example, to lengthen the
objects by 6 feet in the 0-degree direction, type 6'<0 . Then press Enter at the
Specify second point of displacement or <use first point as
displacement>: prompt.
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Tip Usually, you want to stretch at an orthogonal angle. If you are going to stretch by
_», picking, turn ORTHO on. Object snaps, polar tracking, and snap mode are other
4 helpful drawing aids for stretching.

When specifying a displacement by typing at the keyboard, you can use both posi-
tive and negative distances. For example, 6'<180 is the same as —6'<0. Both would
stretch the objects 6 feet to the left.

In this exercise, you practice stretching objects.

On the The drawing used in the following Step-by-Step exercise, ab10-g.dwg, is in the
[ CD@“ | Drawings folder of the AutoCAD 2004 Bible CD-ROM.
Step-by-Step: Stretching Objects
1. Open ab10-g.dwg from your CD-ROM.

2. Save the file as ab10-08.dwg in your AutoCAD BibTe folder. This drawing is
the plan view of a garage, as shown in Figure 10-25. Turn on polar tracking by
clicking POLAR on the status bar. Click SNAP on the status bar and then right-
click SNAP to make sure Polar Snap is on (the Polar Snap item will be unavail-
able if it is already on); otherwise, choose Polar Snap. Turn on OSNAP and set
a running object snap for endpoints.

3. |: Choose Stretch from the Modify toolbar. At the Select objects:
ix prompt, pick @ in Figure 10-25. At the Specify opposite corner:
prompt, pick @. AutoCAD notifies you that it found 32 objects. Press Enter
to end object selection.

2]
Figure 10-25: A plan view of a garage
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4. At the Specify base point or displacement: prompt, pick the endpoint
at the bottom-right corner of the garage. At the Specify second point of
displacement or <use first point as displacement>: prompt, move
the cursor to the right until you see the polar tracking tooltip. Click when the
tooltip says 6'-0"<0. (If you can’t find it, type @6',0 .) AutoCAD stretches the
garage by 6 feet.

5. Save your drawing. It should look like Figure 10-26.

Figure 10-26: The longer garage

Using Construction Commands

Three additional commands are commonly used in the process of constructing
models. The BREAK command removes sections of objects at points you specify.
CHAMFER creates corners, and FILLET creates rounded corners.

Breaking objects

Drawing a long line and then breaking it into two or more shorter lines is often much
easier. A common use for BREAK is to break a wall at a door or a window in an
architectural floor plan. You specify two points on the object, and AutoCAD erases
whatever is between those two points. Typically, you use object snaps to specify the
points. Sometimes, you can use TRIM to break an object, but if you have no conve-
nient cutting edge, you may find BREAK more efficient.

You can break lines, polylines, splines, xlines, rays, circles, arcs, elliptical arcs, and
ellipses.

I:] To break a line, choose Break from the Modify toolbar. You cannot select the
object first. AutoCAD responds with the Select object: prompt. (Notice that
you can only select one object to break.) At this prompt, you have two choices:
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4+ Select the object at one of the break points that you want to create. AutoCAD
then responds with the Specify second break point or [First point]:
prompt. Because you have already specified the first point, you can now spec-
ify the second point. AutoCAD breaks the object between the two points.

4 Select the object by using any method of object selection. AutoCAD then
responds with the Specify second break point or [First point]:
prompt. Right-click and choose First point. At the Specify first break
point: prompt, pick the first break point. At the Specify second break
point: prompt, pick the second break point. AutoCAD breaks the object
between the two points.

I—_-l Sometimes you may want to break an object into two pieces at a point, with-

out erasing any part of the object. Use the Break at Pointbutton on the
Modify toolbar to help you easily break an object at a point. After selecting the
object, pick where you want to break the object at the Specify second break
point or [First point]: prompt. The two new objects look the same as
before on the screen — until you select one of the objects. To break objects at a
point, AutoCAD uses @, which always signifies the last point entered, to specify
the second break point. Thus, the first and second break points are the same.

You can use BREAK to shorten an object. Pick one point on the object where you
want the new endpoint to be. Pick the other point past its current endpoint.
AutoCAD cuts off the object at the point you picked on the object.

N

- ;_-'
& 7

The drawing used in the following Step-by-Step exercise on breaking objects,
abl0-h.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Breaking Objects
1. Open ab10-h.dwg from your CD-ROM.

2. Save the file as ab10-09.dwg in your AutoCAD Bible folder. This is a site
plan, as shown in Figure 10-27. Turn on OSNAP and set running object snaps
for endpoint and intersection.

3. I:] Choose Break from the Modify toolbar. At the Select object: prompt,
pick the line at @. At the Specify second break point or [First
point]: prompt, pick @. AutoCAD shortens the line.

4. Repeat the BREAK command. At the Select object: prompt, pick the circle
(it’s a maple tree) anywhere along its circumference. At the Specify second
break point or [First point]: prompt, right-click and choose First point.
At the Specify first break point: prompt, pick the intersection at @.

At the Specify second break point: prompt, pick the intersection at @.
AutoCAD breaks the circle.

AutoCAD breaks circles counterclockwise. If you had picked @, and then @,
AutoCAD would have left only the smaller arc and erased the rest of the circle.
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5. Turn on Object Snap Tracking by clicking OTRACK on the status bar.
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Figure 10-27: A site plan

6. Start the BREAK command again. Follow the prompts:

Select object: Pick the line at @.

Specify second break point or [First pointl: Right-click and
choose First point.

Specify first break point: Move the cursor to @ to acquire it
as a tracking point. Then move the cursor to the right onto
the line you are breaking. When you see the Endpoint:
Intersection tooltip, click. (You have no visual confirmation
yet that you picked the right point.)

Specify second break point: Move the cursor to @ to acquire
it as a tracking point. Then move the cursor onto the line
you are breaking. At the Endpoint: 4'-2 3/4"<0.0000 tooltip,
click.

AutoCAD breaks the line.
7. Save your drawing. It should look like Figure 10-28.

On the Two AutoLISP programs on the CD-ROM can help you with breaking and unbreak-
,CDW | ing objects. Pend puts a break line at the end of a pipe. See \Software\
\ / Chapl0\Pend. Br draws a line with a break symbol. See \Software\Chapl0\Br.
-_ The Express Tools contain a command, BREAKLINE, to create a break symbol.
Choose Express > Draw > Break-Line Symbol. Another Express Tools command,

OVERKILL (available on the command line) deletes objects that are on top of

other objects. For information about installing Express Tools, see Appendix A on

the CD-ROM.
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Figure 10-28: The edited site plan

Creating chamfered corners

The CHAMFER command creates corners from two nonparallel lines. You can also
chamfer xlines, rays, and polylines. You can simply extend the lines to meet at an
intersection (a square corner), or create a beveled edge. If you create a beveled edge,
you define the edge by either two distances or one distance and an angle relative to
the first line you are chamfering. Figure 10-29 shows the elements of a chamfered
corner.

Second chamfer distance

s

Second line

Chamfer angle N First chamfer

distance

|
|
|
l«— First line

Figure 10-29: A chamfered corner

Chamfering is a two-step process. First you define how you want to chamfer the
corner, specifying either two distances from the corner or a distance and an angle.
Then you select the two lines you want to chamfer. AutoCAD chamfers them by
using the information you specified.
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[/_ To chamfer, choose Chamfer from the Modify toolbar. You cannot select
objects before the CHAMFER command. AutoCAD responds with the (TRIM
mode) Current chamfer Distl = 0.0000, DistZ2 = 0.0000 Select first
line or [Polyline/Distance/Angle/Trim/Method/mUTtiple]: prompt.
AutoCAD starts by listing the current settings. You can define two distances from
a corner or one distance and an angle:

4 To define two distances from the corner, right-click and choose Distance. At
the Specify first chamfer distance <0.0000>: prompt, type the first
chamfer distance or press Enter to accept the default (which is the last dis-
tance you defined). At the Specify second chamfer distance <0.0000>:
prompt, type the second distance. The default for this is always the first
chamfer distance because equal chamfer distances are so common.

4 To define a distance (from the corner) and an angle, right-click and choose
Angle. At the Specify chamfer Tength on the first Tine <1.0000>:
prompt, enter a distance. This is the same as the first chamfer distance. At
the Specify chamfer angle from the first line <0>: prompt, type
the angle between the first line and the chamfer line.

To extend two nonparallel lines to make a corner, set the chamfer distances to zero
and then chamfer the lines. AutoCAD extends them to meet. If they already intersect,
AutoCAD trims them to create a corner. The pick points on intersecting lines should
be on the part of the lines that you want to keep (not on the part of the lines you
want to trim off).

Now that you specified the settings that you want, you're ready to chamfer. Your
distances or distance and angle are displayed as you just specified them. AutoCAD
repeats the Select first Tine or [Polyline/Distance/Angle/Trim/
Method/mUltiple]: prompt. Select the first line. If you are not creating a chamfer
with equal distances, the order in which you select the lines is important. AutoCAD
trims the first line selected by the first distance and the second line selected based
on either the second distance or the angle. At the Select second Tine: prompt,
select the second line. AutoCAD chamfers the lines.

¢ Cross- Choose the Polyline option to chamfer an entire polyline at once. Chapter 16 covers
Reference \  ,olylines. Chapter 24 discusses chamfering 3D models.

By default, CHAMFER trims the original lines that it chamfers. If you want to keep
the full original lines when you add the chamfer line, choose the Trim option and
choose No Trim.

New N\ Use the mUltiple option to continue the prompts and chamfer several corners in
Jond one command.
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On the ) The drawing used in the following Step-by-Step exercise on chamfering lines,
; cD, | abl10-1.dwg, isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

&_,_,/:
Step-by-Step: Chamfering Lines
1. Open ab10-1i.dwg from your CD-ROM.

2. Save the file as ab10-10.dwg in your AutoCAD BibTe folder. This drawing is
a very small section of a “porcupine” mixer, as shown in Figure 10-30.

? (3

o o
R w
‘ |

| —

L.
Figure 10-30: A mechanical drawing showing a small section of a
“porcupine” mixer

3. [/— Choose Chamfer from the Modify toolbar. CHAMFER states the current
mode and distances. If the distances are not zero, follow the prompts
below. If they are already zero, skip to the next step.

Select first line or [Polyline/Distance/Angle/Trim/Method/
mUltiplel: Right-click and choose Distance from the shortcut

menu.
Specify first chamfer distance <1/2>: 0 4
Specify second chamfer distance <0>: J

4. At the Select first Tine or [Polyline/Distance/Angle/Trim/M
ethod/mUTtiple]: prompt, pick @ in Figure 10-30. At the Select second
line: prompt, pick @. AutoCAD chamfers the two lines to make a corner.
(If this doesn’t work, you may have the Trim option set to No Trim. Change
the setting to Trim and try again.)
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5. Repeat the CHAMFER command. Follow the prompts:

Select first line or [Polyline/Distance/Angle/Trim/Method/
mUltiplel: Right-click and choose Angle.

Specify chamfer length on the first line <1>: 9/16 J
Specify chamfer angle from the first Tine <0>: 45 4

6. At the Select first Tine or [Polyline/Distance/Angle/Trim/
Method/mUltiple]: prompt, pick @ in Figure 10-30. At the Select second
line: prompt, pick @. AutoCAD chamfers the two lines, as shown in
Figure 10-31.

7. Save your drawing.
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Figure 10-31: The edited drawing after using the CHAMFER command

Creating rounded corners

The FILLET command creates rounded corners, replacing part of two lines with
an arc. Fillets are often used in mechanical drawings. In certain cases, you can use
FILLET instead of the ARC command to create arcs. As with CHAMFER, you can fil-
let lines, xlines, rays, and polylines —they can even be parallel. You can also fillet
circles, arcs, elliptical arcs, and ellipses.

The FILLET command defines the fillet arc by its radius, as shown in Figure 10-32.

Like chamfering, filleting is a two-step process. First you define the radius of the
fillet arc. Then you select the two lines that you want to fillet. AutoCAD fillets them
by using the information you specified. You cannot select objects before the FILLET
command.



240

Part Il + Drawing in Two Dimensions

- <« Filletarc Figure 10-32: A fillet consisting of two lines
Radius—— and an arc

Arc center

r»-— To fillet, follow these steps:

1. Choose Fillet from the Modify toolbar. AutoCAD responds with the Current
settings: Mode = TRIM, Radius = 0.0000 Select first object or
[Polyline/Radius/Trim/mUltiple]: prompt.

2. Right-click and choose Radius.

3. At the Specify fillet radius <0.0000>: prompt, type the radius you
want. The default is either 0.0000 or the last radius you specified.

4. AutoCAD repeats the Select first object or
[Polyline/Radius/Trim/mUltiple]: prompt. Select the first object you
want to fillet.

5. At the Select second object: prompt, select the second object you want
to fillet. AutoCAD creates the fillet.

By default, FILLET trims the original lines that it fillets, but the FILLET command
recalls the last setting you used. If you want to keep the full original lines when you
create a fillet, right-click and choose the Trim option, and then choose No Trim.

polylines. Chapter 24 discusses filleting 3D models.

ﬁj Choose the Polyline option to fillet an entire polyline at once. Chapter 16 covers
elerence

Filleting with a zero radius gives the same results as chamfering with distances set
to zero. See the previous section on chamfering.

The order in which you select the two objects to be filleted is not important.
However, where you pick the objects is quite important. If two objects intersect,
AutoCAD keeps the objects on the same side of the intersection as your pick point
and fillets them. Those parts of the objects on the far side of the intersection are
erased.

When you fillet arcs and lines, if more than one fillet is possible, FILLET connects
the endpoints closest to your pick points. Filleting circles and lines can result in
unexpected results. Sometimes you need to experiment to find the proper pick
points.
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Use the mUltiple option to continue the prompts and fillet several corners in one
command.

The drawing used in the following Step-by-Step exercise on filleting objects,
ab10-1.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Filleting Objects
1. Open ab10-1i.dwg from your CD-ROM.
2. Save the file as ab10-11.dwg in your AutoCAD Bible folder. This is the

same drawing used in the previous exercise. It is shown in Figure 10-33.
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Figure 10-33: A mechanical drawing showing a small section of a
porcupine mixer

. r»-— Choose Fillet from the Modify toolbar. At the Select first object

or [Polyline/Radius/Trim/mUltiple]: prompt, right-click and
choose Radius. At the Specify fillet radius <1/2>: prompt, type 5/8 .

4. At the Select first object or [Polyline/Radius/Trim/mUltiple]:

prompt, pick the line at @ in Figure 10-33. At the Select second object:
prompt, pick the line at @. AutoCAD fillets the two lines.

. Repeat the FILLET command. At the Select first object or

[Polyline/Radius/Trim/ mUltiple]: prompt, right-click and choose
Radius. At the Enter fillet radius <5/8>: prompt, type 1/4 .
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6. At the Select first object or [Polyline/Radius/Trim/mUltiple]:
prompt, right-click and choose mUlItiple. Pick the line at @ in Figure 10-33. At
the Select second object: prompt, pick the line at @. AutoCAD fillets the
two lines. The prompts continue. This time pick at @ and @.

7. If you want, you can connect the two loose lines that the fillets created and
create some more fillets in the drawing.

8. Save your drawing. It should look like Figure 10-34.

L

Figure 10-34: The filleted drawing

Creating a Revision Cloud

Some AutoCAD users need to mark areas of their drawings that contain revisions,
to draw attention to these revisions. A common method is to draw a revision cloud
around the revised objects. Figure 10-35 shows a drawing with a revision cloud.

New \ A new feature of AutoCAD 2004 makes a revision cloud, a series of arcs that indicate
Roetis that an area has been revised.

To create a revision cloud, follow these steps:

1. Choose Revcloud from the Draw toolbar.

2. Atthe Specify start point or [Arc Tength/0bject] <Object>:
prompt, you can choose from two options:

¢ To change the length of the arc, right-click and choose Arc Length. Then
specify a new arc length. You can specify a minimum arc length and a
maximum arc length that is up to three times the length of the minimum,
for a variable, hand-drawn look.
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e To change a closed object into a revision cloud, right-click and choose
Object. Then pick a circle, ellipse, closed polyline, or closed spline. You
can choose to reverse the direction of the revision cloud. The object is
converted to a revision cloud and the command ends.

3. Click where you want the revision cloud to start. You also see an instruction,
Guide crosshairs along cloud path. . ., which means that you don’t
have to pick to create the arcs. You just have to move the crosshairs along the
path of the desired cloud.

4. Move the crosshairs counterclockwise to create a circular or elliptical shape.
When you approach the start point, the command ends automatically. (You
can end the cloud at any time by pressing Enter.)

,"‘\lote You can pick each arc endpoint to control the size of the arcs, if you want.
~~  However, if you move the crosshairs further than the arc length, an arc is created
automatically. REVCLOUD multiplies the arc length by the Overall Scale factor (see

Chapter 15) to adjust for different scale factors.
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Figure 10-35: The revision cloud shows where the drawing has been modified.

Hiding Objects with a Wipeout

A wipeout covers up existing objects in order to clear space for some annotation
or to indicate that the covered objects will be changed and should therefore be
ignored. A wipe out is a polygonal area with a background that matches the back-
ground of the drawing area.
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New N\ A new command, WIPEOUT, creates a polygon the same color as the screen
o background.

To create a wipeout, follow these steps:

1. Choose Draw => Wipeout.

2. At the Specify first point or [Frames/Polyline] <Polyline>:
prompt, specify the first point of a shape that will cover existing objects. To
use a polyline as the shape, right-click and choose Polyline. Then select the
polyline and choose whether to erase the polyline or not.

3. At the Specify next point or [Undol]: prompt, if you specified a point,
specify the next point.

4. At the Specify next point or [Close/Undo]: prompt, specify another
point or use the Close option to close the wipeout shape. You can also press
Enter to end the command and use the shape you specified.

By default, the wipeout has a frame around it, using the current layer’s color. You
can hide the frames of all wipeouts. Start the WIPEOUT command, choose the
Frames option, and choose Off.

Double-Clicking to Edit Objects

You can double-click objects to edit them. What happens after you double-click
depends on the type of object. In most cases, double-clicking an object just opens
the Properties window where you can change the object’s properties. For example,
double-clicking a polyline does not start the PEDIT command, a command for edit-
ing polylines. For more information about using the Properties palette, see the
“Editing with the Properties Palette” section later in this chapter.

When you double-click certain types of objects in a drawing, you see a dialog box
(usually) that is specific to these objects:

4 Attribute definition: Opens the Edit Attribute Definition dialog box
(the DDEDIT command). See Chapter 18 for more information.

4 Attribute within a block: Opens the Enhanced Attribute Edit dialog box
(the EATTEDIT command). See Chapter 18 for more information.

4 Block: Opens the Reference Edit dialog box (the REFEDIT command).
See Chapter 18 for more information.

4+ Hatch: Opens the Hatch Edit dialog box (the HATCHEDIT command).
See Chapter 16 for more information.
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4 Mline: Opens the Multiline Edit Tools dialog box (the MLEDIT command).
See Chapter 16 for more information.

4 Mtext or leader text: Opens the Multiline Text Editor (the MTEDIT command).
See Chapter 13 for more information.

4+ Text (TEXT or DTEXT commands): Opens the Edit Text dialog box
(the DDEDIT command). See Chapter 13 for more information.

4+ Xref: Opens the Reference Edit dialog box (the REFEDIT command).
See Chapter 19 for more information.

The DBLCKLEDIT command specifies if double-clicking opens a dialog box in these
instances. To turn off double-clicking to edit objects, type dblclkedit and choose
the Off option.

Grips

Grips offer a way to edit objects without choosing commands. By using grips, you
can quickly stretch, move, rotate, scale, copy, and mirror objects.

When you select an object without first choosing a command, the object appears
highlighted with grips — small boxes at preset object snap points. (If you don’t see
grips, they may be turned off. See the “Customizing grips” section later in this
chapter to read how to turn them back on.)

You can continue to select more objects in this way.

You then activate a grip by clicking it and use it to manipulate the object. When the
grip is activated, it turns red (by default). An activated grip is also called a hot grip,
as shown in Figure 10-36. In some cases, you activate more than one grip at a time.
To activate more than one grip, hold down Shift and then click the grips. If you acti-
vate a grip in error, click it again to deactivate it. Grips are so called because you
can “hold on to” the object by dragging the grips with the mouse.

After you activate a grip, right-click with the mouse to open the Grip shortcut menu
listing all the grip options.

You can also press the spacebar or Enter to cycle through five possible commands
on the command line. It takes a little time to get used to working with grips, but as
soon as you do, they are a quick way to make certain changes. As long as you are
familiar with the STRETCH, MOVE, ROTATE, SCALE, and MIRROR commands, you
can easily learn how to accomplish the same edits by using grips because the
prompts are so similar. After you complete the edit, the object remains highlighted
and the grips remain, so that you can further edit the object. If you want to edit
another object, press Esc once to remove the grips. Then select another object or
objects or choose another command.
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Hot grip (red)

Crosshairs |

—<——Grip (blue)
Line's original — |
position
<—Line's new
position

Grip (blue)

Figure 10-36: Moving a line. Grips appear
at preset object snaps. A hot grip is used to
manipulate an object.

Stretching with grips

Stretching with grips involves understanding how the grip points relate to the
object. For example, you cannot stretch a line from its midpoint — if you think
about it, there’s no way to define in which direction to stretch the line. Also, you
cannot stretch a circle. (You can only scale it.) Aside from these types of limita-
tions, anything goes.

Stretching one line

You can stretch one line. The result is similar to using the CHANGE command to
change a line’s endpoint. To stretch a line, select it. Click the grip at the endpoint
you want to stretch. AutoCAD responds with

** STRETCH **
Specify stretch point or [Base point/Copy/Undo/eXit]:

STRETCH is the first grip editing command on the command line. Simply specify the
new endpoint for the line, using any method of specifying a coordinate. AutoCAD
stretches the line. The other options work as follows:
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4 Base point lets you define a base point — other than the activated grip—and
a second point. Right-click to open the Grip shortcut menu and choose Base
Point. AutoCAD displays the Specify base point: prompt. Define a base
point. AutoCAD responds with the original Specify stretch point or
[Base point/Copy/Undo/eXit]: prompt. Define the second stretch point
to stretch the line.

4 Copy puts you in Multiple mode. Right-click to open the Grip shortcut menu
and choose Copy. AutoCAD responds with the original Specify stretch
point or [Base point/Copy/Undo/eXit]: prompt. AutoCAD keeps the
original line and creates a new line stretched as you specify. You can then
continue to create new stretched lines.

4 Undo undoes the last edit. Right-click to open the Grip shortcut menu and
choose Undo.

4 eXit returns you to the Command prompt. Right-click to open the Grip short-
cut menu and choose Exit. Esc also returns you to the Command prompt.

Stretching multiple lines

Stretching more than one line at a time is similar to the most common use of the
STRETCH command. However, it can also be somewhat confusing.

As explained earlier in this chapter for the STRETCH command, objects that cross
the crossing window are stretched while objects entirely within the crossing window
are moved. When you stretch multiple lines, you should activate endpoint grips to
stretch lines and activate midpoint grips to move lines. Picking all those grips accu-
rately can be difficult and time-consuming. Also, small objects close together create
a lot of overlapping grips that are hard to select. For this reason, stretching multiple
lines works best with simple models.

To stretch multiple lines, follow these steps:

1. Choose the objects that you want to stretch. The objects are highlighted and
display grips. You can use any method of choosing objects —you are not
limited to crossing windows.

2. Hold down Shift and pick each grip that you want to stretch. If there are
internal objects that you want to move with the stretch, select their grips,
too—the midpoints of the lines and arcs, and the centers of the circles.

3. Release Shift and pick a grip to use as a base point. AutoCAD responds:

*% STRETCH **
Specify stretch point or [Base point/Copy/Undo/eXit]:

4. Specify a new stretch point. You can also use any of the other options.

At the end of this section on grips, you have the opportunity to try them out in an
exercise.

247
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Moving with grips

Moving objects is easy by using grips. Choose all the objects that you want to
move. Click any grip to activate it. This becomes the base point. Right-click to open
the Grip shortcut menu and choose Move.

Tip You can also press the spacebar to cycle through the grip editing modes. For
~,  example, to move an object, press the spacebar once.
s
After you choose Move editing mode, AutoCAD responds:

* % MO\/E **
Specify move point or [Base point/Copy/Undo/eXit]:

Use any method to specify the second point. Be sure to use @ if you are typing in
relative coordinates. AutoCAD moves the selected objects. The other options work
as follows:

4 Base point lets you define a base point — other than the activated grip. Right-
click to open the Grip shortcut menu and choose Base Point. AutoCAD displays
the Specify base point: prompt. Define a base point. AutoCAD responds
with the original Specify move point or [Base point/Copy/Undo/eXit]:
prompt. Define the second move point to move the objects.

4 Copy puts you in Multiple mode and lets you copy objects. Right-click to open
the Grip shortcut menu and choose Copy (or type ¢ I_). AutoCAD responds
with the original Specify move point or [Base point/Copy/Undo/
eXit]: prompt. AutoCAD keeps the original object and creates a new object
where you specify. You can then continue to create new objects.

4 Undo undoes the last edit. Right-click to open the Grip shortcut menu and
choose Undo.

4 eXit returns you to the Command prompt. Right-click to open the Grip short-
cut menu and choose Exit. Esc also returns you to the Command prompt.

Rotating with grips

Rotating with grips is very similar to using the ROTATE command. Choose all the
objects that you want to rotate. Click any grip to activate it. This becomes the base
point. Right-click to open the Grip shortcut menu and choose Rotate. AutoCAD
responds:

*% ROTATE **
Specify rotation angle or [Base
point/Copy/Undo/Reference/eXit]:
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Type in a rotation angle or pick a point. AutoCAD rotates the objects. The other
options work as follows:

4 Base point lets you define a base point —other than the activated grip. Right-
click to open the Grip shortcut menu and choose Base Point. AutoCAD displays
the Specify base point: prompt. Define a base point. AutoCAD responds
with the original Specify rotation angle or [Base point/Copy/Undo/
Reference/eXit]: prompt. Define the rotation angle to rotate the objects.

4 Copy puts you in Multiple mode and lets you copy objects. Right-click to open
the Grip shortcut menu and choose Copy. AutoCAD responds with the original
Specify rotation angle or [Base point/Copy/Undo/Reference/eXit]:
prompt. AutoCAD keeps the original object and creates a new rotated object
where you specify. You can then continue to create new objects.

4 Undo undoes the last edit. Right-click to open the Grip shortcut menu and
choose Undo.

4+ Reference lets you specify a reference angle and a new angle. Right-click to
open the Grip shortcut menu and choose Reference. AutoCAD responds with
the Reference angle <0>: prompt. Type an angle or pick two points to
specify an angle. AutoCAD displays the Specify new angle or [Base
point/Copy/Undo/Reference/eXit]: prompt. Type an angle or pick a
point. This works just like the Reference option for the ROTATE command.
(See Chapter 9.)

4+ eXit returns you to the Command prompt. Right-click to open the Grip short-
cut menu and choose Exit. Esc also returns you to the Command prompt.

Scaling with grips
Scaling with grips is very similar to using the SCALE command. Choose all the objects

that you want to scale. Click any grip to activate it. This becomes the base point.
Right-click to open the Grip shortcut menu and choose Scale. AutoCAD responds:

*% SCALE **
Specify scale factor or [Base point/Copy/Undo/Reference/eXit]:

Type a scale factor. AutoCAD scales the objects. The other options work as follows:

4 Base point lets you define a base point —other than the activated grip. Right-
click to open the Grip shortcut menu and choose Base Point. AutoCAD displays
the Specify base point: prompt. Define a base point. AutoCAD responds
with the original Specify scale factor or [Base point/Copy/Undo/
Reference/eXit]: prompt. Define the scale factor to scale the objects.

4 Copy puts you in Multiple mode and lets you copy objects. Right-click to open
the Grip shortcut menu and choose Copy. AutoCAD responds with the original
Specify scale factor or [Base point/Copy/Undo/Reference/eXit]:
prompt. AutoCAD keeps the original object and creates a new scaled object
where you specify. You can then continue to create new scaled objects.
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4 Undo undoes the last edit. Right-click to open the Grip shortcut menu and
choose Undo.

4 Reference lets you specify a reference length and a new scale. Right-click to
open the Grip shortcut menu and choose Reference. AutoCAD responds with
the Reference Tength <0>: prompt. Type a length or pick two points to
specify a length. AutoCAD displays the Specify new length or [Base
point/Copy/Undo/Reference/eXit]: prompt. Type a length or pick a point.
This works just like the Reference option for the SCALE command. (See
Chapter 9.)

4 eXit returns you to the Command prompt. Right-click to open the Grip short-
cut menu and choose Exit. Esc also returns you to the Command prompt.

Mirroring with grips
Mirroring with grips is very similar to using the MIRROR command. Choose all the
objects that you want to mirror. Click any grip to activate it. This becomes the first

point of the mirror line. Right-click to open the Grip shortcut menu. Choose Mirror.
AutoCAD responds:

*% MIRROR **
Specify second point or [Base point/Copy/Undo/eXit]:

Specify the second point of the mirror line. AutoCAD mirrors the objects.

Caution By default, AutoCAD erases the original objects. To keep the original objects, you
must use the Copy option. This feature is the opposite of the MIRROR command,
where the default is to keep the original objects.

The other options work as follows:

4 Base point lets you define a base point — other than the activated grip—and
a second point. Right-click to open the Grip shortcut menu and choose Base
Point. AutoCAD displays the Specify base point: prompt. Define a base
point —that is, the first point of the mirror line. AutoCAD responds with the
original Specify second point or [Base point/Copy/Undo/eXit]:
prompt. Define the second point of the mirror line, and AutoCAD mirrors the
objects.

4+ Copy puts you in Multiple mode and lets you keep the original objects. Right-
click to open the Grip shortcut menu and choose Copy. AutoCAD responds
with the original Specify second point or [Base point/Copy /Undo/
eXit]: prompt. AutoCAD keeps the original objects and creates new mirrored
objects. You can then continue to create new mirrored objects.

4 Undo undoes the last edit. Right-click to open the Grip shortcut menu and
choose Undo.

4 eXit returns you to the Command prompt. Right-click to open the Grip short-
cut menu and choose Exit. Esc also returns you to the Command prompt.
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The drawing used in the following Step-by-Step exercise on editing with grips,
abl10-j.dwg, isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Editing with Grips

1.
2.

Open ab10-j.dwg from the CD-ROM.

Save the file as ab10-12.dwg in your AutoCAD BibTe folder. This is a small
section of a drive block, seen from above, as shown in Figure 10-37. Make sure
ORTHO and OSNAP are on.

. Use a selection window to select the entire model. Now hold down Shift and

place a selection window around the small circles and rectangle at the center
of the model to deselect them.

. Pick the grip at @ in Figure 10-37 to activate it. AutoCAD responds with the

following prompt:

** STRETCH **
Specify stretch point or [Base point/Copy/Undo/eXit]:

. Right-click and choose Mirror from the shortcut menu. AutoCAD responds

with the following prompt:

** MIRROR **
Specify second point or [Base point/Copy/Undo/eXit]:

. Right-click and choose Copy so that the original objects that you mirror are

not deleted.

. At the Specify second point or [Base point/Copy/Undo/eXit]:

prompt, move the cursor to the right. You can see the mirror image of the
model. Pick any point to the right (in the 0-degree direction) of the activated

grip.

I ]

Figure 10-37: This small section of a drive block, seen
from above, can easily be edited with grips.

. Right-click and choose Exit to return to the command line. The original

objects are still highlighted.
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9.

10.

11.

12.

13.

14.

15.

Use a large selection window to select all the new objects including the small
rectangle and circles in the middle. Everything (old and new) should be high-
lighted and display grips.

Pick the grip at @ in Figure 10-37 to activate it. Right-click and choose Rotate
from the shortcut menu. At the Specify rotation angle or [Base point/
Copy/Undo/Reference/eXit]: prompt, type 90 . AutoCAD rotates the
model.

Pick the bottom-right grip to activate it. Right-click and choose Scale from
the shortcut menu. At the Specify scale factor or [Base point/
Copy/Undo/Reference/eXit]: prompt, type .5 4. AutoCAD scales the
model.

Pick the grip at the midpoint of the bottom line. Right-click and choose Move
from the shortcut menu. At the Specify move point or [Base point/
Copy/Undo/eXit]: prompt, type @0,-3 1. The model should look like Fig-
ure 10-38.

Figure 10-38: The drive block section,
after several grip edits, looks a little like
a cookie jar.

Press Esc to remove all grips. Define a crossing window by picking first at @,
and then at @ (see Figure 10-38).

Hold down Shift and pick all the grips along the bottom three lines. Release
Shift and pick the grip at the middle of the bottom line. At the Specify
stretch point or [Base point/Copy/Undo/eXit]: prompt, type @0,1 .
AutoCAD shrinks the model.

If the stretch does not come out right (it might be hard to see and activate all
the grips), choose Undo from the Standard toolbar to undo the stretch and try
again.

Save your drawing.
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You can turn grips on and off and customize their size and color. Choose Tools =
Options and click the Selection tab to open the dialog box shown in Figure 10-39.

El Options 2%
Current profile; ellen Current drawing: Drawing2.dwg
Files | Display | Open and Save | Plotting | System | User Preferences | Drafting | Selection | Profiles
Pickbax Size Grip Size
° J u J
Selection Modes Gripz
Moundverh selection Unselected grip color:
[[] Use Shift to add to selection W Color 160
[ Press and drag Selected grip color:
Implied windawing B fes
L=l
Dhiect grouping
[ Associative Hatch Hawer grip colar:
@ Green
Enable arips
] Enable grips within blocks
Enable grip tips
100 Obiject selection limit for dizplay of grips

Figure 10-39: Use the Selection tab of the Options dialog box to

customize grips.

By default, grips are enabled (that is, turned on). Also by default, grips are turned
off for blocks. (Chapter 18 covers blocks.) When grips are off for blocks, you see
only one grip when you select a block—its insertion point. When grips are on, you

see all the grips you would normally see for objects.

In the Grip Colors section, you can choose the colors you want for unselected and
selected (hot) grips. Click the drop-down lists to choose a color.

The Grip Size section lets you drag the slider bar to set the size of the grips. Click
OK after you have made the desired changes.

Editing with the Properties Palette

The Properties palette displays the properties of selected objects. You can use the
Properties palette to change the properties of objects as well.
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New
Feature

Tip

To open the Properties palette, click Properties on the Standard toolbar. (You

= A can also choose Tools = Properties or press Ctrl+1.) The Properties palette,

shown in Figure 10-40, opens on your screen.

\ _  The Properties palette takes the place of the previous Properties window (or
Object Property Manager). If you don't dock the palette, you can set it to collapse
down to its title bar when you're not using it.

x
Line | W
General

Color W ByLayer

Layer 0

Linetype Byl ayer
Linetype scale 1.0000

Plot style ByColor
Lineweight Byl ayer
Hyperlink

Thickness 0.0000

o Geometry

E Start X 6.2630

& Start Y 17.7061

2

o

1>

B /

Figure 10-40: Use the Properties palette

to edit objects and their properties.

Managing the Properties palette

The new auto-hide feature of the Properties palette makes it easy to work with the
palette open all the time. Whenever the cursor is off the palette, it collapses to just
its title bar. To auto-hide the palette, right-click the title bar and choose Auto-hide.

The Properties palette has its own undo function. Right-click the item that you
. changed in the Properties palette and choose Undo. Multiple levels of undo are

"4 available. For more information about palettes, see Chapter 26.

You can dock the Properties palette. Drag the window to the left or right of your
screen. You can resize the window by pointing to its edge until you see the double-
headed arrow cursor, and then clicking and dragging. You can also resize the two
columns by pointing to the column dividing line until you see the double-headed
arrow and then clicking and dragging. If the Properties palette has two many rows
for its size, you can use the scroll bar to see the undisplayed rows.
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Using the Properties palette

The Properties palette can be used to directly edit objects and for editing other
object properties as well:

4 You can change the layer, color, linetype, linetype scale, and lineweight of
objects. (See Chapter 11.)

4 You can edit text and text properties. (See Chapter 13.)
4 You can edit plot styles. (See Chapter 17.)
4 You can edit hyperlinks. (See Chapter 28.)

To change values in the Properties palette, do one of the following:

4 Click a value, select the text, type a new value, and press Enter.

4 Click a value, click the down arrow at its right, and choose from the drop-
down list.

4 Click a value, click the Pick a Point button, and specify a new point by picking
on the screen.

In Figure 10-40, you see the result of opening the Properties window with one line
selected. To change either endpoint of the selected line, type new coordinates in
the Properties palette and press Enter. Of course, this method of editing a line is
only useful when you know the absolute coordinates that you want. When you select
a geometric property, such as Start X, the X coordinate of the line’s start point, you
can also use the Pick a Point button that appears. You can click this button and then
pick a new start point directly on your screen. The new point becomes the new
start point of the line, changing both the X and Y coordinates of the start point if
your pick point requires it.

The information you see in the Properties palette depends on the objects selected:

4 If no object is selected, you see only properties that apply to the entire draw-
ing, such as UCS, current layer, and viewport data. You can select an object
while the window is open to display data on that object.

4 If one object or one type of object (such as all lines) is selected, you see both
general information and geometrical information on that object.

4 If more than one type of object is selected, you see general information, such
as layer, color, and linetype data, but no geometry data.

4 If more than one object is selected and you choose one type of object from
the drop-down list at the top of the window, you see information applying only
to that type of object. This drop-down list provides a quick way to filter the
type of objects you can edit.
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The Properties palette has three buttons at its upper-right corner.

?, The first button, Quick Select, opens the Quick Select dialog box that’s covered
# in the next section. The Quick Select dialog box lets you create a selection set
according to specified criteria— for example, all green lines. You can then change
the properties of these green lines.

—’ES The second button, Select Objects, enables you to select objects for editing in
the Properties palette. After you select the objects you want, you can change
their properties. If you're going to pick objects or use implied windowing, the Select
Objects button is no advantage. You can just select the objects and apply changes
in the Properties palette. However, if you want to use a fence or polygon method of
selection, the Select Objects button is helpful. Follow these steps:

1. Click the Select Objects button.

2. On the command line, type the selection method that you want (such as f for
fence) as you would if a command were active or you had started the SELECT
command.

3. Select the objects that you want.
4. Press Enter to end object selection.
5. Use the Properties palette to make the desired changes. (You can also start an

editing command to use with the selected objects.)

The third button, Toggle value of PICKADD Sysvar, turns PICKADD on and off.
PICKADD changes how you select more than one object. When it’s on (set to 1), the
default, you can continue to select objects and they are added to the selection set.
When it’s off (set to 0), you need to press Shift to add objects to the selection set;
otherwise, selecting an object deselects previously selected objects.

Here’s how to change the PICKADD variable:

4+ 5 When you see the 1, PICKADD is off. Click the button to turn PICKADD on.

i When you see the plus, PICKADD is on. Click the button to turn
* PICKADD off.

Click the Properties palette’s close box to close the window. You will return to the
Properties palette in the next chapter and in later chapters as appropriate.
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Selection Filters

Sometimes you need a more powerful way to select objects. For example, you may
want to:

4 Select all the lines in your drawing to change their color

4 Check the arc radii of all your fillets

4 Find short line segments that should be erased
Before selection filters, you had to write an AutoLISP program to accomplish these
functions. (Sometimes an AutoLISP program is still the easiest way to go. See

Chapters 34 and 35.) Now you can create fairly complex filters that select only the
objects you want.

ﬁj Don’t confuse object selection filters with point filters. Chapter 4 covers point filters.
eirerence

Using Quick Select to select objects

Quick Select, as its name suggests, is a quick, flexible, and simple way to create
object selection filters. Use the FILTER command, covered in the following sections,
to create more complex filters and when you want to save filtering criteria for
future use.

Start Quick Select in one of these ways:

4 Choose Tools = Quick Select.

4+ With no command active, right-click in the drawing area and choose Quick
Select.

4 Choose the Quick Select button in the Object Properties Manager.

4+ Type gselect 4 on the command line.
AutoCAD opens the Quick Select dialog box, shown in Figure 10-41.

To create a filter, start at the top of the dialog box and work your way down. Here’s
how it works:

4+ Apply to: By default the filter applies to the entire drawing, but you can use
the Select objects button to return to your drawing and select objects. The
rest of the filter will then apply only to selected objects, called Current selec-
tion in the drop-down list. If you use this feature at all, you would usually use
a window to select an area of your drawing. (The Select objects button is
unavailable if Append to current selection set is checked at the bottom
of the dialog box.)
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El Quick Select B[]

Apply b ‘Enlire drawing [v]
v

Object type: ‘Mulllple [

Properties: | Cojar

Layer
Linetype
Linetype scale
Plot style
Lineweight

Operatar: ‘= Equals [v]

WValue: ‘. BiyLayer l"]
Hou to apply:

(®) Include in new selection set

() Exclude from new selection set

[[] &ppend to curent selection set

0K ] I Cancel ] [ Help ]

Figure 10-41: Use the Quick Select
dialog box to quickly create a selection
set of objects based on specified criteria.

4+ Object type: By default, the filter lists Multiple as the object type. Click the

drop-down list to choose from the object types available in your drawing (or
in your selection set if you created one), such as line, circle, ellipse, polyline,
and so on. You can choose only one type of object. To create a filter that
includes more than one type of object (but not all types), use the FILTER
command.

4+ Properties: Here you choose the properties for which you want to filter.

(Most of these properties are covered in the next chapter.) All properties
that AutoCAD can search for in its database are listed —these depend on
the object type you chose. You can choose only one property. The values in
the next two sections depend on your choice in the Properties section. If you
want to create a filter that specifies criteria for more than one property, use
the FILTER command.

4 Operator: After you have chosen a property, you can set it equal to or not

equal to a certain value. You can set certain properties as greater than or less
than a value. You can use wildcard matching characters (such as * and ?) for
editable text. Choose the desired operator from the drop-down list.

4 Value: Here you finally choose the value for your property. For example, you

can set the color equal (or not equal) to green or the linetype equal to DASHED.
Choose the desired value from the drop-down list or enter a value in the
text box.
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4+ How to apply: As soon as you create a filter, you can use it to create a selection
set. To do this, check Include In New Selection Set. You can also use Quick
Select to select everything except objects that meet your selection criteria—
to do so, choose Exclude From New Selection set.

4+ Append to current selection set: Check this box to add objects meeting your
criteria to an existing selection set.

To select the objects meeting your criteria and close the dialog box, click OK.

AutoCAD selects the objects that meet your criteria. If you choose “Exclude from
new selection set,” AutoCAD selects all objects that don’t meet your criteria. You
can start a command and use the selection set. If the command must be started
before selecting objects, you can use the Previous option (type p ) at the Select
objects: prompt to select the objects selected by using Quick Select.

N\ The Express Tools include two commands to create filtered selection sets. FASTSE-
LECT creates a selection set of objects that touch the object you pick. You can cre-
ate chains of objects to include objects that touch other touching objects. Choose
Express = Selection tools = Fast Select. GETSEL creates a selection of objects of the
layer and object type that you select. Choose Expressc> Selection tools=> Get
Selection Set. For information on installing Express Tools, see Appendix A on the

CD-ROM.

Using the FILTER command

The advantage of using the FILTER command over Quick Select is that you can cre-
ate more complex filters and save them.

To create a filter, type filter I on the command line. AutoCAD opens the Object
Selection Filters dialog box, as shown in Figure 10-42. If you have already chosen a
command, type 'filter at the Select objects: prompt to create the selection filter
transparently. The box at the top of the dialog box lists the filters you specified.

[ fdd Selected Object <

]

El Object Selection Filters
Select Filter
Arc
Marned Filters
[ Delete Current Filker List ]
Add to List:

[ Apply ] [ Cancel ] [ Help ]

Figure 10-42: The Object Selection Filters dialog box
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“‘\lote The selection filter only finds colors and linetypes of objects that have been specif-
~ cally set as such, rather than as part of a layer definition. Chapter 11 covers layers,
colors, and linetypes.

Creating a single filter

Use the Select Filter section of the dialog box to specify a filter. The drop-down box
lists all the possible filters. Click the arrow to drop the list down. There are several
types of items — objects, object properties such as color or layer, object snaps such
as arc center or circle radius, and logical operators such as AND, OR, and NOT.
These logical operators combine filter specifications in various ways.

The first step is to choose a filter. In Figure 10-43, Line was chosen from the drop-
down list. If the item chosen does not need any further clarification, click Add to
List. The filter appears in the box at the top of the dialog box. Notice that the filter
appears as Object = Line.

El Object Selection Filters
=Dt:izact = Line
ielect Filter .
__II’\E hd
Marned Filters
[ Delete Current Filter List ]
o List:
[ Add Selecled Object < | [Ceer | [ Concdt | [ Aok ]

Figure 10-43: A filter that chooses all lines

Many filters require a value. You have two ways to enter a value:

4+ If you choose an object that can be listed, the Select button becomes active.
Click it and choose the value you want. For example, if you choose Color or
Layer, you choose from a list of colors or layers.

4 If you choose an object that can have any value, the boxes below the drop-
down list box become active. They are labeled X, Y, and Z, but this is mislead-
ing. These boxes are used for X, Y, and Z coordinates only when you choose a
filter requiring coordinates, such as Viewport Center. In most cases, you use
the X box to give the filter a value. In this situation, the Y and Z boxes are not
used. For example, if you choose Text Height, you type the height in the X box.
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However, you don’t always want to specify that a filter equals a value. Let’s say you
want to create a filter that selects all circles with a radius less than 0.75. When you
choose Circle Radius, the X box becomes active. Click the arrow to drop down the

list of relational operators and choose one. Table 10-2 lists the relational operators.

Table 10-2
Relational Operators in the Object Selection Filters Dialog Box
Operator Definition
= Equal to
= Not equal to
< Less than
<= Less than or equal to
> Greater than
>= Greater than or equal to

Equal to any value

Adding a second filter

To add a second filter, you first decide on the relationship between the first and the
second filter and then assign a logical operator. Logical operators always come in
pairs —when you begin one you must also end it. The logical operators are at the
end of the drop-down list of filter objects.

When two or more filters are listed without logical operators, AutoCAD calculates
~  them as if they were grouped with the AND operator. This means that AutoCAD
only selects objects that meet all the criteria specified.

Table 10-3 explains the four logical operators. (AutoCAD calls them grouping
operators because they group filter specifications together.) The Example column
explains the results of two filter specifications: Color = 1-Red and Object = Circle.

Click Substitute and choose a saved filter to insert a saved filter into the filter you
are currently defining. To add filters based on existing objects, choose Add Selected
Object. AutoCAD adds all the properties of the object to the filter definition —
which is often more than you want.

Figure 10-44 shows a filter that selects all lines and all polylines. The XOR operator
was used because it finds objects that meet one criterion or the other but not both.
Obviously, no object can be both a line and a polyline. This is a good example of a
filter that you cannot create using Quick Select.
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Table 10-3
Logical (or Grouping) Operators Used for Selection Filters
Operator Explanation Example
AND Finds all objects that meet all criteria. Finds red circles.
OR Finds objects that meet any of the criteria. ~ Finds all red objects and all
circles.
XOR Finds objects that meet one criterion Finds red objects that are not

or the other but not both. Requires
two criteria between Begin XOR and
End XOR.

NOT Excludes objects that meet the criteria.
May only have one criterion between
Begin NOT and End NOT.

circles and circles that are
not red.

If the NOT operator groups the
Object = Circle filter, finds all
red objects that are not circles.

E] Object Selection Filters
** Begin  ®0OR
Object = Palyline
Object = Line
“End ®OR
Select Filter
Clear List
e o
Mamed Filters
- [ Delete Current Filter List ]
Add ta List:
[ Add Selected Obiest ¢ | Ceomr ] [toe | [ )

Figure 10-44: A filter that selects all lines and all polylines

Naming and editing filters

After you have completed the filter, you should save it. Even if you don’t think you
will use it again, you may make an editing error in the drawing while using it and
have to go back to it. To save a filter, type a name in the Save As text box and click

Save As.
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You edit a listed filter by using three buttons:

4 Edit Item: Choose the line containing the item and click this button to edit
the item. AutoCAD places the object name in the drop-down box and lets you
specify new values for it.

4 Delete: Choose Delete to delete a chosen item in a filter.

4 Clear List: Choose Clear List to clear all the items in a filter and start over.

To choose a named filter to edit, choose it from the Current drop-down list.

Using filters

You can use filters in two ways. Most often you choose a command first and then
realize that you need a filter to select the objects. Follow these prompts:

Select objects: "filter 4

Define the filter in the Object Selection Filters dialog box.
Click Apply.

Applying filter to selection.

Select objects: Type all 4 or use a large selection window to
select all the objects you want to consider in the filter.

x found

y were filtered out

Select objects: o

Exiting filtered selection. x found

Select objects: 4

AutoCAD continues with the command’s usual prompts.

Alternatively, you can start the FILTER command and define the filter. Click Apply.
At the Select objects: prompt, type all or use a selection window. Press Enter to
end object selection. Then start the editing command and use the Previous selec-
tion option to select the filtered objects.

théx}e\ The drawing used in the following Step-by-Step exercise on using selection filters,

| abl0-k.dwg,isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

/'.I
k Ty

Step-by-Step: Using Selection Filters
1. Open ab10-k.dwg from the CD-ROM.

2. Save the file as ab10-13.dwg in your AutoCAD Bible folder. Notice that two
lines of text appearing in the middle of the drawing plus the text at the bottom
of the drawing are black/white rather than blue like all the other text. You
want to check the color of all the text and correct it if necessary.
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3. Right-click the drawing area and choose Quick Select. In the Quick Select dia-
log box, click the Object type drop-down list and scroll down until you see
Text. Choose it.

N

. In the Properties section, color should be selected. If not, select it. In the
Operator section, choose Not equal. In the Value section, choose ByLayer.
Include In New Selection Set should be chosen. Append to Current Selection
Set should not be checked. Click OK. AutoCAD selects three items of black/
white text.

5. Press Esc to deselect the objects and remove the grips. Now you'll try the
same thing using the FILTER command, but add a level of complexity.

=2}

. Type filter .. The Object Selection Filters dialog box opens.

N|

. In the Select Filter drop-down list, choose Text. Click Add to List. At the top,
the filter reads Object = Text.

8. From the Select Filter drop-down list, choose **Begin AND (this is toward the
bottom of the list) and click Add to List.

9. From the Select Filter drop-down list, choose Color. In the drop-down list next
to X: choose ! = (not equal). Choose Select. In the Select Color dialog box,
choose BYLAYER. Click OK. In the Object Selection Filters dialog box, choose
Add to List. The BYLAYER color number displays as 256. (Layers and colors
are covered in the next chapter.)

10. Say that you want to select only the smaller text, not the heading at the bottom
of the drawing, and you know that the larger text’s height is greater than .1 but
the smaller text’s height is smaller than .1. From the Select Filter drop-down
list, choose Text Height. From the X: drop-down list choose < (less than). In
the text box to the right of X:, type .1. Choose Add to List.

11. From the Select Filter drop-down list, choose **End AND and click Add to List.

12. In the Save As text box, type bad text. Click Save As. The Object Selection
Filters dialog box should look like Figure 10-45.

[E] Object Selection Filters

Object = Teut

= Begin  AND

Color |= 256 - By Layer
Text Height < 0100000
“End  AND

Select Filter

Ediltem | [ Delete | [ ClearLit |
R
= . Mamed Filters
Era—

FSaveds | | badtext

[ Delete Current Filter List ]

[ Add Selected Object < | (Cemvr | [coee | [ 1en

Current:

Figure 10-45: A filter that selects all text whose
color is not BYLAYER
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13. Click Apply.

14. At the Select objects: prompt, type all Jd. AutoCAD tells you that 469
objects were found, and 467 were filtered out. Press Enter until you get the
Command prompt.

15. Choose Color Control from the Object Properties toolbar. Choose ByLayer
from the drop-down list. AutoCAD changes the color of the two text objects
to BYLAYER —they turn blue like all the other text.

16. Save your drawing.

As you can see, Quick Select is much easier to use than the FILTER command for all
but quite complex filters, but the FILTER command offers more control.

Groups

Groups let you save a selection set of objects so that you can easily select them
whenever you need to edit them. If you have a certain set of objects that you need
to edit as a group, and a busy drawing that makes their selection time-consuming,
groups are for you.

Creating and modifying groups

To create or modify a group, type group J on the command line to open the Object
Grouping dialog box, as shown in Figure 10-46.

Ohbject Grouping

Group Name Selectable

Group |dentification

Group Name: | |

LDiecciiption: | ‘

[TInclude Unnamed

Create Group

Selectable [ Unnamed

Change Group

[ ak, ] [ Cancel ] [ Help ]

Figure 10-46: The Object Grouping
dialog box
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Creating a new group
To create a new group, follow these steps.

1. Type a name in the Group Name text box. You can use a maximum of 31 char-
acters with no spaces. You can use the hyphen () and underscore (_) anywhere
in the name.

2. If you want, type a description of up to 448 characters. The description can
include spaces.

3. Click New. AutoCAD returns you to your drawing with the Select objects:
prompt. Select the objects you want to be in the group. Press Enter to end
object selection. AutoCAD returns you to the dialog box.

4. Click OK.
You can now use your group.

«‘\lote An object can belong to more than one group.
) 3

The Group Identification section of the Object Grouping dialog box also has a Find
Name button. Use this to find the name of the group to which an object belongs.
AutoCAD lets you select an object and then lists the group’s name or names.

The Highlight button highlights a group. First choose a group from the list in the
Object Grouping dialog box. Click Highlight and AutoCAD returns to your drawing
and highlights all the objects in your group. Click Continue to return to the dialog
box. Use this when you are not sure which group you want to work with.

Changing a group

The Change Group section of the Object Grouping dialog box gives you a great deal
of flexibility in managing groups. To change a group, click any existing group in the
Group Name list at the top of the dialog box. The buttons in the Change Group sec-
tion all become active. You can do the following:

4+ Remove: AutoCAD switches to the drawing area with the Select objects
to remove from group... prompt. Select objects to remove and press
Enter to end object removal. AutoCAD returns you to the dialog box. Click OK.

4 Add: AutoCAD switches to the drawing area with the Select objects to
add to group... prompt. Select objects to add and press Enter to end
object selection. AutoCAD returns you to the dialog box. Click OK.

4+ Rename: Choose the group you want to rename. Change the name in the
Group Name text box. Click Rename. The name changes in the Group Name
list at the top of the dialog box. Click OK.
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4 Re-Order: Each group in the object has a number, starting from zero. In rare

cases, the order may be important to you— for example, if you are running a
program that processes the members of a group. Choose the group you want
to reorder. Click Re-Order. AutoCAD opens the Order Group dialog box. If you
simply want to reverse the order of all the objects, click Reverse Order.
Otherwise, click Highlight. AutoCAD opens a small Object Grouping message
box with Next and Previous buttons. At the bottom-right corner, the box dis-
plays Object: 0, and one of the objects in the group is highlighted. Click
Next to move from object to object. If you are going to reorder the objects,
you probably need to write down the number of each object. Click OK to
return to the Order Group dialog box. Complete the following text boxes:

e Remove from position: This text box is the position number of the
object you want to move.

* Replace at position: This text box is the new position number you want
for the object.

e Number of objects: This text box is the object number or range of
numbers you want to reorder.

4 Description: Updates a description for the group. Type a new description in

the Group Identification section of the dialog box. Then click Description.

4+ Explode: Removes the group entirely. All the objects remain in your drawing,

but they are no longer grouped.

4+ Selectable: Toggles the selectability of the group. If a group is selectable,

then selecting one object of the group selects the entire group. If a group is
not selectable, then selecting one object of the group does not select the
entire group. This option lets you temporarily work with one object in the
group without having to explode the group.

When you choose Highlight from the Order Group dialog box, the Object Grouping
message box opens in the middle of the screen, covering your objects. Drag it to
one corner of the screen so that you can see which objects are being highlighted.

Using groups

Using a group is very simple. If a group is selectable, just pick any object in the
group to select all the objects in a group. You can then edit the objects in the group
as a whole. If you need to temporarily edit one object in a group, change the group’s
selectable status to No, as described in the previous section. Return the selectable
status to Yes to work with the entire group again.

You can change the selectable status of all groups in your drawing by choosing
Tools => Options and clicking the Selection tab. Deselect Object Grouping in the
Selection Modes section to disable object grouping entirely.
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The drawing used in the following Step-by-Step exercise on using groups, ab10-k.
dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Using Groups
1. Open ab10-k.dwg from your CD-ROM.

2. Save the file as ab10-14.dwg in your AutoCAD Bible folder. This is a wiring
diagram, as shown in Figure 10-47. Set ORTHO and OSNAP on. Set an endpoint
running object snap.

3. Type group . In the Group Name box of the Object Grouping dialog box, type
switch. Make sure that the Selectable box is checked. Choose New.

4. At the SeTect objects: prompt, use a window to select the AIR DAMPER
switch, picking at @ and @ in Figure 10-47. Press Enter to end object selection.
AutoCAD returns you to the Object Grouping dialog box. Click OK.

5. Choose COPY from the Modify toolbar. At the Select objects: prompt,
pick anywhere on the switch. The command line informs you of the number
of objects selected and that 1 group has been selected. End object selection
by pressing Enter. (Grouping must be on in order to select the group.)

o TR ARG
o o
o

ELECTRONIC

WIRING DLAGRAM

Figure 10-47: A wiring diagram

6. At the Specify base point or displacement, or [Multiple]: prompt,
right-click and choose Multiple. At the Specify base point: prompt, use
the Endpoint object snap to pick @ (at the left quadrant of the small circle).
At the Specify second point of displacement or <use first point
as displacement>: prompt, choose @, and then @. Press Enter.

7. Save your drawing.
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Summary

This chapter covered all the more advanced editing commands. You read about:

4+ Mirroring objects

4 Creating rectangular and polar arrays
4 Creating an offset of an object

4+ Aligning objects

4+ Trimming and extending objects

4 Stretching objects

4 Lengthening (and shortening) objects
4+ Breaking objects

4+ Creating chamfered corners and fillets for square, beveled, and rounded
corners

4 Using grips to stretch, move, mirror, rotate, and scale objects
4 Double-clicking objects to edit them

4+ Using the Properties palette, to see the properties of objects and to edit
objects

4 Creating filtered sets of selected objects with the Quick Select feature and
the FILTER command

4+ Creating named groups of objects
In the next chapter, I cover layers, colors, linetypes, and lineweights.

¢+ o+ 4






Organizing
Drawings with
Layers, Colors,
Linetypes, and
Lineweights

Until now, you have drawn everything in black or white.
Drawing everything in one color is not a very good way
to draw —besides, it’s boring! If everything is the same color,
it is hard to distinguish the various elements of a drawing. If
you've followed the exercises throughout this book, you have
opened some drawings from the CD-ROM that used various
colors and linetypes (such as dashed lines). For example, in
some of the architectural drawings, you may have noticed
that the walls are a different color than the fixtures (refrigera-
tor, sink, and so on) in the kitchen. When you start to create
text and dimensions, covered in Chapters 13, 14, and 15, you
will almost always use a color that stands out from the main
model you are drawing. You can also create objects with vary-
ing widths, called lineweights. This use of color, linetype, and
lineweight helps to organize your drawings, making them eas-
ier to understand.

In AutoCAD, black and white are the same color. If you use the
default background of black, the default color is white. If you
change the background to white, the same objects appear as
black.

Most often, you assign color, linetype, and lineweight to a
layer. A layer is simply an organizational tool that lets you
organize the display of objects in your drawing. Every object
must have a layer, and every layer must have a color, a line-
type, and a lineweight. You define layers that meet your
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drawing needs. Layers, colors, linetypes, and lineweights are called object proper-
ties. You can easily change any object’s properties. This chapter explains how to cre-
ate and change these object properties to organize your drawing.

Working with Layers

The best way to organize your drawing into colors, linetypes, and lineweights is to
use layers. Layers offer powerful features that enable you to distinguish all the vari-
ous elements of your drawing. In an architectural drawing, for example, common
layers are walls, doors, windows, plumbing, electrical, fixtures, structural elements,
notes (text), dimensions, ceiling, insulation, posts, title block, and so on.
Mechanical drawings might use center, hidden, hatch, object, and title block layers.
Each discipline has its own conventions, and you might have specific conventions
where you work.

Creating layers is an important part of setting up a drawing, in addition to the setup
features covered in Chapter 5. Layers should be created and saved in your tem-
plates so that they are available to you when you start to draw.

Layers give you many ways to organize your drawing:

4 You can assign different colors, linetypes, and lineweights to layers.

4 You can assign the various colors to different pens in a pen plotter, resulting
in a drawing with varying colors or line widths.

4 You can control the visibility of layers. Making a layer invisible lets you focus
on just the objects that you need to draw or edit.

4 You can control which objects are plotted.

4 You can lock a layer so that objects on that layer cannot be edited.

@j You can also assign a plot style to a layer. A plot style is a group of settings that
ererence

affects how your drawing is plotted. Chapter 17 covers plot styles.

Understanding layers

Besides having a color, linetype, and lineweight, every layer must have a name. All
drawings come with a default layer, called layer 0 (zero). Its color is Black/white, its
linetype is Continuous, and its lineweight is Default. (The lineweight for Default is
0.010 inch or 0.25 mm.) All the exercises in this book up to this point have used
layer 0. To create a new layer, you must give it a name, a color, a linetype, and a
lineweight. You can then start drawing on that layer.

Layers also have four states. These states control visibility, regeneration, editabil-
ity, and plottability of layers:
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4+ On/Off: On layers (the default) are visible. Off layers are invisible and are

regenerated with the drawing.

4 Thawed/Frozen: Thawed layers (the default) are visible. Frozen layers are
invisible and are not regenerated with the drawing. However, when you thaw a
frozen layer, it requires a regeneration. If you have floating viewports (covered
in Chapter 17), you can also freeze a layer just in the current viewport, or only

for new viewports that you create.

4 Unlocked/Locked: Unlocked layers (the default) are visible and editable.

Locked layers are visible but cannot be edited.

4+ Plottable/Not Plottable: Plottable layers are plotted. Not plottable layers are
not plotted. This setting affects only layers that are on or thawed because off

and frozen layers are not plotted anyway.

Creating new layers

-... To create a new layer, choose Layer Properties Manager from the Layers tool-
= bar. AutoCAD opens the Layer Properties Manager, as shown in Figure 11-1.

This dialog box lists all current layers and their properties. You can also create new

layers and modify current ones.

El Layer Properties Manager (3[%]
Mamed layer filters [ m ] [ e ]
o & Elele
Shosm ol lapers = E] [T Irwert filker.
[ &4pply to layers toolbar [ Current ] [ Hide details ]
Current Layer: OBJ [ Sawe state ] [ State tanager. ]
MName On| Freez.. | L..| Color Linetype Lineweight Plat Style Plot
0 & (@] 5 white CONTIMNUOUS Default &
AME_FRZ " O T white CONTIMNUOUS Default &
CEN i\ 9 1 mBed CENTERZ Default e
Defpoints . [ ] 5 i CONTIMUOUS Default
DIMS @ (@] 75 g FRed CONTIMNUOUS Default &
HID & (@] T white HIDDEN Default &
MOTES & (@] 75 Green CONTIMNUOUS Default &
(=] & (@] 75 mBlue CONTIMNUOUS Default &
TITLE & (@] 75 [ Cpan CONTIMNUOUS Default &
WELD @ @] 75 mMagenta CONTINUOUS  —— Default &
Detail:
Mame: CEM ] 0 for display
Color: B Fed .v. [ Lack for editing
— [ Do not plat
Lineweight: Defaul .v. [ Freeze in all viewparts
Linetype: ——-— CENTERZ w
10 Total lapers 10 Lapers displayed
[ ak, ] [ Cancel ] [ Help l

Figure 11-1: The Layer Properties Manager after clicking Show

Details to open the Details section of the dialog box

Table 11-1 lists the columns in the dialog box and how to use them.
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Table 11-1

Columns in the Layer Properties Manager Dialog Box

Column Name

How to Change the Setting

Name

On

Freeze in All VP
Lock

Color

Linetype
Lineweight

Plot Style

Plot

Current VP Freeze

New VP Freeze

Click and type the name of the layer.

Click to change the on/off state of a layer.

Click to change the freeze/thaw state of a layer in all viewports.
Click to change the lock/unlock state of a layer.

Click to change the color of a layer.

Click to change the linetype of a layer.

Click to choose a new lineweight.

Click to select a new plot style (Chapter 17 covers plot styles).
Click to change the plottable/not plottable state of a layer.

Click to change the freeze/thaw state in active floating viewports
(only displayed if you have floating viewports and a plot layout is
active).

Click to change the freeze/thaw state in new floating viewports (only
displayed if you have floating viewports and a plot layout is active).

To adjust the display in the Layer Properties Manager, you can do the following:

4 Change the width of the columns in the Layer Properties Manager dialog box
by placing the cursor over the line dividing two column headings and dragging.

4 Double-click the line dividing two columns to minimize the column width.

4 Click any column head to sort the layers by that column. Click again to sort in
the opposite order.

4 Resize the entire dialog box by dragging on any side.

Naming the layer

Click New. A new layer appears, named Layer]l, as shown in Figure 11-2. The name
is highlighted so that you can immediately type in a new name for the layer. Press
Enter after you type the name. Notice that AutoCAD has assigned the default color,
linetype, and lineweight. If you want the color to be black/white, the linetype to be
continuous, and the lineweight to be the default weight, you are finished.

Layer names can be up to 255 characters long and may include spaces. Layer
names retain the uppercase/lowercase characters that you type. Layer names may
not include the following symbols: <> /\";? * | |~
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0 Y O 5w white CONTINUOUS Default  Mormal N
Layerl| ' ® 7 White COMTINUOUS  —— Defaut  Nomal )

Figure 11-2: The new layer appears as Layerl and is
highlighted so that you can enter the new layer name.
AutoCAD assigns the default color, linetype, and lineweight.

Tip To create several new layers at once, click New and type all the layer names you

~, want, separated by commas. If you want a new layer to have the same color
" and/or linetype as an existing layer — which is very common — choose that existing
layer and click New. The new layer will inherit the properties of the selected layer.
You can then make any changes you want.

Assigning a color

To change the default color, move the cursor to the color box in the same row as
the new layer. Click to open the Select Color dialog box, as shown in Figure 11-3
with the Index Color tab displayed.

E] Select Color &

Index Calor True Color Coloi Books
AutoCaD Calar Index [AC1)

Index color, 7 Red, Green, Blue: 0oo

[ [
EEEN
Color:
whiite:
[ ak, H Cancel H Help I

Figure 11-3: The Select Color dialog
box with the Index Color tab displayed

Click the color that you want. At the bottom of the dialog box, the color’s name or
number appears along with a sample of the color. Click OK to close the dialog box
and return to the Layer Properties Manager dialog box.

Tip If the Details section of the Layer Properties Manager is open, you can click the
_»_ Color drop-down list and choose one of the standard colors from the list. The
4  Details section is blank when no layer is selected.
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Note that the Index Color tab offers you a choice of standard colors, gray shades,
and a fuller palette of colors. The standard colors are the original colors AutoCAD
offered, and they are the ones most often used, even today. Their advantage is that
each color is easily distinguishable from the others. AutoCAD gives these colors
both a name and a number, whereas other colors have only a number. The standard
colors are yellow, cyan (turquoise), red, green, blue, white, and magenta.

/\lote AutoCAD gives you a choice of drawing on a black or a white screen. The default
~—  screen is black and the default color is white. When you work on a white screen,
the default color appears black, but it is still called white. Therefore, if you choose
the black color tile in the Select Color dialog box, AutoCAD lists the color as white.
To change the screen color, choose Tools > Options = Display => Colors.

For more color choices, click the True Color tab, shown in Figure 11-4.

El Select Color &
Index Color Tiue Colar Calor Books

Hue: Saturation: Luminance:  Calar model:

mee s e

True Color Stored
as RGB
Red: 46
Green: 203
Blue: 195

Calor:
45,209,195

[ kK H Cancel ][ Help ]

Figure 11-4: The True Color tab of the
Select Color dialog box offers a more
precise way to define color.

New '\ The True Color tab is a new feature of AutoCAD 2004. You can define colors more
feati precisely for presentation-quality printouts.

To define a color, first choose the color model from the Color Model drop-down list.
You have two choices:

4+ HSL (Hue, Saturation, Luminance): Hue is the actual wavelength of light that
defines the color. Saturation is the purity or intensity of the color. Luminance
is the brightness of the color.

4 RGB (Red, Green, Blue): Defines a color according the intensity of red, green,
and blue in the color.
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If you choose the HSL color model, specify the color as follows:
1. Specify the hue by dragging the crosshairs horizontally across the colors or
type a value from 0 to 360° in the Hue text box.

2. Specify the saturation by dragging the crosshairs vertically over the colors or
type a value from 0 to 100% in the Saturation text box.

3. Specify the luminance by dragging the bar on the color slider or type a value
from 0 to 100% in the Luminance text box.

ﬁlote When you define a color using the HSL color model, you also see the RGB values
"~ displayed in the Select Color dialog box.

If you choose the RGB color model, specify the red color by dragging the color bar
or type a value from 1 to 255 in the Red text box. Do the same for the green and
blue color values.

You can also choose a color using the Color Books tab, shown in Figure 11-5.

yevtv \ The Color Books tab is a new feature of AutoCAD 2004.
eature

[E] Select Color [B]=]

Index Color TigColor | Color Books

Color baok,
| PANTONEIR) a4 -cation [~]

RGE Equivalent:
Red: 0O
Green: 138
Blue: 183

PANTOME 13-4417 TC

PANTOME 144318 TC

PANTOME 15-4427 TC

-PANTDNE 17-4433 TCH

PANTOME 17-4247 TC

-F‘ANTDNE 18-4440 TC
-F'ANTDNE 18-4252 TC

Colar:
PANTOME 17-4433TC

.Y
=
=
=
—
~

[ ak, H Cancel ][ Help ]

Figure 11-5: The Color Books tab of
the Select Color dialog box

The Color Books tab of the Select Color dialog box displays colors in color books.
Color books are files that define colors. AutoCAD includes several Pantone color
books. Pantone is a commonly used system of matching colors often used for print-
ing on both paper and fabric.



278

Part Il + Drawing in Two Dimensions

To use a color from a color book, follow these steps:

1. On the Color Books tab of the Select Color dialog box, choose a color book
from the Color Book drop-down list.

2. Drag the color slider or use the up and down arrows to choose a “page” of the
color book. On the left, you see the colors for that page. A page can hold up to
10 colors.

3. Choose one of the colors on the left side of the dialog box.
4. Click OK.

Assigning a linetype

The default linetype is a continuous line. AutoCAD also provides many other line-
types, which are repeating patterns of dashes and/or dots and spaces. Linetypes
can also include text and shapes. Linetypes are covered more fully later in this
chapter.

To change the default linetype, move the cursor to the linetype in the new layer’s
row. Click to open the Select Linetype dialog box, as shown in Figure 11-6.

If the linetype that you want appears on the list, click the linetype and choose OK to
close the dialog box. If the linetype does not appear, you need to load the linetype.
Click Load to open the Load or Reload Linetypes dialog box, shown in Figure 11-7.

Installing Color Books

You can install additional color books. Color book files must have an . acb file extension. In
addition to Pantone color books, you may be able to find DIC or RAL color specification
files.

The default location for color books is in the Support\Color subfolder of your AutoCAD
2004 program folder. If you copy color book files there, you can find them on the Color
Books tab of the Select Color dialog box. Another default location is in the Documents and
Settings\username\Application Data\AutoCAD 2004\R16.0\enu\Support\Color
folder. You use this folder for color books that you install. To use color books from another
location, follow these steps:

1. Choose Tools => Options to open the Options dialog box.

2. Choose the Files tab.

3. Double-click the Color Book Locations item.

4. Click Add and then click Browse. Locate the color book file and click OK.

If you have the Select Color dialog box open while you copy a new color book file to a loca-
tion, close the dialog box and re-open it to access the new colors.
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E] Select Linetype B[]
Loaded linetypes
Linetype Appearance Description
CONTIMUOUS —— Solidline
<] Im (]
I ak, ] [ Cancel ] [ Load. I [ Help ]

Figure 11-6: The Select Linetype dialog box
as it appears before you have loaded any
linetypes

Linetypes are stored in text files with the file name extension . 11in. AutoCAD’s stan-
dard linetypes are stored in acad. 11in. You can create your own linetypes and store
them in acad.11in or another file with the extension . 11in. Click File at the top of the
dialog box if you want to load a linetype from a file other than acad. 1in. Choose the
linetype that you want to load and click Open.

El Load or Reload Linetypes 2] %]
Auvalable Linetypes
Linetppe Description (i
ACAD_IS0024100 SO0dash__ =
ACAD_1S003w100 150 dashspace _ _ _ _ _ __ |
ACAD_|S004w100 150 long-dash dot _
ACAD_|S005w100 150 long-dazh double-dot .
ACAD_|S00EwW100 150 long-dash triple-dot .
ACAD_IS007100 150dat. ...
ACAD_|S008w100 150 lang-dazh short-dash _ _ |
ACAD_1S005100 150 long-dash double-short-dash v
< | I B3
[ OK I I Cancel ] [ Help I

Figure 11-7: The Load or Reload Linetypes
dialog box

¢ Cross- See Chapter 31 for a full discussion of creating your own linetypes.
Reference

To choose a range of linetypes to load, click the first linetype in the range, press
Shift, and click the last linetype in the range. To choose more than one noncontigu-
ous linetype, press Ctrl for each additional linetype you choose. To select all or
clear all of the linetypes, right-click in the dialog box and choose the desired option
from the shortcut menu.
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As soon as you load a linetype and click OK, you return to the Select Linetype dia-
log box. The loaded linetype now appears on the list. Choose it and click OK. You
are now back in the Layer Properties Manager dialog box.

In the Details section of the Layer Properties Manager you can click the Linetype
drop-down list and choose from loaded linetypes.

Assigning a lineweight

A lineweight assigns a width to a line. When you give a layer a lineweight, every
object on that layer has the same lineweight. A lineweight can help to distinguish
various elements of your drawing, both on-screen and on paper. For example, you
could use a thicker lineweight to indicate planned construction changes, for dimen-
sion lines, or even to represent the true width of an object. The LWT button on the
status bar turns on and off the display of lineweights. By default, LWT is off.
Lineweights are covered more fully later in this chapter.

To set a lineweight for a layer, click the Lineweight column of that layer to open the
Lineweight dialog box, shown in Figure 11-8. Choose a lineweight and click OK.

(E] Lineweight g9 Figure 11-8: When you click the Lineweight
column of the Layer Properties Manager, the
e Lineweight dialog box opens so that you can

0.00 mm choose a lineweight.
0.05 mm
0.09 mm
0.13 mm
0.15 mm
0.18 mm
0.20 mm
0.25 mm
0.30 mm
0.35 mm [v]

Lineweights:

*

Original:  Default
M e Default

QK l [ Canicel ] [ Help

Lineweights have the following features:

4 The default lineweight value for layers and objects is called DEFAULT, which
has a value of 0.010 inch or 0.25 mm.

4 On the Model tab, where you draw, lineweights are displayed in relation to
pixels, the unit of measurement for computer screens. A lineweight of 0 is dis-
played with a width of one pixel. Wider lineweights are calculated proportion-
ally to the actual width of the lineweight. The lineweight display on the Model
tab does not change as you zoom in or out.
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4 On Layout tabs (covered in Chapter 17), AutoCAD displays lineweights in real-
world units as they will be plotted. Lineweights act like other objects in your
drawing and they look bigger or smaller as you zoom in and out.

4+ By default, lineweights are measured in millimeters. You can format
lineweights by choosing Format > Lineweight. AutoCAD opens the Lineweight
Settings dialog box, shown in Figure 11-9. The Lineweights section lists avail-
able lineweights. Choose a default lineweight from the Default drop-down list.
The default is 0.01 inch or 0.25 mm. The Adjust Display Scale slider deter-
mines how lineweights are displayed on the Model tab. Adjust this setting if
you use several closely related lineweights but can’t distinguish them on your
screen. The Display Lineweight check box turns the display of lineweights on
and off. (See the next bullet for an easier way to do this.)

4 You can turn the display of lineweights on and off —just click the LWT button
on the status bar.

If you don’t want to use lineweights, you can just ignore them and let AutoCAD dis-
play every object using the default lineweight.

rE] Lineweight Settings &

Lineweights Units for Listing

EyLayer ~ (=) Millimeters [rmm] ) Inches (in)

ByBlock 3

Default [ Display Lineweight
—— 0.00 mm
—— 0.09mm Adjust Display Scale
— 013 mm [v

Min J [GETS
Current Lineweight: Byl ayer
[ ak, 1 [ Cancel ] [ Help ]

Figure 11-9: The Lineweight Settings dialog
box lets you format how lineweights are
measured and displayed.

After you have set your new layer’s color, linetype, and lineweight, you are ready to
use the layer. Click OK to close the Layer Properties Manager.

Onth'e“‘\ The drawing used in the following Step-by-Step exercise on creating layers,
, CDW | abll-a.dwg,isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.
//j

Step-by-Step: Creating a New Layer
1. Open abl1-a.dwg from the CD-ROM.
2. Save the file as ab11-01.dwg in your AutoCAD BibTe folder.

3. ... Choose Layer Properties Manager from the Layers toolbar to open the
=¥ Layer Properties Manager.
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4. Choose New. A new layer named Layer1 appears, highlighted. Type Walls
as the name for the new layer.

5. Click the color square in the Color column to open the Select Color dialog
box. Choose the blue square from the Standard Colors and click OK.

6. Choose New again to create another new layer. Type Hidden ..

7. If the Details section of the dialog box is not displayed, click the Show details
button. Click the Color drop-down box in the Details section and choose
Select Color.

8. In the Select Color dialog box, click the True Color tab. From the Color Model
drop-down list, choose RGB. In the Color text box, type 141, 218, 189. Press
Tab. You should see a teal (blue-green) color. Click OK.

9. In the main layer listing, click Continuous in the same row as the Hidden layer
to open the Select Linetype dialog box. Click Load to open the Load or Reload
Linetypes dialog box. Scroll down until you see the HIDDEN linetype. Choose
it and click OK. In the Select Linetype dialog box, choose HIDDEN and click
OK. Click OK to close the Layer Properties Manager.

10. Click the Layer Control drop-down box on the Layers toolbar to see the two
layers you just created listed there. Click again to close the box.

11. Save your drawing.

Using layers

To use a layer you have just created, click Current in the Layer Properties Manager.
Then click OK to return to your drawing. Objects you create now are drawn on that
layer and display with their color, linetype, and lineweight. (The lineweight only
shows if the LWT button on the status bar is on.)

AutoCAD puts all objects that you draw on the current layer. After you have the lay-
ers you need, you need to switch from layer to layer as you draw. You can continue
to choose Layers on the Layer Properties Manager dialog box, click the name of a
layer, click Current, and then click OK. But there is an easier way — the Layer
Control drop-down list on the Layers toolbar, as shown in Figure 11-10.

el I& [v] Figure 11-10: The Layer Control
Y Q% Bl drop-down list

' 0% "M Hidden

o O "5 M Motes

¥ (O "M Objects

The Layer Control drop-down list has two display modes:

4+ If no object is selected, it displays the current layer.

4 If one or more objects are selected, it displays the layer of the selected object(s).
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To check the current layer, make sure no object is selected. If necessary, press Esc
to deselect any objects.

Jf‘\lote When objects on varying layers are selected, the Layer Control list goes blank, indi-
~  cating that more than one layer is included in the selection.

To open the Layer Control drop-down list, click its arrow. You see a list of all your
layers, including their states and colors. Pass the mouse over the items, and a tooltip
tells you what they mean. The Layer Control drop-down list has three functions:

4+ It switches the current layer so that you can draw on a new layer.
4 It changes the following states of any specific layer on the list:

e On/Off

¢ Frozen/Thawed

e Frozen in Current Viewport/Thawed in Current Viewport

e Locked/Unlocked

4 It changes the layer of a selected object.

Take the time to learn how to use this drop-down list; it can save you a great deal
of time. To change other states of a layer (such as plottable/not plottable), click
Layers Properties Manager on the Layers toolbar to open the Layer Properties
Manager.

Switching the current layer

To switch the current layer, click the Layer Control drop-down list arrow and click
the name of the layer that you want to be current. Be careful to click only the
name — otherwise, you may change the layer’s state. Remember that this only
works if no object is currently selected —so you may need to press Esc first to des-
elect all objects.

After you click a new layer name, the drop-down list automatically closes.

+£ The Layer Previous button on the Layers toolbar switches you to the last layer
=% you used. Click it another time and you are in the layer before that. Use Layer
Previous as a shortcut to finding and choosing the last layer you used on the Layer
Control drop-down list.

Changing a layer’s state

After you create a layer, you can manage that layer — and all the objects on that
layer — by changing its states. You can change some layer states through the Layer
Control drop-down list; others must be changed in the Layer Properties Manager.
The layer states each have different properties and uses:
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- Cross-
Reference

4 On/Off: Turn layers off when objects on those layers interfere with the draw-
ing process. For example, if you want to edit only objects on your Object
layer, but objects exist on other layers nearby, you can turn off the other lay-
ers and easily select the objects on the Object layer with a window. Then turn
the other layers back on. The on/off state is available on the Layer Control
drop-down list.

4+ Thawed/Frozen: You can freeze layers for reasons similar to those that lead
you to turn off layers. In general, freeze layers when you want to work without
those layers for a longer period of time. The thawed/frozen state is available
on the Layer Control drop-down list.

4+ Thawed/Frozen in Current Viewport: You can freeze or thaw layers in some
floating viewports but not in others. For example, you may want to display
dimensions in one viewport but not in others; to do so freeze your dimensions
layer in all the viewports except one. This state is available on the Layer
Control drop-down list if you are working on a layout. You can also check the
Freeze in Current Viewport checkbox in the Details section of the Layer
Properties Manager.

4 Thawed/Frozen in All Viewports: You can freeze or thaw layers in all view-
ports if you want to work without seeing those layers at all. This state is avail-
able in the Freeze in All VP column of the Layer Properties Manager. It also
affects viewports on the Model tab. You can also check the Freeze in All
Viewports check box in the Details section of the Layer Properties Manager.

4+ Thawed/Frozen in New Viewports: You can also freeze or thaw layers in
future viewports that you create. For example, after you display dimensions
or text in one viewport, you may want to make sure they will not appear in
any new viewports that you create. This state is available in the New VP
Freeze column of the Layer Properties Manager or by checking the Freeze in
New Viewports check box in the Details section of the Layer Properties
Manager, if you are working on a layout.

See Chapter 17 for an explanation of floating viewports and layouts.

4 Unlocked/Locked: Lock a layer when you want to ensure that objects on that
layer are not changed. You can still use objects on locked layers for
reference — for example, you can use their object snaps. The unlocked/locked
state is available on the Layer Control drop-down list.

4 Plottable/Not Plottable: Make a layer not plottable when you want to create
reference text or revision marks on your drawing but don’t want to plot them.
Another example: If you have a drawing that contains both actual and planned
structures, you could plot showing only the actual structures. Being able to
change a layer’s plottable state makes it possible for you to create variations
on your drawing, perhaps for different users, such as electricians, plumbers,
and roofers. The plottable/not plottable state is available in the Plot column of
the Layer Properties Manager or click the Do Not Plot check box in the Details
section.
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Tip Both the off and frozen states make layers invisible. AutoCAD introduced the
frozen and thawed layer states to reduce regeneration time —and that’s the main
difference between On/Off and Thawed/Frozen layer visibility options. However,
today's computers are faster, and AutoCAD has since introduced several ways to
avoid regeneration while panning and zooming—such as Aerial View, Zoom
Dynamic, and real-time zooming and panning. Also, remember that thawing a
layer causes a regeneration, whereas turning a layer back on only causes a redraw.
As a result, you might actually save a regeneration by using On/Off instead of
Thawed/Frozen.

L\

Click any of the state icons to toggle a layer’s state. For example, if you want to
freeze a layer, click its sun and it switches to a snowflake. Table 11-2 shows the
icons for each state.

Table 11-2
Layer State Icons
State Icon State Icon
On ) off

Frozen (in all viewports)

Thawed (in all viewports) ':J E,:
Thawed (in current viewport) Frozen (in current viewport) %
o
Thawed (in new viewports) Frozen (in new viewports)
L ]
Unlocked fl':’ Locked @
Plottable % Not plottable %

When you change a layer’s state, the drop-down list stays open so that you can
change the state of more than one layer at a time. Click the top of the list to close it.

Caution Be careful when editing a drawing with frozen or off layers—it's easy to forget
about them. For example, you could move a whole section of your drawing and
leave the frozen objects in that section behind.
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Saving layer states

Often you work with sets of layer states. For example, you may lock certain layers
during part of the editing process so that you don’t change objects on those layers
inadvertently. You may also set some layers as not plottable just before final plot-
ting but want them plotted for a draft plot. You may also want to temporarily
change the properties of certain layers — color, linetype, lineweight, and plot
style—and then change them back.

You could spend a lot of time adjusting all these layer states and properties over
and over. Instead, you can save and restore sets of layer states —the properties
and states of all the layers in a drawing. The save layer states feature automates the
process of restoring layer states and properties by saving the set of all layer states
and properties. After you save this set, you can restore it at any time. AutoCAD uses
the term layer states to include the set of all layer states as well as their properties.

You can also export layer state settings to a file. You can then use the layer state
settings in another drawing with the same or similar layers.

To save a layer state, follow these steps:

1. Set all of the layer states and properties the way you want them. Usually, you
have already done this and should save the state before making changes that
you plan to reverse later on.

2. Choose Layer Properties Manager from the Layers toolbar to open the Layer
Properties Manager.

3. Click Save State to open the Save Layer States dialog box, shown in Figure 11-11.

El Save Layer States (B3] %]
Mew layer state name:
Layer states Layer properties
[10on /0t [ Calar
[1Frozen ¢ Thawed [ Linetype
[ Locked # Unlocked [ Lineweight
] Plot # Mo Plot [ Plot style
MNew VP Frozen / Thawed
Figure 11-11: The Save Layer States

dialog box

4. Type a name for your layer state in the New layer state name text box.

5. Choose which of the layer states and properties you want to save.



Chapter 11 + Organizing Drawings with Layers, Colors, Linetypes, and Lineweights 287

Caution States and properties that you do not save are not affected later when you restore
the layer state. For example, if you save only the on/off state and then change
both a layer’s on/off state and its color, when you restore the layer state, only the
on/off state is returned to its original setting; the layer retains its new color.

6. Click OK.

To restore a layer state, open the Layer Properties Manager and click State Manager
to open the Layer States Manager, shown in Figure 11-12. Choose the layer state
that you want to restore and click Restore. Then click OK to close the Layer
Properties Manager.

=
[

El Layer States Manager

Layer states

dim of Restare
lock2
Edit
Rename
Delete
Irnport...

Expaort...

Cloze

fi iR

Help

Figure 11-12: The Layer States Manager

The Layer States Manager enables you to manage layer states in the following ways:

4+ Restore: Select the layer state you want to restore and click Restore.

4+ Edit: Opens the Edit Layer State dialog box. You can change which states and
properties are saved.

4+ Rename: Renames the layer state.
4 Delete: Deletes the layer state.

4+ Import: Imports a layer state that has been previously exported as a . 1as file.
Importing a layer state gives you access to layer states that others have
saved.

4 Export: Saves the settings of a layer state in a . 1as file. Exporting a layer
state gives others access to your layer state settings.

After you finish using the Layer States Manager, click Close to close the dialog box.

The Express Tools contains many layer-related tools that you can add to your
arsenal. Many of these layer tools can save you considerable time over the course
of creating a drawing. Table 11-3 explains them briefly. See Appendix A on the
CD-ROM for information on installing Express Tools.
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Table 11-3
Express Tools Layer Commands

Layer Name Menu Description

LAYWALK Express = Layers = Layer Walk A full-featured command that helps you
see which objects are on which layers.
You can list the number of objects on
each layer, count the total number of
layers, save layer states, and purge
unused layers, using the dialog box and
the shortcut menu.

LAYMCH Express > Layers > Layer Match ~ Changes the layer of selected objects to
match that of a selected object.

LAYCUR Express > Layers > Changes the selected object's layer to

Change to Current Layer the current layer.
COPYTOLAYER  Expresst> Layers > Copies objects while changing the copy
Copy Objects to New Layer to the layer you specify.

LAYISO Express=> Layers > Layer Isolate  Turns off all layers except the layer of an
object you select, so that you can isolate
a specific layer.

LAYVPI Isolate Layer to Current Viewport Freezes all layers except the layer of an
object you select in all viewports except
the current one, isolating the selected
layer in the current viewport.

LAYOFF Express = Layers > Layer Off Turns the layer of the selected
object(s) off.

LAYON Express > Layers > Turns all layers on.

Turn All Layers On

LAYFRZ Expressc> Layers > Layer Freeze  Freezes the layer of the selected
object(s).

LAYTHW Express = Layers > Thaws all layers.

Thaw All Layers

LAYLCK Express = Layers = Layer Lock Locks the layer of the selected object(s)

LAYULK Express > Layers > Layer Unlock  Unlocks all layers

LAYMRG Express=> Layers=> Layer Merge  Changes the layer of all objects on the
first layer selected to the second layer
selected. The first layer is purged.

LAYDEL Expresst> Layers> Layer Delete  Deletes objects from the specified layer

and purges that layer.
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Changing an existing object’s layer

Sometimes you need to change the layer of an object or objects you have already
drawn. You can do this easily by selecting one or more objects and clicking the
layer name that you want for the object in the Layer Control drop-down list. The list
automatically closes.

You can also change an object’s layer in the Properties palette. Choose Properties
on the Standard toolbar. Use the Properties palette if you want to change more than
one property of an object at one time.

Caution It's easy to inadvertently change an object's layer. Make sure objects are not

On the )

CD-

k

selected (press Esc) if you are about to use the Layer Control drop-down box just
to change the current layer.

Making an object’s layer current
.. If you are adding an object, you usually want to draw on the same layer as an
eXlStll’lg object. You could select the object to see what layer it’s on, press Esc
to deselect the object, and then choose that layer from the Layer Control drop-
down list to make it current. However, this process is easier with the Make Object’s
Layer Current button on the Layers toolbar. Simply select an object and click the
button. AutoCAD makes that object’s layer current.

The drawing used in the following Step-by-Step exercise on working with layers,
abll-b.dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Working with Layers
1. Open ab11-b.dwg from the CD-ROM.

2. Save the file as ab11-02.dwg in your AutoCAD BibTe folder. This drawing is
shown in Figure 11-13. The current layer is 0. Make sure OSNAP is on. Set run-
ning object snaps for endpoint and quadrant.

3. Click the Layer Control drop-down list and click Pipes to change the current
layer to Pipes.

4. Start the LINE command. Draw a line from @ to @ in Figure 11-13, using the
Quadrant running object snap.

5. Click the Layer Control drop-down list and click Object to change the current
layer to Object.

6. Click the Layer Control drop-down list and click the On/Off icon (the light
bulb) of the Dim layer. Click again at the top of the list to close it.

289
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Figure 11-13: This gas extraction well
plan drawing needs to be completed.
Thanks to the Army Corps of Engineers for this drawing.

. Start the CIRCLE command. Right-click and choose 2p to use the two point

option. Draw a circle from the endpoint of @ to @ in Figure 11-13 using the
Endpoint running object snap.

. Without changing the layer, start the CIRCLE command and again use the 2p

option. Draw a circle between the endpoints at @ and @ in Figure 11-13.

. The last circle was drawn on the wrong layer. To change its layer, select the

circle. Then click the Layer Control drop-down list and choose Pipes. Press
Esc to remove the grips and see the result. The circle is now on the Pipes
layer. Notice that the current layer is still Object in the Layer Control display.

- Pick any red object (the Pipes layer). Choose Make Object’s Layer

A= Current from the Layers toolbar. The Pipes layer is now the current layer.
Draw a line from the right quadrant of the circle at @ to the left quadrant of
the circle at @ and @ in Figure 11-13.

- You want to draw a line on the Object layer. Because that is the previous
=== layer you used, click Layer Previous on the Layers toolbar. The Object
layer is now the current layer. Draw a line from the endpoint at @ to the end-

point at @.

Pick any text to see what layer it is on. The Layer Control drop-down box
changes to show the Text layer. Press Esc to deselect the text. Now choose the
words GAS EXTRACTION WELL PLAN at the bottom of the drawing. Click the
Layer Control drop-down box and choose Text. Press Esc to remove the grips.

Save your drawing. It should look like Figure 11-14.
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Figure 11-14: The completed drawing
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Later in this chapter, | explain how to import layers from other drawings and trans-
late layers from one drawing to another.

Modifying layers

Sometimes you need to change the properties of a layer, such as its color or line-
type. This is a powerful tool because every object on that layer is automatically
regenerated with the new properties. Other layer housekeeping tasks are renaming
and deleting layers. You use the Layer Properties Manager for these functions.

Sorting columns

If you have many layers in a drawing, sorting can help you find the layers you need
to work on. You can sort the layer listing in a drawing by any column, by clicking
once on the column title. Click again to see the list in reverse order. (If sorting by
layer name does not appear to be working, increase the value for the MAXSORT sys-
tem variable, which determines the maximum number of symbols that AutoCAD
sorts. Type maxsort ! on the command line and enter a larger number. Press
Enter.) Long layer names display a tooltip with the entire layer name.

Filtering the layer list

Some complex drawings may have dozens of layers. This can make it difficult to
find the layer you want to change in the Layer Properties Manager. You can filter
the layer list so that you only see the layers you want. This makes it easy to change
a group of layers at once. Click the Named Layer Filters drop-down list and pick the
filter that you want.
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Tip

To display all layers except the ones specified by the filter, click Invert filter. If you
want the Layer Control listing on the Layers toolbar to be filtered in the same way,
check Apply to Layers toolbar.

If AutoCAD’s standard filters don’t meet your needs, you can create your own filter.
Click the ellipsis button to the right of the drop-down arrow to open the Named
Layer Filters dialog box, shown in Figure 11-15.

You can set criteria by name, state (on/off, thawed/frozen, thawed/frozen for cur-
rent and new floating viewports, unlocked/locked, plot/don’t plot), color,
lineweight, linetype, and plot style. You can use wildcards to specify any of the
named properties. The two most common wildcards characters are * (asterisk),
which replaces any number of characters, and ?, which replaces any single charac-
ter. Figure 11-15 shows the layer name filter set to d*. The color is also specified as
blue. Therefore, only layers whose names start with the letter d and are blue will be
listed.

After you set the criteria for your filter, type a name in the Filter name text box,
click Add, and click Close. Next, choose your named filter from the Named Layer
Filters drop-down list. AutoCAD filters the layer list. You can invert named filters
that you create and apply them to the listing on the Layers toolbar.

El Named Layer Filters @@ Figure 11-15: The Named Layer Filters
Fiter name: dialog box
Laper name: a

On/0ff:

Freeze/Thaw _

Current viewport Both v

I ——

LockUnlack:

Pt Boh  [v]

Eallm Blue

Linewsight: )

Linetype: *

Plat style: *

When you work with a large number of layers, think carefully about how you name
them. Naming layers in groups is common. For example, if you have several text
layers, you could name them Text Title, Text Notes, and Text Schedule. A systematic
layer-naming scheme makes it easy to filter the layers you need, which in turn
makes it easy to make changes to groups of layers.

L\
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Changing a layer’s color, linetype, and lineweight
... Tochange a layer’s color, choose Layer Properties Manager from the Layers

-

“=* toolbar. AutoCAD opens the Layer Properties Manager. You can change the
color in two ways:

4 Click Show Details if the lower section of the dialog box is not visible. Click
the name of the layer that you want to modify. In the Details section, click the
Color drop-down list and choose the color that you want. (If you don’t want to
choose one of the standard colors, choose Other to open the Select Color dia-
log box, choose a color, and then click OK.) After you have selected the color,
click OK to close the Layer Properties Manager dialog box.

4 Choose the color swatch of the layer that you want to modify. AutoCAD opens
the Select Color dialog box. Choose a color and click OK twice to return to
your drawing.

For more information about choosing colors, see “Assigning a color” earlier in this
chapter.

To change a layer’s linetype, follow the same procedure as for changing the color.
The only difference is that the Details section doesn’t let you load linetypes. If you
need to choose a linetype that is not on the list, click the linetype of the layer to
open the Select Linetype dialog box. There you can either choose a loaded linetype
or load a linetype if necessary.

To change a layer’s lineweight, open the Layer Properties Manager and click the
lineweight for any layer. Choose a new lineweight from the Lineweight dialog box.

Tip You can modify more than one layer at a time. In the Layer Properties Manager

~,  dialog box, right-click and choose Select All to choose all the layers. Choose Clear
A All to deselect all layers. You can choose a range of layers by clicking the first in the
range, pressing Shift, and clicking the last in the range. Finally, you can choose
individual layers by pressing Ctrl for each additional layer. Changes you make to
color, linetype, or lineweight affect all the selected layers.

L

Renaming layers

Thinking out your layer naming scheme in advance is best. Many disciplines and
organizations have layer naming standards. However, sometimes you simply need
to rename a layer.

To rename a layer, choose Layer Properties Manager from the Layers toolbar to

open the Layer Properties Manager. Click the name of the layer, and then click a
second time. A border appears, and the name is highlighted. Type the new name
and press Enter.

;‘\lote You cannot rename layer O. Layer O is the default layer and always remains the
~~  same.
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Deleting layers

To delete a layer, choose Layer Properties Manager from the Layers toolbar to
open the Layer Properties Manager. Click the name of the layer. Choose Delete and
click OK.

You cannot delete the current layer or any layer that has objects on it. (Where
~—  would those objects go?) You also cannot delete layer 0, which is the default layer.
Finally, you cannot delete layers from external references (covered in Chapter 19).

Purging layers and linetypes

Layer and linetype definitions add to the size of your drawing because they are kept
in the drawing’s database. Therefore, eliminating layers and linetypes that you are
not using is worthwhile. You can delete them, but sometimes it is hard to know
which layers contain no objects. The PURGE command lets you delete many types
of unused definitions, including layers and linetypes.

To purge layers and linetypes, choose File &> Drawing Utilities => Purge. AutoCAD dis-
plays the Purge dialog box, shown in Figure 11-16.

El Purge (2] %]

(&) View items pou can purge

O Wiew items pou cannot purge

Items not used in drawing:
= [E2 All items

@ Blocks
_ﬁ Diimension stples
2 Layers

@ tline stples

g Plat styles
B Shapes

&r Teut styles

Confirm each item to be purged

[ Purge nested items

[ Purge &l ] [ Close ] [ Help ]

Figure 11-16: The Purge dialog box

The Incremental save percentage option may prevent a purge during a drawing

~  session from removing all unreferenced layers or linetypes from the drawing. To
avoid this, you can either set incremental save to zero or save the drawing and
reopen it and then immediately use the PURGE command. To set this option,
choose Tools > Options <> Open and Save tab.
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At the top of the dialog box, you can choose to view objects that you can purge or
objects that you cannot purge. Why would you want to view objects that you can-

not purge? Sometimes it is hard to figure out why you can’t purge a certain object

and the new dialog box has a handy feature that lets you select an object and view
possible reasons why it cannot be purged.

To start purging, choose View items you can purge. A plus sign (+) next to each
type of object indicates that it contains purgeable objects. For example, Figure 11-16
indicates that you can purge layers, and shapes. Click the plus sign to display the
specific items.

To purge an individual item, select it and click Purge. Check Confirm each item
to be purged if you want to see a dialog box asking you to confirm each purge.
Click Purge All to purge all possible items. Check Purge nested items to purge
items within other named objects. Usually, these are layers, linetypes, and so on
inside blocks.

Tip You can select more than one item at a time to purge. To select an additional item,
_», press Ctrl as you click. To select a contiguous group of items, click the first item,
4  press and hold Shift, and select the last item in the group.

After you’re done purging, click Close to close the Purge dialog box.

| abll-c.dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.
Step-by-Step: Modifying Layers
1. Open ab1l1-c.dwg from the CD-ROM.

2. Save the file as ab11-03.dwg in your AutoCAD Bible folder. This drawing is
shown in Figure 11-17.

ggthéﬁl\ The drawing used in the following Step-by-Step exercise on modifying layers,

3. Choose Layer Properties Manager from the Layers toolbar to open the Layer
Properties Manager. Next to the Named layer filters drop-down arrow, click
the ellipsis button. In the Filter name text box, type M layers. In the Layer
Name box, type m* to list all layers starting with the letter m. Click Add, and
then click Close. In the Layer Properties Manager, click the drop-down list
arrow and choose M layers. The list now looks like Figure 11-18.

4. Click the top layer. Press Shift and click the next-to-last layer. All the layers
except for Mydims are selected. In the Details section (click Show Details if
this section is not visible), click the Linetype drop-down list arrow and choose
Dashed. Notice that all the selected layers now have a dashed linetype. Click
OK to return to the drawing. AutoCAD regenerates the drawing with the new
dashed linetypes.

5. Choose Layer Properties Manager from the Layers toolbar to open the Layer
Properties Manager again. Choose Mydims. Click it a second time so that a
black border appears around the layer name. Type Titles 1. The name of the
layer is changed. Click OK.
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Figure 11-17: This drawing has 44 layers.

Thanks to Michael J. Lemmons of Winston Products Company in

Louisville, Kentucky, for this drawing.
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Figure 11-18: The Layer Properties Manager now shows only
layers starting with the letter M.

6. Start the ERASE command and select any object on the title block (it is all one
object) and the three labels FRONT, TOP, and RIGHT SIDE. Press Enter to end
the command.

7. Choose Layer Properties Manager from the Layers toolbar to open the Layer
Properties Manager dialog box again. Notice that the Titles layer is not on the
list because this layer no longer starts with the letter M. Click the Named
layer filters drop-down list arrow and choose Show all layers. Scroll down the
list of layers and choose Titles. Click Delete. AutoCAD deletes the layer
because it no longer has any objects on it. Click OK to close the dialog box.

8. Save your drawing.
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Changing Object Color, Linetype, and
Lineweight

The properties of layers — color, linetype, lineweight — can also apply directly to
objects. You can assign a color, linetype, and lineweight to an object. You can also
set a current color, linetype, and lineweight so that all future objects you draw have
those properties regardless of the properties assigned to their layer. In most cases,
you should avoid assigning properties directly to objects because the organiza-
tional value of layers is lost.

@ You can also assign plot styles to objects. See Chapter 17 for more information.
eference

Changing an object’s color

You can control an object’s color by using the Color Control drop-down list on the
Properties toolbar, as shown in Figure 11-19. For more information about choosing
colors, see “Assigning a color” earlier in this chapter. As with the Layer Control
drop-down list, the Color Control drop-down list shows the color of any selected
object. When you create a layer, assign it a color, and draw with that layer, AutoCAD
displays the color as By Layer, as shown in Figure 11-20.

B EyLayer ~| Figure 11-19: The Color Control drop-down list on the

0 Byl aper Properties toolbar
M ByBlock
M Red

O *ellow
O Green
O Cyan

M Elue

M tagenta
™ "white
W Color 12

k3

The ByLayer color means that the color of the object is taken from the color of the
object’s layer. At the same time that you see the selected object’s color in the Color
Control drop-down list, you can look over to the Layer Control drop-down list and
confirm the color assignment of the object’s layer.

The ByBlock color creates objects by using color 7 (white or black, depending on
the screen color), but if the objects are placed in a block, the block takes on the
current color when inserted. (For information about blocks, see Chapter 18.)
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Color Control Selected object
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Figure 11-20: The color of the selected object (some text) is ByLayer

The best way to organize a drawing is to assign colors by layer. It can be confusing
if related elements, such as centerlines in a mechanical drawing, appear in different
colors. Also, if you see another line with the same color and linetype as most cen-
terlines, you may assume it’s a centerline in the wrong place. It is standard practice
throughout the AutoCAD world to organize colors by layer.

Colors have a special significance because when you plot, you can assign colors to
pens — although you can also use AutoCAD 2004’s plot styles (see Chapter 17). If
you use a color-based system, color is the basis you use for plotting with various
width pens or colors. You may want to temporarily change the color of an object to
emphasize it in a plot or for some other reason. However, you should generally
refrain from directly changing the color of objects.

If you need to change the color of an object, here are two ways to do it:

4 To change just an object’s color, select the object. Click the Color Control
drop-down list and choose the color that you want.

4 If you want to change other properties at the same time, select the object and
choose Properties from the Standard toolbar. AutoCAD opens the Properties
palette, shown in Figure 11-21. In this window you can change all the proper-
ties of the object. To change the color, choose Color and click the drop-down
arrow that appears. Choose the color that you want.

You can always change an object's color back to ByLayer, using the same Color

_»_ Control drop-down list.
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Figure 11-21: The Properties palette

Changing the current color

When you change the current color, all future objects are drawn using that color,
regardless of their layer. In general, you should do this only when you have a spe-
cial need for two objects to be on one layer but have different colors. An example
might be text in a title block. You might want the text to have the same layer so that
you can freeze it and thaw it (or turn it on and off) easily without having to remem-
ber that the text and title block are on two separate layers. If you also want part of
the text to have a different color, change the current color before typing in that part
of the text. Remember to change the current color back to ByLayer before drawing
anything else.

To change the current color, make sure no object is selected. Then click the Color
drop-down list and choose the color you want. To use a color not on the list,
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choose Select color to open the Select Color dialog box. (See the section “Assigning
a color” earlier in this chapter for more information on assigning colors.) To change

the current color back to ByLayer, click the Color drop-down list and choose
ByLayer.

You have an opportunity to do an exercise on changing colors later in this chapter.

Changing an object's linetype

Linetypes work according to the same principles as colors. You can change the line-
type of an existing object or objects. You can control an object’s linetype by using
the Linetype Control drop-down list on the Properties toolbar, shown in Figure
11-22. The Linetype Control drop-down list shows the linetype of any selected
object. When you create a layer, assign it a linetype, and draw with that layer,
AutoCAD displays the linetype as ByLayer.

HIDDENZ v Figure 11-22: The Linetype Control drop-down list on the

BuLaver Properties toolbar
BiyBlock

............... HIDDENZ
Other...

The ByLayer linetype simply means that the linetype of the object is taken from the
linetype of the object’s layer.

The best way to organize a drawing is to assign linetypes by layer. It can be confus-
ing if related elements, such as plat borders in a surveyor’s drawing, appear in
different linetypes. Also, if you see another line with the same color and linetype as
most plat borders, you may assume it’s a plat border in the wrong place. It is com-
mon practice throughout the AutoCAD world to organize linetypes by layer.

If you need to change the linetype of an object, you have two options:
4 To change an object’s linetype, select the object. Click the Linetype Control
drop-down list and choose the linetype that you want.

4 Select the object and choose Properties from the Standard toolbar. AutoCAD
opens the Properties palette, shown earlier in Figure 11-21. To change an
object’s linetype, click Linetype, and then click the drop-down arrow that
appears. Choose from one of the linetypes.

You can always change an object’s linetype back to ByLayer, using the same

_», Linetype Control drop-down list.
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As discussed in the section, “Assigning a linetype,” earlier in this chapter, you may
need to load a linetype before you can use it. To load a linetype, choose Linetype
Control from the Properties toolbar. Scroll down to the bottom of the list and
choose Other to open the Linetype Manager. Choose Load to open the Load or
Reload Linetypes dialog box, choose the linetype file (if not acad.1in), and choose
the linetype that you want to load. Click OK. Choose the linetype again in the
Linetype Manager and click OK to return to your drawing.

To filter the list of Linetypes, choose from the Linetype Filters drop-down list box in
the Linetype Manager.

Changing the current linetype

You can also change the current linetype. When you change the current linetype,

all future objects you draw have that linetype and are not drawn according to their
layer’s assigned linetype. In general, you should do this only when you have a
special need for two objects to be on one layer but have different linetypes. An
example might be a table containing notes in one corner of a drawing. You might
want the lines that make up the table to have the same layer so that you can freeze
it and thaw it (or turn it on and off) easily without having to remember that the
table is on two separate layers. If you also want some of the lines to have a different
linetype, change the current linetype before adding those lines. Remember to
change the current linetype back to ByLayer before drawing anything else.

To change the current linetype, click the Linetype drop-down list and choose the
linetype you want, first making sure no objects are currently selected. To change
the current linetype back to ByLayer, click the Linetype drop-down list and choose
ByLayer.

Changing an object’s lineweight

Lineweights let you represent objects with varying line widths. The widths can
represent the width of a pen in a pen plotter that will be used to plot that object.
Lineweights can also be used as an organizational tool, to distinguish certain types
of objects just as colors and linetypes do. Finally, you can use lineweights to repre-
sent the actual properties of objects, such as the width of wires in an electrical
schematic.

Lineweights work according to the same principles as colors and linetypes. You can
control an object’s lineweight by using the Lineweight Control drop-down list on the
Properties toolbar, as shown in Figure 11-23. The Lineweight Control drop-down list
shows the lineweight of any selected object. When you create a layer, assign it a
lineweight, and draw with that layer, AutoCAD displays the lineweight as ByLayer.
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Bilawer |v| Figure 11-23: The Lineweight drop-down list on the
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As with colors and linetypes, the best way to organize a drawing is to assign
lineweights by layer. If you need to change the lineweight of an object, here are
two ways to do it:

4 Select the object. Click the Lineweight Control drop-down list and choose the
lineweight that you want.

4+ Select the object and choose Properties from the Standard toolbar. AutoCAD
opens the Properties palette. To change an object’s lineweight, click
Lineweight, and then click the drop-down arrow that appears. Choose from
one of the lineweights.

Changing the current lineweight

You can also change the current lineweight. When you change the current
lineweight, all future objects you draw have that lineweight and are not drawn
according to their layer’s assigned lineweight.

To change the current lineweight, click the Lineweight drop-down list and choose
the lineweight that you want, first making sure no objects are currently selected. To
change the current lineweight back to ByLayer, click the Lineweight drop-down list
and choose ByLayer.
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On the The drawing used in the following Step-by-Step exercise on changing colors, line-
, CD@" | types, and lineweights, ab11-d.dwg, is in the Drawings folder of the AutoCAD
\ /2004 Bible CD-ROM.

Step-by-Step: Changing Colors, Linetypes, and Lineweights
1. Open abl11-d.dwg from the CD-ROM.

2. Save the file as ab11-04.dwg in your AutoCAD Bible folder. This is an eleva-
tion view of a lavatory cabinet, shown in Figure 11-24.
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Figure 11-24: A lavatory cabinet
Thanks to the Army Corps of Engineers for
this drawing.

3. Pick one of the reflection lines in the mirror. Notice that the color is red but
the layer’s color, as shown in the Layer Control drop-down list, is Magenta.
Select all the reflection lines. Click the Color Control drop-down list and
choose ByLayer from the top of the list. Press Esc to remove the grips.

4. Select the green dimension at the bottom of the cabinet. (The dimension is all
one object.) To make it more visible, click the Color Control drop-down list
and choose Red. Press Esc to see the result.

5. Pick the lines at @ and @ in Figure 11-24. Click the Linetype Control
drop-down list and choose the Hidden linetype. Press Esc so that the hidden
lines are no longer selected.
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6. Select the dashed arc that represents the bottom curvature of the sink. Click
the Lineweight Control drop-down list and choose 0.30 mm. Press Esc. Click
LWT on the status bar to turn on the display of lineweights and see the result.

7. Click the Color Control drop-down list box and choose Cyan to make it the
current color.

8. Start the RECTANG command. Draw a rectangle inside the left cabinet. Use the
COPY command to copy the rectangle to the right cabinet. (To copy, use an
intersection object snap at point @ as the base point and @) as the second
point of displacement.) The rectangles are drawn in Cyan.

9. Save your drawing. It should look like Figure 11-25.
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Figure 11-25: The finished cabinet

Working with Linetype Scales

A noncontinuous linetype is a repeating pattern of dots, dashes, and spaces.
(Linetypes can also include repeating text or shapes.) You may find that the line-
type patterns in your drawing are too long or short for clarity. The linetype scale
may even be so big or so small that the line looks continuous. How often the
pattern is repeated is affected by three factors:

4 The linetype definition
4 The global linetype scale

4+ The individual object’s linetype scale
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Changing linetype spacing by using
a different linetype

One choice is to change the linetype. There are a number of linetypes that come in
short, medium, and long variations, such as Dashedx2, Dashed, and Dashed2, as
shown in Figure 11-26.

o _ <« pashedx2 Figure 11-26: A number of AutoCAD's
-~ — — — — — — — -+ —Dashed  standard linetypes come in three variations,
Dashed2  ¢\,ch as Dashedx2, Dashed, and Dashed2.

AutoCAD’s acad. 1in contains a number of ISO linetypes that meet the specifica-
tions of the International Standards Organization. Your organization or field of
specialty may require the use of these linetypes. If so, you should know that the
ISO linetype pattern definitions are much longer than AutoCAD’s other definitions.
Figure 11-27 shows the ISO dash linetype and AutoCAD’s dashed linetype. You may
need to make adjustments to the linetype scale as a result.

AutoCAD's dashed linetype

T

1SO dash linetype

Figure 11-27: A comparison of AutoCAD’s dashed linetype
and IS0 dash linetype

Changing linetype spacing by changing
the global linetype scale

Another choice is to change the global linetype scale, which affects all noncontinu-
ous linetypes in your drawing. AutoCAD multiplies the linetype definition by the
global linetype scale to calculate the length of each repetition of the linetype:

4 Linetype scales larger than 1 result in longer sections — and fewer repetitions
of the linetype definition per unit.

4 Linetype scales smaller than 1 result in shorter sections —and more
repetitions of the linetype definition per unit.
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When you change the linetype scale, AutoCAD regenerates the drawing and
changes all the linetypes. Figure 11-28 shows three versions of a drawing with line-
types at linetype scales of 0.5, 1, and 2. As you can see, a scale of 2 is too large and
a scale of 0.5 is too small. A scale of 1 is just right. (Goldilocks would have been
happy with it.)

AT

el
i o )

\(;_BR
]
—
\(;_BR
+ H%é

Linetype scale = 0.5 Linetype scale =1 Linetype scale =2

Figure 11-28: Three versions of a drawing, using linetype scales of 0.5, 1, and 2

For purposes of drawing, you simply want to make sure that you can distinguish the
linetype both when you can see the entire drawing on the screen and when you
zoom in close. The main reason to scale linetypes is for plotting. A linetype scale
that works for a drawing of a house on-screen may appear continuous when you
plot it at a scale factor of 1=96.

If you want the linetype to appear exactly according to its definition, use the scale
factor for the linetype scale. Chapter 5 covers scale factors. If the scale factor doesn’t
give you the results you want, try a linetype scale of one-quarter to one-half the scale
factor —in the 1=96 example, you might use a linetype scale of 24 or 48.

To change the linetype scale, choose Format => Linetype to open the Linetype
Manager, shown in Figure 11-29. Click Show Details if the lower portion of the dialog
box is not displayed.

In the Global scale factor text box, type the scale factor you want. Click OK.
AutoCAD regenerates the drawing, changing the scale of every noncontinuous line-
type in the drawing.

The global linetype scale is held in the LTSCALE system variable. You can change

~, the linetype scale by typing LTSCALE at the command line and typing a scale.
s

Changing linetype spacing by changing
the object linetype scale

On occasion, you may want the linetype spacing to be different for one object—or
a small group of objects — only. Perhaps the object is too small to show the linetype
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pattern or you want to set it off visually. AutoCAD also has a current object linetype
scale that works like setting a current color or linetype — all objects drawn after
you set the object linetype scale are drawn with the new linetype scale. In most
cases, you want to make sure you change the current object linetype scale back to
its default of 1 after using it for that one object or group of objects.

Changing the current object linetype scale

To change the linetype scale, choose Format => Linetype to open the Linetype
Manager, as shown in Figure 11-29. Click Show Details if the lower portion of the
dialog box is not displayed. In the Current Object Scale text box, type the scale
factor you want. Click OK. Now all objects that you draw use the current object
linetype scale.

E] Linetype Manager B[]
Linetype filters
_L d... Del
|Show all inetypes [v] [ Inwert filter “

Current Linetype: ByLayer

Linetype Appearance Description
HyLayer
BiyBlock _
CONTIMUOUS ——— Conlinuous
HIDDEN ~ ——mm————— Hdden__ _ _ _ _ _ _ __ __ _ _ _
USTATIONZ _

[ (n] 4 H Cancel H Help

Figure 11-29: The Linetype Manager dialog box

The current object linetype scale is held in the CELTSCALE system variable. You
can change the current object linetype scale by typing celtscale at the command
line and typing in a scale.

If you have also set the global linetype scale to a value other than 1, AutoCAD multi-
plies the two linetype scales to calculate the final result. For example, if you have a
global linetype scale of 12 and a current object linetype scale of 0.5, objects you
draw will have a resulting linetype scale of 6.

Changing an existing object’s linetype scale
It may be more common to draw an object without setting a special object linetype
scale and then decide that you want to change its linetype scale. To change an
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object’s linetype scale, select the object and choose Properties from the Standard
toolbar. In the Properties window, click Linetype Scale and then type the new line-
type scale. This linetype scale only affects the selected object. It does not affect the
global linetype scale.

0nthé‘¢-\ The drawing used in the following Step-by-Step exercise on changing linetype
ECDW scales, abll-e.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

& /  CD-ROM.

o

Step-by-Step: Changing Linetype Scales
1. Open abl1-e.dwg from the CD-ROM.

2. Save the file as ab11-05.dwg in your AutoCAD BibTe folder. This drawing is
of a bushing, as shown in Figure 11-30. Notice that the linetype doesn’t show
clearly on the short line at @ and in the small circle at @.

3. Choose Format = Linetype. Click Show Details to open the Details section of
the Linetype Manager, if necessary. Change the Global scale factor to 0.5. Click
OK. AutoCAD regenerates the drawing. Note that the circles are better, but the
short line at @ still looks like a continuous line.

4. Choose the line at @. Choose Properties from the Standard toolbar. Click
Linetype scale and change it to 0.5. Press Enter. Press Esc to remove the grips
and see the result. Notice the difference in the line, which now has a linetype
scale of 0.5 (global) times 0.5 (object) = 0.25.

5. Save your drawing. It should look like Figure 11-31.

SECTION A-4

Figure 11-30: This drawing of a bushing has two noncontinuous
linetypes.
Thanks to Robert Mack of the Dexter Company, Fairfield, lowa, for this drawing.
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SECTION A—&

Figure 11-31: The drawing’s noncontinuous lines are now more
appropriate.

Importing Layers and Linetypes
from Other Drawings

New
Feature

The AutoCAD DesignCenter gives you access to drawing content and definitions,
such as layers, linetypes, blocks (see Chapter 18), plot layouts (see Chapter 17),
and so on that exist in other drawings. I cover the AutoCAD DesignCenter in more
detail in Chapter 26, but here I explain how to import layers and linetypes from
another drawing. Autodesk calls this “mining your design.” In other words, after
you have created a layer or a linetype, you can easily use it in any new or existing
drawing.

\ _ The DesignCenter has been redesigned for AutoCAD 2004 to use the new palette
interface. For information on working with the palette interface, see “Managing
the Properties palette” in Chapter 10. It has a new tab, DC Online, that provides a
way to share content for AutoCAD drawings. You can use the DesignCenter not
only to access drawing content and definitions but to create tool palettes of block
(symbol) libraries. Chapter 26 covers these tool palettes.

Choose DesignCenter from the Standard toolbar to open the DesignCenter,
shown in Figure 11-32. The DesignCenter’s left pane works like Windows
Explorer left pane, letting you navigate throughout your hard drive or your net-
work. (If you don’t see the left pane, click the Tree View Toggle button on the
DesignCenter’s toolbar). If the DesignCenter opens showing only open drawings,
click Desktop on the toolbar and navigate to the desired folder. After you click a
folder, the drawings in that folder are listed on the right side. Choose Large Icons
from the View drop-down list to see a small preview of each item. To access layers
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and linetypes, either double-click a drawing icon or click its plus sign. Now you see
the various definition categories in the right pane. To see the list of the layers or
linetypes, double-click the layers or linetypes icon in either the left or right pane.
To import a layer or linetype, double-click the layer or linetype’s icon. AutoCAD
brings the layer or linetype definition into your drawing. Click the Layer Control
drop-down list to check it out!
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Figure 11-32: The DesignCenter lets you
locate definitions contained in other
drawings and import them into your
current drawing.

Click the DesignCenter’s Close button to close the DesignCenter.

objects on layer dashed be changed to the layer hidden. Use this feature to main-

ﬁj AutoCAD 2004 enables you to translate layers. For example, you can specify that all
eterence

tain layer standards that you have set up. Chapter 26 fully covers layer translating.

Matching Properties

New
Feature

You may be familiar with the Format Painter button available on the toolbars of
many Windows applications. AutoCAD offers something similar that, at the same
time, enables you to specify which properties you want to match. AutoCAD calls
this process matching properties. It is similar to Excel’s Paste Special command,
which lets you choose what properties you want to paste from what you copied to
the clipboard — everything, or just the formulas, values, formats, and so on.

N\ You can now match polyline and viewport properties. These properties are
matched by default, although you can specify which properties you want to match
in the Property Settings dialog box. See Figure 11-33.
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An object can have so many properties that this can be a useful tool. To match
properties, you need two objects, a source object and a destination object (or
objects). Follow these steps to match properties:

1. Choose the object whose properties you want to match (the source object).

2. y Choose Match Properties from the Standard toolbar. AutoCAD displays a
Format Painter cursor with a pickbox. On the command line, you see the
Select destination object(s) or [Settings]: prompt.

‘\lote You can choose Match Properties from the Standard toolbar first and then choose
~  the source object.

3. If you want to match all the object’s properties, select the object(s) that you
want to receive the matching properties, that is, the destination object(s).

4. If you want to match only some of the object’s properties, right-click and
choose Settings to open the Property Settings dialog box, shown in Figure
11-33. Uncheck all the properties you don’t want to match and click OK.
AutoCAD returns you to the same prompt as before. Select the object(s) you
want to receive the matching properties, that is, the destination objects(s).

El Property Settings B[]
Basic Properties

Calor . ByLayer

Layer ADETLLwW10
Linetype CONTINUDUS

Linetype Scale 1"

Lineweight BiyLayer
Thickness o
PlotStyle EyLayer

Special Properties

Diimension Text Hatch

Figure 11-33: The Property Settings
dialog box

5. Press Enter to end object selection. AutoCAD matches the properties.

On the )
cg. g \. The drawing used in the following Step-by-Step exercise on matching properties,
/ abll-f.dwg,isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Matching Properties
1. Open ab11-f.dwg from the CD-ROM.

2. Save the file as ab11-06.dwg in your AutoCAD BibTe folder. This is a drawing
of a master bedroom suite plan, as shown in Figure 11-34.
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3.

Pick the wall at @ in Figure 11-34. Click Match Properties from the

Standard toolbar. At the Select destination object(s) or
[Settings]: prompt, use a crossing window to select all the folding closet
doors on both sides of the line you just selected. Press Enter to end object
selection. AutoCAD matches the properties of the doors to the properties of
the wall. (The doors turn from gray to black/white.)

. Pick the text MASTER SUITE. Choose Match Properties from the Standard tool-

bar. At the Select destination object(s) or [Settings]: prompt,
right-click and choose Settings. In the Property Settings dialog box, deselect
all the boxes except Text in the Special Properties section. Click OK.

. At the Select destination object(s) or [Settings]: prompt, choose

the text CL. in both closets and press Enter to end the command. AutoCAD
matches the text properties of the text. Notice that the CL. text becomes bold.

. Save your drawing.

MASTER SUITE

Figure 11-34: The master bedroom suite plan

Summary

In this chapter, you read all about layers, colors, linetypes, and lineweights.
You discovered:

4 Using layers to help you organize your drawings by assigning the same

properties to related objects

4+ Creating a layer by giving it a name, color, linetype, and lineweight

4 Changing the layer of existing objects, using the Layer Control drop-down list

or the Properties palette
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4 All about layer states — On/Off, Thawed/Frozen, Unlocked/ Locked, and
Plottable/Not Plottable

4 Changing the properties of existing layers

4 Saving sets of layer states and properties and later restoring them
4+ Filtering the layer listing

4 Purging unused layers and linetypes

4 Altering the color, linetype, and lineweight of any object

4 Globally changing the linetype scale, changing the current linetype scale, and
changing the object linetype scale of existing objects

4 Using the DesignCenter to import layers and linetypes from other drawings

4 Utilizing the Match Properties command to copy properties from one object
to one or more destination objects

The next chapter explains how to get detailed information from your drawing.

+ o+ 4






Getting
Information
from Your
Drawing

Your AutoCAD drawing is intelligent in many ways.
Several commands can give you the details of each

object. In addition, you can get listings that provide informa-
tion about your drawing as a whole. | have mentioned system
variables previously in this book—you can list system vari-
ables and their current settings.

You can perform calculations on objects that may assist you
in certain drawing tasks. For example, you can divide an
object into any number of segments by placing point objects
along the object, or you can place point objects at a specified
distance along the object. You can use AutoCAD’s calculator,
which not only does regular numerical calculations but also
works with coordinates and geometric points on objects.

Drawing-Level Information

Some information applies to the drawing as a whole or even to

your computer system as a whole, rather than to individual
objects. This information can be important when there is a

problem or when you simply need to find the status of system

variables.

Listing the status of your drawing

The STATUS command provides a standard list of information
that can be very helpful. To use the STATUS command, choose

Tools = Inquiry => Status. Figure 12-1 shows a sample status
listing.

CHAPTER

¢+ o+
In This Chapter

Getting drawing-wide
information

Getting information
about obijects

Measuring and
segmenting objects

Using AutoCAD's
calculator

¢ 4+
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Figure 12-1: A sample listing from the STATUS
command

AutoCAD lists the number of objects in your drawing, and then the limits and
extents of the drawing, as well as the extents of the current display on your screen.
Other important items are the snap and grid spacing as well as the current layer,
color, linetype, and lineweight. You can see that Fill is on but the other drawing aid
settings are off. Center, Endpoint, Intersection, and Extension running object snaps
are on. Finally, information also appears about free disk space and free memory.

Obviously, much of this information is available without using the STATUS com-
mand. The easiest items to find are the current layer, color, linetype, and lineweight,
which are readily visible on the Layers and Properties toolbars. However, you
would have to use a number of commands to obtain other information such as the
snap and grid spacing and the drawing limits. STATUS puts it all together in one list-
ing. Finally, the free disk and memory statistics provide valuable information not
easily obtainable otherwise from within your drawing.

The most common use for STATUS is to troubleshoot problems. For example, you
could send the listing to a colleague in another office who needs to work on the
same drawing. Your colleague can then work more easily by using the same settings
you have used.

Listing system variables

In Chapter 5, I explained that AutoCAD stores settings in system variables. In the
previous chapter, for example, I mentioned that the global linetype scale is stored
in the LTSCALE system variable and the object linetype scale is stored in the
CELTSCALE system variable. You may want to know the settings of a group of
related system variables. The SETVAR command provides a listing of all the system
variables and their settings. It may be quicker to view system variable settings by
using the SETVAR command than typing each individual system variable on the
command line.

Too many system variables exist to show the entire listing here, but a few can con-
vey the wealth of information available, as shown in Figure 12-2.
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Dat..."

DCTHAIH “enu”

DEFLPLSTYLE “Hormal"

DEFPLSTYLE "ByLayer"

DELOBT 1

DEMANDLOAD 3

DIASTAT 1 (read only)
DIMADEC 1)

DIMALT OFF

DIMALTD 2

DIMALTF 25.4000

DIMALTREND o.o0

DIMALTTD 2

DIMALTTE 12

DIMALTUO 2

DIMALTZ 12

DIMAPOST "

DIMASO OFF

DIMASSOC il

DIMASE 10.00

DIMATFIT 3

DIMATUHIT 4

DIMAZIN 1]

DIMBELE "h"

DIMBLEL tht

DIMELE “h"

Figure 12-2: A partial SETVAR listing

“\lote Read-only system variables are for information only and cannot be changed. An
—  example is LOGINNAME, which shows the current user's name registered on the
system. Other system variables can be changed.

While some system variables allow any or a variety of values, many are either on or
off. In general, a setting of 1 means on and 0 means off.

Onthe_"“‘\ Appendix C lists useful, new, changed, and deleted system variables, including a
[ CD@\" brief explanation of each.

Most system variables do not need to be set directly. In Chapter 11, for example,

you set the LTSCALE system variable by using the Linetype Manager. However, a
few system variables can be accessed only by typing them on the command line.

You can use SETVAR to set system variables (that are not read-only) as well as to
list them. To list the system variables, choose Tools = Inquiry => Set Variable. At the
Enter variable name or [?]: prompt, type ? 4. At the Enter variable(s) to
1ist <*>: prompt, press Enter to list all the system variables or type the name of
a variable. (You can use the * and ? wildcards in the name.) AutoCAD either lists all
the system variables or just the variable you typed.
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If you type a variable, AutoCAD prompts you for a new value so that you can change
it. For example, if you type celtscale, AutoCAD responds with the Enter new value
for CELTSCALE <1.0000>: prompt. You can then change the system variable by
typing in a new value. You can simply press Enter to accept the current setting.

Tracking drawing time

You can track the time you spend working on a drawing. This feature is most often
used for billing time to clients, or maybe your boss wants to see how much you're
getting done.

E&A Chapter 26 explains how to keep a log file of your drawing activity.
Reference

To use the TIME command, choose Tools > Inquiry = Time. A typical listing is
shown in Figure 12-3.

Command: time

Current time: Friday. December 27. 2002 at £6:02:19:513 FM
Times for this drawing:
Created: Friday. December 27, 2002 at 5:53:28:138 PN
La=st updated: Friday, December 27, 2002 at 5:54:18:857 PM

Total editing time: 0 days 00:07:45.328
Elapsed timer (on): 0 days 00:07:45.047
Hext automatic save in: 0 days 00:04:16.016

Figure 12-3: A typical TIME listing

Table 12-1 shows the meaning of the listing that you get from the TIME command.

Table 12-1
TIME Command Information

Listing Comments
Current time The current date and time. The time is displayed to the nearest

millisecond.
Created The date and time the drawing was created.
Last updated The date and time of the last save of the drawing.
Total editing time Accumulates the time spent in the drawing from session to

session, not including plotting time or time you worked on the
drawing and quit without saving your changes.

Elapsed timer Also accumulates time spent in the drawing, but you can turn
this on and off and reset it.

Next automatic save in Shows when AutoCAD will automatically save your drawing.
Choose Tools = Options and click the Open and Save tab to set
how often AutoCAD automatically saves your drawing.
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You can think of total editing time as your car’s odometer and elapsed time as a
timer (like the trip meter that some cars have that lets you time a specific trip).

At the end of the listing, AutoCAD displays the Enter option
[Display/ON/OFF/Reset]: prompt. The Display option redisplays the listing with
updated times. ON and OFF turn the elapsed time on and off. The Reset option
resets the elapsed time to zero.

Onthé\\ The drawing used in the following Step-by-Step exercise on obtaining drawing
i cD, | information, ab12-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

& /,-" CD-ROM.

Step-by-Step: Obtaining Drawing Information
1. Open ab12-a.dwg from the CD-ROM.

2. Choose Tools = Inquiry = Status. Look at the listing to see how many objects
it contains. Check the limits of the drawing. Look at the grid spacing. Read
through any other items of interest to you.

3. Choose Tools &> Inquiry = Set Variable. At the Enter variable name or
[?]: prompt, type ? . At the Enter variable(s) to list <*>: prompt,
press Enter to accept the default. Look for the BLIPMODE setting. Check the
location of the drawing (DWGPREFIX). Look for the global linetype scale
(LTSCALE). Press Enter until you see the Command: prompt again.

4. Press Enter to start the SETVAR command again. At the Enter variable
name or [?]: prompt, type ltscale .1. Type 50 J to change the linetype scale.
Type regen . (Notice that the noncontinuous linetypes now show up more
clearly.)

5. Choose Tools = Inquiry = Time. Check the current time against your watch.
(AutoCAD takes the time from your computer’s clock.) Look at the total edit-
ing time to see how long you have had the drawing open. Press Enter to end
the command.

6. Do not save this drawing. Leave the drawing open if you are going on to the
next exercise.

Object-Level Information

Several commands exist solely to provide information about the objects in your
drawing.

Listing objects
The LIST command displays information about selected objects. The information

displayed depends on the object. For example, the LIST command gives you the
radius of a circle and the length of a line.
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To list an object, choose Tools > Inquiry => List. Figure 12-4 shows a typical listing
for a line.

LINE Layer: "objects"
Space: Model space
Handle = 34D

from point, X=0'-4 9-64" ¥=0'-1 3-64" Z= o'-o"
to point, X=0'-5 41-64" ¥=0'-1 3-64" Z= o'-o"
ILength =0'-1 1-2", Angle in XY Plane = 1]
Delta X =0'-1 1-2", Delta ¥ = 0'-0", Delta Z = o'-o"

Figure 12-4: A typical listing for a horizontal line

Table 12-2 shows the meaning of the information you receive when you list an

object.
Table 12-2
LIST Command Information

Data Comments

Layer AutoCAD lists the object’s layer. If the color and linetype are not
ByLayer or ByBlock, AutoCAD lists these as well.

Space AutoCAD tells you if the object is in model space or paper space.
(Chapter 17 covers paper space.)

Handle Every object in your drawing has a handle. AutoCAD uses handles to
keep track of objects.

from point Because AutoCAD is listing a line, it shows the start point.

to point The endpoint of the line.

Length The line’s length.

Angle in XY Plane The line's angle. This line is horizontal, so its angle is zero.

Delta X The change in the X coordinate from the start point to the endpoint.

Delta Y The change in the Y coordinate from the start point to the endpoint.

The Layers and Properties toolbars makes it easy to tell an object’s layer, linetype,
and color. Remember, when you select an object, its layer, linetype, lineweight,
color, and plot style appear in these toolbars. Most of this information is also avail-
able from the Properties palette — choose Properties from the Standard toolbar.

Calculating distances

AutoCAD makes it easy to calculate the distance between any two points by using
the DIST command. Choose Tools = Inquiry = Distance. AutoCAD prompts you for



Chapter 12 + Getting Information from Your Drawing 37 ]

two points. You can use any means of specifying a point, although object snaps or
snap mode are useful if you want to be sure which point you are specifying. Here is
a typical display for a vertical line:

Distance = 19'-0", Angle in XY Plane = 270, Angle from XY Plane
=0
Delta X = 0'-0", Delta Y = -19'-0", Delta Z = 0'-0"

You can use this information to check dimensions (covered in Chapter 14) or to
make further calculations that you need for drawing.

Finding coordinates

Finding a coordinate is even easier than calculating a distance. Choose Tools &>
Inquiry = ID Point. AutoCAD prompts you for a point. You can use any means of speci-
fying a point, although object snaps or snap mode are useful. Here is a typical listing:

X =61'-51/8"Y =232"-45/8"27=20"-0"
You can use this information to find or calculate an absolute coordinate.

On thé‘\ The drawing used in the following Step-by-Step exercise on obtaining object infor-
cD, | mation, ab12-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

\ /,-" CD-ROM.

Step-by-Step: Obtaining Object Information

1. Open ab12-a.dwg from the CD-ROM if it is not already open from the previ-
ous exercise. This is a civil engineering drawing showing several plots of land,
as shown in Figure 12-5. OSNAP should be on. Set a running object snap for
endpoint.

70

Figure 12-5: A civil engineering drawing of several plots of land
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Caution

2. Choose Tools = Inquiry = List. At the Select objects: prompt, pick @

in Figure 12-5. Press Enter to end object selection. The result is shown in
Figure 12-6. Note the surveyor’s units.

ARC Layer: "0"
Space: Hodel space

Handle = 7D3951
center point, X= 7249.24 ¥= 3753.29 Z= o.on
radius 1937.35
start angle S 89d28'Ge" U

end angle 5 76d38'19" W

length 434.28

Figure 12-6: The result of using the LIST
command on an arc

. Choose Tools => Inquiry = Distance. At the Specify first point: prompt,

choose the endpoint at @ in Figure 12-5, using the Endpoint running object
snap. At the Specify second point: prompt, choose the endpoint at @.
Here’s the result:

Distance = 2740.90, Angle in XY Plane = N 89d23'34" E, Angle

from XY Plane = E
Delta X = 2740.75, Delta Y = 29.05, Delta Z = 0.00

. Choose Tools => Inquiry = ID Point. At the Specify point: prompt, pick the

endpoint at @ in Figure 12-5. Here is the result:
X = 6065.67 Y = 3450.58 Z = 0.00

. Do not save this drawing. Leave the drawing open if you are going on to the

next exercise.

The precision set in the Units dialog box (Format => Units) affects the results of the
LIST, DIST, and ID (Locate Point) commands. See Chapter 5 for more information
on the Units dialog box.

Calculating area and perimeter

AutoCAD can also calculate the area and perimeter of any area. To start the AREA
command, choose Tools => Inquiry => Area.

You can specify points bounding the area that you want to calculate. The points do
not have to be on an object. AutoCAD calculates the area and perimeter as if you
had drawn lines between all the points. AutoCAD automatically closes the area if
you don’t close the area by picking the last point the same as the first point. This
option is limited to areas with straight sides.
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Instead of picking points, you can use the Object option to calculate the area of
objects, which gives you the flexibility to use areas that include curves. Acceptable
objects are circles, ellipses, splines, polylines, polygons, regions, and objects created
with the 2D SOLID command. (Chapter 16 covers splines, polylines, regions, and
solids.) AutoCAD calculates an area but adds a length instead of a perimeter. For a cir-
cle, you get a circumference. Although a polyline may have the exact same shape as
an arc, you cannot calculate the area of an arc. Polylines and splines can be open.
AutoCAD calculates the area as if you had drawn a line from the endpoint to the start
point but does not include that last imaginary line when calculating the length.

To calculate the area of irregular shapes, you can keep a running total by using the
Add option. Start by specifying the first area. Then use the Add option and specify a
second area. AutoCAD adds the two areas. You can continue to add areas. You can
also use the Subtract option to subtract areas.

Figure 12-7 shows an example of calculating the open area in an office floor plan by
picking points. The point objects show the points that were used to calculate the
area and perimeter.

Figure 12-7: Calculating the area and perimeter
for an office floor plan

I OFFICES

g

[

You can also use the BOUNDARY command to create one polyline or region from a
complex area. (Chapter 16 covers boundaries and polylines.) You can then use the
Object option of the AREA command instead of picking points. However, notice that
BOUNDARY included the open doors in the area selected for the office floor plan, as
shown in Figure 12-8.
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Figure 12-8: Using the BOUNDARY command to
create an object for use with the AREA command.
The boundary is indicated with a dashed line.

OFFICES =1 |
===

=
| |
On the ' The drawing used in the following Step-by-Step exercise on using the AREA com-
, CDW | mand, abl2-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible
K /  CD-ROM.

Step-by-Step: Using the AREA Command

1. Open ab12-a.dwg from the CD-ROM if it is not already open from the previ-
ous exercise.

2. Use ZOOM Window to zoom in on the parcels of land labeled D and E, as shown
in Figure 12-9. OSNAP should be on with a running object snap for endpoint.

3. Choose Tools => Inquiry = Area.

4. At the Specify first corner point or [0bject/Add/Subtract]:
prompt, right-click and choose Add to start Add mode. At the Specify first
corner point or [Object/Subtract]: prompt, pick @ in Figure 12-9 by
using the Endpoint running object snap. At the Specify next corner
point or press ENTER for total (ADD mode): prompt, continue to pick
0. ©. 0. and @. Press Enter. AutoCAD lists the area and perimeter. (Your fig-
ures may be different if you picked different points.)

Area = 123575.16, Perimeter = 1480.17
Total area = 123575.16

5. At the Specify first corner point or [0bject/Subtract]: prompt,
pick @ in Figure 12-9. At the Specify next corner point or press ENTER
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for total (ADD mode): prompt, pick @, @, and @. Press Enter to complete
point selection. AutoCAD reports the area and perimeter of the second area
and adds the two areas together to give you the total area. Press Enter again
to end the command.

Area = 183399.88, Perimeter = 1884.62
Total area = 306975.04
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Figure 12-9: The AREA command can calculate the area of
parcels D and E.

6. Do not save the drawing. Keep it open if you are continuing on to the next
exercise.

The MASSPROP command is mostly used for 3D drawings, but it can also be used
on regions, which are 2D solid surfaces, such as a shape cut from sheet metal. This
command provides area and perimeter but also other engineering calculations,
such as centroids, moments of inertia, the product of inertia, and so on. Chapter 24
covers this command further.

Getting information from the Properties palette

You can also get information about an object by selecting it and choosing
Properties from the Standard toolbar. I discussed this Properties palette in Chap-
ter 11 for changing layer, color, linetype, and lineweight properties. As you can see
in Figure 12-10, the window also lists the line’s start and end points, delta (change)
in X, Y, and Z, length, and angle — much like the LIST command. However, you can
change the start and end points directly in this window.
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— %] Figure 12-10: The Properties window lists
Line hd information about a selected object.
General =
Color W BylLayer
Layer 0
Linetype ByLayer
Linetype scale 1.0000
Plot style ByColor
Lineweight ByLayer
Hyperlink
Thickness 0.0000
Geometry
Start X 8.1636
Start'Y 10.6058
Start Z 0.0000
End X 16.5354
End Y 9.9588
End Z 0.0000
Delta X 8.3718
Delta Y 0.6470 it
Delta Z 0.0000 ]
Length 8.3967 o
-
o
ALl
&

Measurement Commands

AutoCAD can make calculations on objects for you. The DIVIDE command divides
an object into equally spaced sections. The MEASURE command divides an object
into sections of a specified length. These commands are useful in many fields — you
might need to space bolt holes evenly around the edge of a bushing, or place fence
studs along the edge of a plot every five feet.

Dividing objects
The DIVIDE command divides an object into equally spaced sections. DIVIDE does

not break the object —it simply places point objects along the object. You can then
use the Node object snap if you want to draw from those points.

To divide an object, choose Draw = Point => Divide. Select the object you want to
divide. AutoCAD responds with the Enter the number of segments or
[BTock]: prompt. Type in the number of segments that you want to create.
AutoCAD places the point objects and ends the command.



Tip

Chapter 12 4+ Getting Information from Your Drawing

Remember that you can set the point display by choosing Format=> Point Style. An
_»,  easy-to-see point style is especially useful for the DIVIDE command. Specify the
4 point style before using the command.

To create eight segments, for example, AutoCAD places seven point objects. If you
have in your mind the number of point objects you want, add one when specifying
the number of segments.

You can use the Block option to place a block of your choice along the object
instead of a point object. Chapter 18 covers blocks. If you choose the Block option
(right-click and choose Block), AutoCAD responds with the Enter name of block
to insert: prompt. Type the name of the block. AutoCAD asks, ATign block
with object? [Yes/No] <Y>. Answer Y or N depending on whether you want to
align the block with the object.

Aligning a block is appropriate for curved objects and blocks that are not com-

~  pletely symmetrical.

AutoCAD asks for the number of segments you want, and you type that number, as
described earlier. Figure 12-11 shows an electrical schematic. Here you want to
divide a line so that you can evenly space wires entering the ignition module. Four
wires need to come in so that the line was divided into five segments, using an easy-
to-see point object.

Point objects Divided line

[GNITION MODULE

- T T 7

GAS VALVE RED | |
- POWER =
Ll o o ﬂ»: ‘ WALVE ‘ -
_i.! | SENSOR | |

i ‘ ‘

! | GROUND |

B

YEL

Figure 12-11: Dividing a line into five segments by using
point objects
Thanks to Robert Mack of the Dexter Company, Fairfield, lowa for this drawing.

You can practice using the DIVIDE command after the next section.
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Measuring objects

The MEASURE command is similar to the DIVIDE command except that you specify
the distance between point objects instead of the total number of segments.
AutoCAD starts measuring from the endpoint closest to where you pick the object.
MEASURE does not break the object —it simply places point objects along the
object. You can then use the Node object snap if you want to draw from those
points.

To measure an object, choose Draw = Point => Measure. Select the object you want
to measure. AutoCAD responds with the Specify length of segment or
[Block]: prompt. Type the segment length you want. AutoCAD places the point
objects and ends the command.

Remember that you can set the point display by choosing Format = Point Style. An
easy-to-see point style is especially useful for the MEASURE command. Specify the
point style before using the command.

As with the DIVIDE command, you can place a block along the object using the
Block option. AutoCAD prompts you for the name of the block and lets you choose
if you want to align the block with the object. AutoCAD asks for the segment length,
and you type in the lengths between the points, as described earlier. Figure 12-12
shows a plat drawing with one side of a lot measured into 20-foot segments.

0.0

/4200

460.00
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<t
207 UTILITY CASEMENT
10° ON EACH SIDE OF
LOT LINE (TYPICAL)

6’2 4’W

i =

o g3 W

20855’

Figure 12-12: Measuring a line into 20-foot segments by using
point objects
Thanks to Bill Maidment of Caltech, Inc. Fairfield, lowa for this drawing.

0nthé\"5~\ The drawing used in the following Step-by-Step exercise on using the DIVIDE and
, cD, | MEASURE commands, ab12-a.dwg, is in the Drawings folder of the AutoCAD
\-& /2004 Bible CD-ROM.
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Step-by-Step: Using the DIVIDE and MEASURE Commands

1. Open abl2-a.dwg from the CD-ROM if it is not already open from the previ-
ous exercise.

2. If you didn’t do the previous exercise, use ZOOM Window to zoom in to the
parcels labeled D and E, as shown in Figure 12-13.

3. Choose Format = Point Style and choose the fourth style in the first row.
Choose Set Size Relative to Screen and set the size to 5%. Click OK.

4. Choose Draw = Point = Divide. At the Select object to divide: prompt,
choose @ in Figure 12-13. At the Enter the number of segments or
[Block]: prompt, type 3 . AutoCAD places two points along the line, divid-
ing it into three segments. (If you want, draw lines from the points perpendic-
ular to the opposite side of the parcel to divide it into three parcels.)

5. Choose Draw = Point => Measure. At the Select object to measure:
prompt, choose @ in Figure 12-13. At the Specify length of segment or
[Block]: prompt, type 120 - (10 feet). AutoCAD places two points along the
line.

6. Do not save your drawing. Keep it open if you are continuing on to the next
exercise.
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Figure 12-13: The site plan zoomed in to parcels D and E

AutoCAD’s Calculator

AutoCAD’s calculator is a geometric calculator that not only can calculate numbers
like an ordinary calculator but also can calculate points and vectors. The calculator
supports object snaps (except apparent intersection, extension, and parallel) and
has its own functions so that it is actually a simple programming language. In fact,
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you can even use AutoLISP variables in your expressions. Here I show you the
basics of the calculator.

To start the calculator, type cal 4 on the command line. If you are in the middle of
a command, type 'cal .

Calculating numbers

Calculating numbers is straightforward and uses standard rules of precedence. The
following illustrates this point:

Command: cal
.>> Expression: 3*(2+3)/5-1
2.0

Because the 2+3 sum is in parentheses, it is calculated first so that the expression mul-
tiplies 3 by 5 (which is 15), divides it by 5 (which is 3), and subtracts 1 (which is 2).

Using CAL in this way is just like having a handheld calculator by your computer.

When you use CAL transparently, AutoCAD assumes you want the result to be a
response to a prompt. Let’s say you want to draw a horizontal line. You know it has
to be the total of two other lines whose length you know. Follow the prompts:

Turn on ORTHO.

Start the LINE command.

Specify first point: Pick the start point for the line. Move
the cursor to the right to draw at a zero-degree angle and so
you can use Direct Distance Entry.

Specify next point or [Undo]: 'cal J

>> Expression: 3.953+6.8725 d

10.8255

End the LINE command. AutoCAD draws a line whose length is the sum of the two
numbers.

You can add feet and inches as well. Use the format 6'5" or 6-5". Don’t put any
spaces between the feet and inches. With the calculator, all inches must be marked
with a double prime (), unlike regular AutoCAD command-line usage. (See the side-
bar “The ins and outs of fractional inches in CAL.”)

Using coordinates

You can use coordinates in CAL expressions. Coordinates are enclosed in square
brackets. Let’s say you want to draw a line that is equal to the length of two other
objects in your drawing that you happen to know are 3.953 and 6.8725 units long.
You want the line to be at a 20-degree angle. At the Specify next point or
[Undo]: prompt, start CAL transparently:
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>> Expression: [@(3.953+6.8725)<201]

This creates a relative polar coordinate whose length is the sum of two numbers.

Using object snaps

You can use the object snaps as part of CAL expressions. When you press Enter
after completing the expression, AutoCAD prompts you for the objects for each
object snap in the expression, one after another.

One of the most common uses for object snaps is to find the midpoint between two
points. In Figure 12-14, you want to draw a line starting from the midpoint between
the centers of two circles.

To accomplish this, first make sure that OSNAP is off. Then start the LINE command
and start CAL transparently at the Specify first point: prompt. Follow the
prompts:

>> Expression: (cen+cen)/2

>> Select entity for CEN snap: Select the first circle.
>> Select entity for CEN snap: Select the second circle.
(4.86897 7.73008 0.0)

The ins and outs of fractional inches in CAL

Using fractional inches in CAL expressions is tricky. If you type 3'2-1/2" as a CAL expression,
AutoCAD replies Error: Invalid feet'-inches" format. AutoCAD expects a hyphen
only between feet and inches. Otherwise, it assumes a hyphen is a minus sign. To write out
fractional inches, think of them as little division problems being added to the whole inches.
Therefore, if you type the following expression

(3'2"+1"/2")+(23"+3"/8")
61.875

AutoCAD takes 3'2" and adds 1" divided by 2" to get 3'2-1/2". Similarly, in the second
expression, AutoCAD adds 23" to 3" divided by 8" to get 23-3/8". Yes, it's slightly awkward.
If 3'-2" returns 38.0, as shown below (3' = 36" and 2 more inches is 38"), how do you sub-
tract 2" from 37

>> Expression: 3'-2"
38.0

The trick is to put parentheses around the three feet so that AutoCAD doesn’t assume the
next expression is part of the same feet-inches expression, as shown here:

>> Expression: (3')-2"
34.0

Here AutoCAD takes the three feet (36") and subtracts 2" to get 34.
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Figure 12-14: Drawing a line from the midpoint between the
centers of the two circles

In this expression, AutoCAD actually calculates the average between the coordi-
nates of the centers of the two circles. If you subtract coordinates, as in the follow-
ing expression, CAL gives you the change in X and Y, not the length between the
two coordinates. In the following expression, two endpoints on a line were chosen:

>> Expression: end-end 4 > Select entity for END snap:
>> Select entity for END snap:
(-57.3212 -20.8632 0.0)

Compare this to using the DIST command as shown next. As you can see, the delta
X and delta Y numbers match the CAL results:

Command: '_dist Specify first point: Specify second point:
Distance = 61.0000, Angle in XY Plane = 20, Angle from XY Plane
=0

Delta X = 57.3212, Delta Y = 20.8632, Delta Z = 0.0000

To calculate the length of the line, use the abs function from the list of mathemati-
cal functions in Table 12-3. The following expression shows how this works:

>> Expression: abs(end-end) J
>> Select entity for END snap:
>> Select entity for END snap:
61.0
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You can easily use CAL as a substitute for the From object snap. For example, at the
Specify first point: prompt you can enter ' cal .l and type mid+[3,-2.5] .
AutoCAD prompts you for the object for which you want the midpoint and starts
the line (3,-2.5) units from there.

Using mathematical functions

CAL supports many mathematical functions typical of a scientific calculator.
Table 12-3 lists these functions.

A real number is any positive or negative number. Type large numbers without
~~  commas. AutoCAD restricts you to integers between —32768 and +32767 but real
numbers (numbers with decimal places) can be larger.

Table 12-3

CAL Mathematical Functions
Function What It Does
sin(angle) Calculates the sine of the angle.
cos(angle) Calculates the cosine of the angle.
tang(angle) Calculates the tangent of the angle.
asin(real) Calculates the arc sine of the real number.
acos(real) Calculates the arc cosine of the real number.
atan(real) Calculates the arc tangent of the real number.
In(real) Calculates the natural log of the real number.
Log(real) Base-10 log of the number
exp(real) Calculates the natural exponent of the real number.
exp10(real) Calculates the base-10 exponent of the real number.
sqr(real) Calculates the square of the real number.
sqrt(real) Calculates the square root of the real number.
abs(real) Calculates the absolute value of the real number (the number not

round(real)
trunc(real)
r2d(angle)
d2r(angle)
pi

including its + or — sign), also used to calculate lengths.
Rounds the number to its nearest integer.

Truncates any decimal value leaving only the integer.
Converts radian angles to degrees.

Converts degree angles to radians.

Returns the constant pi.
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Using CAL's special functions

CAL has a set of special functions that you can use to find points. Table 12-4 lists
most of these functions and what they do. You can find a complete list in the
AutoCAD Command Reference.

Table 12-4
Special CAL Functions
Function What It Does
rad Gets the radius of the selected object.
cur Gets any point that you pick.
@ Gets the last point calculated.
vec(p1,p2) Calculates the vector from point p1 to point p2.

vecl(p1,p2)
pld(p1,p2,dist)

plt(p1,p2,t)

dist(p1,p2)
dpl(p.p1.p2)

ang(p1,p2)

ang(v)

ang(apex,p1,p2)

ill(p1,p2,p3,p4)

Calculates a one-unit vector from point p1 to point p2.

Calculates a point on the line from point p1 to point p2 that is dist
units from point p1; if dist is 0.327, calculates the point 0.327 units
from p1.

Calculates a point on the line from point p1 to point p2 that is t
proportion from point p1; if t is 0.45, calculates the point 0.45 of the
distance from p1 to p2 (or almost halfway between them).

Calculates the distance between point p1 and point p2.

Calculates the distance from point p to the line from point p1 to
point p2.

Calculates the angle between the X axis and the line from point p1
to point p2.

Calculates the angle between the X axis and a vector you define; an
example of a vector would be (end-end) where you pick the two
endpoints of a line.

Calculates the angle between the lines from apex to point p1 and
apex to point p2; (the apex is the vertex of the angle).

Calculates the intersection of two lines from p1 to p2 and from p3
to p4.

A vector is a direction, which is expressed as delta X, delta Y.

e
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Remember that you can specify these points in many ways, most commonly by
object snaps. You can use the cur function to pick any point on the screen.

Onthéx‘\ The drawing used in the following Step-by-Step exercise on using the CAL com-
icnw | mand (AutoCAD'’s calculator), ab12-a.dwg, is in the Drawings folder of the
K / AutoCAD 2004 Bible CD-ROM.

Y,

Step-by-Step: Using CAL

1. Open abl12-a.dwg from the CD-ROM if you do not have it open from the previ-
ous exercise.

2. Save the drawing as ab12-01.dwg in your AutoCAD BibTe folder.

3. If you did not do the previous exercise, use ZOOM Window to zoom in to the
parcels labeled D and E, as shown in Figure 12-15.

Bt AP K. BTG RON, 5

\ f%s‘f%& %)
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G J Fl| B E
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Figure 12-15: Parcels D and E in the civil engineering
drawing

4. In the exercise on calculating area earlier in this chapter, you calculated a
total area of 306975.04, in units of inches. To calculate what that is in square
feet, type cal . At the Expression: prompt, type 306975.04/144 1. AutoCAD
calculates 2131.77.

5. In the Step-by-Step exercise on the DIVIDE command earlier in this chapter,
you divided a line into three segments by placing two points on the line. You
can use CAL to calculate the length of those segments. Type cal .. At the
Expression: prompt, type abs(end-end)/3 .. AutoCAD prompts you for the
two endpoint snaps. Pick the two ends of the line at @ in Figure 12-15.
AutoCAD calculates 262.37.
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6. Suppose that you want to draw a line starting from the intersection of two
intersecting lines going from corner to diagonally opposite corner and ending
perpendicular to the top line of the land parcel. Start the LINE command. At
the Specify first point: prompt, type 'cal .. At the Expression: prompt,
type ill(end,end,end,end) 1. AutoCAD prompts you for four endpoints. Pick
the endpoints (in Figure 12-15) at @ and @ to define the first line, and then at
© and @ to define the second line. AutoCAD starts the line at the intersection
of the two lines. At the Specify next point or [Undo]:: prompt, choose
the Perpendicular object snap and pick @. Figure 12-16 shows the result.
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Figure 12-16: Using CAL, you can calculate the
intersection of two lines without drawing the lines.

7. Save your drawing.

Summary

AutoCAD stores a great deal of information in each drawing. In this chapter you
read about:

4+ Getting a general status listing

4 Listing system variable settings

4 Tracking drawing time
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4 Getting information about individual objects by using the LIST, DIST, and ID
command

4 Calculating area and perimeters

4 Using the Properties palette to display all of an object’s properties

4+ Dividing and measuring objects by placing point objects along them

4 Using AutoCAD’s calculator to use calculated results as part of your command
input

In the next chapter, I explain how to create and edit text.

+ o+






Creating Text

All drawings include text that labels or explains the
objects in the drawing. Such text is called annotation.
In each release, AutoCAD has improved the capabilities of its
text objects so that you can now easily format and edit text to
provide a professional appearance to your drawing. A wide
array of font, alignment, and spacing options are available.
You can also import text from a word processor. This chapter
tells you all you need to know about creating text in AutoCAD.

Creating Single-Line Text

/Note

A great deal of text in a drawing consists of short labels or
comments. Use single-line text when you want each line of
text to be a separate object or when you are creating a small
amount of text. Single-line text has fewer options than the
multiline text that I explain later in this chapter, but it is easy
to create and to place accurately in a drawing.

Creating a single line of text using the defaults for font, height,
and so on is very simple. Choose Draw &> Text => Single Line
Text. This starts the DTEXT command. DTEXT stands for

dynamic text. You can see the text on the screen as you type it.

Follow the prompts:
Current text style: "Standard"

0.2000

Specify start point of text or

[Justify/Stylel: Pick a start point for the

text.

Specify height <0.2000>: Type a height, or

press Enter to accept the default.

Specify rotation angle of text <0>: Type a

rotation angle, or press Enter to accept the

default.

Enter text: Type one line of text. Press Enter

when you are finished.

Enter text: Press Enter to end the command.

Text height:

You must actually press Enter to end the command. You
~—~  cannot use the Return button of the mouse or the
Spacebar.

CHAPTER

¢+ e
In This Chapter

Creating and editing
single-line text

Understanding text
styles

Creating, editing,
and formatting

multiline (paragraph)
text

Managing text to
improve performance

Using the Find
command

Checking spelling

¢+ 4+
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%

The next section covers the Justify option. The Style option is discussed later in
this chapter.

Single lines of text are very common in drafting. DTEXT continues to prompt you
for lines of text so that you can type line after line. Unfortunately, you cannot con-
trol the spacing between the lines.

\Software\Chapl13\ARRT on the CD-ROM. It (for the TEXT command) and
Idt (for DTEXT) let you specify the spacing between lines of text as you create
them. Look in \Software\Chapl13\TIt.

Onthe“}f\ You can use it to fit text into a schedule or other chart in your drawing. Look in
»

| cn-@w .

Thanks to Leonid Nemirovsky, http://home.pacifier.com/~nemi, for creating
It.Tspand 1dt.1sp at my request.

One advantage of DTEXT is that each line of text is a separate object, making it easy
to move or copy individual lines of text.

AutoCAD remembers the location of the previous line of text even if you have used
other commands in the meantime. To continue text below the last line of text you
created, press Enter at the Specify start point of text or
[Justify/Style]: prompt.

LEADER and QLEADER commands. Chapter 14 covers the QLEADER command.

@ You can also create text connected to arrows that point to objects, using the
elerence

Justifying single-line text

When you pick a start point for text, the relationship between the start point
and the actual letters is determined by the justification. The start point is also
called the insertion point. When you want to refer to text by using object snaps,
you use the Insert object snap. If you select text without first choosing a com-
mand, grips appear at the insertion point as well at the bottom-left corner.

By default, text is left-justified. To change the text’s justification, right-click and
choose Justify at the Specify start point of text or [Justify/Stylel:
prompt. AutoCAD responds with this bewildering prompt:

Enter an option
[Align/Fit/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]:

Align and Fit offer two ways to fit text into a specified space. Both respond with the
same two prompts:

Specify first endpoint of text baseline:
Specify second endpoint of text baseline:
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Specify the beginning and the end of the text line. Align then prompts you for the
text and then squeezes or stretches the text to fit within the text line. The height of
the text changes accordingly to maintain the proportions of the font.

Fit adds the Specify height <0.2000>: prompt. Type in the height you want and
then type the text. Fit also squeezes or stretches the text to fit within the text line
but maintains the text height you specified, distorting the font letters to fit the
space. Figure 13-1 shows an example of normal, fitted, and aligned single-line text.

Steps to grade

Steps to grade
Steps to grade

Figure 13-1: Normal (left-justified),
aligned, and fitted text

The other justification options specify the placement of the text’s insertion point in
relationship to the text line. They are shown in Table 13-1. Each insertion point is
marked with a small x.

Table 13-1
Text Justification Options
Example Option Description
LCa rage Left Because this is the default justification,

AutoCAD provides no suboption for left-
justification when you choose the Justify
option. The insertion point is on the
baseline.

39 rage Center Text is centered around the insertion point.
The insertion point is on the baseline.

ard ge Right Text is right-justified from the insertion point.
The insertion point is on the baseline.

Cara ge Middle Text is centered both vertically and
horizontally. The vertical center point is
measured from the bottom of the lowest to
the top of the tallest possible letter.

Continued

341
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Table 13-1 (continued)

Example

Option

Description

TGorane

Garage
Garage

{>arage

Garage

Garage

\zarage

argge

Garage

Top Left

Top Center

Top Right

Middle Left

Middle Center

Middle Right

Bottom Left

Bottom Center

Bottom Right

Text is left-justified and the insertion point is
at the top of the highest possible letter. For
some fonts the insertion point appears
slightly above the highest letter; for others it
appears exactly at the top.

Text is centered and the insertion point is at
the top of the highest possible letter.

Text is right-justified and the insertion point
is at the top of the highest possible letter.

Text is left-justified and centered vertically.
The vertical center point is measured from
the bottom of the lowest to the top of the
tallest possible letter.

Text is centered both horizontally and
vertically. The vertical center point is
measured from the bottom of the lowest to
the top of the tallest possible letter.

Text is right-justified and centered vertically.
The vertical center point is measured from
the bottom of the lowest to the top of the
tallest possible letter.

Text is left-justified. The insertion point is
below the lowest descending letter. For
some fonts the insertion point appears
slightly below the lowest letter; for others, it
appears exactly at the bottom.

Text is centered. The insertion point is below
the lowest descending letter.

Text is right-justified. The insertion point is
below the lowest descending letter.

If you know the option abbreviation of the justification you want, you can use it at
the Specify start point of text or [Justify/Stylel: prompt.If you
choose a justification that centers or right-justifies, the text does not appear with
the proper justification until after you press Enter for the second time and return to
the command prompt.
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Setting the height

Setting the height of text is fairly straightforward. The default is 0.2 units but this is
not suitable for all applications. The main point to consider is the scale factor. If
you are drawing a house and plan to plot it at 1"=8' (1=96), you need to figure out
how big to make the text so that you can still read it when it is scaled down.

For example, if you want the text to be 0.2 units high and your scale factor is 96,
your text needs to be 19.2 inches high (0.2 x 96). On the other hand, if you are draw-
ing a very small object, such as a computer chip and your scale is 0.10, your text
needs to be 0.02 inches high. The dimension text in Figure 13-2 is five inches high,
but at a scale factor of 64, it plots at %: inches high.

Figure 13-2: The dimension text in this drawing is
5 inches high.

AutoCAD calculates text height in units. Most word processors calculate text
height in points. A point is % of an inch. Therefore, 12-point text, a standard for
most business letters, is about 0.17 inches high. The default of 0.2 units, if you are
using inches as your unit, is just over 14 points, which is usually appropriate for
annotating a drawing. (You don’t usually hold a drawing as closely as you do a let-
ter, so a larger point size is appropriate.)

For information about changing the scale of text, see the section “Editing single-line
text” later in this chapter.

Setting the rotation angle

The final prompt in DTEXT is the rotation angle. This angle applies to the entire
line of text, not to individual characters. (You can specify slanted text — AutoCAD
calls it obliqued text —using the STYLE command covered later in this chapter.)
Figure 13-3 shows text rotated at 315 degrees.
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.
\ 3 ol

Figure 13-3: Text rotated at 315 degrees

Adding special characters and formatting

The DTEXT command does not offer the same type of formatting options available
for paragraph text (covered later in this chapter). Therefore, you have to use spe-
cial codes to create special characters and formats. These codes are shown in

Table 13-2.

Table 13-2

Special Character Codes for AutoCAD Text Fonts

Code

Results

%%0
%%%u
%0%d
%C%p

%9%c

Toggles overscore mode on/off.

Toggles underscore mode on/off.

Draws degree symbol (°).

Draws plus/minus tolerance symbol (+).

Draws circle diameter dimensioning symbol (@).

Figure 13-4 shows text using some of these codes, along with the entries that

created them.

N

The drawing used in the following Step-by-Step exercise on creating text with
DTEXT, al3-ab.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

& /,--" CD-ROM.
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5.3 not 35.8 %%u35.3%%u not 35.8
21.5 %%c1.5

+.002 %%p.002

Figure 13-4: Using special characters and
formatting with AutoCAD text fonts

Step-by-Step: Creating Text with DTEXT
1. Open ab13-a.dwg from your CD-ROM.

2. Save the file as ab13-01.dwg in your AutoCAD Bible folder. This is a master
bathroom plan drawing, as shown in Figure 13-5. Make sure OSNAP is on. Set
running object snaps for endpoint, midpoint, and intersection.

3. Choose Draw => Text &> Single Line Text. Follow the prompts:

Current text style: "ROMANS" Text height: 0'-4 1/2"

Specify start point of text or [Justify/Stylel: Right-click
and choose Justify.

Enter an option [Align/Fit/Center/Middle/Right/TL/TC/TR/ML/
MC/MR/BL/BC/BR]1: Right-click and choose BC.

Specify bottom-center point of text: Use the Midpoint running
object snap to pick @ in Figure 13-5.

Specify rotation angle of text <0>: Pick the endpoint at @.
Enter text: 2-0 4

Enter text: 4
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Figure 13-5: The master bathroom
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4. Start the DTEXT command again. Follow the prompts:

Specify start point of text or [Justify/Stylel: Right-click
and choose Justify.

Enter an option
[Align/Fit/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]:
Right-click and choose Middle.

Specify middle point of text: Pick @ in Figure 13-5. (This
point doesn't have to be exact.)

Specify rotation angle of text <45>: 0 4

Enter text: %%UMASTER BATH .

Enter text: 4

5. Save your drawing. It should look like Figure 13-6.
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Figure 13-6: The master bathroom plan drawing with added single-line text

Using the TEXT command

The TEXT command was AutoCAD’s original command for creating text. DTEXT was
an update, showing the characters on your screen as you typed. The relationship
between these commands is as follows:

4 When used in a drawing, the TEXT and DTEXT commands function identically.

4 You can type -text on the command line to get the original TEXT behavior,
which ends the command after one line of text.

4 Only the TEXT commands works in script files, menus, or AutoLISP routines.

Editing single-line text

As with any drawing object, the need often arises to edit your text. You can edit
single-line text in two ways.
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The most common way to edit single-line text is to use the DDEDIT command.
Double-click the text. Remember that each line of text created with DTEXT or TEXT
is a separate object. AutoCAD opens the Edit Text dialog box with your text high-
lighted in an edit box, as shown in Figure 13-7. You can start typing to completely
replace the text or click where you want to change part of the text and use standard
Windows techniques to edit the text. Click OK or press Enter to make the changes
and return to your drawing.

E] Edit Text B[]

Tt %%UNDTES

[ ok ][ Concel | [ Helo |

Figure 13-7: The Edit Text dialog box

If you start the DDEDIT command by choosing Modify > Objects > Text <> Edit (or
., typing DDEDIT on the command line), you are prompted to select an annotation

"4 object. Select the object and the Edit Text window opens. When you click OK, you

are again prompted to select an object. The command continues to prompt you
for objects until you press Enter at the prompt. Use this method when you want to
edit several lines of text.

You can also change text using the Properties palette. Select any text object and
click Properties on the Standard toolbar to open the Properties window, as shown
in Figure 13-8. Here you can edit not only the text content but also every other con-
ceivable property, including layer, linetype, lineweight, color, insertion point, justifi-
cation, rotation angle, and several other properties that I cover in the next section
on text styles.

Scaling text

You can now change the scale of selected text (either one text object or several at
once) without moving the text insertion point. The SCALETEXT command scales
text without moving the text insertion point. All the text objects stay in their origi-
nal location.

To use SCALETEXT, follow these steps:

1. Choose Modify &> Object > Text > Scale.
2. Select the text objects to scale.

3. Atthe Enter a base point option for scaling [Existing/Left/
Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR] <Existing>:
prompt, press Enter to use the existing insertion point of the selected text or
choose a new base point. (Your last choice for this prompt becomes the new
default, so if you used another option, type e J.) These options are the same
as the Justify options described earlier in this chapter.

347
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Text Mwas
General B

Color W BylLayer
Layer 0
Linetype — bByla...
Linetype scale 1.0000
Plot style ByColor
Lineweight Byl a...
Hyperlink
Thickness 0.0000

Text
Contents Bath
Style Standard
Justify Left
Height 0.4000
Rotation 0
Width factor 1.0000
Obliquing 0

Text alignment X 0.0000
Text alignmentY 0.0000
Text alignmentZ  0.0000

Geometry
Position X 11.3088
Position Y 3.9974
Position Z 0.0000
Misc
Upside down No =

&l = PROPERTIES

Figure 13-8: The Properties
window lets you edit all text
properties, including text
content, in one place.

. At the Specify new height or [Match object/Scale factor]

<3/32>: prompt, right-click and choose Scale factor to specify a scale factor,
just as you would for the SCALE command (see Chapter 9.) You can also type
a new height or use the Match object option to match the height of the
selected text objects to another existing text object. AutoCAD prompts you to
select an object with the desired height.

. If you chose the Scale factor option, type the factor you want at the Specify

scale factor or [Reference] <2>: prompt.

. If you want to specify the scale factor with reference to existing text or a

value, use the Reference option. At the Specify reference Tength <1>:
prompt, type a length or specify two points that measure the reference length.
At the Specify new length: prompt, type a value or pick two points to indi-
cate the new length.
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Justifying text

The JUSTIFYTEXT command lets you change the justification of selected text
objects without moving the text. To use JUSTIFYTEXT, Choose Modify => Object =>
Text = Justify. Then select the text objects you want to modify. At the Enter a
justification option [Left/Align/Fit/Center/Middle/Right/TL/TC/
TR/ML/MC/MR/BL/BC/BR] <Left>: prompt, right-click and choose the justification
you want.

| HeF dwg, is in the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

k S/

Step-by-Step: Editing Text
1. Open ab13-b.dwg from your CD-ROM.

Onthé“'}f\ The drawing used in the following Step-by-Step exercise on editing text, ab13-b.

2. Save the file as ab13-02.dwg in your AutoCAD Bible folder. This is an air and
vacuum release valve, as shown in Figure 13-9.

3. Double-click the text 1/2" PIPING. The Edit Text dialog box opens. Highlight
the text 1/2 and type 3/8. Click OK. AutoCAD changes the text.

4. Choose Properties from the Standard toolbar. Click Quick Select in the
Properties palette. In the Quick Select dialog box, choose Text from the Object
type drop-down list. In the Operator drop-down list, choose Select All. Click
OK. AutoCAD selects all the text objects in the drawing.

SEWAGE AR AND I3
VACUUM RELEASE

VALVE 1/27 PIPING

AR AND WACUUM RELEASE WALVE
MNLT.S.

Figure 13-9: An air and vacuum release valve
Thanks to the Army Corps of Engineers for this drawing.

5. Choose Layer. From the Layer drop-down list, choose TEXT. Choose Color.
From the Color drop-down list, choose ByLayer. All text is now on the TEXT
layer using the ByLayer color. Press Esc to remove the grips and see the
result.
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6. Select the text at the bottom of the drawing that reads N.T.S. From the grips

you can tell that it has a middle left justification. Choose Modify => Object =>
Text = Justify (or type justifytext J on the command line). At the prompt,
type be .

AutoCAD ends the command. If you want, select the text again to see that the
insertion point grip is now at the bottom center of the text.

. Choose Modify => Object o> Text &> Scale (or type scaletext . on the command

line). Follow the prompts:

Select objects: Select the two lines of text at the bottom of
the drawing.

Select objects: o

Enter a base point option for scaling
[Existing/Left/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR
] <BC>: Type e to use the existing base point.

Specify new height or [Match object/Scale factor] <1/8">:
Right-click and choose Scale factor.

Specify scale factor or [Reference] <2">: Type 1.5 J.

AutoCAD scales the text without moving it.

. If you want, click the Properties palette’s Close button to close it. Save your

drawing.

Understanding Text Styles

You certainly do not always want to use AutoCAD’s default font. AutoCAD lets you
create text styles that give you full creative control over the font, font style (bold,
italic, or both), character width, obliquing angle, and text height. You can even
design backward, upside-down, and vertical text. (Vertical text is like the text you
occasionally see on the spine of a book. It goes down instead of to the right.)

Text styles are similar to layers, which I discuss in Chapter 11. Like a layer, each
text style:

4+ Has a name and several properties.

4 [s saved with the drawing.

4 Can be made current when you want to use it.

4 Can be renamed and deleted.

Creating text styles is part of the typical drawing setup procedure. You should
include text styles in your drawing templates.
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ated using AutoCAD'’s shape files, and TrueType fonts —the fonts used by most
Windows applications. See Chapter 32 for instructions on creating your own fonts.

@ AutoCAD comes with two types of fonts —the original . shx fonts, which are cre-
elerence

Creating a new text style

To create a new text style, choose Format => Text Style. This starts the STYLE
command and opens the Text Style dialog box, shown in Figure 13-10.

E] Text Style ea
Style Name
|sIMPLEX v [ Mew. | [ Rensme.
Fo Coe )
Forit Name Font Sile Height
s
[useBigFont
Effects Previen
[ Upside down Width Factor, |1.000000
[ Backwards Dblique Angle: |0 AaBRCcD
[ Wertical AaBbCD

Figure 13-10: The Text Style dialog box

Choose New to open the New Text Style dialog box, as shown in Figure 13-11. Type
the name of your new text style and click OK. Text style names can be up to 255
characters and can include spaces. AutoCAD returns you to the Text Style dialog
box where you define the new text style.

[l New Text Syle @@ Figure 13-11: The New Text Style dialog box
Style Mame: | stilel
Font

In the Font section of the Text Style dialog box, you specify the font, font style, and
text height. Click the Font Name drop-down list arrow to see the list of fonts. Fonts
with the double-T icon are TrueType fonts. The other fonts are AutoCAD’s own
fonts. AutoCAD fonts are defined in a shape file that has the file name extension
.shp and are compiled into a file with the extension . shx for faster access.

Click a font to choose it. You can see a preview of the font in the Preview section of
the dialog box. The Preview section also has an edit box. Type some characters and
click Preview to see the preview of those characters.
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If the font you have chosen supports different styles, such as bold or italic, you can
choose one of them in the Font Style drop-down box. None of the AutoCAD fonts
supports font styles, but many of the TrueType fonts do.

Type in the height you want for your font. Remember to take into account the scale
factor if necessary.

You can leave the height at zero if you want to be able to vary the text height within
that one style. If the height is zero, AutoCAD prompts you for a height whenever
you use the DTEXT or TEXT command.

Caution If you create a text style using a height other than zero and use that text style when

you define a dimension style, the text style height overrides the text height that
you specify separately in the dimension style. See Chapter 15 for more information
on dimension styles.

Effects

In the Effects section, you specify the orientation, width factor, and oblique angle of
the text style.

The default width of characters is set to 1. You can specify a smaller number to
compress text and a larger number to expand it, as shown in Figure 13-12.

width=15 Bearing Housing
width= 8 Bearing Housing

Figure 13-12: Text using different width factors

The oblique angle refers to the angle of the individual letters. It is generally used to
create an effect, such as italic text. Of course, you don’t need to use an oblique
angle if you are using a TrueType font that supports italic text.

The angle definition used to define oblique text is different from the angle definition
used for other objects. Up and down text —that is, normal text —is a zero oblique
angle. A positive angle slants the text to the right —typical for italic text. A negative
angle slants the text to the left. Figure 13-13 shows text with a positive and negative
oblique angle.

Oblique angle=-10 Bearing Houzing

Oblique angle= 10 Bearing Housing

Figure 13-13: Text using differing oblique
angles
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You can create text that is backward (like a mirror image) or upside-down. Some
fonts let you create vertical text. Figure 13-14 shows an example of each kind of
text. Check the appropriate check box to create the effect you want.

2ve-10 owd

DM 3A-3A2

N~lWwi~lw O=sd

Figure 13-14: Vertical, backward, and
upside-down vertical text

After you finish defining your text style, click Apply to make it current. Click Close
to return to your drawing.

Renaming and deleting text styles

You can rename and delete text styles easily. To rename a text style, start the STYLE
command to open the Text Style dialog box. Choose Rename to open the Rename
Text Style dialog box, as shown in Figure 13-15. It works just like the New Text Style

dialog box.
E]l Rename Text Style (&%
Style Mame: notes

Cancel

Figure 13-15: The Rename
Text Style dialog box

To delete a text style, choose it from the Style Name drop-down list of the Text Style
dialog box and click Delete. AutoCAD asks you to confirm. Click Yes to delete the
text style. You cannot delete a text style that is being used.

0nthe—“\ The drawing used in the following Step-by-Step exercise on creating text styles,
, cn@“ | abl13-b.dwg, isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

\
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Step-by-Step: Creating Text Styles
1. Open ab13-b.dwg from your CD-ROM.
2. Save the file as ab13-03.dwg in your AutoCAD BibTe folder.

3. Choose Format => Text Style to open the Text Style dialog box. Click New. In
the New Text Style dialog box, type Notes and click OK.

4. From the Font Name drop-down list, choose romans . shx. In the Height text
box, change the height to 1/16". In the Width Factor text box, change the
width factor to .95. In the Oblique Angle text box, type 10. Click Apply to
make the new style current. Click Close.

5. Start the DTEXT command. At the Specify start point of text or
[Justify/Style]: prompt, pick a start point at the lower-left corner of the
drawing. At the Specify rotation angle of text <0>: prompt, press
Enter. At the Enter Text: prompt, type Note: Not drawn to scale. .. Press
Enter again to end the command.

6. Save your drawing. It should look like Figure 13-16. If you are going on to the
next exercise, keep this drawing open.

SEWAGE AR AND X
VACUUM RELEASE
VALVE

AR AND VACUUM EELEASE WALWVE
NLUT.S.

Hote: Mol druwn to seole,

Figure 13-16: You have added text by using a new
text style.

Modifying a text style

To change a style, choose Format = Text Style. From the Style Name drop-down list,
choose the text style you want to change. Make changes the same way you did
when creating the style. Choose Apply and then Close. AutoCAD regenerates the
drawing and changes all text that uses the style you changed. This is a powerful
way to control the look of text in your drawing.

ﬁlote Unfortunately, only changes to the font and text style affect current text. Other
~  changes, such as width factor, oblique angle, orientation, and height, are ignored.
However, new text takes on these other changes.
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To change existing text to another text style, choose Properties from Standard tool-
bar and select the text. In the Properties palette, choose a new text style in the Text
Style drop-down list.

Making a style current or changing a text

= y
object’s style
You can choose the current style when you use one of the text commands. If you
use DTEXT or TEXT, AutoCAD displays the Specify start point of text or
[Justify/Style]: prompt. Right-click and choose Style. (AutoCAD displays the
current style and height before the prompt.) If you know the name of the style you
want to use, type it and press Enter. AutoCAD repeats the Specify start point

of text or [Justify/Style]: prompt. You can choose the Justify option or
pick a start point to continue the command.

\ _ The new Styles toolbar makes is easier to make a style current or change the text
style of existing text. To make a style current, choose the style from the Text Style
Control drop-down list. To change the text style of existing text, select the text and
choose a new style from the list.

If you use MTEXT, the Multiline Editor opens, as explained in the next section.
Choose the text style you want from the Style drop-down list.

Importing a text style
As explained in Chapter 11, you can use the DesignCenter to import features from
other drawings. To import a text style, follow these steps:
1. Choose DesignCenter from the Standard toolbar to open the DesignCenter.
2. In the left pane, navigate to the drawing that has the text style you want.
3. Double-click the drawing icon or click its plus sign.
4.

To see the list of the text styles, double-click the text styles icon in either the
left or right pane.

5. Double-click the text style’s icon to import it into your drawing.

. Click the DesignCenter’s Close button to close the DesignCenter.

ﬁ‘\ The drawing used in the following Step-by-Step exercise on changing text styles,

; cn@“ | ab13-3.dwg, isin the Results folder of the AutoCAD 2004 Bible CD-ROM.

- Step-by-Step: Modifying Text Styles

1. If you have ab13-03.dwg open from the previous Step-by-Step exercise,
continue to use it for this exercise. Otherwise, open ab13-03.dwg from the
Results folder of your CD-ROM.
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2. Save the file as ab13-04.dwg in your AutoCAD Bible folder.

3. The note at the bottom-left corner of the drawing uses the Notes text style.
Choose Format => Text Style. In the Text Style dialog box, make sure NOTES
is the style name listed, and then choose italic.shx from the Font Name
drop-down list. Choose Apply and then Close.

4. AutoCAD regenerates the drawing and changes the text’s font.

5. Save your drawing.

Creating Multiline Text

New
Feature

New
Feature

Single-line text is awkward when you want to type quite a bit of text. The main dis-
advantage is that single-line text does not use word wrap, a feature that wraps text
to the next line to keep a neat right margin. Multiline text (also called paragraph
text and not to be confused with multilines) solves this problem and also offers
many more formatting options compared to single-line text. The entire paragraph of
multiline text is one object.

N\ AutoCAD 2004 introduces a new frameless Multiline Text editor. New features
include tabs and indenting. Many of the features that were previously on tabs in
the Multiline Text Editor are now available from a shortcut menu that you access
by right-clicking anywhere in the text area.

The Multiline Text Editor that you use to create multiline text resembles Windows
word processors. You use this box both to create and also to edit text and its
properties.

Using the Multiline Text Editor

A To create paragraph text, choose Multiline Text from the Draw toolbar. This
starts the MTEXT command. AutoCAD tells you the current style and text
height. For example:

Current text style: ROMANS. Text height: 4 1/2"

AutoCAD continues with the Specify first corner: prompt. Specify one corner
of a bounding box to specify where to place the text. At the Specify opposite
corner or [Height/Justify/Line spacing/Rotation/Style/Width]: prompt,
specify the diagonally opposite corner of the bounding box. You can also choose one
of the other options to specify the text properties before you type in the text. Some
of these options are also available in the Multiline Text Editor, which opens after you
have specified the bounding box. Figure 13-17 shows the Multiline Text Editor.

N\ When you specify the corners of the Mtext box, you see sample text at the cursor
to give you an idea of the actual current height of the text. You can change the
sample text with the new MTJIGSTRING system variable.
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Text Formatting

Standard o] & T M u oK.

R RREY! .‘.‘.|‘

Figure 13-17: The Multiline Text Editor

Type your text in the large edit box. The Multiline Text Editor wraps the text to the
next line when AutoCAD senses that the text has met the right side of the bounding
box you specified. Although you have created a bounding box with four sides,
AutoCAD only limits the text by the paragraph width, that is, the left and right
margins. If you type too much text for the bounding box, AutoCAD expands the
Text Editor.

e

When you type, the text may be enlarged or reduced in size. This can be discon-
certing, but when you close the editor, the text takes on the correct size. To stop
the text from resizing and the MText Editor from floating, set the MTEXTFIXED sys-
tem variable to 1.

To format selected or new text, use the buttons on the Multiline Editor’s toolbar:

4 Style: Choose any text style from the Style drop-down box.
4 Font: Choose any font from the Font from the drop-down list.

4+ Text Height: Choose a height from the drop-down list or type a new height in
the Text Height box.

4 Bold: If Bold is supported for the font, select text and click Bold.
4 Italic: If Italic is supported for the font, select text and click Italic.
4 Underline: Select text and click Underline.

4 Undo: Undoes recent editing operations.

4 Redo: Redoes recent editing operations.

4+ Stack/Unstack: Toggles stacking and unstacking fractions. Use this option to
stack characters that are not numerals and not immediately before or after
the three AutoStack symbols (slash, pound sign, and carat). Select the text
and click Stack/Unstack. See the next section for more details.

4 Color: Choose ByLayer or any color from the Color drop-down box. To choose
from additional colors, choose Select Color to open the Select Color dialog
box. (See Chapter 11 for details on using this dialog box.)
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Tip To create an exponent (or superscript), type a number and then a carat, as in 2.
Select the number and the carat and click the Stack/Unstack button. To create a
4  subscript, type a carat, and then the number, as in #2, and stack it.

Right-click in the editor to display the shortcut menu. The shortcut menu contains
many important controls that are no longer available elsewhere. You have the fol-
lowing options:

4 Undo: Undoes the last Mtext edit.

4+ Redo: Redoes the last undo operation.

4 Cut: Places selected text in the Windows clipboard and removes it from the
editor.

4 Copy: Place selected text in the Windows clipboard.
4+ Paste: Places text from the Windows clipboard.

4 Indents and Tabs: Opens the Indents and Tabs dialog box, as shown in
Figure 13-18. You can set the following:

¢ First line indentation: Sets the indentation for the first line of the
paragraph.

¢ Paragraph indentation: Sets the indentation for every line of the para-
graph except the first line. Use this indentation for creating bulleted and
numbered lists.

Tip To indent an entire paragraph, use both first line and paragraph indentation.

L\

e Tabs: Type the location of each tab.

Tip It's easier to set indentation and tabs on the Multiline Editor's ruler than in the dia-
log box. Drag the first line indent marker (the top triangle at the left of the ruler) or
the paragraph indent marker (the bottom triangle) to the left or right. To set a tab,
click on the ruler where you want the tab. To delete a tab, drag a tab marker off the

L\

ruler.

& Indents and Tabs @@ Figure 13-18: Use the new Indents and
Indentation Tah stop position Tabs dialog bOX to set IndentS and tabs
First line: 0.8000 f text

e or your text.

Paragraph:

0.0000
Set
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4+ Justification: Choose a justification from the submenu. The justifications are
discussed in the “Justifying single-line text” section earlier in this chapter.

4 Find and Replace: Opens the Replace dialog box so that you can find or
replace specified text. If you want the search to match the case of the speci-
fied text, choose Match Case. If you want the search restricted to whole words
that match the specified text, choose Whole Words. To find text, ignore the
Replace text box. To both find and replace text, enter text in both boxes. Make
sure that the cursor is at the beginning of the text if you want to search the
entire Mtext object.

4+ Select All: Selects all the text.

4+ Remove Formatting: Removes formatting, such as bold and italic. Does not
remove color or font changes.

4+ Combine Paragraphs: Combines separate paragraphs into one. First select
the paragraphs that you want to combine.

4+ Change Case: Changes the case of selected text to uppercase or lowercase.

4 AutoCAPS: Automatically changes newly typed and imported text to upper-
case, even if the Caps Lock key is not on. (And it’s a cute pun on AutoCAD.)

4 Symbol: Inserts the degree, plus/minus, or diameter symbol. You can also
insert a non-breaking space. Or choose Other to open the Windows Character
Map to choose any of the available symbols. Click a symbol, and then click
Select. Click Copy and then click the Close button to close the Windows
Character Map. In the Text Editor, press Ctrl+V to paste in the symbol.

4 Import Text: Opens the Select File dialog box, which lets you choose a text
(.txt) or Rich Text Format (. rtf) file to import. Find the file, choose it, and
click Open. AutoCAD inserts it into the Multiline Text Editor. The maximum
file size is 16 kilobytes. Other techniques for importing text are covered later
in this chapter.

Rich Text Format preserves formatting from application to application. Text-only
documents retain no formatting.

After you finish creating multiline text, close the editor in one of three ways:

\

Feature

4 Click OK on the Text Formatting bar
4 Click anywhere outside the Multiline Text Editor (but inside the drawing area)
4 Press Ctrl + Enter

You can snap to the corners of the Mtext bounding box using the Node Object
Snap. (See Chapter 4 for an explanation of object snaps.)
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Creating stacked fractions automatically

You can create automatic stacked fractions and tolerances as you type, using a system sim-
ilar to those described earlier for creating special characters with DTEXT/TEXT.

You can also type unstacked fractions (as in 1/2), select the fraction text, and then click
Stack/Unstack on the Character tab. To create stacked fractions as you type, open the
Multiline Text Editor and follow these steps:

1. Type the numerator (or text that you want on top).
2. Type the character that defines the fraction format you want:
¢ Type a slash (/) to create a fraction separated by a horizontal line.
¢ Type a pound symbol (#) to create a fraction separated by a diagonal line.

e Type a carat (2) to create a tolerance stack, which is like a fraction separated
by a horizontal line except that there is no horizontal line.

3. Type the denominator.

4. Type a space (or other nonnumeric character). AutoCAD opens the AutoStack
Properties dialog box.

5. Change any settings you want to change and click OK. AutoCAD creates the stacked
fraction.

To use the settings in the AutoStack Properties dialog box:
4 Uncheck Enable AutoStacking to disable the automatic stacked fraction feature.

4 Uncheck Remove Teading blank if you want to retain a space between whole
numbers and fractions.

4 Choose whether you want the slash to result in a fraction with a horizontal line or a
fraction with a slash. This choice has no effect on how the pound sign and carat work.
If you want the slash to result in a fraction with a slash (which would seem to make
more sense), you have no automatic way to create a fraction with a horizontal line.

4 Check Don't show this dialog again; always use these settings to stop
the dialog box from opening when you create automatic stacked fractions.

4 Click OK to create the stacked fraction or Cancel to leave the numbers as you typed
them.

AutoStack only works with numerals immediately before and after the slash, pound sign,
and carat.

You can also set the properties of individual stacked fractions. Right-click the fraction in the
Multiline Text Editor and choose Properties from the menu. In the Stack Properties dialog
box you can change the following properties:

4 Text: Edit the upper and lower text.
4 Style: Change the fraction style. (See the sidebar figure for the three possible styles.)
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4 Position: Position the fraction so that the top, center, or bottom is aligned with
other text.

4 Size: Change the size of the numbers that make up the fraction. Fraction numbers
are usually smaller than regular numbers.

[8)8%]

«~—— Typed as 3/5

??/5 ~—— Typed as 3#5
% <«— Typed as 37b

Specifying and changing line spacing
You can specify the spacing between lines in multiline text. Line spacing is useful
for fitting text into a schedule or table in your drawing. To set line spacing:

1. Start the Mtext command.

2. At the Specify first corner: prompt, pick the first corner of your
Mtext box.

3. At the next prompt, Specify opposite corner or [Height/Justify/
Line spacing/Rotation/Style/Width]:, choose Line spacing.

4. At the Enter Tine spacing type [At Teast/Exactly] <Exactly>:
prompt, choose Exactly.

5. Atthe Enter 1ine spacing factor or distance <1x>: prompt, type a
number, such as 1 to specify a one unit space between lines of text. (If you
type 1x, you get single line spacing, which varies according to the size of
the text.)

6. Then continue with the command.

This setting persists for future Mtext objects. To change existing line spacing, select
(but do not double-click) the multiline text. Open the Properties palette and set one
or more of the following:

4 Line space factor: Specifies line spacing as a multiple of lines. Single line
spacing is 1.0000; double line spacing is 2.0000.

4 Line space distance: Specifies line spacing in units. Use this measurement
(along with a line space style of Exactly) to fit text into an existing table or
schedule.
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4 Line space style: Choose At Least (the default) to adjust line spacing based on
the height of the largest charter in the line of text. Choose Exactly to specify
line spacing that is the same regardless of differences in character height.

Specifying and changing width and rotation
To change the width of an Mtext object, you can use its grips:
1. Select the Mtext object.

2. Click one of the grips that you want to stretch to make it “hot.” (For instructions
on using grips to edit objects, see Chapter 10.)

3. At the Specify stretch point or [Base point/Copy/Undo/eXit]:
prompt, pick a new location for the grip, to make the multiline text wider or
narrower.

You can use the Properties palette to change the width and height. You can specify

the exact width when creating the Mtext object by using the Width option after you
specify the first corner of the Mtext box. Otherwise, you generally specify the width
by picking the two corners of the Mtext box.

Tip When the Multiline Text Editor is open, you can change the width of the Mtext
_»_ object by dragging on the right edge of the ruler. You can also change the width of
4 the editor itself by dragging on the right edge of the editor box.

To rotate an existing Mtext object, use the Properties palette or use the grips:

1. Select the Mtext object.
2. Click one of the grips to make it “hot.”
3. Right-click and choose Rotate.

4. At the Specify rotation angle or [Base point/Copy/Undo/Reference/
eXit]: prompt, pick a new location for the grip or type a rotation angle.

You can also specify the rotation while creating the Mtext object. Use the Rotate
option that appears on the command line after you specify the first corner.

Editing paragraph text

To edit paragraph text, double-click the text to open the Multiline Text Editor.

“‘\lote If you choose single-line text created with TEXT or DTEXT, AutoCAD opens the Edit
~—  Text dialog box (refer to Figure 13-7).

Make your changes in the edit box. The techniques are similar to those in any word
processor. Your options are:
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4+ Select text and press Del to delete the text or type to replace the selected text.

4 Click to move the insertion point to where you want to insert text and start
typing. (To type over text, press Insert to enter overtype mode.)

4+ Use the toolbar or shortcut menu to change formatting.

To change characters, you must first highlight the characters. This lets you make
height or font changes to individual words or even letters. When changing proper-
ties that affect the entire paragraph, such as justification, you do not first highlight
the characters.

gg the ) \ Mmt combines two MText objects into one MText paragraph. Look in \Software\
Ch13\Mmt.

L

Importing text

As mentioned earlier, you can import text from the Multiline Text Editor. You can
import text in three other ways:

4 You can use drag-and-drop to insert text into a drawing. Open Windows
Explorer and locate the file. It should be a text (. txt) or Rich Text Format
(.rtf) file. Position the Explorer window so that you can see the file name
and your AutoCAD drawing at the same time. Click the file and drag it to your
drawing. Close Windows Explorer and move the text to the desired location.

4 You can copy text from another file to the Windows clipboard. Open the
other file, select the text, and choose Copy from the Standard toolbar. Return
to your drawing by clicking the AutoCAD button on the Windows Taskbar.
Choose Paste from the Standard toolbar. The OLE Properties dialog box
opens (by default). Specify the properties of the object and click OK.

4 If you are in the Multiline Text Editor, you can paste the text directly into the
editor. Right-click in the editor and choose Paste (or use Ctrl+V). You can then
format the text.

- Cross- For more information on importing text, see Chapter 27.
Reference

On the 1) The files used in the following Step-by-Step exercise on creating multiline text,
CD. abl3-c.dwg and ab13.txt, are in the Drawings folder of the AutoCAD 2004

\ Bible CD-ROM.

Step-by-Step: Creating Multiline Text
1. Open ab13-c.dwg from your CD-ROM.

2. Save the file as ab13-05.dwg in your AutoCAD BibTe folder. This is a plat
drawing, as shown in Figure 13-19.
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Figure 13-19: The plat drawing

Thanks to Bill Maidment of Cantech, Inc,, Fairfield, lowa for this drawing.

3. Choose Multiline Text from the Draw toolbar. At the prompts, pick points @
and @ in Figure 13-19. The Multiline Text Editor opens. In the Text Height box,
change the height to 12.5. In the main editing box, type the following:

Containing 108.33 acres including 5.97 acres existing R.O.W. and 4.56 acres
proposed R.O.W.

4. Highlight the text 108.33 and click Underline. Right-click in the text window
and choose Justification => Middle Left. Click OK AutoCAD places the text.

5. Do a Zoom Window around the table at the lower-right corner of the drawing,
so that the table takes up about half the drawing area. Start the MTEXT com-
mand. Follow the prompts:

Specify first corner: Pick @ in Figure 13-19.

Specify opposite corner or [Height/Justify/Line
spacing/Rotation/Style/Width]l: Right-click and choose Height.
Specify height <10>: 60 J

Specify opposite corner or [Height/Jdustify/Line
spacing/Rotation/Style/Width]l: Right-click and choose Line
spacing.

Enter Tine spacing type [At Teast/Exactly] <At least>: Right-
click and choose Exactly.

Enter Tine spacing factor or distance <1x>: 100 d

Specify opposite corner or [Height/Justify/Line
spacing/Rotation/Style/Widthl: Pick @ in Figure 13-19.

The Multiline Editor opens. Depending on your zoom, the text cursor may be
larger or smaller than the rows of the table, which is okay.
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6. If necessary, drag the right and bottom edges of the editor’s text area to
approximately match the size of the table. You may also need to drag the
right side of the ruler itself to match the width of the table. At the tab line just
to the right of the vertical line of the second column, click in the ruler to add a
tab. You see a small “L” to indicate a tab at this location.

7. Click at the left of the first line. Type the following table, pressing the Tab key
to move from column to column and pressing Enter at the end of each line.
Use the Spacebar before the acre figures in the last three rows to line up the

numbers.

1 22.93
2 2.85
3 1.51
4 1.38

8. Click anywhere outside the Multiline Text Editor to close the editor and see
the results. The text should be lined up in the table. Choose Zoom Previous to
see the entire drawing again.

9. Open Windows Explorer (Usually Start => Programs = Windows Explorer).
Find ab13.txt on your CD-ROM. Move the Windows Explorer window so that
you can see both ab13. txt and your AutoCAD screen. Drag ab13.txt from
the Windows Explorer window to @ in Figure 13-19. If necessary, pick a grip,
press the Spacebar once to choose the Move option and click at the proper
location.

10. Select the text and open the Properties palette. (Click Properties on the
Standard toolbar.) Next to the Width item, type 500 . Next to the Height item,
type 12.5 ..

11. Use ZOOM Window to zoom in on the new text. You can see how %%d became
the degree symbol. This text was originally single-line text in an older
AutoCAD drawing. You can see why you wouldn’t want to retype it!

12. Choose Zoom Previous on the Standard toolbar to return to your original
view. Save your drawing.

Managing Text

Text is a complex object type. Text greatly increases drawing size and adds redraw
and regeneration time. The more complex fonts, such as the TrueType fonts, can
have a huge impact on how long it takes to open and save a file. The three tech-
niques described in this section help you to manage text and improve performance
while editing your drawing. The last section introduces a way to control the mirror-
ing of text objects.
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Tip

When you draw in three dimensions, you need to figure out how to combine

2 three-dimensional models with two-dimensional text. You can use the HIDETEXT

(8

system variable to choose whether you want text to act like a 3D or a 2D object.
Use the On setting, the default, if you want text to be hidden behind other objects
and to hide other objects when you use the HIDE command, such as other 3D
objects. If you use the Off setting, text will not hide other objects, or be hidden,
unless it has a thickness. (See Chapter 21 for more on the HIDE command and
adding a thickness to objects.)

Using Quicktext

The QTEXT command replaces all text with rectangles that approximate the
placement of the original text, as shown in Figure 13-20. All text objects, including
dimensions, attributes, and tolerances, are affected. To use QTEXT, type qtext . on
the command line. Type on J to get the rectangles; Type off . to return to regular
text. Then type regen . at the command line. Quicktext takes effect only after a
regeneration. It does not apply to OLE objects that you have pasted into a drawing
from the Windows clipboard. (See Chapter 27.)

Figure 13-20: A drawing with QTEXT on. Rectangles have
replaced all the text.
Thanks to Rod Greer of R. G. Greer Design, Inc., Fergus, Ontario for this drawing.

Using AutoCAD fonts

AutoCAD fonts are simpler than TrueType fonts, and some AutoCAD fonts are
simpler than others. The simplest font is txt . shx, the font used by the default
Standard text style. You can easily define a text style using an AutoCAD font and
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then change the font to something nicer just before plotting. AutoCAD immediately
changes the font of all text using that style. Be aware that the text may take up
more or less space than before.

When AutoCAD cannot find the specified font, it uses an alternate font. This may
happen if you receive a drawing done by someone else that uses a custom or third-
party font that you don’t have. You can specify the alternate font by choosing
Tools => Options and clicking the plus sign next to Text Editor, Dictionary, and Font
File Names on the Files tab. Choose Alternate Font File to specify the alternate font,
which is simpTex.shx by default.

You can further control the fonts used by AutoCAD by customizing the Font
Mapping File, \acad. fmp. The format is current_font; font_to_substitute. You
need to use the actual file names of the fonts. To substitute a simpler font for the
Arial Black font, you could add the following line:

Ariblk.ttf;simplex.shx

To find the Windows TrueType fonts, look in the Fonts subfolder of your Windows
folder.

To find acad. fmp, choose Tools => Options and click the File tab. Double-click Text

~  Editor, Dictionary, and Font File Names. Double-click Font Mapping File. Click the

New
Feature

path list to view the location of acad. fmp. AutoCAD only reads the font-mapping
file when it opens a new drawing, so that any changes you make are effective only
after you start a new drawing.

Freezing text layers

Freezing text layers can help regeneration time dramatically —a good reason to
give text its own layer. Don’t forget to freeze dimension text, too. Dimensions are
usually placed on a separate layer (see Chapter 14).

Using MIRRTEXT

When you mirror sections of your drawing that include text, you usually don’t want
backward text (unless you are Alice going through the looking glass). The MIRRTEXT
system variable controls whether text is mirrored or retains its normal orientation.

\ The default value for MIRRTEXT is now off, so that mirrored text is not backward.
The text is copied to the mirrored location, but reads from left to right (if that is the
direction of the language you are using).
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If you do want to mirror the text, type mirrtext .. At the New value for
MIRRTEXT <0>: prompt, type 1 dto turn MIRRTEXT on. This system variable is
saved with the drawing, so that you may still need to change it when you open
older drawings.

On théﬁ‘c-\ The drawing used in the following Step-by-Step exercise on managing text, ab13-d.
i co, | dwg, isin the Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Managing Text
1. Open ab13-d.dwg from your CD-ROM.

2. Save the file as ab13-06.dwg in your AutoCAD Bible folder. This is a small
section of an electrical schematic, as shown in Figure 13-21. Make sure
ORTHO and OSNAP are on and set running snaps for endpoint, midpoint, and

intersection.
[GMNITION MODULE
ﬁ“ o
RED
|@\ POWER |
BRN | \
O VALVE
BLK | |
|o‘ SENSOR |
|o‘ GROLND |
_
(2]

Figure 13-21: A section of an
electrical schematic

3. Type qtext . At the Enter mode [ON/OFF] <OFF>: prompt, type on_.l.
Type regen .. AutoCAD replaces the text with rectangles.

4. Type qtext .. At the Enter mode [ON/OFF] <ON>: prompt, type off .. Type
regen .I. AutoCAD redraws the original text.
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5. Start the MIRROR command. Follow the prompts:

Select objects: Start a window by picking @ in Figure 13-21.
Specify opposite corner: Pick @. Press Enter to end object
selection.

Specify first point of mirror line: Use the Midpoint running
object snap to pick the midpoint at @.

Specify second point of mirror line: Pick any point vertical
to the first point.

Delete source objects? [Yes/No] <N>: d

AutoCAD mirrors the objects and the text. The text is backward.
6. Choose Undo from the Standard toolbar.

7. Type mirrtext . At the Enter new value for MIRRTEXT <1>: prompt,
type 0 .

8. Repeat the mirror operation using the same instructions as in Step 5. This
time AutoCAD mirrors the objects, but the text reads properly, as shown in
Figure 13-22.

IGNITION MODULE

RED

|

BRN
WaLVE

|

BLK
SENSOR

GROUND

gl
s

Figure 13-22: The text on the right was
mirrored with MIRRTEXT set to 0.

9. Save your drawing.

Express Tools has a number of text routines that you may find very helpful. Table
13-3 lists these tools. See Appendix A on the CD-ROM for information on installing
Express Tools.
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Table 13-3
Express Tools for Text
Command Menu Description
RTEXT Express = Text=> Displays text from an outside file. You
Remote Text can specify the text style, height, and
rotation. Use RTEDIT on the command
line to edit remote text.
TEXTFIT Express = Text=> Stretches or shrinks Text objects (but
Text Fit not MText) to fit between two points.
TEXTMASK Express = Text=> Creates a wipeout, 3D face, or 2D solid
Text Mask object behind the text with a little extra
space around the text. You can use this
to make text on top of a hatch more
legible.
TEXTUNMASK Express = Textw> Removes a text mask.
Text Unmask
TXTEXP Express > Textr> Transforms Text or Mtext into
Explode Text geometrical shapes.
TXT2MTXT Express = Text=> Converts Text objects to Mtext objects.
Convert Text to MText
ARCTEXT Express = Text > Aligns text along an arc.
Arc-Aligned Text
TORIENT Express = Text=> Rotates multiple text, Mtext, and
Rotate Text attribute definitions to a specified angle
without moving them or aligns them so
that they are horizontal or right-side up
for easy reading.
TCIRCLE Express = Text > Encloses selected Text or Mtext inside a
Enclose Text with Object  circle, slot (a rectangle but with arcs at
each end), or a rectangle.
TCOUNT Express = Text=> Numbers lines of text by adding a prefix,
Automatic Text suffix, or overwriting the text.
Numbering
TCASE Express = Text=> Offers the following ways to change
Change Text Case the case of text: uppercase, lowercase,

sentence case, title case, and toggle
case.
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Finding Text in Your Drawing

In a large, complex drawing with a lot of text, you may have difficulty finding spe-
cific text that you need to edit. The FIND command lets you find and replace text
anywhere in your drawing —not only single-line text and multiline text but also text
in block attributes, dimensions, and hyperlinks.

To use the FIND command, choose Edit = Find to open the Find and Replace dialog
box, as shown in Figure 13-23.

E] Find and Replace 2% ]

Find text stiing Seaichin

fivatve v Enlie drawing v

Replace nith:
[ ~| [Coptens. |

Search results:

Contest
#%UAIR AND VACUUM RELEASE WALWEX%U

Figure 13-23: The Find and Replace
dialog box finds text anywhere in your
drawing.

Here’s how to use the Find and Replace dialog box:

1. Type the text you want to find in the Find text string text box. Use the
drop-down list to choose recently used text strings.

2. If you want to replace the text you find with new text, type it in the Replace
with text box. This box also includes a drop-down list of recently used text
strings.

3. If you want to limit or expand the scope of your search, use the Search in
drop-down box. If you selected objects before starting the FIND command,
this drop-down list displays Current selection. You can choose Entire Drawing
from this list. You can also click the Select objects button to return to your
drawing and select objects. The FIND command then limits its search to
selected objects.

4. Choose Options to specify the type of text FIND will search. By default it
searches all types of text. You can also choose the Match case and Find whole
words only options.
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5. Click Find (Next) to find the next instance of the text string. The dialog box
displays the text in the context of the text around it.

6. Click Replace to replace the text string with the replacement text. Click
Replace All to replace all instances of the text string with the replacement text.

7. If the Search in drop-down list is set to Current selection, you can click Select
All to return to your drawing with all instances of the text string you have
searched for selected. AutoCAD tells you on the command line how many
objects it has selected. You can use this to delete all these objects, for example.
Also, because the objects have grips, it is easy to locate them in your
drawing —this is useful for a drawing large enough so that you can’t read the
text when you have the entire drawing displayed on your screen.

8. Use the Zoom To button to zoom in to a selection that the FIND command has
found. You can then edit the text. As with the Select All button, this feature is
useful for large drawings where the text is not legible unless you zoom in.

9. After you are finished, click Close to close the dialog box.

Checking Your Spelling

“\Iote

If you take pride in the accuracy of your drawings, you might as well make sure that
the text is spelled correctly. Use the SPELL command to check your spelling.
AutoCAD’s spelling checker acts just like the one in your word processor.

Choose Tools => Spelling and select some text objects to open the Check Spelling
dialog box, as shown in Figure 13-24. You can type all J to check the spelling for the
entire drawing.

Spell checking also checks text inside blocks. See Chapter 18 for the full explanation
~—  of blocks.

E] Check Spelling B[]
Current dictionary: American English

Current word Cancel
Suggestions:

ET [ lghore ] [ Ignare Al ]
E>T< [ LChange ] [ Change Al ]
EXT

it [ 8w | [ Lookw |
EX.

Change Dictionaries..
Contest
EXT

Figure 13-24: The Check Spelling
dialog box
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You have the following options:

4 Ignore: Choose Ignore to ignore the current instance of this word only.
4+ Ignore All: Choose Ignore All to ignore all instances of this word.

4+ Change: Select the suggested word you want and choose Change to change
the current instance of the word to one of the suggested words.

4 Change All: Select the suggested word you want and choose Change All to
change all instances of the word to one of the suggested words.

4 Add: Choose Add to add the word to the dictionary. The word will not appear

again as misspelled.

4 Lookup: Use this if you type a word in the Suggestion text box and want to
check its spelling. AutoCAD then lists words similar to the word in the
Suggestion text box.

AutoCAD automatically moves from word to word until you see the message
Spelling Check Complete.

Strangely enough, if you don't have any misspelled words in your drawing, you

_»_ cannot open the Check Spelling dialog box. AutoCAD simply issues the Spelling

(8

Check Complete message. The trick is to insert a misspelled word and then use
the SPELL command. You can erase or correct the word afterward.

Customizing the spelling dictionary

You can change the main and custom spelling dictionaries. To change the spelling
dictionaries, choose Change Dictionaries from the Check Spelling dialog box to
open the Change Dictionaries dialog box, as shown in Figure 13-25.

P =~
E] Change Dictionaries (8] %]
M ain dictionary Apply & Close
|Amemcan English [V] [ Cancel ]
Custam dictionary
C:A\Documents and SettingsE ligah Finkelst
Custam dichionary words
Add
sz z
ALIS 3
AutoCAD 3
AutoCDM
Autodesk.
AutoEDM [w]

Figure 13-25: The Change Dictionaries
dialog box
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The main dictionary comes with AutoCAD and is not customizable. You can choose
from various languages depending on your version of AutoCAD. For example, my
list lets me choose from American English, British English (ise), British English
(ize), French with unaccented capitals, and French with accented capitals.

The custom spelling dictionary is the dictionary you add to when you click Add in
the Check Spelling dialog box. It is a simple text file that includes words that you
have added during spelling checks, as well as a list of AutoCAD-related words
already included by AutoCAD. To see these words, scroll down the list in the
Custom dictionary words section of the Change Dictionaries dialog box.

You can add words to the custom dictionary by typing them in the Custom dictio-
nary words text box and clicking Add. This feature lets you add a number of words
at one time.

Another way to edit the custom dictionary is to open the file directly with a text edi-

_»,  tor. The AutoCAD custom dictionary is called sample.cus. To find sample.cus,

(8

choose Tools=> Options and click the File tab. Double-click Text Editor, Dictionary,
and Font File Names. Double-click Custom Dictionary File. Click the path list to view
the location of sample.cus.

Figure 13-26 shows sample.cus opened in Notepad, the Windows text editor.

Figure 13-26: Opening sample.cus in
Notepad so that you can edit it directly

& Sample.cus - Notepad 9|=)]*]

File Edit Format View Help

laC aD

ACIS
AUTOCAD
AUT OCDM
Autodesk
AUTOEDM
AutoFT1ix
AutoLathe
AUTOLISP
autoshade
autosketch
Autosolid
Autosurt
Autovision

You can use a different custom dictionary. It can be useful, for example, to use the
same dictionary in AutoCAD as you use in your word processor. For example, here’s
how to use the Microsoft Word dictionary:

1. Find Word'’s custom dictionary. If necessary, choose Start = Find and use the
Windows Find dialog box to find the file. It is called custom.dic. As with the
AutoCAD custom dictionary, you can open it with Notepad and edit it directly.

2. As explained in the previous Tip, find the location of sample.cus. Use
Windows Explorer to copy the file to that folder. You can hold down Ctrl as
you drag it from one folder to another or use the right mouse button to click
the file, choose Copy, and then paste it in its new location.
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3. Click custom.dic to highlight it. Click it again and change its file name exten-
sion to . cus. Press Enter. (Windows asks you if you are sure you want to do
this. Click Yes.)

4. Click Change Dictionaries in the Check Spelling dialog box to open the Change
Dictionaries dialog box. In the Custom dictionary text box, type in the name of
the dictionary file, or choose Browse, find it, and click Open.

5. Click Apply & Close to return to the Check Spelling dialog box and then Cancel
to return to your drawing.

Summary

In this chapter, you learned how to create, edit, and manage text. You read about:

4+ Using DTEXT and TEXT to create single-line text

4+ Editing single-line text

4 Scaling and justifying text without moving it

4 Creating text styles to control the formatting of your text

4 Utilizing MTEXT for creating and editing paragraph text, including using the
new Multiline Text Editor

4 Importing text
4 Managing text for fastest display

4 Finding and replacing text and how to check spelling in your drawing
In the next chapter, you read how to create dimensions.

+ o+ ¢






CHAPTER

Drawing
Dimensions

+ ¢+

In This Chapter

) . . Working with
Dlmensmns are an important part of most AutoCAD AutoC AgD,s
drawings. Dimensions indicate the measurement of the dimensions

models you have created and are used in the manufacturing
process. AutoCAD’s dimensions offer a great deal of flexibility.
In this chapter, I cover the process of drawing dimensions.

In the next chapter, I explain how to customize the format of
your dimensions by using dimension styles.

Drawing linear and
aligned dimensions

Dimensioning arcs,
circles, and angles

Working with AutoCAD’s Creating ordinae
Dimensions

Dimensioning is usually done after you complete all or most of

Drawing leaders

a drawing. Dimensioning a drawing all at once lets you create Editing dimensions
a unified, organized look for your dimensions. Before you can
dimension drawing, you need to understand the elements of a + + + +

dimension and how to prepare for dimensioning.
r Cross- In Chapter 17, | explain how to dimension a drawing on a
Reference
paper space layout.

The elements of a dimension

A dimension is a complex object, containing many parts.
Understanding these parts and how they relate to the object
you are dimensioning is an important first step. Figure 14-1
shows a typical linear dimension.
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Arrowhead Dimension text Dimension line

-~ 4.7500 -

~——Extension line

Line object
Figure 14-1: The parts of a dimension

The parts of a dimension are:

4+ Extension lines: These extend from the dimensioned object to the dimension
line and arrowheads. A small gap usually separates the dimensioned object
and the start of the extension lines. Extension lines visually clarify the extents
of the object being dimensioned.

;‘\lote In dimensions, the word extension (or extend) is used in two other ways besides

‘ ~—  referring to extension lines. First, the extension line itself usually extends not only
from the object being dimensioned but past the dimension line. You can specify
the amount of this extension. Also, in architectural dimensions, the dimension line
extends past the extension lines. You can specify this extension as well.

4+ Dimension text: This tells you the actual measurement of the dimensioned
object. You can format this text in decimals, fractions, scientific units, and
SO on.

4 Dimension line: This extends between the extension lines.

4 Arrowheads: These mark the intersection of the dimension line and the
extension lines. They can take several forms, such as tick marks, open arrows,
or dots.

Dimensions have two interesting properties that you need to understand before
you can successfully work with them.

4+ Dimensions are blocks. | have mentioned blocks before, and they are fully
covered in Chapter 18. Blocks are groups of objects that you can manipulate
as one object. As a result, if you pick a dimension, all parts of the dimension
are selected.



Tip

Chapter 14 + Drawing Dimensions

4+ Dimensions are associative. This means that an association connects the
dimension and the object it dimensions. If you change the size of the object,
AutoCAD automatically adjusts the dimension.

All the parts of a dimension can be formatted individually. You generally format
a dimension by creating a dimension style, which is a named set of formats for
dimensions —just as a text style is a named set of formats for text. Dimension
styles are the topic of the next chapter.

Preparing to dimension

Before starting to create dimensions, you should prepare as follows:

L\

1. Create a layer for your dimensions. It is important that dimensions be easily
distinguishable from the rest of your drawing. The color is usually a contrast
to that of your models. For example, if your models are black (and you are
working on a white screen), you might want your dimensions to be green,
magenta, or cyan.

If you often turn layers on and off (or freeze and thaw them), you may want to cre-
ate a separate dimension layer for each layer of drawing data. For example, if you
dimension an electrical layer that you turn off regularly, you can have a special
Dim-elec dimension layer that you can turn off with the electrical layer.

2. If you are dimensioning an existing drawing that was created in a pre-2002
version of AutoCAD, turn on associative dimensioning with the DIMASSOC
system variable. Type dimassoc on the command line and type 2 . at the

prompt. (You can also choose Tools = Options, click the User Preferences tab,
and check the check box in the Associative Dimensioning section of the dialog

box. Then click OK.)

3. Create a text style for your dimensions.

Set the height of the text style to zero. You can then set the text height when you
create the dimension style. If you do specify a fixed height in your text style, that
height overrides any height you specify in the dimension style.

4. Choose Tools &> Drafting Settings, click the Object Snap tab, and set the run-
ning object snaps you want. Endpoint and intersection are a necessity. Add
center and quadrant if you need to dimension arcs and circles. Click OSNAP
on the status bar to turn it on.

5. Create a dimension style. The next chapter covers dimension styles.

6. Save your dimension layer, dimension text style, and dimension style in your
drawing templates.
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The Dimension toolbar makes it easy to find the dimension commands quickly. The
Dimension menu offers most of the same commands as the toolbar.

To display the Dimension toolbar, right-click any toolbar and check Dimension from
the list. The list automatically closes. The Dimension toolbar is shown in Figure 14-2.

Diameter Dimension Edit
Ordinate Quick  Tolerance | Update

Linear Continue

|
1
A

Dimension Style

|
¥

,I?H StandardT v

Di

op ]
MY O0A
T A A

2

—ba
S

r®
Ibw—

Aligned Quick

Leader

Radius | Baseline Center Mark| Dim Style Control

Angular Dimension Text Edit
Figure 14-2: The Dimension toolbar

@ The dimensioning command names are generally long. For example, to draw a lin-
elerence

ear dimension, you would type dimlinear .. As briefly mentioned in Chapter 3,
AutoCAD has shortcuts for many commands, including the dimensioning com-
mands, contained in acad.pgp. Chapter 29 covers these shortcuts and how to
create your own.

Drawing Linear Dimensions

Just as the most common objects are lines, the most common dimensions are linear
dimensions.

Use linear dimensions for lines, a straight segment of a polyline, or a straight seg-
ment in a block. You can also use a linear dimension for arcs and circles —you get
the linear length of the arc (not its perimeter length) and the diameter of the circle.

Specifying the dimensioned object

|.._.| To dimension a line, choose Linear Dimension from the Dimension toolbar.
AutoCAD responds with the Specify first extension Tine origin or
<select object>: prompt. You can now either pick two extension line origin
points or press Enter (or right-click) and select an object for dimensioning.
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Make it standard practice to use object snaps for choosing extension line origins.
The point you pick specifies the definition point that determines the final mea-
surement. Also, proper association of dimensions with their objects depends on
the points you specify. Accurate dimensioning requires accurate drawings and
therefore exact specification of the points you want to use for the dimensions.

L\

If you are dimensioning more than one object, such as the distance from the end-
point of one line to the endpoint of another line, pick the first extension line origin.
At the Specify second extension line origin: prompt, pick the second
extension line origin. These two points define the length of the dimension.

If you are dimensioning one object, press Enter (or right-click) at the Specify
first extension Tine origin or <select object>: prompt. AutoCAD dis-
plays the Select object to dimension: prompt. Pick the object.

At the Specify dimension Tine location or [Mtext/Text/Angle/
Horizontal/Vertical/Rotated]: prompt, pick a point for the location of the
dimension line. As you move the mouse, you can see the results on your screen,

as shown in Figure 14-3. If you want an exact location, you can type in a relative
coordinate, such as 0,.5 to specify that the dimension line should be 0.5 units
above the object. Snap mode may also work well for you, depending on the drawing
environment.

\ \\Q Figure 14-3: Picking a dimension line
\\ location for a linear dimension
| _alle |
| S |
Il
Pick point

Dimensioned object

Object snap tracking makes it a snap to pick points for dimensioning. For example,
if you are dimensioning a house, your first extension line origin may be the outside
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corner of the house, but the second extension line origin may be an inner wall. At
the Specify first extension Tine origin or <select object>: prompt,
move the cursor over the inner wall endpoint to acquire it. Move the cursor back to
the line you are dimensioning and click when you see the tooltip showing the snap
point you chose. AutoCAD places the dimension just where you need it.

0nthé\“\ The drawing used in the following Step-by-Step exercise on drawing linear dimen-
| G0 | sions, abl4-a.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

\ /| co-ROM.

Step-by-Step: Drawing Linear Dimensions
1. Open abl14-a.dwg from your CD-ROM.

2. Save the file as ab14-01.dwg in your AutoCAD Bible folder. This is a plan of
a bedroom, as shown in Figure 14-4. ORTHO and OSNAP should be on. Set run-
ning object snaps for endpoint, midpoint, and intersection. The current layer
should be set to Dim.

L i

C ———

5

Figure 14-4: A bedroom plan

3. To display the Dimension toolbar, right-click any toolbar. Click Dimension. If
you want, drag the toolbar to the top or bottom of your screen until it docks.

4. |.._.| Choose Linear Dimension from the Dimension toolbar. At the Specify
first extension line origin or <select object>: prompt, pick
@ in Figure 14-4. At the Specify second extension line origin: prompt,
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pick @. At the Specify dimension Tine location or [Mtext/Text/
Angle/Horizontal/Vertical/Rotated]: prompt, move the cursor to the
right until you have sufficient space for the dimension text and click.

5. Repeat the DIMLINEAR command. At the Specify first extension Tine
origin or <select object>: prompt, press Enter. At the Select object
to dimension: prompt, pick @ (the window) in Figure 14-4. At the Specify
dimension Tine Tocation or [Mtext/Text/Angle/Horizontal/
Vertical/ Rotated]: prompt, move the cursor down until you have suffi-
cient space for the dimension text and click.

6. Save your drawing. It should look like Figure 14-5.

L_\ F

BEDRUOM :

18

114

Figure 14-5: The bedroom with two
linear dimensions

Using dimension options

You can also use one of the options offered at the command prompt to further con-
trol the final dimension. Dimension options control the text and the angle of the
dimension.

MText

The MText option lets you replace the dimension text AutoCAD calculates or add
a prefix or suffix to it. When you right-click and choose MText at the Specify
dimension line Tocation or [Mtext/Text/Angle/Horizontal/Vertical/
Rotated]: prompt, AutoCAD opens the Multiline Text Editor, as shown in

Figure 14-6.
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‘,ﬂ\lote
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Text Formatting

Standard [sv] B T [ve][0 2000 ] u ‘mv] ok

Figure 14-6: Changing the dimension text with the
Multiline Text Editor

The angle brackets represent the dimension text that AutoCAD automatically cre-
ates. The best use of the MText option is to add some text before or after the mea-
surement, such as TYP (for typical —used when one dimension applies to several
objects) or subject to final approval. To add text before the measurement, place
the cursor before the angle brackets. Similarly, to add text after the measurement,
place the cursor after the angle brackets. Add the text and click OK.

If the measurement text itself does not appear the way you want it, you should
change the annotation specifications in the dimension style. You can also specify a
prefix or suffix (such as mm) for all dimensions, as explained in the next chapter.

You can delete the brackets and type your own dimension text, but you lose the
ability of the dimension’s measurement to automatically adjust to any change in the
object’s size.

Typing your own dimension text is most commonly used where a dimension repre-
sents several sizes and refers to a size chart elsewhere in the drawing. For example,
the text “Dim A" might be used for this purpose.

Text

The Text option also lets you change dimension text but does not open the Multiline
Text Editor. Instead, you can quickly retype the entire dimension text as you want it
on the command line.

Angle

The angle of the text (horizontal, vertical, or aligned) is specified in your dimension
style. However, you can use this option to change the angle of the dimension text
for a particular circumstance. Right-click and choose Angle to get the Specify
angle of dimension text: prompt. Type in an angle or pick two points to align
the text with an existing object.

Horizontal/Vertical

The DIMLINEAR command assumes that you want a horizontal dimension if you
select a horizontal object or two definition points running horizontally —ditto for a
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vertical dimension. Also, if you want to draw a vertical dimension of an object at an
angle, you can specify this simply by moving the mouse cursor horizontally when
specifying the dimension line location, as shown in Figure 14-7. If for some reason
you need to force either a horizontal or vertical dimension, you can use the vertical
or horizontal options.

0.5385

%

Figure 14-7: By dragging the mouse cursor to the right,
you can create a vertical dimension for this angled line.
The vertical dimension measures the change in the
Y coordinates of the line, not the length of the line.

Rotated

Use a rotated linear dimension when the length you want to dimension is not paral-
lel to the extension line origins. Just as the vertical dimension in Figure 14-7 does
not measure the length of the line its extension lines extend to, a rotated linear
dimension does not measure a specific object but the distance of an imaginary line
parallel to the dimension line. Rotated dimensions are not very common, but when
you need them they are the only way to get the dimension measurement you need.

To use a rotated dimension, start a linear dimension, pick the two extension line
origins and choose the Rotate option. At the Specify angle of dimension line
<0>: prompt, type the angle (or pick two points). AutoCAD draws the dimension.

Figure 14-8 shows a hexagonal stepping-stone with a rotated linear angle. The exten-
sion lines of the dimension extend to a line at 104.5 degrees, but in this case you
want to measure a length at an angle of 135 degrees. Note that AutoCAD has really
dimensioned an imaginary line parallel to the dimension line, shown in the figure as
a dashed line, rather than the side of the hexagon.
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AN
S

N
zzees ™

Figure 14-8: Drawing a rotated
linear dimension for a hexagonal
stepping stone

0nthé\\ The drawing used in the following Step-by-Step exercise on using linear dimen-
| HhF | sion options, ab14-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

\@/ CD-ROM.

Step-by-Step: Using Linear Dimension Options
1. Open ab14-b.dwg from your CD-ROM.

2. Save the file as ab14-02.dwg in your AutoCAD BibTe folder. This is part of a
plan of a house with an unusual-shaped ceiling, as shown in Figure 14-9.
OSNAP should be on. Set running object snaps to endpoint and intersection.
If the Dimension toolbar doesn’t appear, right-click any toolbar and check
Dimension.

Figure 14-9: A house plan with an
octagonal ceiling
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3. Choose Linear Dimension from the Dimension toolbar. Follow the prompts:

Specify first extension Tine origin or <select object>: Jd
Select object to dimension: Pick @ in Figure 14-9.

Specify dimension Tine location or
[Mtext/Text/Angle/Horizontal/Vertical/Rotated]: Right-click
and choose Angle.

Specify angle of dimension text: Choose @ in Figure 14-9.
Specify second point: Choose @ in Figure 14-9.

Specify dimension Tine location or [Mtext/Text/Angle/
Horizontal/Vertical/Rotated]: Position the dimension Tine
above the wall you dimensioned.

You wouldn't actually dimension an architectural drawing in this style.

4. Repeat the DIMLINEAR command. Follow the prompts:

Specify first extension Tine origin or <select object>: _
Select object to dimension: Pick @ in Figure 14-9.

Specify dimension Tine location or
[Mtext/Text/Angle/Horizontal/Vertical/Rotated]: Right-click
and choose Mtext. In the Multiline Text Editor move the
cursor after the angled brackets and type TYP. Click OK.
Specify dimension Tine location or [Mtext/Text/Angle/
Horizontal/Vertical/Rotated]: Position the dimension line
above the window you dimensioned.

Notice that the text is attached to a leader because it is now too long to fit
between the extension lines.

5. Save your drawing. It should look like Figure 14-10.

Figure 14-10: The dimensioned drawing

387
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Drawing Aligned Dimensions

When you want to dimension a linear object that is not orthogonal, use an aligned
dimension. The dimension lines of an aligned dimension are always parallel to the
object —unlike rotated dimensions. An aligned dimension measures the actual
length of the object, not a vertical or horizontal distance that you dimension with a
linear dimension. Therefore, your choice of linear, linear rotated, or aligned dimen-
sion depends on the distance you want to measure. Figure 14-11 shows several
aligned dimensions.
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Figure 14-11: Three aligned dimensions

Specifying the dimensioned object

4\’ To create an aligned dimension, choose Aligned Dimension from the Dimension
toolbar. This starts the DIMALIGNED command. AutoCAD responds with the
Specify first extension Tine origin or <select object>: prompt. As
with linear dimensions, you can now either pick two extension line origins or press
Enter to select an object.

Because Figure 14-11 shows a cross-section view, there is no single object you can
select. To create the aligned dimensions shown, you need to pick two extension line
origins.

AutoCAD then displays the Specify dimension Tine location or [Mtext/
Text/Angle]: prompt. Pick a point for the location of the dimension line. If you want
an exact location, you can type in a relative coordinate, such as @2<45 to specify that
the dimension line should be 2 units in a 45-degree direction from the extension line
origins you specified.
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Using the options

After you have chosen what you want to dimension, you have three options —
MText, Text, and Angle. The previous section discusses these options in detail.

On the ™ The drawing used in the following Step-by-Step exercise on drawing aligned
i CDW | dimensions, abl4-b.dwg, is in the Drawings folder of the AutoCAD 2004 Bible
& /  CD-ROM.

Step-by-Step: Drawing Aligned Dimensions
1. Open ab14-b.dwg from your CD-ROM.

2. Save the file as ab14-03.dwg in your AutoCAD Bible folder. This is the same
drawing used in the previous Step-by-Step exercise, as shown in Figure 14-12.
OSNAP should be on. Set running object snaps to endpoint and intersection.
If the Dimension toolbar isn’t visible, choose View > Toolbars and check
Dimension. Click Close.

Figure 14-12: A section of a floor plan
of a house

3. 4\’ Choose Aligned Dimension from the Dimension toolbar. Follow the
prompts:

Specify first extension Tine origin or <select object>:
Choose @ in Figure 14-12.

Specify second extension line origin: Choose @ in Figure
14-12.

Specify dimension Tine location or

[Mtext/Text/Anglel: Right-click and choose Mtext. In the
Multiline Text Editor, move the cursor to the right of the
angled brackets and type Typ. Click OK.

Specify dimension line location or

[Mtext/Text/Anglel: Pick a location for the dimension line.



390  Partll + Drawing in Two Dimensions

4. Save your drawing. It should look like Figure 14-13.

]|

[m] 00 ]|

Figure 14-13: The house plan with an aligned
dimension

Creating Baseline and Continued Dimensions

Often, you want to create a whole series of attached, connected dimensions.
AutoCAD offers two ways to accomplish this — baseline and continued dimensions:

4 Baseline dimensions are a series of dimensions that all start from one point.
The first extension line is the same for all the dimensions. The second dimen-
sion includes the first dimension plus an additional distance and so on.

4 Continued dimensions are a series of dimensions that are all attached. The
second dimension starts where the first dimension ends and so on. Each
dimension measures a different object or distance.

Figure 14-14 shows both baseline and continued linear dimensions. You can also
create baseline and continued angular and ordinate dimensions. Quick Dimension,
covered later in this chapter, can quickly create baseline and continued linear
dimensions. Here [ cover the traditional method.
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Figure 14-14: A floor plan of a house using both baseline and continued

dimensions

Drawing baseline dimensions

ir:« To draw a baseline dimension, first create one linear, angular, or ordinate
dimension in the regular way. (Angular and ordinate dimensions are covered
later in this chapter.) Then choose Baseline Dimension from the Dimension toolbar.
AutoCAD responds with the Specify a second extension Tine origin or
[Undo/Select] <Select>: prompt.

If the previous dimension was a linear, angular, or ordinate dimension, AutoCAD
uses its first extension line as the base for the new baseline dimension. Specify a
new second extension line origin, and AutoCAD creates the baseline dimension with
the same first extension origin as the original dimension and the new second exten-
sion origin you just specified.

If you don’t want to work with the previous dimension in the drawing, press Enter.
AutoCAD responds with the Select base dimension: prompt. Be careful to pick
the dimension closer to the side you want to use as the baseline. AutoCAD then
prompts you to specify a second extension line origin. When you do so, AutoCAD
creates the dimension.

AutoCAD continues to prompt you for second extension line origins so that you can
quickly create a chain of baseline dimensions. At each prompt you can right-click
and choose Undo to undo the previous dimension. You can also press Enter at any
time and select a different dimension to work from. Press Esc to end the command
(or press Enter twice).



392

Part Il + Drawing in Two Dimensions

Drawing continued dimensions

W Continued dimensions work similarly to baseline dimensions. To continue a
dimension, first create one linear, angular, or ordinate dimension in the regular
way. Then choose Continue Dimension from the Dimension toolbar. AutoCAD
responds with the Specify a second extension Tine origin or [Undo/
Select] <Select>: prompt.

If the previous dimension was a linear, angular, or ordinate dimension, AutoCAD
uses its second extension line as the beginning of the new continued dimension.
Specify a new second extension line origin, and AutoCAD creates the continued

dimension.

If you don’t want to continue from the previous dimension in the drawing, press
Enter. AutoCAD responds with the SeTect continued dimension: prompt. Be
careful to pick the dimension closer to the side you want to continue from. AutoCAD
then prompts you to specify a second extension line origin. When you do so,
AutoCAD creates the dimension.

AutoCAD continues to prompt you for second extension line origins so you can
quickly create a chain of continued dimensions. At each prompt you can right-click
and choose Undo to undo the previous dimension. You can also press Enter at any
time and select a different dimension to work from. Press Esc to end the command
(or press Enter twice).

gg theﬁl\ The drawing used in the following Step-by-Step exercise on drawing baseline and

K /2004 Bible CD-ROM.

| continued dimensions, ab14-b.dwg, is in the Drawings folder of the AutoCAD

Step-by-Step: Drawing Baseline and Continued Dimensions
1. Open ab14-b.dwg from your CD-ROM.

2. Save the file as ab14-04.dwg in your AutoCAD Bible folder. This is the same
drawing used in the previous two exercises, as shown in Figure 14-15. OSNAP
should be on with running object snaps for endpoint and intersection. If the
Dimension toolbar isn’t visible, right-click any toolbar and check Dimension.

3. Turn on ORTHO and OTRACK on the status bar.

4. Choose Linear Dimension from the Dimension toolbar. Follow the prompts:

Specify first extension Tine origin or <select object>: Pick
the endpoint at @ in Figure 14-15.

Specify second extension line origin: Pass the cursor over @
to acquire it for object snap tracking. Move the cursor to
the right so that it's vertically under @ and click when you
see the 1'-6'<0° tooltip.

Specify dimension Tine location or [Mtext/Text/Angle/
Horizontal/Vertical/Rotated]: Pick a dimension Tine Tocation
to the right of the model.
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5. |...H Choose Continue Dimension from the Dimension toolbar. At the Specify
a second extension line origin or [Undo/Select] <Select>:

prompt, move the cursor over the endpoint or intersection at @ to acquire it
for object snap tracking. Move the cursor to the right, vertically below @ and
click when you see the tooltip. AutoCAD places the continued dimension.
Notice that AutoCAD uses a leader to place the text because there is not
enough room between the extension lines. (If the leader is placed to the left,
select it and pick the grip on the text. Pick a point to the right of the model
and click to move the leader to the right.)

Figure 14-15: The house plan with the
octagonal ceiling

6. AutoCAD repeats the Specify a second extension line origin or
[Undo/Select] <Select>: prompt. Pick the endpoint at @ in Figure 14-15.
AutoCAD places the dimension. Press Enter twice to end the command.

7. Choose Linear Dimension from the Dimension toolbar. Follow the prompts:

Specify first extension Tine origin or <select object>:
Choose the endpoint at @ in Figure 14-15.

Specify second extension line origin: Move the cursor over @
to acquire it. Move the cursor down so that it's horizontal
to @. When you see the 4'0"<270° tooltip, click.

Specify dimension line location or [Mtext/Text/Angle/
Horizontal/Vertical/Rotated]: Pick a dimension line location
fairly close to the line you dimensioned leaving just enough
room for the dimension text.

8. w Choose Baseline Dimension from the Dimension toolbar. At the Specify
a second extension Tine origin or [Undo/Select] <Select>:
prompt, pick the endpoint or intersection at @ in Figure 14-15. Press Enter
twice to end the command.
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9. Save your drawing. It should look like Figure 14-16.
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Figure 14-16: The floor plan with
baseline and continued dimensions

Dimensioning Arcs and Circles

When you dimension an arc or a circle, you measure its radius or diameter. It is also
common to mark arc and circle centers to clarify what you are measuring. Arc and
circle dimensions are most commonly used in mechanical drawings.

Marking arc and circle centers

Circle and arc centers are often marked in mechanical drawings because the center
is an important aspect of a circle or arc but is not obvious without a mark. You set
the size and type of mark when you create a dimension style, as explained in the
next chapter. You can use a center mark (a small cross) or centerlines, as shown in
Figure 14-17.

Choose Center Mark from the Dimension toolbar. At the Select arc or
circle: prompt, pick the arc or circle you want to mark. AutoCAD draws
the mark or lines.

Creating radial dimensions

@ To dimension the radius of a circle or arc, choose Radius Dimension from the
Dimension toolbar. AutoCAD responds with the Select arc or circle:
prompt. Select an arc or circle. At the Specify dimension Tine location or
[Mtext/Text/Angle]: prompt, pick where you want the dimension line to appear.
AutoCAD automatically adds an R before the measurement to indicate the radius, as
shown in Figure 14-18.
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@ Center mark

-+ Centerlines
Figure 14-17: Circles —one with

a center mark and the other with
centerlines

Figure 14-18: This radius dimension uses a leader (a line
and arrow pointing to the object) outside the circle because

F5/15 | the circle is too small to place the dimension inside it.

You can also choose the MText, Text, or Angle option, as described in the “Drawing
Linear Dimensions” section earlier in this chapter.

Creating diameter dimensions

To dimension the diameter of a circle or arc, choose Diameter Dimension from

the Dimension toolbar. AutoCAD responds with the Select arc or circle:
prompt. Select an arc or circle. At the Specify dimension line location or
[Mtext/Text/Angle]: prompt, pick where you want the dimension line to appear.
AutoCAD automatically adds the diameter symbol before the measurement to indi-
cate the dimension, as shown in Figure 14-19.
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Figure 14-19: A diameter dimension

You can also choose the MText, Text, or Angle option, as described in the section
“Drawing Linear Dimensions.”

Dimensioning Angles

AutoCAD offers several options for dimensioning angles. You may want to dimen-
sion the angular relationship between two lines, but the lines may intersect at their
midpoints or may not intersect at all. Therefore, you need to be able to specify the
vertex of the angle you want to dimension. Figure 14-20 shows an angular dimen-
sion with the points used to define it.

ﬁ To create an angular dimension, choose Angular Dimension from the
Dimension toolbar. AutoCAD displays the Select arc, circle, line,
or <specify vertex>: prompt and responds differently depending on what
you select:

4 If you press Enter, AutoCAD asks for the angle vertex, the first angle endpoint,
and the second angle endpoint. These three points define the angle.

4 If you select an arc, AutoCAD dimensions the entire arc, using the arc’s center
as the angle vertex.

4 If you select a circle, AutoCAD uses the pick point as the first angle endpoint
and the circle’s center as the angle vertex. AutoCAD then displays the
Specify second angle endpoint: prompt. Pick a point on the circle.

4+ If you select a line, AutoCAD asks for a second line. AutoCAD measures the
angle between the two lines. If the lines don’t intersect, AutoCAD uses their
implied intersection as the angle vertex.
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Figure 14-20: An angular dimension
Thanks to Mary Redfern of the Bethlehem Corporation,
Easton, Pennsylvania, for this drawing.

After you define the angle, AutoCAD responds with the Specify dimension arc
line location or [Mtext/Text/Angle]: prompt. Pick a point for the dimen-
sion arc line—which is the same thing as a dimension line except that AutoCAD
uses an arc for angular dimensions.

You can also choose the MText, Text, or Angle option, as covered in the section
“Drawing Linear Dimensions.”

In the following exercise, you get to practice drawing radial, diameter, and angular
dimensions.

Onthé“‘\ The drawing used in the following Step-by-Step exercise on drawing radial, diam-
iCD' | eter, and angular dimensions, abl4-c.dwg, is in the Drawings folder of the
\ / AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Drawing Radial, Diameter,
and Angular Dimensions
1. Open ab14-c.dwg from your CD-ROM.

2. Save the file as ab14-05.dwg in your AutoCAD Bible folder. This is a view of
a bearing housing for an industrial washing machine, as shown in Figure 14-21.
OSNAP should be on. Set running object snaps to endpoint, intersection, and
center. If the Dimension toolbar isn’t visible, right-click any toolbar and check
Dimension.
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Figure 14-21: A bearing housing for an
industrial washing machine

Thanks to Robert Mack of the Dexter Company, Fairfield,
lowa, for this drawing.

Choose Center Mark from the Dimension toolbar. At the Select arc or
circle: prompt, pick one of the four small circles at the corners of the
model. Repeat the command for the other three circles.

Choose Diameter Dimension from the Dimension toolbar. At the Select

arc or circle: prompt, choose the circle at @ in Figure 14-21. At the
Specify dimension Tine location or [Mtext/Text/Anglel: prompt,
pick a location for the dimension line.

Choose Radius Dimension from the Dimension toolbar. At the Select

arc or circle: prompt, choose @ from Figure 14-21. At the Specify
dimension line location or [Mtext/Text/Angle]: prompt, pick a location for the
dimension line. The line may appear to the left of the angle; try moving the
cursor until the dimension appears to its right.

. é[ Choose Angular Dimension from the Dimension toolbar. Follow the

prompts:

Select arc, circle, line, or <specify vertex>: d

Specify angle vertex: Pick @ in Figure 14-21.

Specify first angle endpoint: Pick the endpoint at @. (Press
Tab 7f necessary until you see the endpoint tooltip.)
Specify second angle endpoint: Pick the endpoint at @.
Specify dimension arc line location or [Mtext/Text/Angle]:
Choose a location for the dimension line.
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Dimensioning minor, major, and supplemental angles

When two lines meet at an angle, they create two angles —the minor angle and the major
angle. The angle that is less than 180 degrees is the minor angle. The major angle is always
more than 180 degrees. AutoCAD also lets you measure the supplemental angle, which is
the difference between 180 degrees and the minor angle. These angles are shown here.

70,00 290,00 K

Minor Angle Major Angle Supplemental Angle

Here's how you create each type of dimension. Start the DIMANGULAR command. AutoCAD
responds with the Select arc, circle, Tine, or <specify vertex>: prompt.

To dimension the minor angle, select both lines. Then at the Specify dimension arc
Tine Tocation or [Mtext/Text/Anglel: prompt, place the dimension arc line inside
the angle, as shown in the figure. (You can also press Enter, specify the angle vertex and the
two lines, and place the dimension arc line inside the angle.)

To dimension the major angle, press Enter. (Do not select the lines.) At the prompts, spec-
ify the angle vertex and the two lines. At the Specify dimension arc line location
or [Mtext/Text/Anglel: prompt, place the dimension arc line outside the angle, as
shown in the figure.

To dimension the supplemental angle, select both lines. At the Specify dimension arc
Tine Tocation or [Mtext/Text/Anglel: prompt, place the dimension arc line outside
the angle, as shown in the figure.

As you can see, how you specify the angle and where you place the dimension arc line
determine which angle you measure.

7. Repeat the DIMANGULAR command. At the Select arc, circle, Tine,
or <specify vertex>: prompt, pick the arc at @. At the Specify dimen-
sion arc line location or [Mtext/Text/Angle]: prompt, pick a loca-
tion for the dimension line.

8. Repeat the DIMANGULAR command. At the Select arc, circle, line,
or press ENTER: prompt, pick @ in Figure 14-21. At the Second Tine:
prompt, pick @. At the Dimension arc line Tocation (Mtext/Text/
Angle): prompt, pick a location for the dimension line to the left of the model.

9. Save your drawing. It should look like Figure 14-22.

399
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Figure 14-22: The bearing housing with
center marks, radial and diameter dimensions,
and angular dimensions

Creating Ordinate Dimensions

Ordinate dimensions are used in mechanical drawing. They dimension an object
by labeling X or Y coordinates based on a 0,0 coordinate placed somewhere on the
model. Figure 14-23 shows a drawing with some ordinate dimensions.
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Figure 14-23: Ordinate dimensions in a
mechanical drawing of a tension arm for
a commercial dryer
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To place the 0,0 coordinate on the model, choose Tools &> Move UCS. At the prompt,
pick a point on the model, using object snaps for an exact measurement. If you want
to check the UCS, choose View = Display = UCS Icon = Origin. Also make sure On is
checked. As long as there is room, the UCS icon moves to the new 0,0 coordinate.

.+ % To create an ordinate dimension, choose Ordinate Dimension from the

»+— Dimension toolbar. At the Specify feature location: prompt, pick the
part of the model that you want to dimension. Running object snaps with OSNAP
turned on makes this an easy task.

At the Specify leader endpoint or [Xdatum/Ydatum/Mtext/Text/Angle]:
prompt, pick the endpoint for the leader. AutoCAD generally decides whether to
dimension the X coordinate (Xdatum) or Y coordinate (Ydatum) based on where
you pick the leader endpoint. Pick the leader endpoint perpendicular from the coor-
dinate’s axis you want to measure. To measure an X coordinate, move up or down
from the feature you selected. To measure a Y coordinate, move left or right to pick
the leader endpoint.

Usually you work with ORTHO on to create straight lines. If you need to create bent
lines to avoid previously drawn dimensions, turn ORTHO off. If you pick a leader
endpoint at a nonorthogonal angle from the feature, you may need to force
AutoCAD to measure the coordinate you want using either the Xdatum or Ydatum
option. Use the MText option to open the Multiline Text Editor and edit the dimen-
sion text. Use the Text option to change all the text on the command line.

To perfectly line up the dimensions, when specifying the leader endpoint, use object
tracking to track the endpoint of the previous leader. You can also turn on SNAP.

On the The drawing used in the following Step-by-Step exercise on drawing ordinate

o

/  CD-ROM.
.

| CDW | dimensions, ab14-d.dwg, is in the Drawings folder of the AutoCAD 2004 Bible

Step-by-Step: Drawing Ordinate Dimensions
1. Open ab14-d.dwg from your CD-ROM.

2. Save the file as ab14-06.dwg in your AutoCAD BibTe folder. This drawing
shows a simple sheet metal template, as shown in Figure 14-24. Snap should
be on. Set a snap distance of 0.25 units. Right-click the SNAP button on the
status bar and make sure that grid snap is on. If the Dimension toolbar isn’t
visible, right-click any toolbar and check Dimension.

3. Choose Tools => Move UCS. At the Origin point <0,0,0>: prompt, pick @ in
Figure 14-24.

4. & % Choose Ordinate Dimension from the Dimension toolbar. At the Specify
e feature location: prompt, choose @ in Figure 14-24. At the Specify
leader endpoint or [Xdatum/Ydatum/Mtext/Text/Angle]: prompt, pick
a point 0.5 units to the left of @, as shown in Figure 14-25. (Because Snap is on,
this is easy. If necessary, press F6 until you get polar coordinates to display in
the lower-left area of the drawing screen.)
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Figure 14-24: A sheet metal template
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Figure 14-25: The dimensioned template
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5. Repeat the DIMORDINATE command. At the Specify feature location:
prompt, choose @ in Figure 14-24. At the Specify leader endpoint or
[Xdatum/Ydatum/Mtext/Text/Angle]: prompt, pick a point 0.5 units
below @.

6. Continue to dimension the drawing, using Figure 14-25 as a guide. (Tip: Type
multiple ! dimordinate ! so that AutoCAD automatically repeats the com-
mand. Press Esc when you no longer need the command.)

7. Save your drawing.

Drawing Leaders

Leaders are lines pointing to objects. At the end of a leader, you place any text you
want. Use leaders to label objects or provide explanatory text. Leaders are not
associative; that is, AutoCAD calculates no dimension text. Figure 14-26 shows two
leaders.
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Figure 14-26: Using leaders to point to objects and add
explanatory text

I

The QLEADER command provides a simple, easy-to-use method of creating leaders.
The Leader Settings dialog box lets you specify how you want your leaders to
appear. The older LEADER command is still available from the command line.

'@ To create a leader, choose Quick Leader from the Dimension toolbar. At the
Specify first leader point, or [Settings]<Settings>: prompt, if
you want to specify the leader settings, press Enter or right-click and choose
Settings to open the Leader Settings dialog box.

Using the Leader Settings dialog box

The Leader Settings dialog box is shown in Figure 14-27 with the Annotation tab dis-
played. Here you customize how you want your leaders to work so that when you
actually create them, they automatically look the way you want. These settings
determine what prompts you see after you specify all the points of the leader. You
can always change these settings at the first prompt of the QLEADER command.

E] Leader Settings 8]
| Annotation || esder Line & Arraw| Attachment
Annctation Type MText options:
() MText Prampt for width
(O Copy an Object [ by Jet justify
O Tolerance [ Erame test
O Block Reference Annotation Heuse
O Mane (%) None
() Reuse Mest
[ Ok ] [ Cancel ] [ Help ]

Figure 14-27: The Annotation tab of the Leader
Settings dialog box
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The Annotation tab

The annotation tab includes settings about what goes at the end of the leader. In
the Annotation Type section of the dialog box, choose the type of annotation:

4 The default is MText, which creates multiline text.

4+ Choose Copy an Object to have the QLEADER command prompt you to copy
an existing object in your drawing — single line text, multiline text, a block, or
a tolerance.

4 If you choose Tolerance, QLEADER opens the Tolerance dialog box so that you
can create a tolerance control frame. The next chapter covers control frames.

4+ Choose Block Reference if you want QLEADER to prompt you to select an
existing block (a group of objects that are treated as one object) for the anno-
tation. You might have a block consisting of some text and special symbols
that are hard to create from scratch each time. Some users put surface, toler-
ance, or other symbols at the ends of leaders.

4 Choose None to create a leader with no annotation.

If you chose MText, use the MText options section to specify how MText works. You
have three choices:

4+ Choose “Prompt for width” if you want QLEADER to let you specify a bounding
box or a width in units. The advantage of this option, which is on by default, is
that QLEADER wraps the leader text so that it doesn’t get too long if you decide
to get verbose.

4 Choose “Always left justify” if you don’t want to set a width and want instead
to have QLEADER always left-justify text.

4 Choose “Frame text” if you want a box around the text.

The Annotation Reuse section enables you to clone your leader annotation. To
reuse the text you are about to create, choose Reuse Next. QLEADER automatically
uses it for subsequent leaders. (After you use this option, AutoCAD automatically
sets this option to Reuse Current.)

The Leader Line & Arrow tab

Use the Leader Line & Arrow tab, shown in Figure 14-28, to specify how you want
the lines and arrow of the leader to look.
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E] Leader Settings 8]
Annotation || eader Line & Aravw] Atachment
Leader Line: Arrowhead
() Straight - S
O Spline B Clozed filled 52
Mumber of Points Angle Constraints
[ W Limit First Segment: | Ary angle v
3 : Maximum Second Segment | any angle :v
[ Ok ] [ Cancel ] [ Help ]

Figure 14-28: The Leader Line & Arrow tab of the
Leader Settings dialog box

In the Leader Line section, choose either Straight line or Spline leader lines. The
number of points determines how many times QLEADER displays the Specify next
point: prompt. By setting a maximum you can streamline the process of creating
leaders and avoid ungainly looking leader lines with many segments. However, you
can’t set the maximum to less than two.

In the Arrowhead section, use the drop-down list to choose an arrowhead style. The
picture shown of each type of arrowhead helps you decide.

Use the Angle Constraints section to control the possible angle of the first and second
leader lines to conform to standards in your industry or your sense of aesthetics.

The Attachment tab

Use the Attachment tab, shown in Figure 14-29, to specify how MText is attached to
the leader line.

El'Leader Settings (B %]

Annotation | Leadsr Line & Ao EAltachmenlé

Multi-ine Text Attachment

Text on left side Text on right side
@ Top of top line @
0] Middle of top line ®
@ Middle af multi-ine text O
® Middle of bottam line '
i Bottom of bottom line: C

[ Underline bottam line:

[ Ok ] [ Cancel ] [ Help ]

Figure 14-29: The Attachment tab of the Leader
Settings dialog box
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New
Feature

The Attachment tab contains two columns of buttons. The left column sets the
attachment for leaders that you draw from right to left. The arrow is to the right
and the text is therefore on the left of the leader. By default, the leader line points to
the middle of the bottom line of text —that is, to the middle of the last character of
the text.

The right column sets the attachment for leaders that you draw from left to right.
The arrow is to the left and the text is on the right of the leader. By default, the
leader line points to the middle of the top line of that —that is, to the middle of the
first character of the text.

Here are your choices for text on both the left and the right:

4 Top of top line: The leader line meets the text at the top of the first line of
text. The line will point to the top of an uppercase letter.

4 Middle of top line: The leader line meets the text at the middle of the first line
of text, which is halfway between the top and the bottom of an uppercase letter.

4 Middle of multi-line text: The leader line meets the text at the middle of the
invisible bounding box containing all the text.

4 Middle of bottom line: The leader line meets the text at the middle of the
bottom line of text.

4 Bottom of bottom line: The leader line meets the text at the bottom of the
bottom line of text.

Check Underline bottom line to place a line under the bottom line of text. After you
have completed the settings in the Leader Settings dialog box, click OK. AutoCAD
now continues with the QLEADER command.

\ The Express Tools include the QLDETACHSET command, which detaches a leader’s
annotation from the leader line, to create two separate objects. Choose Express =
Dimension = Leader Tools > Detach Leaders from Annotation. QLATTACH attaches
leaders and MText objects. Choose Expresst> Dimensionc>Leader Tools=>
Attach Leader to Annotation. For information about installing Express Tools, see
Appendix A on the CD-ROM.

Creating a leader

As mentioned earlier, when you choose Quick Leader from the Dimension toolbar,
you see the Specify first Teader point, or [Settings]<Settings>:
prompt. You can continue directly to draw the leader or use the Settings option. If
you use the Settings option, once you close the Leader Settings dialog box, AutoCAD
returns you to the original prompt. Now you can specify your first leader point, usu-
ally on or near the object that the leader text labels or explains. The starting point is
usually indicated with an arrow.
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AutoCAD continues with the Specify next point: prompt. You can continue to
pick points, up to the limit specified on the Leader Line & Arrow tab of the Leader
Settings dialog box. Usually you pick the endpoint of the leader before that limit.
Press Enter to stop picking points of the leader.

If the Prompt for Width option has been selected on the Annotation tab of the
Leader Settings dialog box, QLEADER displays the Specify text width
<0.0000>: prompt. You can pick a point and AutoCAD displays a dashed line so
that you can visually determine the width. Otherwise, type a width in units.

At the Enter first line of annotation text <Mtext>: prompt, you have
two choices:

4 To use the current text style, type the first line of text on the command line.
Press Enter at the end of the line. QLEADER displays the Enter next line
of annotation text: prompt. You can continue to type in new lines of text.
Press Enter to end the command.

4+ To open the Multiline Text Editor, press Enter. You then type your annotation
text. You have the advantage of being able to format the text as you work.
Click OK to close the Text Editor and complete the leader.

Onthékl\ The drawing used in the following Step-by-Step exercise on drawing leaders,
| abl4-e.dwg,isinthe Drawings folder of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Drawing Leaders
1. Open abl4-e.dwg from your CD-ROM.

2. Save the file as ab14-07.dwg in your AutoCAD BibTe folder. This is a drawing
of a set of pulleys, as shown in Figure 14-30. If the Dimension toolbar isn’t visi-
ble, right-click any toolbar and check Dimension. OSNAP should be turned off.
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Figure 14-30: A set of pulleys
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3. ,ﬁz Choose Quick Leader from the Dimension toolbar. At the Specify first
leader point, or [Settings]<Settings>: prompt, right-click and
choose Settings. Click the Attachment tab and set both text on the left and on
the right to Middle of multiline text. Click OK.

4. Follow the prompts:

Specify first leader point, or [Settings]<Settings>: Pick @
in Figure 14-30 (near but not on the drawing object).
Specify next point: Pick @.

Specify next point: 4

Specify text width <0>: 2 J

Enter first line of annotation text <Mtext>: BREAK EDGES .
Enter next Tine of annotation text: TYP (8) PLACES u

Enter next Tine of annotation text: o

AutoCAD places the leader.

5. Repeat the QLEADER command. Pick points @ and then @ in Figure 14-30.
Right-click or press Enter. At the Specify text width <2>: prompt, press
Enter to use the same width as previously. At the Enter first Tine of
annotation text <Mtext>: prompt, type DRILL ‘F" HOLE. Press Enter
twice to end the command and place the leader.

6. Save your drawing. It should look like Figure 14-31.
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Figure 14-31: The pulleys with two leaders
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Using Quick Dimension

Quick Dimension enables you to dimension several objects at one time. You can use
Quick Dimension for baseline, continued, and ordinate dimensions. You can also
dimension multiple circles and arcs. Later in this chapter [ explain how you can use
Quick Dimension to edit dimensions as well. While Quick Dimension may seem like
the answer to all your dimension-related prayers, you can’t use it in every case.
However, it works well in “mass production” situations.

New '\ Dimensions created with the QDIM command are now fully associative, so that any
fetis changes you make to objects automatically update their associated dimensions.

Here’s how it works, in three easy steps:
1. M Choose Quick Dimension from the Dimension toolbar.

2. Atthe Select geometry to dimension: prompt, select all the objects that
you want to dimension. You can’t use object snaps; you need to select
objects. If you select an object in error, type r J and then pick the object again
to remove it. Then type a . to start adding objects again.

3. At the Specify dimension line position, or [Continuous/
Staggered/ Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/
SeTtings1<Continuous>: prompt, right-click and choose the type of dimension
you want to create. Figure 14-32 shows a set of continuous dimensions. The
datum point option sets a new base point for baseline and ordinate dimensions.
You can press Enter to use the type of dimension you used just previously
because that shows as the default. AutoCAD immediately creates the dimen-
sions for you.

1

—"I Figure 14-32: A set of continuous dimensions

51413 created with Quick Dimension
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, ch, Dimension to create dimensions, ab14-f.dwg, is in the Drawings folder of the
& / AutoCAD 2004 Bible CD-ROM.

0nthé~‘}\ The drawing used in the following Step-by-Step exercise on using Quick
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Step-by-Step: Using Quick Dimension to Create Dimensions
1. Open ab14-f.dwg from your CD-ROM.

2. Save the file as ab14-08.dwg in your AutoCAD BibTe folder. This is the same
drawing you used in the previous exercise, except that some of the dimen-
sions have been removed (see Figure 14-33). OSNAP should be turned off.

If the Dimension toolbar isn’t displayed, right-click any toolbar and choose
Dimension.

3AE] 3 IT/RA 21
Dl BALS

Figure 14-33: You can use Quick Dimension to
dimension the circles and create continuous dimensions.

3. Choose Quick Dimension from the Dimension toolbar. Follow the prompts:

Select geometry to dimension: Pick the circle at @ in Figure
14-33.

Select geometry to dimension: Pick the circle at @ in Figure
14-33.

Select geometry to dimension: 4

Specify dimension line position, or
[Continuous/Staggered/Baseline/0Ordinate/Radius/Diameter/datum
Point/Edit/SeTtings]

<Staggered>: Right-click and choose Radius.

Specify dimension line position, or
[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datum
Point/Edit/SeTtings]

<Radius>: Pick a point on the left circle at about 80 degrees
from the right quadrant.

Quick Dimension places the radius dimensions.
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4. Repeat the QDIM command. Follow the prompts:

Select geometry to dimension:

14-33.

Select geometry to dimension:

Select geometry to dimension:

at @.

Select geometry to dimension:

at @

Select geometry to dimension:

Pick the Tine at @ in Figure

Pick the line at @ 1n.

Pick the vertical centerline

Pick the vertical centerline

Pick the Tine at @.

Select geometry to dimension:

Specify dimension Tine position, or
[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datum
Point/Edit/SeTtings]
{Staggered>: Right-click and choose Baseline.

Specify dimension Tine position, or
[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datum
Point/Edit/SeTtings]
<Baseline>: Pick a point below the model .

Quick Dimension places the baseline dimensions.

5. Save your drawing. It should look approximately like Figure 14-34.
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Figure 14-34: The model with added radius and baseline

dimensions

4154 —m—]

[ | —pr]

!
ol

\\m i *{
g it

71

q—15fﬁ—-—

11 a3

7% 2o

gk

2

411



412

Part Il + Drawing in Two Dimensions

Editing Dimensions

Dimensions have many properties — text size, arrowhead size, text placement, and
so on. You change most of these properties by changing the dimension style, either
globally changing all dimensions using that style or overriding a dimension style
setting for a particular dimension. The next chapter covers dimension styles, but
here I cover several other ways to edit dimensions.

Editing associativity
By default, new drawings created in AutoCAD 2004 are associative. However, draw-
ings created in releases prior to 2002 will not have the new associativity.

The DIMASSOC system variable specifies whether dimensions are associative. Here
are the settings:

4+ 0 creates exploded dimensions. Each part of the dimension is a separate
object and there is no association between the dimension and the object it
dimensions.

4 1 creates non-associative dimensions. The dimension is all one object but is
not updated if the object it dimensions is changed.

4 2 creates associative dimensions. The dimension is all one object and is
updated if the object it dimensions is changed.

DIMREASSOCIATE

Use the DIMREASSOCIATE command to associate dimensions with their objects.
You need to use this command when you open drawings created in releases of
AutoCAD 2000i or earlier in Release 2004. You might also need to use this command
when dimensions become disassociated from their objects, perhaps through some
editing process, or to reassociate dimensions after you have disassociated them for
some reason.

To use DIMREASSOCIATE, follow these steps:

1. Choose Dimension = Reassociate Dimensions.

2. At the Select objects: prompt, select the dimensions that you want to
associate. Press Enter to end object selection.

You see a prompt that varies according to the type of dimension you have
selected. For example, for linear dimensions, you see the Specify first
extension Tine origin or [Select object] <next>: prompt. At the
same time, you see a marker in the form of an X that corresponds to the
prompt, as shown in Figure 14-35. The marker indicates an association point—a
point that connects an object and all or part of its dimension. If the X has a box
around it, the dimension is already associated with the point marked by the X.
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/‘\lote If you use the wheel of a mouse to pan or zoom, the X disappears. Press Esc and
~  start the command again or type ‘redraw ..

4,280 ‘ |

FLAT BLANE LAYOLT

Figure 14-35: When you associate a dimension with an object,
AutoCAD displays an association point on the object.

3. Use an object snap to specify the location of the X (whether the same as
shown or a different location) or use the Select Object option to select an
object (right-click and choose Select Object). To skip to the next prompt, with-
out associating the dimension to the marked point, press Enter.

4. Continue to respond to the prompts in turn. AutoCAD prompts you through
all the dimensions you selected.

Caution When specifying object snaps, be careful that you choose the point you want. For
example, if you use an Endpoint object snap where two lines meet, you cannot be
sure which line's endpoint you have chosen. When you move or stretch the line
you expect to be associated with the dimension, you may find that the dimension
does not budge. That's because it's actually associated with a different line.
Selecting the object itself is often a better solution, because the dimension is asso-
ciated with the object.

DIMDISASSOCIATE

Occasionally, you may want to edit a dimension in such a way that you need to
remove its associativity. Perhaps you need to squeeze it into a tight corner. For these
times, use the DIMDISASSOCIATE command by typing it on the command line. At the
prompt, select the dimensions that you want to disassociate from their objects.

,Alote AutoCAD does not disassociate dimensions that are on locked layers. Unlock the
~ layer first and then disassociate the dimension.
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DIMREGEN

The DIMREGEN command updates the locations of all associative dimensions. This
command is only needed in three unusual situations:

4 If you pan or zoom with a wheel mouse in a paper space layout while model
space is active

4 If you open a drawing containing dimensioned objects that have been edited
with a previous version of AutoCAD

4 If you open a drawing containing external references that are dimensioned in
the current drawing and dimensioned objects in the external reference have
been changed

Using the DIMEDIT command

A The DIMEDIT command offers four ways to edit dimensions. The advantage
B=4 of this command is that you can change more than one dimension at a time.
Choose Dimension Edit from the Dimension toolbar. AutoCAD responds with the
Enter type of dimension editing [Home/New/Rotate/Oblique] <Home>:

prompt. Right-click to choose one of the options:

4+ Home: Moves dimension text to its default position as defined by the dimen-
sion style.

4+ New: Lets you type new text to replace the existing text. AutoCAD opens the
Multiline Text Editor showing the angle brackets that represent the dimension
text. You can use this option to add a suffix, such as TYP (typical) to several

dimensions.
4 Rotate: Rotates the dimension text. This works like the rotation angle for text.

4 Oblique: Angles the extension lines of the dimension. Use this when you have
several dimensions close together that interfere with each other. Specify the
final angle of the extension lines, not the rotation from the current angle.

x“\lote The Oblique item on the Dimension menu executes the DIMEDIT command with
~  the Oblique option.

As soon as you choose an option, DIMEDIT prompts you to select objects. You can
select as many dimensions as you wish.

You have the opportunity to use the DIMEDIT command in an exercise after the
next section.



Chapter 14 + Drawing Dimensions /415

Using the DIMTEDIT command

hﬁl The DIMTEDIT command repositions dimension text. To start the command,
choose Dimension Text Edit from the Dimension toolbar. Although its name
gives the impression that you can edit the text content, you can only change its
position. You can only edit one dimension at a time. AutoCAD responds with the
Select dimension: prompt. Select a dimension.

At the Specify new location for dimension text or [Left/Right/
Center/Home/Angle]: prompt, you can use the cursor to pick a text location.
You can also right-click and choose one of the options:

4+ Left: Left-justifies the text of linear, radial, or diameter dimensions.

4 Right: Right-justifies the text of linear, radial, or diameter dimensions.
4+ Center: Centers the text of linear, radial, or diameter dimensions.

4+ Home: Returns dimension text to its default position and angle.

4+ Angle: Rotates dimension text. This option is equivalent to the Rotate option
of the DIMEDIT command.

Onth'eh‘c-\ The drawing used in the following Step-by-Step exercise on using DIMEDIT and
,CDW | DIMTEDIT to edit dimensions, abl4-g.dwg, is in the Drawings folder of the
& / AutoCAD 2004 Bible CD-ROM.

Y.

Step-by-Step: Using DIMEDIT and DIMTEDIT to Edit
Dimensions
1. Open ab14-g.dwg from your CD-ROM.

2. Save the file as ab14-09.dwg in your AutoCAD Bible folder. This is a civil
engineering drawing whose dimensions need some editing. It is shown in
Figure 14-36. If the Dimension toolbar isn’t visible, right-click any toolbar and
check Dimension.

3. A The dimension at @ in Figure 14-36 is not in the proper units because
B=H the text was entered explicitly as 14.41. To correct this error, choose
Dimension Edit from the Dimension toolbar. At the Enter type of dimen-
sion editing [Home/New/Rotate/Oblique] <Home>: prompt, right-click
and choose New. The Multiline Text Editor opens, showing the angle brackets.
Because you want the original text, click OK. At the Select objects:
prompt, pick @. Press Enter to end object selection. (You could correct sev-
eral dimensions this way.) AutoCAD corrects the dimension, automatically
creating the text in the current units.
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New
Feature

\

4. hil The dimension text at @ in Figure 14-36 is too close to the dimension line

of the vertical dimension that crosses it. Choose Dimension Text Edit
from the Dimension toolbar. At the Select dimension: prompt, pick @. At
the Specify new Tocation for dimension text or [Left/Right/
Center/Home/Angle]: prompt, right-click and choose Right. AutoCAD
moves the text to the right.

5. Save your drawing.
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Figure 14-36: A dimensioned civil
engineering drawing

The Express Tools command, DIMREASSOC does the same thing you accom-
plished in Step 3 of this exercise, restoring the default measurement value to
modified dimension text. Choose Expressc> Dimension > Reset Dim Text Value.
For information about installing Express Tools, see Appendix A on the CD-ROM.

Editing dimension text

You can edit dimension text as you would any other multiline text object. Choose
Modify > Object > Text => Edit. At the Select an annotation object or
[Undo]: prompt, choose the dimension. AutoCAD opens the Multiline Text Editor.
Using the Multiline Text Editor for dimension text has already been covered in this
chapter under the MText option of the dimensioning commands.
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Using the Object Property Manager
to edit dimensions

You can edit dimensions by using the Properties palette just as you can edit the
properties of any other object. Double-click any dimension to open the Properties
palette. You see the properties of the dimensions that you can edit, as shown in
Figure 14-37.

Parts of this window make more sense after you learn about dimension styles,
which are covered in the next chapter. For example, the listings for Primary Units,
Alternate Units, Fit, Lines & Arrows, Text, and so on duplicate the tabs on the New
Dimension Style and Modify Dimension Style dialog boxes. Choose Misc to open a
line for Dim style where you can switch to another dimension style. (You can also
change the dimension style from the drop-down list on the Dimension toolbar.) You
can change the color, layer, lineweight, and linetype. To override the automatic
dimension text, enter the text in the Text Override field of the Text section of the
Properties palette.

Aligned Dimension ™

General
Color W BylLayer
Layer 0
Linetype
Linetype scale 1.0000

Plot style ByColor
Lineweight

ByLayer

ByLayer
Hyperlink
Associative Yes

Misc

&«

Lines & Arrows
Text

Fit

Primary Units

Alternate Units

PROPERTIES

Tolerances

=
x

Gl

Figure 14-37: The Properties window
as it appears with one aligned dimension
selected
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Using Quick Dimension to edit dimensions

You can also use Quick Dimension to edit dimensions, whether created with QDIM
or some other dimensioning command. When you select the geometry and dimen-

sions you want to edit, AutoCAD places an “x” at each eligible edit point, as shown
in Figure 14-38.
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Figure 14-38: When you edit with QDIM, AutoCAD
places an “x" at eligible edit points.

Here’s what you can do with QDIM:

4 You can join two dimensions by removing the edit points between them.

4 You can split a dimension into two dimensions by adding edit points within
the existing dimension.

4 You can move the dimension line.
4 You can change the type of dimension.
Caution Editing with QDIM works best when the geometry is simple. Unless you can select

only the geometry and dimensions that you want to work with, you will end up
changing dimensions that you don't want to edit.

To edit dimensions with QDIM, follow these steps:

1. Choose Quick Dimension from the Dimension toolbar.

2. Atthe Select geometry to dimension: prompt, select the geometry and
the dimensions that you want to edit.
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3. At the Specify dimension 1line position, or [Continuous/Staggered/
Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/SeTtings]
<Continuous>: prompt, right-click and choose Edit. You see a cross at each
eligible edit point.

4. At the Indicate dimension point to remove, or [Add/eXit] <eXit>:
prompt, you can:

e Select the points of the dimensions you want to remove. If you see two
possible edit points in line with each other that could be creating the
dimension you want to remove, select both of them.

¢ Right-click and choose Add. Use object snaps to add one or more points.
¢ Right-click and choose Exit to continue with the command.

5. At the Specify dimension Tine position, or [Continuous/Staggered/
Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/SeTtings]
<Continuous>: prompt, right-click and choose an option if you want to
change the type of dimension.

6. The prompt repeats. Pick a location for the new set of dimensions.
7. Press Enter to end the command.

AutoCAD updates the dimensions.

Using grips to edit dimensions

Grips are ideal for moving dimension lines and text. The grips at the dimension line
endpoints and the text insertion point are quite useful for making adjustments in
dimensions.

To move a dimension line closer or farther from the dimensioned object, pick the
dimension to display the grips. Pick one of the grips at the endpoints of the dimen-
sion line to highlight it. The Specify stretch point or /Base point/Copy/
Undo/eXit: prompt appears. Drag the dimension line to the desired location. Press
Esc to remove the grips.

To move dimension text, pick the dimension to display the grips. Pick the grip on
the dimension text to highlight it. Drag the dimension text to its desired location.

For best results, turn ORTHO on while trying to drag the dimension line or the
., dimension text. Polar tracking also works well.

s

Figure 14-39 shows the process of dragging a dimension to the right.
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Figure 14-39: Using grips to relocate a dimension
Thanks to Bill Maidment of Cantech Inc,, Fairfield, lowa, for this drawing.

Editing objects and dimensions together

Until now, you have not taken advantage of the associativity of AutoCAD’s dimen-
sions. This feature enables you to edit objects and have the dimensions automati-
cally adjust to the new object measurements. Stretching the object with the
STRETCH command or grips is usually the best way to accomplish this. AutoCAD
adjusts both the object and the dimension. Figure 14-40 shows a house plan before
and after stretching to move a window six inches to the left. The crossing window
included the entire window, so it was simply moved. However, the crossing window
crossed the walls on either side of the window and both dimensions so that they
were stretched six inches to the left. Notice the change in the dimension text, indi-
cating the new measurements.

Onthéi“\ The drawing used in the following Step-by-Step exercise on using DDEDIT, QDIM,

; CDW

grips, and STRETCH to edit dimensions, ab14-h.dwg, is in the Drawings folder

/," of the AutoCAD 2004 Bible CD-ROM.

Step-by-Step: Using DDEDIT, QDIM, Grips, and
STRETCH to Edit Dimensions
1. Open ab14-h.dwg from your CD-ROM.

2. Save the file as ab14-10.dwg in your AutoCAD BibTe folder. This is a cross
section of a valve part, as shown in Figure 14-41. Open the Dimension toolbar
if it is not displayed.
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Figure 14-40: When you stretch objects, the dimensions
are automatically updated.
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Figure 14-41: A dimensioned cross section
of a valve part
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3. To replace the dimension marked Ht., choose Modify &> Object > Text => Edit.
At the Select an annotation object or [Undol]: prompt, choose the
dimension at @ in Figure 14-41. The Multiline Text Editor opens with the text
displayed. Select the current text and type <>. Click OK. AutoCAD automatically
creates the original measured dimension. Press Enter to end the command.

4. Select the two dimensions marked @ in Figure 14-41. Also select the cyan cen-
ter line and the two green hidden lines. Choose Quick Dimension from the
Dimension toolbar. At the first prompt, right-click and choose Edit. At the
Indicate dimension point to remove, or [Add/eXit] <eXit>: prompt, choose the
two edit points (each marked with an “x”) on the cyan center line. Right-click
and choose Exit. At the Specify dimension line position, or [Continuous/
Staggered/Baseline/Ordinate/Radius/Diameter/ datumPoint/Edit/SeTtings]
<Continuous>: prompt, place the dimension line where it was previously.
(You can use the outside arrows as a guide.)

5. Pick the dimension at @. Click the grip on the text to activate it. Drag it to the
left slightly to place it closer to the object it is dimensioning.

6. Choose Stretch from the Modify toolbar. Follow the prompts:

Select objects: Pick at @.

Specify opposite corner: Pick at @.

9 found

Select objects: o

Specify base point or displacement: 0,-.25 J
Specify second point of displacement: J

AutoCAD stretches the valve part and adjusts the dimension that measures
its height.

7. Save your drawing. It should look like Figure 14-42.
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Figure 14-42: The edited valve part
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Summary

AutoCAD'’s dimension features enable you to dimension almost anything. In this
chapter, you read about:

4 Creating linear, radial, dimension, angular, and ordinate dimensions

4 Formatting and creating leaders

4 Dimensioning with the Quick Dimension feature

4+ Editing dimensions

In the next chapter, I continue the subject of dimensions by explaining how to gain
total control with dimension styles.

+ 0+ ¢






Creating
Dimension

Styles and
Tolerances

In Chapter 14, you drew many dimensions using AutoCAD’s
default style. However, you have a great deal of control
over the way dimensions look. Now that you are familiar with
dimensions, you can learn how to bend them to your will.

Understanding Dimension Styles

You should create your dimension styles before dimensioning.

Some drawings have several dimension styles, although a
drawing can look confusing if it has too many dimension
styles. In general, you create a dimension style, save it in your
template drawings, and (you hope) rarely have to deal with it
again except to override a setting for a unique situation.

The various disciplines each have their own standards and
customs regarding dimensions. AutoCAD’s dimension styles
are flexible enough to accommodate any type of dimensioning
practice.

To create a dimension style, choose Dimension Style from the
Dimension toolbar to open the Dimension Style Manager,
shown in Figure 15-1. The current dimension style is shown as
Standard. The Standard dimension style is AutoCAD’s default
dimension style.
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In This Chapter

Understanding
dimension styles

Defining a new
dimension style

Changing dimension

styles

Creating geometric
tolerances

¢ 4+
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E] Dimension Style Manager (6] %]

Current Dimstyle: STANDARD

Styles: Preview of. STAMDARD

ARCH Set Curent

ARCH_36
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RO.8045—"

List: Description
STAMDARD
Al styles

Figure 15-1: The Dimension Style Manager

The Dimension Style Manager is the master control room where you manage dimen-
sions. Here you create new dimension styles and modify existing ones.

The preset Standard dimension style that AutoCAD comes with is most appropriate
for mechanical drafting. Whichever type of drafting you do, you will probably find
the need to make some changes to the default dimension style. You do this by cre-
ating a new dimension style. A preview of the current dimension style is shown at
the right side of the dialog box.

To create a new style, click New to open the Create New Dimension Style dialog
box, shown in Figure 15-2. Type a new name in the Name text box. In the Start With
drop-down box, choose which existing dimension style you want to use as a basis
for the new dimension style. If you have more than one to choose from, choose the
style that most resembles the new style you want to create.

rE] Create New Dimension Style 23

Hew Style Wame:
Skart Wfith:

Usze for:

Copy of STANDARD
STANDARD

All dimenzsions

&ll dimenszions
Linear dimensions
Angular dimenzions

R adius dimensions
Diameter dimensions
Ordinate dimenzions
Leaders and Tolerances

Figure 15-2: The Create New Dimension

Style dialog box
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You use the Use for drop-down box to create variant dimension styles for one type
of dimension.

The Use for drop-down box, shown expanded in Figure 15-2, lets you decide if you
want to use the dimension style for all dimensions or only for a specific type of
dimension. Usually, you create a dimension style for all dimension types. Later in
this chapter, I explain how to create variants of dimension styles for specific types
of dimensions, such as angular dimensions or leaders.

After you are done, click Continue.

You can also use the Dimension Style Manager to rename a dimension style. Click
its name to select it. Click it a second time to see an edit box. Type the new name
and press Enter.

Defining a New Dimension Style

Dimension styles have many components, so the process of defining a dimension
style is complex. Your task is organized for you by the tabs of the dialog box.

When you click Continue in the New Dimension Style dialog box, AutoCAD opens a
second New Dimension Style dialog box, as shown in Figure 15-3.

The New Dimension Style dialog box has the following tabs:
4 Lines and Arrows: Sets specifications for dimension lines, extension lines,

arrowheads, and center marks.

4 Text: Determines the appearance, placement, and alignment of dimension
text.

4 Fit: Sets how text and arrows fit inside narrow dimensions, where text is
placed when it doesn’t fit in its default position, the scale factor for dimension
features, and whether to place a dimension line inside narrow dimensions.

4 Primary Units: Determines the format and precision for the primary measuring
unit for both linear and angular dimensions.

4 Alternate Units: Determines the format and precision for secondary units, if
turned on (such as metric measurements if your primary units are English, or
vice versa).

4 Tolerances: Formats tolerances.
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Managing dimension lines and arrows

An important part of defining a dimension style is specifying how the dimension
lines and arrows look. You do so on the Lines and Arrows tab of the New Dimension
Style dialog box. In Chapter 14, Figure 14-1, I illustrated the parts of a dimension.
Refer to that figure if you need a refresher.

The Lines and Arrows tab is divided into four sections: Dimension Lines, Extension
Lines, Arrowheads, and Center Marks for Circles.

Dimension lines

To set the color of the dimension line so that it differs from that of the rest of the
dimension, click the Color drop-down list and choose a color. Choose Select Color to
open the Select Color dialog box if you want to use a nonstandard color. Remember,
dimensions are blocks — one object. The default color is ByBlock so that dimensions
take on the color of the current layer or color setting. In general, you should have a
separate layer for dimensions. Then the entire dimension is the color set for that
layer. Use this setting only if you want the dimension lines to be a different color
from your dimension layer color. The arrowheads do not have a separate color set-
ting and always follow the dimension line setting.

El New Dimension Style: Copy of STANDARD B=)

Lines and Amaws | Test | Fit Primary Urits | Altemate Urits | Tolerances
Dirnenzion Lines

Colar: [ A| 10159 |—
Lineweight: — ByBlock v —_
Extend beyond ticks: 1‘1?55 20207
Baseline spacing: ooaet & — \
Suppress: Diim Line 1 Diim Ling 2 /
PP [ Dim Line [ Dim Line RU.8045—/
Extension Lines Anowheads
— 2 Closed filed
Color; M EyBlock - Tst ¥ Closed file :v:
Linewseight: — ByBlock ™ ik i Closed filed nd
" | Leader B Closed filled v
Extend beyond dim lines: 00348 2 =
Arrow size: 0-03M8" |2
Qffset from origin: 00118 = —
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[ 0K ] [ Cancel ] [ Help l

Figure 15-3: The New Dimension Style dialog box with
the Lines and Arrows tab displayed
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r Cross- See Chapter 11 for a discussion of how to use the Select Color dialog box.
Reference’\  gee Chapter 18 for coverage of blocks.

To set a lineweight for the dimension line, click the Lineweight drop-down box
and choose a lineweight. The default lineweight is ByBlock, which means that the
lineweight will follow the lineweight of the dimension’s layer. In general, you want
your objects to stand out, so dimensions should have the same or a lower
lineweight than your objects.

The Extend beyond ticks text box determines how far the dimension lines extend
past the extension lines. When you have arrowheads at the ends of the dimension
lines, the Extension option is unavailable. However, if you choose Architectural tick,
Oblique, Dot Small, Integral, or None in the Arrowheads section of the dialog box,
the Extend beyond ticks option becomes available. This type of extension is typical
for architectural drafting. Figure 15-4 shows a dimension with an architectural tick
and a 0.1-unit extension.

Architectural tick Extension

24 ’_O EE ‘

1 *
Figure 15-4: A typical architectural dimension showing the text above
one dimension line, an architectural tick, and the dimension line slightly
extending beyond the extension lines

The Baseline spacing text box determines the distance between successive dimen-
sion lines when you create baseline dimensions. AutoCAD uses this specification to
create evenly spaced dimension lines.

In some dimension styles, the dimension text splits the dimension line into two
parts, as shown in Figure 15-5. This creates two dimension lines. You can suppress —
that is, turn off —the first or second dimension line (or both dimension lines) by
checking the appropriate box (or boxes). The first line is nearest where you speci-
fied the first extension line origin. (If you selected an object instead of specifying two
extension line origins, you may not be able to predict which dimension line is the
first and which is the second. Experiment.) You would usually suppress dimension
lines when they interfere with other dimensions or with objects in your drawing.
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First dimension line Second dimension line
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Figure 15-5: A typical mechanical dimension with text splitting two
dimension lines

Extension lines

As with dimension lines, you can pick a color for the extension lines that differs
from that of the rest of the dimension. Click the Color drop-down list and choose

a color. Choose Select Color to open the Select Color dialog box if you want a non-
standard color. The default color is ByBlock so that extensions take on the color of
the current layer or color setting.

Extension lines typically extend slightly past the dimension line, as you can see in
some of the figures in this chapter. Use the Extend beyond dim lines text box to
specify this extension distance.

Extension lines do not usually touch the object they dimension to make it ea